Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

tortoiseSVN Authentication failed (wo gebe ich user u. passwort an)

Frage Microsoft Windows Tools

Mitglied: herpes

herpes (Level 1) - Jetzt verbinden

20.06.2008, aktualisiert 26.06.2008, 24894 Aufrufe, 23 Kommentare

wo stelle ich bei tortoiseSVN ein, mit welchem user und passwort auf einen
externen svn server zugegriffen wird?

hallo und guten abend!
ich habe jetzt alles versucht, gesuchmaschient, gelesen...stundenlang, nix funktioniert.

dabei moechte ich doch nur ganz einfach mit tortoiseSVN auf einen svn server zugreifen.
lesen kann ich, aber schreiben nicht.
das wundert mich auch nicht, da ich nirgendswo das login und das passwort angeben
kann, bzw einstellen kann!
wenn ich auf einen ordner mit rechter maustaste anklicke, bei tortoiseSVN dann -> importieren
angebe, kann ich zwar die url zu dem svnserver angeben, aber es kommt ein
'authorization failed'...
warum bekomme ich nie einen Authentication Dialog, wie in der hilfe unter
5.1.5. Authentication
angezeigt?

der serveradmin behauptet, das wuerde funkionieren,
also muss es ja an mir liegen!

bin sehr dankbar fuer jede hilfe
vielen dank schonmal
gruss
steffi
Mitglied: stollkuehn
20.06.2008 um 01:49 Uhr
hi und guten morgääähn,

dass ließe sich leichter beantworten, wenn du uns wie du dich verbinden willst? per ssh, svn, oder http oder besser https.

mit ssh wäre der syntax so:

svn+ssh://myuser@MyConnection/usr/local/repos

ähnlich funktionierts auch mit den anderen verbindungsmethoden.

Gruß

Stefan

ps: hier noch die deutsche doku
Bitte warten ..
Mitglied: herpes
20.06.2008 um 12:23 Uhr
hallo stefan!
danke schon mal fuer deine naechtliche antwort...
also,ich soll/will mich ueber per svn einloggen:

svn://85.55.xxx.xxx/projektordner

ich ab jetzt

svn://username@85.55.xxx.xxx/projektordner

angebeben (in der hoffnung ein passwort angeben zu muessen)
aber es kommt wieder ein
'autorisation failed' wenn ich committen will....

danke fuer den link zur doku!

hier steht wieder, das man tortoiseSVN installiert und sich
beim einchecken der authentication dialog oeffnet
wo man dann das login/pw eingeben kann..
nur nichtbei mir ?!?!

*kopfkratz*
steffi
Bitte warten ..
Mitglied: stollkuehn
20.06.2008 um 12:55 Uhr
hi steffi,

bist du den sicher dass du direkt per svn arbeitest? hört sich für mich eher an als ob du per http oder https die daten holen musst.

serveradmins, und ich bin einer, sagen viel wenn der tag lang ist . spass bei seite.

versuche einfach mal:

http://username@85.55.xxx.xxx/projektordner

oder

https://username@85.55.xxx.xxx/projektordner

oder

svn+http://username@85.55.xxx.xxx/projektordner

bzw.

svn+https://username@85.55.xxx.xxx/projektordner

das sind, mal abgesehen von der option das ganze per ssh zu machen, die üblichtsten formen daten per svn auszuchecken.

wenn's nicht klappt, melde dich einfach nochmal

Gruß

Stefan
Bitte warten ..
Mitglied: herpes
20.06.2008 um 14:28 Uhr
hallo stefan

hab leider kein glueck..
wenn ich bei der relocate option angebe:

svn+http://username@85.55.xxx.xxx/projektordner
ergibt einen tunnel schemefehler ...

und

http://username@85.55.xxx.xxx/projektordner
https://username@85.55.xxx.xxx/projektordner

oder auch

http://85.55.xxx.xxx/projektordner
https://85.55.xxx.xxx/projektordner

(also ohne username)
dann bekomme ich ein ein

01.
error * PROPFIND request failed on /projektordner]

aber schoen, das es auch serveradmins gibt die bei aller arbeit stress, armen
verzweifelten steffies helfen koennen !!

lieben gruss
steffi
Bitte warten ..
Mitglied: stollkuehn
20.06.2008 um 14:37 Uhr
das ist der vorteil wenn ich mal zuhause sitze und in ruhe alles machen kann ausserdem mach ich es ja eh den ganzen tag. usern mit ihren problemen zu helfen

mal ganz blöd gefragt, kannst du denn überhaupt eine verbindung mit dem server aufbauen? per telnet oder vielleicht nen einfacher ping?

die teile der ip die du mir gegeben hast, sprechen ja für nen server der nicht irgendwo in nem intranet rumlungert. von wo versuchst du denn die verbindung aufzubauen? zuhause? arbeit?

gerade hab ich noch den noch rausgekramt. Wie siehts denn mit deinen Firewalleinstellungen aus?

Gruß

Stefan
Bitte warten ..
Mitglied: herpes
20.06.2008 um 17:13 Uhr
ich sitze auch zuhause. mein xp fierwall ist deaktiviert.
den svn server und das verzeichniss kann ich schon auslesen
inkl der history
aber ich hab keine schreibrechte, kann also nicht commiten.
der serveradmin hat mir ein login und ein passwort gegeben mit dem das funktionieren
soll.... aber ich komme ueberhaupt nicht in die lage das passwort eingeben zu muessen...

bei
http://85.55.xxx.xx/projektname:8080

(also mit port angaben)
kommt :
01.
Error * PROPFIND request failed on '/projektname:8080' PROPFIND of '/projektname:8080': 501 Not Implemented (http://85.55.xxx.xx)

aber interssant ist:

svn://85.55.xxx.xx/projektname:8080

da kommt dann
01.
Error * Kann Datei »D:\Development\SVNRepos\projektname:8080\format« nicht öffnen:  Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung  ist falsch.
das seltsame ist, das ich dazu fast nix finde wenn ich mich durch die
gegend google und auch in den faq nix finde, so als waere ich der einzige
mensch der das problem hat..das kann ja fast nicht sein..
asoso als indiez das das an mir liegt...
Bitte warten ..
Mitglied: stollkuehn
20.06.2008 um 18:05 Uhr
versteh ich das also richtig, dass der checkout ohne user und pw erfolgt?

ah ich glaub ich den fehler. Versuchs mal so:

svn://user@85.55.xxx.xxx:8080/projektname

der port gehört hinter die domain und nicht hinter das serververzeichnis

hoffe das hilft

gruß

Stefan
Bitte warten ..
Mitglied: herpes
20.06.2008 um 18:26 Uhr
hallooeoochen..
also

svn://user@85.55.xxx.xxx:8080/projektname

verursacht einen tiemout...

ojehhh
Bitte warten ..
Mitglied: stollkuehn
20.06.2008 um 18:33 Uhr
und was passiert wenn du statt svn:// http:// nimmst?

Gruß

Stefan
Bitte warten ..
Mitglied: herpes
20.06.2008 um 18:42 Uhr
das dauert dann auch ne ganze weile und dann kommt
wieder

01.
PROPFIND request failed 
02.
PROPFIND  of/projektname : could not connect to server (http://85.55.55.55:8080)

*?*
Bitte warten ..
Mitglied: stollkuehn
20.06.2008 um 19:12 Uhr
ich blicks grad nicht mehr.

wie checkst du aus. Syntax?

vllt kommen wir dann weiter, wenn wir das pferd von hinten aufzäumen.

Gruß

Stefan
Bitte warten ..
Mitglied: herpes
20.06.2008 um 19:23 Uhr
huhu
danke nochmal fuer deine geduld!!!

ich checke aus mit tortoiseSVN
also:
->windows explorer-> meinen projektordner ordner [projektname]
->rechte maustaste-> svn checkout
da gebe ich an
svn://user@85.55.xxx.xxx:8080/projektname

alles klar..

wenn ich dann ne datei hinzufuegen mochte zu r versionierung
zb ueber commit dann bekomme ich ein
'authorization failed'
nur durfte konnte ich mich bisher nicht authorisieren
Bitte warten ..
Mitglied: stollkuehn
22.06.2008 um 00:51 Uhr
hi steffi,

sorry freitag abend war grillabend und ich hatte dann nicht mehr wirklich zeit.

ich hab jetzt mal windows bei mir gestartet und das ganze mit nem repo getestet zu dem ich zugang habe und auch commiten kann. Ich hatte bei mir dabei auch überhaupt keine probleme. das hilft dir zwar nicht weiter, allerdings ist so wie du mir jetzt alles haarklein erzählt hast für mich auch kein fehler zu erkennen.

was man jetzt probehalber noch probieren könnte, dass ist aber natürlich nur bedingt tauglich, wenn es sich um ein produktives repo handelt, dass du alles mal in einen anderen ordner auscheckst und dann wieder commitest ohne was am Source zu ändern. ist zwar doof wegen der versionierung aber evtl ist irgend eine setting kaputt.

Was auch sein kann, was ich mir auch vorstellen könnte, ist dass das repo auf dem server ne falsche config hat. evtl hat dein user nur rechte zum auschecken aber nicht zum commiten. allerdings würde da eine andere fehlermeldung zu erwarten sein.

ich bin jedenfalls, wie du vielleicht mitbekommen hast, jetzt auch mit meinem latein am ende, geduld habe ich aber jeden falls noch ohne ende

so ich geh jetzt noch film gucken mit meinem nachbarn und schau nachher noch mal vorbei.

c ya


Stefan
Bitte warten ..
Mitglied: herpes
23.06.2008 um 11:45 Uhr
hallo stefan!
hey, du bist ja wirklich supernett, das du da so angagiert bist!!
schliesslich ist ja wochenende (gewesen) und grillparties sind
defenitv passender zu einem freitag
also bloede *~*###`` server probleme und doofe steffies!

ich werde mir mal ubuntu installieren auf einer
extra partition und dann einen subversion client
und dann mit einem ganz jungfraeulichen betriebssystem
auf den subversion server zugreifen,
dadurch kann ich mir sicher sein, das nicht irgendwo
eine versteckte conf datei die authentifizierung mitschickt.
ich hatte irgendwann mal subclipse installiert, viellciht hat sich
da irgendwas irgendwo abgelegt (auch wenn ich alles entsprechende
geloecht habe, auch in der registry)

wenn das dann nix nuetzt, weiss ich fast sicher das das an dem server liegen muss..
bzw dasnn wueder ich dich viellciht bitten ob du mal den server auschecken
koenntest, bzw ob du die authentifizieren muss, wenn du ein chekout/commit machst.
die ip wuerde ich dir per email schicken, natuerlich nur wenn es dir nix ausmacht...

wie gesagt: echt super das du mir da so ausdauernt hilfst... ich haette sonst warscheinlich
die megakriese, weil viel wald und kein baum in sicht !!

lieben gruss
steffi
Bitte warten ..
Mitglied: stollkuehn
23.06.2008 um 12:50 Uhr
guten morgen steffi *grins*,

installier dir ubunutu in eine virtuellen pc. dasm acht weniger aufwand und du hast dein system innerhalb deiner bestehenden windows installation. so mache ich das seit jahren. alle bekannten und wichtigen os die ich brauche habe ich so immer im zugriff ohne jeweils neubooten zu müssen.

als vpc kann ich virtualbox oder virtualpc empfehlen.

wenn du genug platz hast dann ist das mit der anderen partition schon ok.

Unter ubuntu installier dir auf der console einfach mit

01.
  sudo apt-get install subversion
dann hast du sowohl client als auch server auf deinem system installiert, wobei der server für dich keine rolle spielt. anschließend
einfach nen checkout mit

01.
svn co "svn://user@server/projekt lokalesverzeichnis
commiten dann einfach per

01.
svn ci "lokalesverzeichnis"
wenn das klappt ist irgendwas mit dein checkout unter windows falsch gelaufen. dann wie gesagt den aktuellen arbeitstand vom server in ein anderes verzeichnis auschecken, damit die einstellungen neu gesetzt werden.

kein problem, wenn ich helfen kann, tue ich das doch gerne. und so hilflos erscheinst du mir doch nicht. ich bin eher der jenige der gerade hilflos ist, weil ich mit meinem latein solangsam ans ende komme

wenn alles nicht hilf schick mir wie du angedeutet hast ne mail.hier findest du alle relevanten daten.

ich hoffe das ganze kratzen an dem problem bringt dann auch die lösung für dich

Gruß

Stefan
Bitte warten ..
Mitglied: herpes
23.06.2008 um 16:07 Uhr
hallo stefan
das mit dem vpc ist ne gute idee,
das steht echt auch mal an...
ging jetzt fuer mich schneller (weil schon mal gemacht)
ubuntu auf einer anderen partition zu installieren.

dann wie von dir per apt-get subversion installiert.
und einen checkout gemacht:
01.
steffi@laptop:~$ svn co 'svn://username@85.xx.xx.xx./projektname' 
02.
Ausgecheckt, Revision 0.
is nix drinn im repository, aber immerhin
er kann es auslesen.
also, eine datei lokal in dem verzeichniss angelegt
aber
wenn ich aber einen commit mache
kommt garnix:
01.
steffi@laptop:~$ svn ci 'projektname' 
02.
steffi@laptop:~$ 
es kommt weder eine fehlermeldung noch sonst
irgennd ein return..?!?!
es wird auch nicht hochgeladen..!


bzw wenn ich das so mache
01.
steffi@laptop:~$ svn ci 'svn://username@85.xx.xx.xx/projektname' 
02.
svn: »svn://username@85.xx.xx.xx« ist keine Arbeitskopie 
03.
svn: Kann Datei »svn://username@85.xx.xx.xx/.svn/entries« nicht öffnen: No such file or directory
warum fragt der mich nicht nach dem passwort?


tsss.hmmmm...
tendenz geht in richtung misskonfiguartion
svn server.
allerdings finde ich es seltsam das ich bei den
subversion clients keine moeglichkeit habe eine
passwort eingabe zu erzwingen..(?)
den usernamen kann ich ja mit angeben
auch wenn ich
01.
svn://username:meinpasswort@85.xx.xx.xx/projektname

fuer den checkout angebe, kann ich nicht anschliessen nicht committen!

ja, das kratzen hilft sehr viel! und vielleicht hilfts hja spaeter noch jemanden mit dem selben problem
und dem /der ist dann vielleicht geholfen..
Bitte warten ..
Mitglied: stollkuehn
23.06.2008 um 17:14 Uhr
hi steffi,

da hatte ich die angabe des usernamen und des passwords per commandline glatt vergessen,
01.
svn ci --username DEINUSERNAME PROJEKT
sollte keine passwortabfrage kommen dann vllt so.
01.
svn ci -username DEINUSERNAME -password GEHEIM PROJEKT
weitere Optionen bekommst du mit
01.
svn ci --help
angezeigt.

Gruss

Stefan

EDIT: weitere Optionen gibts mit
01.
svn help
Wobei die gerade jetzt noch nicht interessant für dich sind
Bitte warten ..
Mitglied: herpes
25.06.2008 um 14:55 Uhr
halloechen stefan
also sieht es jetzt defenitiv so aus, dass das ein konfiguartionsfehler
ist...ich habe dem admin jetzt mal bescheid gegeben das ich/wir alles versucht haben
und ihm auch den link zu dem posting hier geschickt...

er wird sich dann (heute?) damit beschaeftigen und vielleicht kann
ich das dann hier als geloest makieren
weil ich mich dann endlich authentifizieren kann...
ich meld mich dann nochmal...
bis dahin
*tuedellueh*
Bitte warten ..
Mitglied: stollkuehn
25.06.2008 um 15:03 Uhr
hi steffi,

das klingt doch nach zielgrade. jetzt musst du es nur noch über die linie schaffen. ich drücke dir beide daumen ganz feste

Bis dahin

Liebe Grüße

Stefan
Bitte warten ..
Mitglied: herpes
26.06.2008 um 17:00 Uhr
YES! YIPIIEEH! juheee!
es funktioniert!
jetzt kommt auch das authentifizierungsfenster.
es war also ein server-konfigurationsfehler!

also hier nochmal in einem satz fuer spaetere opfer falsch konfigurierter
suberverion server:
wenn zb. bei
subclipse (eclipse subversion plugin)
oder
tortoiseSVN (subversion client fuer windows )
kein authentifizierungs-fenster, und beim
commiten ein 'authentification failed' erscheint,
dann ist die ursache der miskonfigurierte subversion server!!

vielen vielen dank lieber stefan,
ohne dich haette ich die ansage vom server admin
der server waere richtig konfiguriert,
niemals in frage gestellt, und den fehler bis zur
absoluten verzweiflung bei mir selber gesucht

gutgelaunte gruesse
wir lesen uns
steffi
Bitte warten ..
Mitglied: stollkuehn
26.06.2008 um 17:27 Uhr
hallo steffi,

dann bin ich froh das wir das auch gelöst haben. dann viel spaß beim versionieren (ich möchte es nicht mehr missen).

---CASE CLOSED----

Bis bald

Stefan

ps. machst du den thread bitte noch zu
Bitte warten ..
Mitglied: herpes
26.06.2008 um 18:08 Uhr
huhu stefan
<quote>ps. machst du den thread bitte noch zu</quote>

hab ich doch...da sit doch jetzt der gruene hacken am
threat titel?
(der kam nachdem ich beim eintrag editieren den 'beitrag geloest' hacken
gesetzt habe...oder was meinst du ??)

winki
Bitte warten ..
Mitglied: stollkuehn
26.06.2008 um 18:14 Uhr
hi steffi,

ups jetzt seh ich es auch. wahrscheinlich hat mein browser zuviel gecached. who knows.

so dann jetzt wirklich closed

read ya

Stefan
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Windows Server
User-ID zu Application Crash

Frage von pablovic zum Thema Windows Server ...

Router & Routing
Radius für 15 User direkt über Mikrotik- oder Ubiquiti-Router (4)

Frage von Muesliriegel zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (13)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...