Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Totalcommander und Truecrypt wollen nicht mehr miteinander

Frage Microsoft Windows Tools

Mitglied: 8schpi

8schpi (Level 1) - Jetzt verbinden

16.11.2009, aktualisiert 17.11.2009, 5536 Aufrufe, 5 Kommentare

Ich habe seit neuestem ein Problem beim Starten von Truecrypt aus Totalcommander heraus. Das Problem ist reproduzierbar.

Wenn ich Truecrypt aus dem WindowsExplorer heraus starten möchte (Doppelklick auf die EXE-Datei) gibt es kein Problem. Um mögliche Ursachen auszuschließen habe ich jegliche Verknüpfungen und Skripte unberücksichtigt gelassen und will Truecrypt nur durch Doppelklick auf die EXE-Datei starten.
Zur Veranschaulichung hier ein Bild: http://picfu.net/732843

Wenn ich das gleiche aus dem bekannten Dateiexplorer Totalcommander (www.ghisler.ch, Version 7.50a) versuche, bekomme ich für mich unverständlicherweise seit kurzem die Fehlermeldung "Betriebssystem wird nicht unterstützt". Auch hier habe ich versucht das Programm Truecrypt über einen Doppelklick auf das Programmsymbol zu starten.
Zur Veranschaulichung ein weiteres Bild: http://picfu.net/a78b52

Ich habe Truecrypt auf einem USB-Stick als portable Edition (Version 6.2a) installiert. Wenn ich Truecrypt auf der Festplatte installiere gibt es keine Änderung an dem Verhalten. Das Problem tritt nur bei einem Computer mit Windows XP Professionell auf. Auf einem zweiten Computer mit Windows Vista funktioniert die gleiche Portable Installation problemlos.
Auf dem Windows XP Rechner wurde keine Software installiert (außer möglicherweise automatische Updates), die Truecrypt Version wurde nicht umgestellt und es hat vorher längere Zeit funktioniert (wochenlang jeden Tag mind. 1 mal). Auf einmal hat es aufgehört zu funktionieren…

Software neuinstalliert, neugestartet, gegoogelt usw. hab ich schon. Hat alles nix geholfen.
Ich hoffe Ihr habt Rat.
Mitglied: DerWoWusste
16.11.2009 um 22:26 Uhr
Hallo. Was für einen Rat erhoffst Du Dir?
Der Total Commander (Version?) macht eine unsaubere Abfrage und fertig - was könnte man daran schon drehen?
Bitte warten ..
Mitglied: 8schpi
17.11.2009 um 13:14 Uhr
Die Totalcommander Version ist wie auf dem Screenshot zu sehen Version 7.50a. Habs auch in dem Beitrag oben nochmal ergänzt.

Wenn ich den Rat schon vorher wüsste bräuchte ich nicht fragen, oder hab ich das falsch verstanden?

Es muss ja wohl ein Fehler im Zusammenspiel der beiden (drei) Programme sein. Da ich mir keinen Reim daraus machen kann warum es beim Explorer funktioniert und beim TC nicht könnte ein Rat oder eine Erläuterung zum beispiel dahingehend sinnvoll sein warum und welche Unterschiede zwischen dem Starten von Programmen aus TC und Explorer heraus bestehen.

Die Erklärung "TC macht eine unsaubere Abfrage und fertig" ist mir vorerst zu wenig.

Der Fehler taucht grundsätzlich immer bei der Maschine in der Konstellation auf. Ansonsten hatte ich TC eigentlich als solides Programm (keine unsauberen Abfragen, Programmstarts etc.) kennengelernt. Oder seid ihr da anderer Meinung?
Bitte warten ..
Mitglied: DerWoWusste
17.11.2009 um 14:57 Uhr
Versuch es mal mit 6.3 von TrueCrypt oder einer früheren Version von Total Commander.
Mein Punkt ist: es liegt an Total Commander. Einzustellen ist da nichts, Du kannst es höchstens an die Programmierer von Total Commander herantragen.
Bitte warten ..
Mitglied: 8schpi
17.11.2009 um 19:09 Uhr
Hallo DerWoWusste,
danke für Deine Überlegungen.
Die Version 6.3 ist fehlerhaft in Bezug auf die Kommandozeilenparameter. Aber probiert habe ich es schon mal. Ich bin wieder zurück nach 6.2a, weil das die letzte Version ist die mit Kommandozeilenparametern funktioniert hat. Es hat aber definitiv eine Zeit lang (länger als 4 Wochen täglich mind. 1x pro Tag) von derselben Quelle (=USB Stick) mit Totalcommander 7.50a und Truecrypt 6.2a funktioniert. Auf meinem 2.Rechner mit Windows Vista klappt es immer noch tadellos. Deswegen ist es ja so unerklärlich…
Bitte warten ..
Mitglied: 8schpi
25.11.2009 um 18:41 Uhr
Mittlereweile weiß ich, dass der Fehler nicht auftaucht, wenn ich Totalcommander als Admin starte. Die Fehlermeldung selber ist aber von Truecrypt (taucht ja auch nur in Verbindung mit Truecrypt zusammen auf).
Scheint also eher ein Berechtigungsproblem zu sein. Ich habe Truecrypt schon mehrmals de- und nach einem Neustart wieder Installiert (für alle Benutzer, als Administrator) aber immer das gleiche Problem (siehe oben).
Und das bis dato unerklärliche: Es ging vorher mit der gleichen Truecrypt Version und der gleichen Totalcommanderversion (ich hatte nur zwischendurch die mittlerweile auch nicht mehr neue Version 6.3 von Truecrypt ausprobiert.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Verschlüsselung & Zertifikate
Veracrypt und Truecrypt: Hidden-Volumes sind nicht versteckt

Link von Blutiger-Anfaenger zum Thema Verschlüsselung & Zertifikate ...

Verschlüsselung & Zertifikate
Windows 7 über Truecrypt-Partition installiert (18)

Frage von user1985 zum Thema Verschlüsselung & Zertifikate ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...