Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

TP-Link router Archer C7 - bekomme keine AC-Geschwindigkeit beim Upload

Frage Netzwerke LAN, WAN, Wireless

Mitglied: WhiteLion

WhiteLion (Level 1) - Jetzt verbinden

27.02.2014, aktualisiert 28.02.2014, 7465 Aufrufe, 10 Kommentare, 2 Danke

moin leute,
ich hab mit den TP-Link Router Archer C7 gekauft um dort eine externe Platte anzuschließen, um schnell und drahtlos Daten von meinem Laptop hochzuladen (per FTP im LAN).... Ich dachte erst meine Killer Wireless N 1202 würde den AC-Standard auch unterstützen, aber irgendwie bin ich dann auf mein Problem gestoßen, was ich auch mit der Neuanschaffung einer Intel 7260 AC Karte noch habe: Der Download ist bei beiden Karten erträglich, also bei ca. 9 bis 11 MegaBYTE der Upload ist bei der "Killer-Karte" bei 3,4 MegaBYTE und bei der neuen Intel sogar noch darunter bei 2,9 MegaBYTE. Verbunden bin ich über das 5GHz Netzwerk - Ich verstehe das nicht. Ist die Intel-Karte gar keine echte AC Karte oder warum ist der Upload so gering ? - Welche Dinge mache ich falsch ?

3a1ccafa2e7f92082742233b62e465ea - Klicke auf das Bild, um es zu vergrößern

a6f1f14de9141f2a231a4e0f4e003bb5 - Klicke auf das Bild, um es zu vergrößern
Mitglied: MrNetman
27.02.2014, aktualisiert um 18:48 Uhr
802.11ac erreicht die extrem hohen Datenraten nur mit weiteren Tricks.

Aber vorher:
1MByte/s = 8 Mbit/s (Anzeige Treiber) Nimm einfach immer die gleiche Größe, dann habe wir es leichter.

für die volle Bandbreite benötigt man neben guten ausbreitungsbedingungen auch mehrere Antennen und mehrere Sende- und Empfangszüge. Wobei man immer nur eines optimieren kann: Reichweite oder Datendurchsatz. Man benötigt gleichzeitig agierende Sender (Spatial Sreams) um große Bandbreiten durch zu setzen. Es ist durchaus real, dass mehrere Empfänger genutzt werden. Die können sowohl Reichweite als auch Durchsatz verbessern. Mehr Sender brauchen mehr Strom. So ist dein WLAN-Modul fürs Notebook mit zwei Sendern und 2 Empfängern ausgestattet. Das reicht mit 40 MHz Bandbreite gerade für 300Mbit/s Brutto. Je breitere Kanäle du verwendest, desto wichtiger ist die Reinheit deines Luft-Mediums. Für 600Mbit/s benötigt es 80MHz breite Kanäle, das sind im 5 GHZ Band gleich vier Stück der normalen Kanäle. Netto ist man froh, wenn man die Hälfte erreicht.
Du überträgst eine Datei mit 500MByte mit 24 Mbit/s?

Also wird dein upload immer langsamer sein als dein Download. rein technsich bedingt.

Geschwindigkeitstest macht man in einem gesharten Medium unidirektional und mit dem UDP Protokoll, da die Wartezeiten für andere Teilnehmer und die TCP ACKs Pausen verursachen.
Netio ist ein Beispiel dafür.

Gibt es Nachbarn? (mit z.B: inSSIDer prüfen)
Hast du den Gigabit-Port Kupferport auch angeschlossen? (abziehen)
Wie sieht der Geschwindigkeitsvergleich mit der echten Kupferverbindung aus?

Ist der Router sauber konfiguriert? (der kann mit seinen 6 Antennen, 3 pro Band, und dualband-Radios mehr als der Client. Das wären 3 spatial Streams, die der Empfänger aber nicht dekodieren kann.)
Wenn er schon mit der default SSID betrieben wird, dann ist vielleicht der Rest auch nicht optimal eingestellt.
Hast du schon mal ohne Verschlüsselung getestet? nur getestet

Also noch mal einen Versuch mit sauberen Bedingungen.

Gruß
Netman
Bitte warten ..
Mitglied: WhiteLion
27.02.2014, aktualisiert 28.02.2014
Hey Netman. - Danke dir erstmal für deine schnelle Antwort
Ich werde also in Zukunft mit 8 multiplizieren, damit es durchsichtiger wird.

Also ich habe nicht wirklich viel Ahnung wieviel die Antwennen netto übertragen sollten oder wie genau der AC - Mode seine Durchsätze erzielt.
Die Entfernung zum Router sind ca. 3 Meter Luftlinie und außer einer Tischplatte ist nichts zwischen Router und Laptop. Auch das rantragen bis auf 1m brachte nichts in punkto FTP Übertragung. - Ich würde gerne anders testen, leider weiss ich nicht wie ich eine UDP Übertragung herstellen kann.
Ich müsste dann wohl meinen zweiten Laptop per LAN Kable an den Router anschließen und dann mit irgendeiner Software agieren ?? (Netio??)

Mich wundert es, dass ich in den Eigenschaften der WLAN-Karte nur ....5.2GHz N sehe und nichts von AC - Ist das normal ?
Dort kann ich auch nur "20Hz" oder "Auto" einstellen...

Ich habe mal einen Screenshot von inSSID beigelegt... dort steht auch nur 450 MBit/s und "N" ... das ist mir unklar ob das so richtig ist.
Screenshot: http://puu.sh/7cC4L

Überlappungen gibt es laut in SSID mit Nachbarn keine.

Als ungesichertes WLAN hatte ich keine besseren Übertragungsraten.

Ich hoffe Du kannst mir helfen?

PS: Hier noch meine Routersettings bzgl 5GHz:
http://puu.sh/7cErU.png
http://puu.sh/7cEx6.png

EDIT: Ich frage mich mitlerweile ob der Router wirlich ein AC Netzwerk erstellt, denn auch hier im Screenshot wird mir nur ein "N-Netzwerk" angezeigt:
http://puu.sh/7dn27.png
Bitte warten ..
Mitglied: MrNetman
28.02.2014 um 09:47 Uhr
zu netio: http://www.nwlab.net/art/netio/netio.html und zum Download und Artikeln http://www.heise.de/download/netio.html
ein kleines Programm, das auf beiden Stationen läuft (einer WLAN-Statin, einer staionören) und mittels eine Konfiguration auf der einen Seite automatisch Testst durchführt.

für 600Mbit/s benötigt man vier Antennen und vier Streams bei 802.11n. AC ist eine Fortführung mit der selben Technologie und noch höheren Bandbreiten. AC Kompatibel bedeutet aber auch, dass ein ac Gerät in einer solchen Umgebung zurecht kommt, die Protokolle, besonders das Aushandeln versteht. Es bedeutet nicht, dass es mit der theoretisch vom Standard vorgegebenen Maximalgeschwindigkeit arbeiten kann.

Screenshots kann man hier lokal mittels der Edit Funktion einbinden. Das ist besser als externe und unbekannte Links.

Manchmal ist eine extrem kurze Entfernung hinderlich. Theoretisch sollten die Radios/Teilnehmer die Leistung zurück drehen. Das klappt wohl nicht immer und so werden schon mal Empfänger übersteuert. Zweitens gilt für sehr kurze Entfernungen, dass die spatialen Streams zu kurze Laufzeiten haben und sich damit nicht ausreichend gut unterscheiden um im Empfänger wieder sauber zu sammen gebaut werden zu können. 3m könnten aber ok sein. das sind immerhin 15ns Zeitdifferenz.

Dein inSSIDer Screenshot ist sehr aufschlussreich:
Der AP benutzt jeweils 40MHz breite Kanäle.
Er sendet sowohl im 2,4 als auch im 5 GHZ Band. Du hast also eine dopplete Verbindung, die sich gut in die Quere kommen kann.
im 2,4 GHZ Band hast du massenhaft Konkurrenz von deinen Nachbarn. Die Kanäle 6+10 belegen 4/2,5,6,7,8,9,10,11,12/2. Aber der Pegel zu den Nachbarn ist wenigstens nicht s groß.

Du bist aber sich mit der 5GHZ SSID eingeloggt?
Dort sind mit 2 Antennen und 40 MHz Bandbreite brutto für deinen Client nur 300Mbit/s erreichbar. Das ist egal, ob dein Router 3 Streams unterstützt und so 450Mbit/s machen könnte.

Gruß
Netman
Bitte warten ..
Mitglied: WhiteLion
28.02.2014 um 10:29 Uhr
Leider lassen sich keine Screenshots anhängen, wenn ich auf "Zitieren" oder "Kommentieren" drücke.... Keine Ahnung warum das jetzt nicht mehr geht. - Deshalb die externen Links.
Ich habe das 2,4 GHz Netzwerk ausgestellt und jetzt nurnoch 5GHz an. - Leider brachte das keine Verbesserung.
Ich bin immer mit der 5GHz Verbindung eingeloggt (und auch gewesen).
Ich weiss gar nicht mehr was ich noch machen soll ... ganze teure Hardware gekauft damit ich schnell meine Sachen drahtlos auf die Platte bekomme und nun dümplet er mit 24-28 MBit vor sich hin.
Ich verzweifel noch
Bitte warten ..
Mitglied: MrNetman
28.02.2014 um 10:39 Uhr
zu Bildern.
Editiere deinen ursprünglichen Post. Dann kannst du Bilder hochladen.
Diese Links kannst du an jeder beliebigen Stelle bei einer Antwort einhängen.

Hast du den unidrektionalen Test mit netio schon mal gemacht. Protokoll udp. Damit kannst du die theoretisch höchste Geschwindigkeit feststellen.
Für die spatial Streams ist es von Vorteil die Antennen zu verdrehen, also nicht gleichmäßig stehen zu lassen.
Vergleich auch mal die Kupferperformance und die über 2,4GHz. Nur um ein Gefühl für netio zu bekommen und evtl. einen Hinweis auf eine üngünstige Implementierung von z.B: Treibern. Bei 2,4GHz werden ja andere Antennen benutzt.

Kopf hoch.
Bitte warten ..
Mitglied: WhiteLion
28.02.2014 um 13:32 Uhr
Also, ich habe jetzt zwei Tests mit netio durchgeführt, in dem ich den Laptop 2 per LAN-Kabel an den Router angeschlossen habe.
Nach wie vor funkt der Router nur auf 5GHz, weil ich das 2,4GHz Netz ausgeschaltet habe. An den Antennen hab ich gedreht und Entfernung zum Router und dem Laptop 1 (Der mit dem WLAN) betrug immer zwischen 2-4 Metern ohne Hindernisse. - Ich habe das ganze mehrfach getestet, um zu gucken ob verstellen der Antennen und/oder der Abstand eine Wesentliche Auswirkung auf das Ergebniss hat, was aber nicht der Fall war:


Variante 1 (WLAN Laptop ist Client und Test mit UDP):

e:\test\wizard\00006\Install\data>win32-i386 -u 192.168.0.102
NETIO - Network Throughput Benchmark, Version 1.32
(C) 1997-2012 Kai Uwe Rommel
UDP connection established.
Packet size 1k bytes: 26.72 MByte/s (11%) Tx, 31.15 MByte/s (11%) Rx.
Packet size 2k bytes: 5838.90 KByte/s (0%) Tx, 13.62 MByte/s (0%) Rx.
Packet size 4k bytes: 10.35 MByte/s (0%) Tx, 20.30 MByte/s (0%) Rx.
Packet size 8k bytes: 12.21 MByte/s (0%) Tx, 25.72 MByte/s (13%) Rx.
Packet size 16k bytes: 17.66 MByte/s (0%) Tx, 30.39 MByte/s (21%) Rx.
Packet size 32k bytes: 21.01 MByte/s (1%) Tx, 21.19 MByte/s (60%) Rx.
Done.
____________________________________________________

Variante 2 (WLAN Laptop ist Client und Test mit TCP):

e:\test\wizard\00006\Install\data>win32-i386 -t 192.168.0.102
NETIO - Network Throughput Benchmark, Version 1.32
(C) 1997-2012 Kai Uwe Rommel
TCP connection established.
Packet size 1k bytes: 20.05 MByte/s Tx, 27.53 MByte/s Rx.
Packet size 2k bytes: 21.97 MByte/s Tx, 27.90 MByte/s Rx.
Packet size 4k bytes: 21.83 MByte/s Tx, 29.11 MByte/s Rx.
Packet size 8k bytes: 22.39 MByte/s Tx, 29.29 MByte/s Rx.
Packet size 16k bytes: 22.55 MByte/s Tx, 30.04 MByte/s Rx.
Packet size 32k bytes: 22.11 MByte/s Tx, 31.16 MByte/s Rx.
Done.
____________________________________________________

Variante 3 (WLAN Laptop ist Server und Test mit UDP):
e:\test\wizard\00006\Install\data>win32-i386 -s
NETIO - Network Throughput Benchmark, Version 1.32
(C) 1997-2012 Kai Uwe Rommel
TCP server listening.
UDP server listening.
UDP connection established ...
Receiving from client, packet size 1k ... 34.75 MByte/s
Sending to client, packet size 1k ... 29.83 MByte/s
Receiving from client, packet size 2k ... 13.95 MByte/s
Sending to client, packet size 2k ... 5984.61 KByte/s
Receiving from client, packet size 4k ... 20.66 MByte/s
Sending to client, packet size 4k ... 9910.56 KByte/s
Receiving from client, packet size 8k ... 28.40 MByte/s
Sending to client, packet size 8k ... 12.04 MByte/s
Receiving from client, packet size 16k ... 34.98 MByte/s
Sending to client, packet size 16k ... 17.76 MByte/s
Receiving from client, packet size 32k ... 11.52 MByte/s
Sending to client, packet size 32k ... 21.99 MByte/s
Done.
____________________________________________________

Variante 4 (WLAN Laptop ist Server und Test mit TCP):

TCP connection established ...
Receiving from client, packet size 1k ... 21.78 MByte/s
Sending to client, packet size 1k ... 14.75 MByte/s
Receiving from client, packet size 2k ... 22.77 MByte/s
Sending to client, packet size 2k ... 15.97 MByte/s
Receiving from client, packet size 4k ... 28.45 MByte/s
Sending to client, packet size 4k ... 16.87 MByte/s
Receiving from client, packet size 8k ... 27.66 MByte/s
Sending to client, packet size 8k ... 17.09 MByte/s
Receiving from client, packet size 16k ... 26.87 MByte/s
Sending to client, packet size 16k ... 17.67 MByte/s
Receiving from client, packet size 32k ... 27.43 MByte/s
Sending to client, packet size 32k ... 18.34 MByte/s
Done.


Ich bin mit unsicher wie ich das ganze deuten kann ... was sagst du dazu ?
Bitte warten ..
Mitglied: MrNetman
LÖSUNG 28.02.2014, aktualisiert um 15:35 Uhr
Na guck an, das ist doch so übel nicht.

Variante 3 (WLAN Laptop ist Server und Test mit UDP):
e:\test\wizard\00006\Install\data>win32-i386 -s
NETIO - Network Throughput Benchmark, Version 1.32
(C) 1997-2012 Kai Uwe Rommel
TCP server listening.
UDP server listening.
UDP connection established ...
Receiving from client, packet size 1k ... 34.75 MByte/s
Sending to client, packet size 1k ... 29.83 MByte/s

34.75Mbyte/s sind 278 Mbit/s
Mehr ist auch nicht zu erwarten oder? Wie ich oben schon erwähnt habe kommt man netto kaum auf mehr als 50% der Nominalrate.
Der Test hat noch etwas nettes. Die große Testdatei wird ja über viele Ethernet Pakete verschickt, die ihrerseits einen Overhead haben. Netio rechent diesen mit ein. Es geht ja um die Drahtgeschwindigkeit, auch wenns jetzt ein Luftdraht ist

Zu den anderen Ergebnissen.
Die 1k Pakete sind auch einzelne Ethernetrahmen. Die größeren Pakete werden in mehrere einzelne Ethernet-Frames aufgeteilt. Das erklärt, wieso du bei 2k Paketen einen Einbruch hast.


Bei UPD wird nicht auf eine Bestätiung gewartet. da wird der Kanal voll geblasen.
Bei TCP wird zweimal auf das Paket geachtet: Einmal beim WLAN und dann bei TCP.
Die Bestätigungen kosten Zeit und senken die Übertragungsrate.

Wenn du jetzt noch per Kupfer und WLAN den Datendurchsatz an der Platte vergleichst, hast du eine stabile Größenordnung, was du in Zukunft zu erwarten hast.

Gruß
Netman
Bitte warten ..
Mitglied: WhiteLion
28.02.2014, aktualisiert um 15:46 Uhr
Erstmal herzlichen Dank für Deine ausführliche Hilfestellung.
Mit der Verbindung ist also Alles OK, so gibt es der Test ja auch her.



HIER DIE LÖSUNG:
Das Problem war folgendes bzw scheint folgendes zu sein:
Der Router (TP-Link Archer C7) ist direkt mit der Festplatte verbunden und scheint beim Schreiben nicht in der Lage zu sein die Festplatte mit einer höheren Schreibgeschwindigeit zu versorgen. (Lesen geht wie bereits erwähnt (komischer weise) viel schneller als schreiben) ... ich bin natürlich nicht davon ausgegangen, dass dort das Nadelöhr liegen kann. Ein test die Festplatte von dem Laptop mit LAN-Kabel zu beschreiben führte nämlich ebenfalls zu dem Ergebnis ( ca. 25 MBit/s).
Nun da ich das Problem kenne, muss ich mir wohl eine andere Lösung einfallen lassen, wie z.B. einen NAS oder zumindest ein Festplattengehäuse mit LAN - Anschluss.....
Bitte warten ..
Mitglied: MrNetman
28.02.2014 um 16:03 Uhr
Na, da hatte ich doch einen richtigen Riecher
Und so schlecht scheinen neue Technologien ncht zu sein, wenngleich werbung und Realität weit auseinander klaffen.

Habe eben eine Info bekommen, in der dein Router erwähnt wird.
Ich zitiere:
http://www.com-magazin.de/praxis/wlan/gigabit-wlan-standard-802.11ac-26 ...
TP-Link Archer C7: Angeblich schafft dieser Router eine Datenrate von 1750 MBit/s. Es werden aber nur die maximalen Datenraten zweier eigenständiger Funknetze addiert, 1300 MBit/s bei WLAN-ac, 450 MBit/s bei WLAN-n.

Bei 20 MHz beträgt die Bandbreite nur 96,3 MBit/s, bei 40 MHz höchstens 200 MBit/s, bei 80 MHz bereits 433 MBit/s und bei 160 MHz ordentliche 867 MBit/s. Pro Antenne kann höchstens eine Frequenzbreite genutzt werden. Das würde WLAN-ac auf 867 MBit/s beschränken. Insgesamt sieht WLAN-ac über den Einsatz von acht Antennen vor. Grundlage für den Einsatz mehrerer Antennen ist MIMO.

Wie sagte ein Kollege: Ohm's law is still vaild.
Zaubern tun andere.

ein schönes Wochenende
Gruß
Netman

P.S.: USB 2.0 hat maximal 480Mbit/s. Und auch Geräte daran haben oft Stromsparmechanismen, sind folglich nicht auf Geschwindigkeit sondern auf sinnvolle Einsatzbedingungen optimiert.
Bitte warten ..
Mitglied: woiswas
24.09.2014 um 11:11 Uhr
Möchte noch zu diesem Modell folgendes mitteilen:
TP-Link hat bei diesem Modell Probleme mit dem 5Ghz-Band und der Hardware V1 bestätigt. Geräte können über den Support gegen eine V2 getauscht werden.
Ich komme im 2.4Ghz Band auf 22,3 MBit, im 5 GHz auf nur 14,4 MBit, mit Hardware V1. Muss mein Gerät tauschen.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Router & Routing
TP-Link Router VPN Verbindung Router Oberfläche nicht erreichbar (3)

Frage von D46505Pl zum Thema Router & Routing ...

Router & Routing
Unbekannter sichert sich TP-Link-Domains zur Router-Konfiguration (2)

Link von kaiand1 zum Thema Router & Routing ...

LAN, WAN, Wireless
gelöst TP-Link WA501G als Client einrichten - Keine IP Adresse wir bezogen (14)

Frage von bestelitt zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (15)

Frage von liquidbase zum Thema Windows Update ...

DSL, VDSL
Problem mit variernder Internetgeschwindigkeit (12)

Frage von schaurian zum Thema DSL, VDSL ...