Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Treiber bei Rückstellung von RAID 1 auf AHCI

Frage Hardware Festplatten, SSD, Raid

Mitglied: erikas

erikas (Level 1) - Jetzt verbinden

12.09.2012 um 10:13 Uhr, 5619 Aufrufe, 9 Kommentare

Hallo Forum,
mal ne Verständnisfrage.
Wenn ich bei einem Intelboard ein Raid 1 auflöse und Win7 dann per regestry anweise den AHCI bzw IDE Treiber für die HDDs zu verwenden, muss ich dann zwingend auch im BIOS den SATA mode auf AHCI stellen, oder kann der auch problemlos auf Raid stehen bleiben?

Hintergrund: Nach der Umstellung wie oben beschrieben verliert ein per LAN an dieses System angebundener Rechner 2-3x am Tag für ca 2 Minuten die LAN Verbindung zum System. Da ich remote sitze kann ich das BIOS nicht so ohne weiteres umstellen.

Beste Grüße
E.
Mitglied: Lochkartenstanzer
12.09.2012, aktualisiert um 10:39 Uhr
Wäre es notwendig gewesen, würde Deine Kiste nicht hochfahren.

Wenn überhaupt würde ich das auf pfriemeleien in der Registry zurückführen.

Wie äußert sich denn das "verbindung verlieren"?

Was sagen die Syslogs.

lks
Bitte warten ..
Mitglied: erikas
12.09.2012 um 10:56 Uhr
Und auch dahin ging die Frage. Verursacht der Raid modus eventuell so etwas wie ein Syncintervall welches auf Grund des fehlenden Raid Verbundes Netzwerkprobleme macht?

Die logfiles des Systems ('Server') sind 'clean' bis auf einen SQL Fehler der aber schon länger existiert und nicht meine Baustelle ist. Die logfiles der Clients dagegen weisen hin und wieder Fehler von MSO2010 Produkten auf (word, excel) da die Daten auf dem ('Server') liegen und bei fehlendem Netzwerk... , ansonsten ebenfalls sauber.

Grüße
E.
Bitte warten ..
Mitglied: Lochkartenstanzer
12.09.2012 um 11:04 Uhr
Zitat von erikas:
Und auch dahin ging die Frage. Verursacht der Raid modus eventuell so etwas wie ein Syncintervall welches auf Grund des fehlenden
Raid Verbundes Netzwerkprobleme macht?

Die onboard-raids sind fast alle "fakeraids", d.h. die Intelligenz steckt im Treiber.

Solange Dein Windows den AHCI-treiber benutzt und nciht den RAID-treiber (im Geräte-Manager nachschauen) soltle das nicht passieren.

lks
Bitte warten ..
Mitglied: erikas
12.09.2012 um 11:30 Uhr
Das System nutzt den IAstor.sys, von daher sollte das dann wohl passen.
Hmm, Idee wie weiter?

Die 'pfriemeleien in der Registry' für alle die es auch brauchen sind übrigens ein Fixit von MS und hier beschrieben.
http://support.microsoft.com/kb/922976

Grüße
E.
Bitte warten ..
Mitglied: Dobby
12.09.2012 um 11:35 Uhr
Hallo erikas,

warum solltest Du im BIOS den den SATA Mode auf AHCI stellen müssen, steht das so in dem Benutzerhandbuch
vom Mainboard? Vorab noch eins, für diesen Beitrag hier und heute und alle anderen Beiträge wer weiß noch wo: Alles was Du vorher erzählst und preis gibst, muss man Dir nicht aus der Nase ziehen oder erfragen.
Und das heißt im Klartext für Dich, schnellere Hilfe, von mehr Leuten, die Ziel führend ist und
auch verständlich für Dich. und dafür denke ich hast Du ja den Beitrag gestartet!


Es gibt drei Sorten und sehr viele Level von RAID´s.

- Ein reines Software RAID - Software RAID
- Ein RAID an einem Mainboard RAID Controller - Soft RAID
- An einer extra RAID Controller Karte - Hardware RAID

Ist Dein Windows 7 Betriebssystem denn auf dem RAID Level 1 installiert?
Oder ist Windows 7 auf einer Festplatte installiert und es befindet sich ein RAID Level 1 im System?

Du baust Dir einen PC zusammen oder kaufst Dir einen, dann bootest Du den PC, dann gehst Du während des Bootvorgangs in das BIOS entweder vom Mainboard oder vom Controller und nimmst dort die Einstellungen bezogen auf das RAID vor, es sei denn Du betreibst ein reines Software RAID.
Booten > rein ins Bios vom Mainboard oder RAID Controller > das RAID anlegen

Und wenn Du dann das RAID wieder auflösen möchtest, geht das auch auf diese Weise.
Booten > rein ins Bios vom Mainboard oder RAID Controller > das RAID auflösen

Was allerdings dabei nicht verändert wird ist in der Regel der/die Treiber für den/die RAID Controller, egal ob auf dem Mainboard verbaut oder als separate Controller Karte, zu mindestens nach meinem Wissensstand.

Es sollte Dir aber auch klar sein, wenn Windows 7 auf dem RAID 1 installiert wurde das es danach nicht mehr so richtig bootet und es um Deine Daten sehr schlecht stehen könnte/wird.

Bitte nimm eine Datensicherung vor, seit Windows 7 gibt es ein Datensicherungsprogramm was auch etwas zu taugen scheint, es legt ein Image von der Gesamten Platte mit der Systempartition an und kann nach dem Auflösen des RAID 1 auch wieder zurück gespielt werden. Es sollte auch eine extra Datensicherung aller Deiner Daten erfolgen falls bei so einem zurück spielen (Restore) Probleme auftreten und Du Dein Windows 7
und Deine Programme wieder neu installieren musst, dann hast Du wenigstens alle Deine privaten Daten gesichert und zu Windows und Deine Programmen hast Du in der Regel ja auch CD/DVD´s von denen Du wieder installieren kannst.

Das sollte so oder so ähnlich alles funktionieren, je nach dem für was Du Dich entscheidest und was wirklich bei Dir verbaut und angelegt ist, aber das ändern der Treiber oder der BIOS Einstellungen hinsichtlich der SATA Ports wäre mir wirklich neu.

Das mit der Systemregistrierdatenbank ist so ein nicht tot zu bekommender "Ever Green", also da würde ich als allerletztes was dran "schrauben" und verändern oder lieber gleich neu installieren! Da weiß man wenigstens was läuft und wie es läuft. Bei Kopfschmerzen traut sich halt auch nur jeder seine Lieblings Tabletten zu empfehlen und nimmt nicht eine Operation am offenen herzen vor.

Gruß
Dobby
Bitte warten ..
Mitglied: erikas
12.09.2012 um 11:47 Uhr
Hi Dobby,
ich danke für Deine ausführliche Antwort.
Ich bin nicht der Spezie, aber meine erlebt zu haben, dass wenn ich ein Software Raid-1 im BIOS umstelle und dann boote keinen Erfolg (Stopfehler) habe weil Windows den falschen Treiber lädt. - So zumindest bei mir.

In der Reihenfolge 'Regeintrag ändern', 'Array im Controller Setup auflösen' geht das Booten dagegen von Statten. Aber wie gesagt nur angelesen und angewendet, nicht verstanden... Profis sind gefragt.


Hast Du denn noch eine Idee warum der 'Server' nun einige Mal am Tag die Netzwerkverbindung kappt?

Grüße
E.
Bitte warten ..
Mitglied: Dobby
12.09.2012 um 12:16 Uhr
Zitat von erikas:
Hi Dobby,
Hallo erikas,

ich danke für Deine ausführliche Antwort.
Nicht dafür, lieber jetzt Zuviel, aber dafür muss ich Dir im Nachhinein das Taschentuch nicht reichen, wenn Dir der Server "abraucht" und die Daten futsch sind.
Beim über lesen habe ich bemerkt, dass es sich ein wenig bissig ließt, es sei Dir vergewissert, es war nicht so gemeint.

Ich bin nicht der Spezie, aber meine erlebt zu haben, dass wenn ich ein Software Raid-1 im BIOS
umstelle und dann boote keinen Erfolg (Stopfehler) habe weil Windows den falschen Treiber lädt. - So > zumindest bei mir.
Nein, aber genau das meinte ich weiter oben, Du lieferst gute Fakten vorab und dann kommen die richtigen Sachen von den Leuten. Das ist kurz und schmerzlos erklärt und zwar alles!

1. Du hast ein RAID Level 1 und auf dem ist das Betriebssystem installiert!
Dort werden dann die Daten gespiegelt und doppelt vor gehalten, das bedeutet Du hast zweimal Dein Betriebssystem vorhanden!!!!! Wenn Du nun das RAID 1 auflöst und wieder bootest, ja woher soll denn nun
der Rechner wissen welches der beiden vorhandenen OS er nehmen soll! und woher soll denn nun Windows wissen von welcher Platte gebootet werden soll. Daher der Rat ein Image anzulegen, die Daten zu sichern
und dann die Platten zu formatieren und das image zurück zu spielen. Aber in Deinem Fall hilf es höchst wahrscheinlich schon eine Platte kurz abzuhängen und dann ist da auch nur noch ein OS was booten kann,
wenn der Masterboot Record auf dieser auch geschrieben wurde.

In der Reihenfolge 'Regeintrag ändern', 'Array im Controller Setup auflösen' geht das Booten dagegen
von Statten. Aber wie gesagt nur angelesen und angewendet, nicht verstanden... Profis sind gefragt.
Irgendwie kommt es mir so vor, als wenn Du das Raid auflösen möchtest und dann einfach so weiter arbeiten möchtest wie vorher, aber das wird so wohl nichts. Kann natürlich auch sein das ich mich hier irre, dann vorab ein "Entschuldigung" von mir.

Hast Du denn noch eine Idee warum der 'Server' nun einige Mal am Tag die Netzwerkverbindung kappt?
Naja wenn Du ein RAID eins "aufgesetzt" dann läuft ein System und die Daten werden nur auf eine anderen
Festplatte gespiegelt, aber wenn Du nun den RAID 1 Verbund auflöst hast Du zwei echte Systeme am laufen mit zwei identischen IP Adressen und dann kommt der Server, wenn er seinen Cache erneuert wohl durcheinander und die Verbindung bricht ab.

Auch wenn sich das jetzt irgendwie wieder bissig anhört, ich weiß es halt nicht anders zu umschreiben,
aber so eine "Work arround" Lösung streben wir doch alle mal an, kein Thema aber das muss dann eben auch Hand und Fuß haben. und ein Image ziehen, das RAID auflösen, und das Image auf eine Festplatte zurück spielen ist doch auch irgendwie schnell gemacht.

Grüße
E.

Gruß
Dobby
Bitte warten ..
Mitglied: erikas
12.09.2012 um 12:48 Uhr
Hey Dobby,
bist nicht bissig, keine Sorge.

Auf dem Raid 1 war dummer Weise tatsächlich das OS nebst Daten.
Nach dem Auflösen wie du richtig vermutest kurz erste Platte abgehängt und mit der zweiten Platte gestartet.
Erste Platte dran (SATA machts möglich) formatiert, fertig.
Daher denke ich IP oder sonstige Konflikte sind es nicht zumal die im Protokoll stehen müssten.

Ein image vorab zu ziehen macht m.E. weniger Sinn da Win7 nach einer Rückspielung auf eine einzelne, leere Platte dann doch wieder das RAID vermissen würde und damit nicht startet - oder?

Grüße
E.
Bitte warten ..
Mitglied: Dobby
12.09.2012 um 12:59 Uhr
Zitat von erikas:
Hey Dobby,
bist nicht bissig, keine Sorge.
Ok,
Ein image vorab zu ziehen macht m.E. weniger Sinn da Win7 nach einer Rückspielung auf eine einzelne,
leere Platte dann doch wieder das RAID vermissen würde und damit nicht startet - oder?
Das kann ich Dir leider nicht sagen.

Grüße
E.
Gruß
Dobby
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...