Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Treiberproblem mit WinServer2008-Startabbild (WDS)

Frage Entwicklung Installation

Mitglied: mr-hanky

mr-hanky (Level 1) - Jetzt verbinden

17.02.2010, aktualisiert 04.03.2010, 6617 Aufrufe, 3 Kommentare

Hi,

folgende Situation: In unserem Netzwerk steht der Umstieg auf Windows XP Prof bevor. Dafür habe ich WDS auf einem Server eingerichtet. Von einer Windows Server 2008 CD habe ich mir die boot.wim und die install.wim kopiert und damit ein Startabbild erstellt und daraus ein Aufzeichnungsabbild. Mit dem Aufzeichnungsabbild habe ich ein image von Windows XP erstellt.
Problem: Nun wollte ich dieses Image auf einer anderen Maschine installieren. Da konnte ich via PXE auch mit dem Longhorn-Startabbild booten. In dem Auswahlfenster wurde mir jedoch kein Installationsabbild angezeigt. Dank Google habe ich herausgefunden, dass es daran liegt, dass das Startabbild keine passenden Treiber für die Netzwerkkarte hat. In der Theorie kann man jetzt das Startabbild mit ImageX mounten und die Treiber integrieren. Ich habe aber gelesen, dass ich dafür nen Vista/Server2008 Rechner benötige. Sowas haben wir nicht und werden wir auch so bald nicht haben.
Frage: Gibt es eine andere Lösung für dieses Problem? Ein anderer Weg die Treiber zu integrieren? Ein anderes Startabbild nutzen, wo sich die Treiber integrieren lassen?

Danke schon mal im Vorraus,

Gruß Daniel
Mitglied: Edi.Pfisterer
17.02.2010 um 18:50 Uhr
Hallo!
Welches Serverbetriebssystem verwendest Du aktuell?
In der Überschrift lese ich WinServer2008, weiter unten steht dann "Sowas haben wir nicht"....

Ich vermute, du hast einen 2003SP2/3 im Einsatz.

Ich habe aktuell keine Erfahrung mit 2003 + WDS, denke aber, du wirst schon richtig gegoogelt haben, das diese Kombination manche Nachteile hat.

Trotzdem habe ich einen Lösungsansatz für Dich!

Versuche, den WDS wieder in den Legacymode zurückzubiegen (ist im Netz ausführlich beschrieben).
Danach gilt für Dich alles, was für RIS galt.

Eine ausführliche Anleitung für RIS gibts hier

Letzter Tipp: Manche Hersteller (zB Broadcom und Intel) haben eigene NIC-Treiber für RIS. du musst UNBEDINGT diese verwenden, ansonsten wirds nix werden mit dem imaging ....

Falls Du damit Probleme hast, einfach hier posten, welche NIC Du verbaut hast...

gutes gelingen
lg
Bitte warten ..
Mitglied: mr-hanky
04.03.2010 um 11:20 Uhr
Welches Serverbetriebssystem verwendest Du aktuell?
In der Überschrift lese ich WinServer2008, weiter unten steht dann "Sowas haben wir nicht"....

Das Image für das Startabbild ist von Windows Server 2008. In unserem Netzwerk nutzen wir aber nur Windows Server 2003 Enterprise.

Ich vermute, du hast einen 2003SP2/3 im Einsatz.

Rischtisch

Versuche, den WDS wieder in den Legacymode zurückzubiegen (ist im Netz ausführlich beschrieben).
Danach gilt für Dich alles, was für RIS galt.

Darüber habe ich lang und ausführlich ebenfalls nachgedacht. Ich finde die Image-Lösung aber nicht schlecht, weil ich mir jede nachträgliche Softwareinstallation erspare. Ich erstelle einfach für die diversen Software-Kombinationen jeweils ein eigenes Image.

Habe aber bereits eine Lösung gefunden: Wenn man einen installierten Windows Server 2008 oder Windows Vista/7 hat, kann man da das Microsoft Windows AIK installieren, dann mit dem Befehl

ImageX /mountrw "Pfad zu boot.wim" 2 C:\WinPE\mount
mounten. Dannach kann man mit dem Befehl

peimg /inf:"Pfad zu *.inf" C:\WinPE\mount
Treiber installieren. Zum Schluss müssen die Änderungen nur gespeichert und das Image unmountet werden:

ImageX /unmount /commit C:\WinPE\mount
Bitte warten ..
Mitglied: Edi.Pfisterer
04.03.2010 um 11:52 Uhr
Hoi!
schön, dass Du eine lösung gefunden hast...

zur ergünzung:
RIS bzw. WDS legacy kann ganze images anbieten (inkl. treibern u anwendungsprogrammen...)

vorgangsweise:
1 musterclient über RIS FLAT aufsetzen (dh, nur XP-sp3)
auf diesem mustercleint alles installieren

abschliessend durch aufruf von \\dc1\remoteinstall\blablabla\riprep
das ganze auf den server zurückspielen
unattendedfile anpassen --> fertig isses

anleitung gibts zb hier

lg
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Server
WDS mit PXE Linux (3)

Frage von HansWurstAugust zum Thema Windows Server ...

Windows Server
gelöst SCCM und WDS Server als separate Verteilungspunkte über PXE konfigurieren (1)

Frage von MiMa89 zum Thema Windows Server ...

Windows Server
WIM Images anpassen für WDS Server (5)

Frage von IT-Biene zum Thema Windows Server ...

Sicherheits-Tools
ESET Rescue CD per WDS PXE Boot (12)

Frage von bytetix zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...