Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Truecrypt NTFS Partition unter Linux einbinden Probleme

Frage Linux Linux Tools

Mitglied: BluBb-mADe

BluBb-mADe (Level 1) - Jetzt verbinden

14.04.2012, aktualisiert 18:52 Uhr, 5897 Aufrufe, 9 Kommentare

Hey Leute,

ich habe folgendes Probem:
Ich habe meine externe Festplatte unter Windows mit Truecrypt verschlüsselt und kann sie auch jederzeit unter windows mounten
jedoch bekomme ich wenn ich die selbe festplatte unter linux mounten will immer nur ne meldung "Incorrect password or not a TrueCrypt volume."
Ich habe es über das Linux GUI und auch über die shell versucht...aber es ist wie verhext...
ich habe automount, exakte parameter
01.
truecrypt --mount /dev/sdb1 /media/truecrypt1 --filesystem=ntfs-3g
,
automount im gui, explizit angegebene partitionen und alle kombinationen daraus schon ausprobiert...
das passwort tippe ich immer in englischem tastaturlayout ein
da ich nur eine deutsche tastatur habe und ich sonst irgendwo in einer englischen shell aufgeschmissen wäre.
Ich habe natürlich auch das tastaturlayout unter linux vorher auf englisch umgestellt.

Ich habe die Vermutung dass es daran liegt dass das Passwort "!" (und andere sonderzeichen) enthällt und das dieses (oder andere) von der shell als steuerzeichen erkannt wird.
jedoch bekomme ich keinerlei fehlermeldungen mit denen ich was anfangen könnte. Kann das prinzipiell sein?

Oder mache ich einen ganz banalen fehler und steh jetzt auf dem schlauch?

Gruß
BluBb_mADe

*edit
ubuntu kernel 3.2.6 x64 komplett dm-crypt luks verschlüsselt, truecrypt 7.1a, windows 7 x64 komplett truecrypt verschlüsselt, alles up2date
Mitglied: mak-xxl
14.04.2012 um 18:32 Uhr
Moin BluBb-mADe,

versuche das mounten einmal so:

ntfs-3g /dev/sdb1 /media/truecrypt1 -o streams_interface=windows
Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: BluBb-mADe
14.04.2012 um 18:46 Uhr
die gesammte externe patte is verschlüsselt nicht nur eine partition der platte...ich will NICHT die windows system partition mounten (was im übrigen auch nicht geht)
sondern nur die externe usb festplatte...

01.
ntfs-3g /dev/sdb1 /media/truecrypt1 -o streams_interface=windows
führt zu:
01.
NTFS signature is missing. 
02.
Failed to mount '/dev/sdb1': Invalid argument 
03.
The device '/dev/sdb1' doesn't seem to have a valid NTFS. 
04.
Maybe the wrong device is used? Or the whole disk instead of a 
05.
partition (e.g. /dev/sdb, not /dev/sdb1)? Or the other way around?
trotz dem danke für den schnellen vorschlag.
Bitte warten ..
Mitglied: mak-xxl
14.04.2012 um 19:21 Uhr
Moin BluBb-mADe,

Sorry, gesamte Platte:

truecrypt [--text] --filesystem=ntfs-3g --fs-options="rw,sync,utf8,uid=$UID,umask=0007" /dev/sdb1 /media/truecrypt1
Um Fehler beim Passwort auszuschließen, kannst Du sicherlich temporär das Ganze per Keyfile testen.

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: BluBb-mADe
14.04.2012 um 19:58 Uhr
Ich bekomm immer noch:

01.
truecrypt --text --filesystem=ntfs-3g --fs-options="rw,sync,utf8,uid=$UID,umask=0007" /dev/sdb1 /media/truecrypt1 
02.
Enter password for /dev/sdb1:  
03.
Protect hidden volume (if any)? (y=Yes/n=No) [No]: n 
04.
Incorrect password or not a TrueCrypt volume.
das is die info von fdisk über die platte:
01.
Disk /dev/sdb: 2000.4 GB, 2000398934016 bytes 
02.
255 heads, 63 sectors/track, 243201 cylinders 
03.
Units = cylinders of 16065 * 512 = 8225280 bytes 
04.
Sector size (logical/physical): 512 bytes / 512 bytes 
05.
I/O size (minimum/optimal): 512 bytes / 512 bytes 
06.
Disk identifier: 0x7d16bvc2 
07.
 
08.
   Device Boot      Start         End      Blocks   Id  System 
09.
/dev/sdb1   *           1      243202  1953513472    7  HPFS/NTFS
ich bin mir GANZ sicher dass das das richtige passwort ist.
ich habe extra zum test meine systempartition ein zweites mal
mit cryptsetup eingehängt, da ich dort das selbe passwort
verwende. und das funktioniert einwandfrei...warum zur hölle kann ich
die truecrypt platten nicht unter linux mounten...

mit keyfile meinst du, dass ich mir unter windows n keyfile anlege und das dann unter linux benutze denk ich mal...
das werde ich jetzt sofort tun...
ich melde gleich das ergebnis :D
Bitte warten ..
Mitglied: BluBb-mADe
14.04.2012 um 21:16 Uhr
sooo, das ergebnis:
keyfile=kein problem...
keyfile+passwort=geht nicht
passwort=geht nicht

wenn hier niemand sonst noch eine schlaue idee kommt muss ich es wohl dabei belassen...

*grummel*

Trotz dem danke.

Gruß
BluBb_mADe
Bitte warten ..
Mitglied: mak-xxl
14.04.2012 um 22:58 Uhr
Zitate von BluBb-mADe:

keyfile+passwort=geht nicht

Äußeres + Hidden-Volume? (-> KeyFile + KeyFile?) Dann aber so mounten:

truecrypt -k /home/user/keys --text --filesystem=ntfs-3g --fs-options="rw,sync,utf8,uid=$UID,umask=0007" /dev/sdb1 /media/truecrypt1
oder, besser (geschütztes Hidden-Volume):

truecrypt -P -K -k /home/user/keys --text --filesystem=ntfs-3g --fs-options="rw,sync,utf8,uid=$UID,umask=0007" /dev/sdb1 /media/truecrypt1
passwort=geht nicht

Das mit den Sonderzeichen oder generell kein Passwort?

wenn hier niemand sonst noch eine schlaue idee kommt muss ich es wohl dabei belassen...

Wenn Passwort mit Sonderzeichen fehlschlägt - andere Shell(s) probiert?
Unter Windows regulären Dismount ausgeführt?

Falls Konfusion über Äußeres + Hidden-Volume besteht und auch sonst immer - siehe hier.

*grummel*

Freundliche Grüße von der Insel - Mario
Bitte warten ..
Mitglied: BluBb-mADe
15.04.2012 um 17:14 Uhr
Nein es ist kein äußeres volumen und auch kein hidden.
Nichts irgendwie spezielles. Die ganz normale standardoption
gesammte platte verschlüsseln oder wie das heißt...

Es ist eine ganz normale mit Truecrypt partitioniert und verschlüsselte platte.
das passwort enthällt ziemlich viele verschiedene sonderzeichen...vieleicht macht das gui von
truecrypt nichts anderes als im hintergrund die shell zu bedienen...und dabei geht dann irgendwas schief
ich habe unter windows das passwort von der festplatte entfernt und statt
dessen ein keyfile erstellt mit dem ich das volumen auch unter linux einwandfrei mounten kann.
wenn ich jetzt jedoch das passwort unter windows wieder einrichte und das keyfile entferne geht es unter linux
wieder nicht...

aber unter windows funktioniert alles einwandfrei...

naja jetzt werd ich einfach jedes mal den ganzen mist auf keyfile ändern und dann so arbeiten...
Bitte warten ..
Mitglied: DerWoWusste
16.04.2012 um 00:04 Uhr
Moin.
Wären Zeichen des Kennwortes ein Problem, dann sollte es aber zumindest über die GUI gehen, oder? Auch könntest Du eine weitere Partition/Container erstellen und zum Test ein banales KW. nur aus Buchstaben bestehend wählen.
Bitte warten ..
Mitglied: BluBb-mADe
28.04.2012 um 13:23 Uhr
xDD
ich habe das Problem gefunden...
eine Taste ist unter linux anders belegt...
Windows DE="<" --> Windows EN="\"
Linux DE="<" --> Linux EN=">"

Warum auch immer...

naja jetzt weiß ich's

Gruß
BluBb_mADe
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Linux Netzwerk
Linux DNS Probleme (8)

Frage von winlin zum Thema Linux Netzwerk ...

Verschlüsselung & Zertifikate
Windows 7 über Truecrypt-Partition installiert (18)

Frage von user1985 zum Thema Verschlüsselung & Zertifikate ...

Windows 10
Windows 10 Anniversary Update zerstört Linux Partition (6)

Frage von klaraF zum Thema Windows 10 ...

Ubuntu
gelöst Linux neu erstellte vhd einbinden (2)

Frage von ClepToManix zum Thema Ubuntu ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (22)

Frage von patz223 zum Thema Windows Userverwaltung ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (19)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...