Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Trunk bei Cisco Switch einrichten

Frage Netzwerke Netzwerkmanagement

Mitglied: 91993

91993 (Level 1)

11.10.2012 um 15:54 Uhr, 3970 Aufrufe, 15 Kommentare

Hallo zusammen,

ich hab hier ein kleines Problem.

ih setze hier einige HP Pro Curve Switche ein. Der Trunk auf den HP Swichten ist bereits eingerichtet. Jetzt sind zwei Cisco Switche dazu gekommen. Ich habe jetzt die Cisco Switche konfiguriert sodass ich Änderungen über die Weboberfläche, Telnet und Cisco Network Assistant durchführen kann. Leider war ich noch nicht in der Lage einen einfach Trunk auf den Cisco Switchen erfolgreich einzurichten. Kann mir jemand sagen welche Befehle ich dafür benötige?

Danke und Gruß

AW3103
Mitglied: brammer
11.10.2012 um 16:12 Uhr
Hallo,

01.
ena  
02.
configure terminal 
03.
interface FastEthernet0/24 
04.
 description Trunk to .... 
05.
 switchport trunk encapsulation dot1q 
06.
 switchport mode trunk 
07.
end 
08.
wr me
brammer
Bitte warten ..
Mitglied: 91993
11.10.2012 um 16:23 Uhr
Hallo brammer,

danke für die schnelle Antwort. Bei der Eingabe von Zeile 5 bekomme ich diese Fehlermeldung: invalid input detected at ´^´marker. Der "marker" steht beim e von encapsulation.

Gruß

AW3103
Bitte warten ..
Mitglied: 91993
11.10.2012 um 16:27 Uhr
Jetzt ist mir noch was eingefallen. Wenn ich bei den HP´s einen Trunk einrichte gibt es den Befehl Trunk 2,4 trk2 lacp. Sprich ich gebe beim Befehl die Ports der Switche mit die zu einem Trunk werden sollen. Wie ist das denn beim Cisco Switch?
Bitte warten ..
Mitglied: MrNetman
11.10.2012 um 16:27 Uhr
Hi AW,

da gibt es noch die Hilfe auf der Kommandozeile:
switchport trunk ? Siehe http://www.cisco.com/en/US/docs/security/asa/asa82/command/reference/cl ... command help

GRruß
Netman
Bitte warten ..
Mitglied: MrNetman
11.10.2012, aktualisiert um 16:37 Uhr
Zitat von 91993:
Sprich ich gebe beim Befehl die Ports der Switche mit die zu einem Trunk werden sollen. Wie ist das denn beim Cisco Switch?
Was denkst du, was in Zeile 4 von brammer bei den Punkten stehen soll?
Außerdem ist es nur eine Beispielkonfiguration oder nimmst du einen Fast Ethernet Port dafür.
Außerdem ist Trunk als Begriff nicht ganz sauber, ganz eindeutig.
Kann sein:
Etherchannel, LACP ... die Kombination von Links.
VLAN-Port, Uplink-Port mit VLANs, kombinierter Edge und VoIP Port
Bitte warten ..
Mitglied: brammer
11.10.2012 um 16:51 Uhr
Hallo,

zeile 4 ist nur eine Beschreibung...

Wenn der der Siwtch das "switchport trunk encapsulation dot1q" nicht annimmt, was für ein cisco ist das mit welchem IOS?
Ist das evtl ein Lanlite Switch oder ein ganz altes schätzchen?
Du kannst auch immer ein "?" einsetzen dann bietet der Switch dir ein Hilfe an.

brammer
Bitte warten ..
Mitglied: dog
11.10.2012, aktualisiert um 17:09 Uhr
Wenn ich bei den HP´s einen Trunk einrichte gibt es den Befehl Trunk 2,4 trk2 lacp.

HALT!


Jetzt werden hier Begriffe durcheinandergeworfen.

Trunk bei HP = Bündelung mehrere Schnittstellen
Trunk bei Cisco = Port der mit Tagged VLANs arbeitet
HP Trunk bei Cisco = Bonding / Etherchannel
Cisco Trunk bei HP = Tagged Interface
Bitte warten ..
Mitglied: aqui
11.10.2012, aktualisiert um 18:01 Uhr
Genau !! Am besten benutzt man den Ausdruck LAG = Link Aggregation dann gibt es wenigstens kein Miussverständniss.
ACHTUNG Cisco benutzt bei Link Aggregation per Default sein proprietäres PaGP statt LACP.
Damit scheitert natürlich eine Link Aggregation zu HP. Fazit: LACP nutzen.
So wird es konfiguriert (2 Port LAG als Uplink (alle VLANs tagged) auf dem Cisco Port 0/1 und 0/2):
interface Port-channel 1
description 2 Port LAG zum HP mit Fa0/1 und Fa0/2
switchport mode trunk
(switchport trunk encapsulation dot1q)
!
interface FastEthernet0/1
switchport mode trunk
channel-group 1 mode active
!
interface FastEthernet0/2
switchport mode trunk
channel-group 1 mode active

Das "active" bewirkt das statt PaGP der Standard LACP verwendet wird den auch HP versteht.
Du solltest nachdem du die HP Gurken angeschlossen hast unbedingt ein "show etherchannel" eingeben um zu sehen das sich der aggregated Link sauber geformt hat !
Sinnvoll ist es das auf dem HP auch zu machen um beidseitig die korrekte Funktion des Trunks / Etherchannel zu verifizieren !!

Nebenbei: VORSICHT auch wenn du Spanning Tree verwendest. Die HP Billiggurken können kein PVST+ (Per VLAN Spanning Tree) was die Ciscos im Default verwenden. Wenn du ein redundantes Szenario hier hast mit Backup Links musst du da aufpassen im L2.
HP kann mit MSTP oder Single Span nur STP Protokolle aus der Steinzeit weils nichts kosten darf.
Wie gesagt, das gilt nur wenn du ein redundantes Netzwerk betreibst. Wenn es nur ein einseitiger Link ist kannst du das ignorieren und solltest ggf. "no spanning" auf den Cisco und HP Uplinks konfigurieren um STP hier ganz auszuschalten.
Bitte warten ..
Mitglied: brammer
11.10.2012 um 17:59 Uhr
Hallo,

Durch die Fragestellung gehe ich aber davon aus das hier ein Trunk zwischen den beiden ciscos gemeint war!
Bitte warten ..
Mitglied: aqui
11.10.2012, aktualisiert um 18:08 Uhr
Na ja wer Schwierigkeiten hat bei IOS einen Trunk, LAG einzurichten hat vermutlich auch etwas Schwierigkeiten die richtigen Hersteller spezifischen Termini für die Beschreibung zu finden....
Nachfragen ist also besser um uns hier unnötige Tipparbeit zu ersparen.
dogs Einwand ist also schon berechtigt um das klarzustellen was hier wirklich gewollt ist ?!
Letztlich hat AWG3103 ja aber nun beide Konfig Varianten fertig zum Abtippen und kann sich das für ihn gewollte ja frei aussuchen Es sei denn...
Seine Cisco Switches sind die SF oder SG non IOS Billigvarianten ?! Dazu sagt er aber sinnigerweise ja nix
Bitte warten ..
Mitglied: 91993
12.10.2012 um 09:23 Uhr
Guten Morgen zusammen,

danke erstmal für die vielen Meldungen. Hier nochmal kurz erklät was ich genau machen möcht um weitere Missverständnisse auszuschließen.

Ich habe hier einen Cisco WS-C2960S-48TS-L mit IOS 15.0.2 SE und möchte diesen Switch mit einem HP ProCurcve 2510G-48 (J9280A) mit einem Trunk verbinden. Den Trunk auf dem HP Switch habe ich bereits eingerichtet und erfolgreich getestet.

Leider hab ich es bis jetzt nicht geschafft den Trunk entsprechend auf dem Cisco Switch zu konfigurieren damit sich beide über diesen unterhalten können.

Gruß

AW3103
Bitte warten ..
Mitglied: MrNetman
12.10.2012 um 09:58 Uhr
Hallo AeWe3,
Leider hab ich es bis jetzt nicht geschafft den Trunk entsprechend auf dem Cisco Switch zu konfigurieren damit sich beide über diesen unterhalten können.
Wie hier schon oft erwähnt fehlt die, besser deine, Definition von Trunk. Siehe dog schreibt am 11.10.2012 um 17:08:06 Uhr
Willst du mehrere Ports verbinden oder einen Port mit VLANs?

bitte präzisieren und lesen

Gruß
Netman
Bitte warten ..
Mitglied: 91993
12.10.2012 um 10:11 Uhr
Hallo Netman,

ich möchte aus zwei Prots einen Trunk erstellen.

Danke und Gruß

AW3103
Bitte warten ..
Mitglied: aqui
12.10.2012, aktualisiert um 13:30 Uhr
Ächz, was für eine schwere Geburt um final mal mit dir das Wort Trunk zu klären !!
Also, es gilt die Nomenklatur die Kollege dog oben schon richtig angemahnt hat !
Bitte jetzt also mal lesen worum es da geht !!
Trunk beim Rest der Hersteller bedeutet Etherchannel bei Cisco !! Alles klar ?!?
Nur nochmal der Vertiefung, damit du es nicht schon wieder überliest !
Damit gilt dann die obige Cisco Beispielkonfiguration für dich einfach zum Abtippen.
Damit du auch das auch nicht wieder überliest ist sie deshalb in BLAU gehalten !
Einfach abtippen also auf deime 2960 (mit deinen Interface Nummern natürlich), die dort angemahnten Tips bitte wirklich lesen und beachten und du und dein HP "Trunk" werden glücklich sein....
(Ist ja heut' am Freitag nicht gerade einfach...)
Bitte warten ..
Mitglied: 91993
12.10.2012 um 13:40 Uhr
Hallo Aqui,

danke für die genervte Antwort Leider konfiguriere ich hier zum ersten Mal einen Cisco Switch. Bis jetzt hatte ich das Vergnügen nur mit anderen Switch Herstellern. Deswegen bitte ich Dich hier um etwas Nachsicht.

Danke und Gruß

AW3103
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
LAN, WAN, Wireless
VLAN Mikrotik keine Verbindung zum Gateway Cisco Switch (16)

Frage von Joshua2go zum Thema LAN, WAN, Wireless ...

Router & Routing
gelöst Kein Zugriff auf Cisco Switch SG300 über OpenVPN (4)

Frage von miuliu zum Thema Router & Routing ...

Voice over IP
Cisco 2600xm SIP Trunk autentifizieren

Frage von Herbrich19 zum Thema Voice over IP ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...