Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Ts3 Server wird geblockt

Frage Netzwerke Netzwerkprotokolle

Mitglied: Luciver1981

Luciver1981 (Level 1) - Jetzt verbinden

10.12.2013, aktualisiert 11.12.2013, 4874 Aufrufe, 57 Kommentare, 5 Danke

Hallo Admins bin am verzweifeln seit gestern geht mein Ts3 Server nichtmehr obwohl keinerlei Änderungen stattgefunden haben. Maschine ist ein Vserver auf dem Debian installiert ist. Der TS Server scheint sauber zu laufen es kann aber keiner verbinden.

ps -aux bringt folgendes zu tage
root         1  0.0  0.0  10320   748 ?        Ss   13:05   0:00 init [2] 
root         2  0.0  0.0      0     0 ?        S    13:05   0:00 [kthreadd/36858] 
root         3  0.0  0.0      0     0 ?        S    13:05   0:00 [khelper/36858] 
root       360  0.0  0.0   5912   700 ?        Ss   13:05   0:00 /sbin/syslogd 
110        371  0.0  0.0  21096   992 ?        Ss   13:05   0:00 /usr/bin/dbus-daemon --system 
avahi      383  0.0  0.0  31608  1420 ?        Ss   13:05   0:00 avahi-daemon: running [v36858.local] 
avahi      384  0.0  0.0  31608   504 ?        Ss   13:05   0:00 avahi-daemon: chroot helper 
root       458  0.0  0.0  17320  1444 ?        S    13:05   0:00 /bin/sh /usr/bin/mysqld_safe 
mysql      495  0.0  1.0 177964 22752 ?        Sl   13:05   0:01 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-external-locking --port=3306 --socket=/var/run/mysqld/mys 
root       496  0.0  0.0   3788   592 ?        S    13:05   0:00 logger -p daemon.err -t mysqld_safe -i -t mysqld 
root       572  0.0  0.1  71616  2544 ?        Ss   13:05   0:00 /usr/sbin/cupsd 
root       847  0.0  0.0  48872  1176 ?        Ss   13:05   0:00 /usr/sbin/sshd 
root       860  0.0  0.0 131272   988 ?        Ssl  13:05   0:00 /usr/sbin/nscd 
root       867  0.0  0.0  10124   652 ?        Ss   13:05   0:00 /usr/sbin/pptpd 
root       915  0.0  0.0  15736   864 ?        Ss   13:05   0:00 /usr/sbin/xinetd -pidfile /var/run/xinetd.pid -stayalive -inetd_compat -inetd_ipv6 
root       941  0.0  0.0  80488  1256 ?        S    13:05   0:00 /usr/sbin/smbd -D 
root       970  0.0  0.0   6184   796 ?        Ss   13:05   0:00 /usr/sbin/dhcdbd --system 
root      1018  0.0  0.0  39152  1828 ?        Ss   13:05   0:00 /usr/sbin/NetworkManager --pid-file /var/run/NetworkManager/NetworkManager.pid 
root      1026  0.0  0.0  24088  1280 ?        Ss   13:05   0:00 /usr/sbin/NetworkManagerDispatcher --pid-file /var/run/NetworkManager/NetworkManagerDispatcher.pid 
root      1039  0.0  0.0 113744  1764 ?        Ss   13:05   0:00 /usr/sbin/gdm 
root      1050  0.0  0.0  26572  1136 ?        Ss   13:05   0:00 /usr/bin/system-tools-backends 
proftpd   1062  0.0  0.0  68556  1556 ?        Ss   13:05   0:00 proftpd: (accepting connections) 
root      1082  0.0  0.0  10356   732 ?        Ss   13:05   0:00 /usr/sbin/cron 
root      1113  0.0  0.5 223132 12524 ?        Ss   13:06   0:00 /usr/sbin/apache2 -k start 
root      1159  0.0  0.7  71580 15396 ?        Ss   13:06   0:00 /usr/bin/perl /usr/share/webmin/miniserv.pl /etc/webmin/miniserv.conf 
www-data  1164  0.0  0.3 223132  6616 ?        S    13:06   0:00 /usr/sbin/apache2 -k start 
root      1405  0.0  0.2  69436  4268 ?        Ss   13:22   0:00 sshd: root@notty 
root      1407  0.0  0.1  36612  2128 ?        Ss   13:23   0:00 /usr/lib/openssh/sftp-server 
root      1434  0.0  0.1  68416  3020 ?        Ss   13:26   0:00 sshd: ts3-aktuell [priv] 
1009      1436  0.0  0.0  68416  1688 ?        S    13:26   0:00 sshd: ts3-aktuell@pts/1 
1009      1437  0.0  0.0   9800  1932 pts/1    Ss   13:26   0:00 -sh 
1009      1821  0.0  0.0   6536   856 pts/1    R+   13:54   0:00 ps -aux
Iptables -L

sagt das keine Regeln bestehen also auch nichts geblockt wird

netstat -tulpen
Proto Recv-Q Send-Q Local Address           Foreign Address         State       User       Inode       PID/Program name 
tcp        0      0 0.0.0.0:10000           0.0.0.0:*               LISTEN      0          3950232050  - 
tcp        0      0 127.0.0.1:30033         0.0.0.0:*               LISTEN      1009       1531547281  2005/ts3server_linu 
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      0          3938598675  - 
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN      0          3938208215  - 
tcp        0      0 127.0.0.1:10011         0.0.0.0:*               LISTEN      1009       1531720395  2005/ts3server_linu 
tcp        0      0 0.0.0.0:1723            0.0.0.0:*               LISTEN      0          3938702868  - 
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      107        3937373926  - 
tcp6       0      0 :::80                   :::*                    LISTEN      0          3945125101  - 
tcp6       0      0 :::21                   :::*                    LISTEN      108        3941885290  - 
tcp6       0      0 :::22                   :::*                    LISTEN      0          3938598464  - 
udp        0      0 127.0.0.1:55000         0.0.0.0:*                           1009       1531719332  2005/ts3server_linu 
udp        0      0 0.0.0.0:5353            0.0.0.0:*                           111        3936025153  - 
udp        0      0 0.0.0.0:52845           0.0.0.0:*                           111        3936025275  - 
udp        0      0 0.0.0.0:631             0.0.0.0:*                           0          3938208407  - 
udp        0      0 127.0.0.1:9987          0.0.0.0:*                           1009       1531609273  2005/ts3server_linu 
udp        0      0 0.0.0.0:10000           0.0.0.0:*                           0          3950232051  - 
udp        0      0 127.0.0.1:9000          0.0.0.0:*                           1009       1531653221  2005/ts3server_linu 
udp        0      0 127.0.0.1:9001          0.0.0.0:*                           1009       1531673424  2005/ts3server_linu 
udp        0      0 127.0.0.1:9002          0.0.0.0:*                           1009       1531699226  2005/ts3server_linu 
udp6       0      0 :::58595                :::*                                111        3936025282  - 
udp6       0      0 :::5353                 :::*                                111        3936025205  - 
udp6       0      0 :::517                  :::*                                0          3939418501  - 
udp6       0      0 :::518                  :::*                                0          3939418515  -
Hat jemand eine idee was dazwischen funken könnte?

57 Antworten
Mitglied: Cthluhu
10.12.2013, aktualisiert um 14:18 Uhr
Hi,
Zitat von Luciver1981:
Der TS Server scheint sauber zu laufen
Wie kommst du zu dieser Erkenntnis?
IMHO sollte teamspeak als ts3server_linux_amd64 mit ps aux sichtbar sein. Das seh ich bei dir aber jetzt nicht.
Was sagen die logs?
Was passiert wenn du mit telnet versuchst auf zu offenen ports zuzugreifen?

Mit freundlichen Grüßen

Cthluhu
Bitte warten ..
Mitglied: Luciver1981
10.12.2013, aktualisiert 11.12.2013
Hallo ja zu dem Zeitpunkt war er nicht an jetzt ist er da.
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND 
root         1  0.0  0.0  10320   748 ?        Ss   13:05   0:00 init [2] 
root         2  0.0  0.0      0     0 ?        S    13:05   0:00 [kthreadd/36858] 
root         3  0.0  0.0      0     0 ?        S    13:05   0:00 [khelper/36858] 
root       360  0.0  0.0   5912   700 ?        Ss   13:05   0:00 /sbin/syslogd 
110        371  0.0  0.0  21096   992 ?        Ss   13:05   0:00 /usr/bin/dbus-daemon --system 
avahi      383  0.0  0.0  31608  1420 ?        Ss   13:05   0:00 avahi-daemon: running [v36858.local] 
avahi      384  0.0  0.0  31608   504 ?        Ss   13:05   0:00 avahi-daemon: chroot helper 
root       458  0.0  0.0  17320  1444 ?        S    13:05   0:00 /bin/sh /usr/bin/mysqld_safe 
mysql      495  0.0  1.0 177964 22880 ?        Sl   13:05   0:01 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-external-locking --port=3306 --socket=/var/run/mysqld/mys 
root       496  0.0  0.0   3788   592 ?        S    13:05   0:00 logger -p daemon.err -t mysqld_safe -i -t mysqld 
root       572  0.0  0.1  71616  2544 ?        Ss   13:05   0:00 /usr/sbin/cupsd 
root       847  0.0  0.0  48872  1176 ?        Ss   13:05   0:00 /usr/sbin/sshd 
root       860  0.0  0.0 131272   988 ?        Ssl  13:05   0:00 /usr/sbin/nscd 
root       867  0.0  0.0  10124   652 ?        Ss   13:05   0:00 /usr/sbin/pptpd 
root       915  0.0  0.0  15736   864 ?        Ss   13:05   0:00 /usr/sbin/xinetd -pidfile /var/run/xinetd.pid -stayalive -inetd_compat -inetd_ipv6 
root       941  0.0  0.0  80488  1256 ?        S    13:05   0:00 /usr/sbin/smbd -D 
root       970  0.0  0.0   6184   796 ?        Ss   13:05   0:00 /usr/sbin/dhcdbd --system 
root      1018  0.0  0.0  39152  1828 ?        Ss   13:05   0:00 /usr/sbin/NetworkManager --pid-file /var/run/NetworkManager/NetworkManager.pid 
root      1026  0.0  0.0  24088  1280 ?        Ss   13:05   0:00 /usr/sbin/NetworkManagerDispatcher --pid-file /var/run/NetworkManager/NetworkManagerDispatcher.pid 
root      1039  0.0  0.0 113744  1764 ?        Ss   13:05   0:00 /usr/sbin/gdm 
root      1050  0.0  0.0  26572  1136 ?        Ss   13:05   0:00 /usr/bin/system-tools-backends 
proftpd   1062  0.0  0.0  68556  1556 ?        Ss   13:05   0:00 proftpd: (accepting connections) 
root      1082  0.0  0.0  10356   732 ?        Ss   13:05   0:00 /usr/sbin/cron 
root      1113  0.0  0.5 223132 12524 ?        Ss   13:06   0:00 /usr/sbin/apache2 -k start 
root      1159  0.0  0.7  71580 15396 ?        Ss   13:06   0:00 /usr/bin/perl /usr/share/webmin/miniserv.pl /etc/webmin/miniserv.conf 
www-data  1164  0.0  0.3 223212  8284 ?        S    13:06   0:00 /usr/sbin/apache2 -k start 
root      1405  0.0  0.2  69436  4268 ?        Ss   13:22   0:00 sshd: root@notty 
root      1407  0.0  0.1  36612  2128 ?        Ss   13:23   0:00 /usr/lib/openssh/sftp-server 
root      1434  0.0  0.1  68416  3020 ?        Ss   13:26   0:00 sshd: ts3-aktuell [priv] 
1009      1436  0.0  0.0  68416  1688 ?        S    13:26   0:00 sshd: ts3-aktuell@pts/1 
1009      1437  0.0  0.0   9824  1972 pts/1    Ss   13:26   0:00 -sh 
www-data  1973  0.0  0.4 223400  9404 ?        S    14:14   0:00 /usr/sbin/apache2 -k start 
1009      2005  1.5  1.1 220256 24532 pts/1    Sl   14:16   0:03 ./ts3server_linux_amd64 
root      2034  0.0  0.0  31624  1144 pts/1    S    14:17   0:00 su 
root      2035  0.0  0.0   9328  1640 pts/1    S    14:17   0:00 bash 
root      2040  0.0  0.0   6536   852 pts/1    R+   14:19   0:00 ps -aux
per Serverquery funktioniert. Aber z.b. der Standartport 9987 scheint nicht zu funktionieren.

Logs des TS:
2013-12-10 13:27:40.037637|INFO    |ServerLibPriv |   | TeamSpeak 3 Server 3.0.10.1 (2013-11-08 11:09:56) 
2013-12-10 13:27:40.037854|INFO    |ServerLibPriv |   | SystemInformation: Linux 2.6.32-042stab076.7 #1 SMP Thu Apr 25 13:35:47 MSK 2013 x86_64 Binary: 64bit 
2013-12-10 13:27:40.040712|INFO    |DatabaseQuery |   | dbPlugin name:    SQLite3 plugin, Version 2, (c)TeamSpeak Systems GmbH 
2013-12-10 13:27:40.040756|INFO    |DatabaseQuery |   | dbPlugin version: 3.7.3 
2013-12-10 13:27:40.041058|INFO    |DatabaseQuery |   | checking database integrity (may take a while) 
2013-12-10 13:27:40.238334|INFO    |Accounting    |   | Your license was updated by the licensing server 
2013-12-10 13:27:40.247069|INFO    |Accounting    |   | Licensing Information 
2013-12-10 13:27:40.247130|INFO    |Accounting    |   | type              : Non-profit 
2013-12-10 13:27:40.247186|INFO    |Accounting    |   | starting date     : Wed May 23 00:00:00 2012 
2013-12-10 13:27:40.247206|INFO    |Accounting    |   | ending date       : Fri Nov 23 00:00:00 2012 
2013-12-10 13:27:40.247223|INFO    |Accounting    |   | max virtualservers: 10 
2013-12-10 13:27:40.247238|INFO    |Accounting    |   | max slots         : 512 
2013-12-10 13:27:42.419238|INFO    |              |   | Puzzle precompute time: 2145 
2013-12-10 13:27:42.419728|INFO    |FileManager   |   | listening on 0.0.0.0:30033 
2013-12-10 13:27:42.952078|INFO    |CIDRManager   |   | updated query_ip_whitelist ips: 127.0.0.1,  
2013-12-10 13:27:42.952581|INFO    |Query         |   | listening on 0.0.0.0:10011 
2013-12-10 13:27:43.082219|INFO    |              |   | License expired, but there is a new one available.. retrieving 
2013-12-10 13:27:43.138016|INFO    |              |   | License expired, but there is a new one available.. retrieving 
2013-12-10 13:27:43.178974|INFO    |              |   | License expired, but there is a new one available.. retrieving 
2013-12-10 13:27:43.215263|INFO    |Accounting    |   | Your license was updated by the licensing server 
2013-12-10 13:27:43.305450|INFO    |Accounting    |   | Licensing Information 
2013-12-10 13:27:43.305525|INFO    |Accounting    |   | type              : Non-profit 
2013-12-10 13:27:43.305557|INFO    |Accounting    |   | starting date     : Thu Nov 14 00:00:00 2013 
2013-12-10 13:27:43.305578|INFO    |Accounting    |   | ending date       : Fri May 23 00:00:00 2014 
2013-12-10 13:27:43.305595|INFO    |Accounting    |   | max virtualservers: 10 
2013-12-10 13:27:43.305611|INFO    |Accounting    |   | max slots         : 512
Bitte warten ..
Mitglied: SlainteMhath
10.12.2013 um 14:40 Uhr
Moin,

check doch mal deine Config. Sieht aus als würde der TS nur an localhost lauschen

01.
udp 0 0 127.0.0.1:9987 0.0.0.0:* 1009 1531609273 2005/ts3server_linu
lg,
Slainte

PS und pipe deine Ausgaben doch mal durch grep "ts3server", dann werden deine posts etwas kürzer.
Bitte warten ..
Mitglied: Luciver1981
10.12.2013 um 14:45 Uhr
Welche Config meinste Sainte? Und es reicht doch auch wenn er an localhost lauscht? bei der grep "ts3server" passiert garnichts
Bitte warten ..
Mitglied: SlainteMhath
10.12.2013 um 14:53 Uhr
Welche Config meinste Sainte?
Die vom ts3server? Da gibts doch sicher ein config file oder ähnliches.

Und es reicht doch auch wenn er an localhost lauscht?
Nur wenn du nicht über's Netzwerk connecten willst. Ansonsten müsste der ts3server einen ähnlichen Eintrag im netstat haben wie z.b. ssh
01.
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 0 3938598675 -
also LocalAdress = 0.0.0.0 (alle) und nicht 127.0.0.1 (localhost)

Ich meine die Ausgaben durch grep pipen.. etwa so:
01.
netstat -tulpen | grep "ts3server"
Bitte warten ..
Mitglied: Luciver1981
10.12.2013, aktualisiert 11.12.2013
Nein es gibt leider kein configfile sondern das ist in einer Datenbank abgespeichert.

der Grep:
tcp        0      0 0.0.0.0:30033           0.0.0.0:*               LISTEN      1009       2070198499  2917/ts3server_linu 
tcp        0      0 0.0.0.0:10011           0.0.0.0:*               LISTEN      1009       2070449753  2917/ts3server_linu 
udp        0      0 0.0.0.0:55000           0.0.0.0:*                           1009       2070448917  2917/ts3server_linu 
udp        0      0 0.0.0.0:9987            0.0.0.0:*                           1009       2070246186  2917/ts3server_linu 
udp        0      0 0.0.0.0:9000            0.0.0.0:*                           1009       2070295975  2917/ts3server_linu 
udp        0      0 0.0.0.0:9001            0.0.0.0:*                           1009       2070342310  2917/ts3server_linu 
udp        0      0 0.0.0.0:9002            0.0.0.0:*                           1009       2070393909  2917/ts3server_linu
mir fällt auf das dort das listen fehlt and den anderen Ports. Port 10011 was der Query Port ist läuft.
Bitte warten ..
Mitglied: Cthluhu
10.12.2013 um 15:04 Uhr
Hi,

Dein netstat zeigt
udp 0 0 127.0.0.1:9987 0.0.0.0:* 1009 1531609273 2005/ts3server_linux

Da sollte aber 0.0.0.0:9987 stehen. Mit 127.0.0.1. geht nur localhost. D.h. du müsstest den Client auf der selben Maschine wie den Sever laufen lassen.

Mit freundlichen Grüßen

Cthluhu
Bitte warten ..
Mitglied: Luciver1981
10.12.2013 um 15:06 Uhr
Das hatte ich nur zu Testzwecken mit 127.0.0.1 ist wieder auf Standart 0.0.0.0
Bitte warten ..
Mitglied: apfelqoo
10.12.2013 um 15:07 Uhr
Poste mal bitte den Inhalt deiner ts3 config, welche da "ts3server.ini" heißt.
Bitte warten ..
Mitglied: Luciver1981
10.12.2013 um 15:09 Uhr
Ist eine Linuxmaschine und da gibt es meines Wissens keine ts3server.ini sondern ist in der ts3server.sqlitedb
Bitte warten ..
Mitglied: Luciver1981
10.12.2013 um 15:12 Uhr
DAs Problem scheint zu sein das er nicht die Ports 9987,9000,9001,9002 abhört. Aber wie kann ich das wieder hinbiegen?
Bitte warten ..
Mitglied: apfelqoo
10.12.2013 um 15:12 Uhr
Doch, die hast du 100 prozentig

Die ts3server.sqlitedb enthält "nur" die Datenbank mit den eigentlichen Servern, Benutzern, Rechten etc.
Bitte warten ..
Mitglied: Luciver1981
10.12.2013 um 15:18 Uhr
Hab ich keine dazu müsste man den server speziell starten und dort creatini machen.
Bitte warten ..
Mitglied: Luciver1981
10.12.2013, aktualisiert 11.12.2013
Wenn ich ./ts3server_linux_amd64 createinifile=1 ausführe kommt folgende Fehlermeldung
2013-12-10 14:18:52.635028|INFO    |ServerLibPriv |   | TeamSpeak 3 Server 3.0.10.1 (2013-11-08 11:09:56) 
2013-12-10 14:18:52.635166|INFO    |ServerLibPriv |   | SystemInformation: Linux 2.6.32-042stab076.7 #1 SMP Thu Apr 25 13:35:47 MSK 2013 x86_64 Binary: 64bit 
2013-12-10 14:18:52.635389|INFO    |DatabaseQuery |   | Please make sure you use the supplied ts3server_minimal_runscript.sh to run the server, or set LD_LIBRARY_PATH yourself 
2013-12-10 14:18:52.635419|CRITICAL|DatabaseQuery |   | unable to load database plugin library "libts3db_sqlite3.so", halting!
Bitte warten ..
Mitglied: Cthluhu
10.12.2013 um 15:23 Uhr
Zitat von apfelqoo:

Doch, die hast du 100 prozentig
Eine server.ini gibts bei der Linux version tatsächlich nicht (hab ich auch keine und läuft trotzdem).

Zitat von Luciver1981:

DAs Problem scheint zu sein das er nicht die Ports 9987,9000,9001,9002 abhört. Aber wie kann ich das wieder hinbiegen?
Die Ports werden schon abgehört. Das sieht man an den 0.0.0.0:9987 einträgen in der Ausgabe von netstat.

Probier mal nmap.
nmap -sU -p 9987 localhost
Wobei localhost durch die externen IP/Hostnamen deines Server ersetzt werden soll (kannst auch gern mal mit localhost probieren, wenn du direct am Server eingeloggt bist). Das checkt ob der UPD Port 9987 tatsächlich offen ist.
Bitte warten ..
Mitglied: Luciver1981
10.12.2013, aktualisiert um 15:25 Uhr
nmap kennt mein debian nicht ist noch die 5
Bitte warten ..
Mitglied: Xolger
10.12.2013 um 15:27 Uhr
Ich denke
01.
apt-get install nmap
sollte helfen.

Gruß
Xolger
Bitte warten ..
Mitglied: Luciver1981
10.12.2013 um 15:31 Uhr
Oh man bin ich dumm. Dachte das wäre ein Standartbefehl. Hab jetzt nmap -sU -p 9987 127.0.0.1 direkt über ssh ausgeführt und folgendes erhalten:
9987/udp open|filtered unknown
Bitte warten ..
Mitglied: Cthluhu
10.12.2013, aktualisiert um 15:32 Uhr
Zitat von Luciver1981:

nmap kennt mein debian nicht ist noch die 5
Das musst du dann halt nachinstallieren. IMHO ist nmap bei debian squeeze dabei gewesen.
Du musst da aber auch nicht am server installieren. Das wär sogar förderlich, wenn du das von einem anderen Rechner aus testet.

EDIT: da war ich wohl zu langsam mit dem Tippen.
Bitte warten ..
Mitglied: Cthluhu
10.12.2013 um 15:32 Uhr
Zitat von Luciver1981:

Oh man bin ich dumm. Dachte das wäre ein Standartbefehl. Hab jetzt nmap -sU -p 9987 127.0.0.1 direkt über ssh
ausgeführt und folgendes erhalten:
9987/udp open|filtered unknown
Ok, das sieht gut auf. Und jetzt nmap auf einem anderen Rechner (127.0.0.1 auf die externe IP des Server umschreiben nicht vergessen) laufen lassen.
Bitte warten ..
Mitglied: Luciver1981
10.12.2013 um 15:45 Uhr
Ok habs auf meiner Windows maschine gemacht: 9987/udp open|filtered unknown
Bitte warten ..
Mitglied: Cthluhu
10.12.2013 um 15:54 Uhr
Zitat von Luciver1981:

Ok habs auf meiner Windows maschine gemacht: 9987/udp open|filtered unknown

Dann sollte Teamspeak der Teamspeak client ja auf deiner Windows Machine zu deinem Server connecten können. Teste mal die anderen nötigen ports mit
nmap -p 10011 $HOSTNAME
bzw
nmap -p 30033 $HOSTNAME
von deiner Windows Kiste aus.
Bitte warten ..
Mitglied: Luciver1981
10.12.2013, aktualisiert um 16:02 Uhr
Sind beide offen, über den Queryport also 10011 komm ich ja auch auf die maschine nurnicht mit dem Client auf die 9987,9000,9001,9002 aber bei dem nmap von 9987 steht filterd wie kann das sein für den Port gibts keine regel in iptables.
Bitte warten ..
Mitglied: apfelqoo
10.12.2013 um 16:17 Uhr
Zitat von Cthluhu:

> Zitat von apfelqoo:
>
> Doch, die hast du 100 prozentig
Eine server.ini gibts bei der Linux version tatsächlich nicht (hab ich auch keine und läuft trotzdem).

> Zitat von Luciver1981:
>
> DAs Problem scheint zu sein das er nicht die Ports 9987,9000,9001,9002 abhört. Aber wie kann ich das wieder hinbiegen?
Die Ports werden schon abgehört. Das sieht man an den 0.0.0.0:9987 einträgen in der Ausgabe von netstat.

Probier mal nmap.
nmap -sU -p 9987 localhost
Wobei localhost durch die externen IP/Hostnamen deines Server ersetzt werden soll (kannst auch gern mal mit localhost probieren,
wenn du direct am Server eingeloggt bist). Das checkt ob der UPD Port 9987 tatsächlich offen ist.

Entschuldigung, mein Fehler - wenn die TS3 DB nicht auf SQLite sondern mysql läuft benötigt man eine zusätzliche config. Man benötigt sie außerdem, wenn man möchte, dass der Server nur auf einer bestimmten IP Adressen von außen erreichbar ist. bzw. um den qry port zu ändern.
Bitte warten ..
Mitglied: Luciver1981
10.12.2013 um 16:26 Uhr
In der Log vom Virtuellen Server steht:
2013-12-10 14:21:20.620824|INFO |VirtualServer | 1| listening on 0.0.0.0:9987

ist doch ok so oder?
Bitte warten ..
Mitglied: Cthluhu
10.12.2013 um 16:31 Uhr
Zitat von Luciver1981:
2013-12-10 14:21:20.620824|INFO |VirtualServer | 1| listening on 0.0.0.0:9987

ist doch ok so oder?
Ja, das passt. Gibt beim Teamspeak Client ein log? Wie lautet die Fehlermeldung am Client genau?
Bitte warten ..
Mitglied: Luciver1981
10.12.2013 um 18:02 Uhr
es kommt nur das er nicht mit dem Server verbinden kann
Bitte warten ..
Mitglied: Luciver1981
10.12.2013 um 18:27 Uhr
mit ss -tlnp kommt nur der queryport aber nicht die anderen ports des TS
Bitte warten ..
Mitglied: Cthluhu
10.12.2013 um 18:33 Uhr
Zitat von Luciver1981:

mit ss -tlnp kommt nur der queryport aber nicht die anderen ports des TS
Is ja klar weil du mit "-t" auf TCP einschränkst. Der 9987 des TS ist aber ein UDP Port.
Bitte warten ..
Mitglied: Luciver1981
10.12.2013 um 18:41 Uhr
upss stimmt. komme trotzdem nichtmehr weiter hab auch noch einen ts3server erstellt das gleiche
Bitte warten ..
Mitglied: Cthluhu
10.12.2013 um 18:43 Uhr
Du unterschlägst uns immer noch das Log vom Client.

Kommst du denn mit dem Client auf andere TS3-Server? (Nicht dass gar an deiner Windows Kiste liegt und wir hier an der falschen stelle suchen.)
Bitte warten ..
Mitglied: Luciver1981
10.12.2013, aktualisiert 11.12.2013
Ja klar komm ich auf andere Server nur unser Server ist nicht erreichbar hab langsam die befürchtung das es an der Lizenz liegt??? siehe erster post

hier der log:
2013-12-10 18:05:27.882449|INFO    |ClientUI      |  1| Initiating connection: *.*.*.*:9987  
2013-12-10 18:05:27.960454|INFO    |ClientUI      |  1| Connect status: Connecting 
2013-12-10 18:05:33.587776|INFO    |ClientUI      |  1| Connect status: Disconnected 
2013-12-10 18:05:33.588776|INFO    |ClientUI      |  1| Failed to connect to server, want autoreconnect = 0
Bitte warten ..
Mitglied: Cthluhu
10.12.2013 um 20:04 Uhr
An der Lizenz liegt es glaube icht nicht. Der TS3 Server läuft auch ohne Lizenz (halt dann nur ein default Server auf 9987 mit nur wenigen Slots, aber fürs connecten braucht man noch keine Lizenz).

Liegt da vielleicht noch eine Firewall irgendwo quer? Am Router bei dir oder am Router vorm TS3 Server?

Schau mal mit Wireshark oder tcpdump lokal und am Server ob da UDP Pakete auf Port 9987 vorbeikommen, wenn du dich mit dem TS Client verbinden willst. Wenn die UDP-Pakete nur in eine Richtung kommen, passt noch eine Firewall Einstellung nicht.
Bitte warten ..
Mitglied: Luciver1981
10.12.2013 um 20:08 Uhr
Also an meinen router kann es nicht liegen da alle nicht drauf kommen und es ist ein VSERVER und Iptables sind die Ports freigegeben.
Bitte warten ..
Mitglied: Luciver1981
10.12.2013 um 20:24 Uhr
Wenn ich ihn als root laufen lasse geht er????? Was kann ich tun?
Bitte warten ..
Mitglied: Cthluhu
10.12.2013 um 21:05 Uhr
Zitat von Luciver1981:

Wenn ich ihn als root laufen lasse geht er????? Was kann ich tun?
Zugriffsrechte kontrollieren!
Wie sind die Zugriffsrechte auf die Dateien des Teamspeak Servers?
Bitte warten ..
Mitglied: Luciver1981
10.12.2013 um 21:19 Uhr
Wie kann ich die rechte für den kompeltten ordner mit allen unterordner und dateien auf einmal 777 setzen?
Bitte warten ..
Mitglied: 16568
10.12.2013 um 22:18 Uhr
Zitat von Luciver1981:

Wie kann ich die rechte fügr den kompeltten ordner mit allen unterordner und dateien auf einmal 777 setzen?

Leute, ab hier wirds gefährlich!
Threadstarter ist nicht mal in der Lage, in die richtige Kategorie zu posten, und spätestens bei der Frage nach 777 wird es Zeit für den Linux-Grundkurs.


Lonesome Walker
Bitte warten ..
Mitglied: Xolger
10.12.2013, aktualisiert um 22:36 Uhr
Gib mal
01.
man chmod
ein. Dann sollte es kein Problem sein.
Aber immer schön vorsichtig.


Gruß
Xolger
Bitte warten ..
Mitglied: SlainteMhath
11.12.2013 um 08:44 Uhr
Moin,

vielleicht hilft's auch erstmal per
01.
chown
den ts3 user zum Owner aller Files und Dirs der s2 installation zu machen Du bevor mit du mit chmod 777 um dich wirfst (wenn dann würde ich's eh erstmal mit 740 versuchen)

lg,
Slainte
Bitte warten ..
Mitglied: Luciver1981
11.12.2013, aktualisiert 12.12.2013
Ok läuft wieder Danke an Alle.
Bitte warten ..
Mitglied: SlainteMhath
11.12.2013 um 10:54 Uhr
Zitat von Luciver1981:
Ok läuft wieder Danke an alle außer Walker dein blöden Kommentar kannst dir sparen hast nichts zum Thema
beigetragen.
Naja, ganz unrecht hat er ja nicht. Verrate uns doch bitte noch was jetzt die Lösung war.
Bitte warten ..
Mitglied: Luciver1981
12.12.2013 um 09:03 Uhr
Ich weis das ich kein Linuxguru bin, eher learning by doing aber mich regt es auf wenn sich Leute einmischen und nur dumme Kommentare von sich geben aber nicht an der Lösungsfindung beteiligen. Ok also es lag doch an den Berechtigungen gelegen. Aber da hätte eigentlich TS loggen müssen das die Datenbank nicht geöffnet bzw. geschrieben werden kann. Hab jetzt alles auf 755 sollte so ok sein?
Bitte warten ..
Mitglied: SlainteMhath
12.12.2013 um 09:15 Uhr
"Ich weis das ich kein Straßenverkehrs Guru bin, eher learning by doing, das nächste mal halt' ich dann auch am Zebrastreifen an..."

Oder: ist der Server erstmal gehackt und verbreitet spam/kipo/malware werden die Gesichter lang (und die Fragen hier im Forum wieder hektischer )
Aber egal, das gehört nicht in den Thread hier.

Hab jetzt alles auf 755 sollte so ok sein?
740 wäre besser - mit 755 kann dir immer noch jeder in die Config bzw Shellscripts schreiben.
Bitte warten ..
Mitglied: Luciver1981
12.12.2013 um 10:25 Uhr
Naja bin sehr vorsichtig mit dem Server gibt eigentlich nur verschlüsselte Verbindungen mal vom TS abgesehen, FTP und Sendmail usw ist alles deaktiviert.
Bitte warten ..
Mitglied: SlainteMhath
12.12.2013 um 10:43 Uhr
Naja bin sehr vorsichtig mit dem Server gibt eigentlich nur verschlüsselte Verbindungen mal vom TS abgesehen, FTP und
Sendmail usw ist alles deaktiviert.
Ahso?

Prozesse:
01.
root       572  0.0  0.1  71616  2544 ?        Ss   13:05   0:00 /usr/sbin/cupsd  
02.
root       867  0.0  0.0  10124   652 ?        Ss   13:05   0:00 /usr/sbin/pptpd  
03.
root       941  0.0  0.0  80488  1256 ?        S    13:05   0:00 /usr/sbin/smbd -D  
04.
proftpd   1062  0.0  0.0  68556  1556 ?        Ss   13:05   0:00 proftpd: (accepting connections)  
05.
root      1113  0.0  0.5 223132 12524 ?        Ss   13:06   0:00 /usr/sbin/apache2 -k start  
06.
root      1159  0.0  0.7  71580 15396 ?        Ss   13:06   0:00 /usr/bin/perl /usr/share/webmin/miniserv.pl /etc/webmin/miniserv.conf 
und hier die entsprechenden Offenen Ports dazu:
01.
Proto Recv-Q Send-Q Local Address           Foreign Address         State       User       Inode       PID/Program  
02.
tcp        0      0 0.0.0.0:10000           0.0.0.0:*               LISTEN      0          3950232050  -  
03.
tcp        0      0 0.0.0.0:1723            0.0.0.0:*               LISTEN      0          3938702868  -  
04.
tcp6       0      0 :::80                   :::*                    LISTEN      0          3945125101  -  
05.
tcp6       0      0 :::21                   :::*                    LISTEN      108        3941885290  -  
06.
udp        0      0 0.0.0.0:5353            0.0.0.0:*                           111        3936025153  -  
07.
udp        0      0 0.0.0.0:52845           0.0.0.0:*                           111        3936025275  -  
08.
udp        0      0 0.0.0.0:631             0.0.0.0:*                           0          3938208407  -  
09.
udp        0      0 0.0.0.0:10000           0.0.0.0:*                           0          3950232051  -  
10.
udp6       0      0 :::58595                :::*                                111        3936025282  -  
11.
udp6       0      0 :::5353                 :::*                                111        3936025205  -  
12.
udp6       0      0 :::517                  :::*                                0          3939418501  -  
13.
udp6       0      0 :::518                  :::*                                0          3939418515  -
und das ganze gepaart mit
Iptables -L
sagt das keine Regeln bestehen also auch nichts geblockt wird

Offensichtlich unterscheiden sich unsere Definitionen von "vorsichtig" und "nur verschlüsselte Verbindungen" gewaltig :P

Naja, las mal gut sein
Bitte warten ..
Mitglied: Luciver1981
12.12.2013 um 13:13 Uhr
Ok FTP war wieder an nach Neustart aber lokkathost zeigt mir nur ssh webmin und Http als aktiv offene dienste an. Sicherlich fehlt dort udp
Bitte warten ..
Mitglied: SlainteMhath
12.12.2013 um 13:41 Uhr
Und stell dir mal die Fragen
- Warum läuft der Druckserver? (cups)
- Wer soll den auf die (Windows-) Fileshares zugreifen? (smbd)
- Warum verwendest du ein als gecracked geltentes VPN Protokoll? (pptpd)
- Was für Webseiten laufen da? (apache)

Offensichtlich lässt lookathost nicht nur udp aus sondern auch IPv6 komplett.
Bitte warten ..
Mitglied: Cthluhu
12.12.2013, aktualisiert um 13:47 Uhr
Nur mal sicherhaltshalber:
mach mal
01.
netstat -tulpen
und zwar im Produktivfall (also nicht einer der Fälle wie vorhin, ala "ups da war na ganz was anderes aktiv als geplant").
Dann teste mit nmap mit dem -p parameter genau die Ports ab die laut netstat geöffnet sind. Damit siehst du dann was tatsächlich alles von außen erreichbar ist.
Bitte warten ..
Mitglied: Luciver1981
12.12.2013 um 14:23 Uhr
@slainte
cups denk ich mal mit smb gekommen ist aber so konfiguriert das es nur im vpn erreichbar ist also bind von smb an die virtuelle Schnittstelle des Openvpn.
PPTPd hab ich gekillt
es laufen 2 Webseiten drauf ein Normal und eine als subdomain.

@Cthluhu
fördert das zu Tage:
01.
tcp        0      0 0.0.0.0:10000           0.0.0.0:*               LISTEN      0          3950232050  - 
02.
tcp        0      0 0.0.0.0:30033           0.0.0.0:*               LISTEN      1009       2317072294  - 
03.
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      0          3938598675  - 
04.
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN      0          2898449757  - 
05.
tcp        0      0 0.0.0.0:10011           0.0.0.0:*               LISTEN      1009       2317236007  - 
06.
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      107        3937373926  - 
07.
tcp6       0      0 :::80                   :::*                    LISTEN      0          3945125101  - 
08.
tcp6       0      0 :::22                   :::*                    LISTEN      0          3938598464  - 
09.
udp        0      0 0.0.0.0:55000           0.0.0.0:*                           1009       2317235523  - 
10.
udp        0      0 0.0.0.0:5353            0.0.0.0:*                           111        3936025153  - 
11.
udp        0      0 0.0.0.0:52845           0.0.0.0:*                           111        3936025275  - 
12.
udp        0      0 0.0.0.0:631             0.0.0.0:*                           0          2898449853  - 
13.
udp        0      0 0.0.0.0:9987            0.0.0.0:*                           1009       2317108687  - 
14.
udp        0      0 0.0.0.0:10000           0.0.0.0:*                           0          3950232051  - 
15.
udp        0      0 0.0.0.0:9000            0.0.0.0:*                           1009       2317143404  - 
16.
udp        0      0 0.0.0.0:9001            0.0.0.0:*                           1009       2317165747  - 
17.
udp        0      0 0.0.0.0:9002            0.0.0.0:*                           1009       2317213587  - 
18.
udp6       0      0 :::58595                :::*                                111        3936025282  - 
19.
udp6       0      0 :::5353                 :::*                                111        3936025205  - 
20.
udp6       0      0 :::517                  :::*                                0          3939418501  - 
21.
udp6       0      0 :::518                  :::*                                0          3939418515  -
leider ohne die namen der jeweiligen dienste
Bitte warten ..
Mitglied: Cthluhu
12.12.2013 um 14:31 Uhr
Du solltest nicht die ausgabe von netstat hier posten (hast du ja schon ein paar mal), sondern die ports welche laut netstat offen sind, mit nmap abklopfen. Damit überprüfst was genau von intern (VPN) und was von extern (über den global erreichbaren Hostnamen den du beim nmap aufruf verwendest) erreichbar ist.
Bitte warten ..
Mitglied: Luciver1981
12.12.2013, aktualisiert um 14:44 Uhr
Nmap am server:

01.
Interesting ports on localhost.localdomain (127.0.0.1): 
02.
Not shown: 1710 closed ports 
03.
PORT      STATE SERVICE 
04.
22/tcp    open  ssh 
05.
80/tcp    open  http 
06.
631/tcp   open  ipp 
07.
3306/tcp  open  mysql 
08.
10000/tcp open  snet-sensor-mgmt
01.
an der externen ip 
02.
Not shown: 1712 closed ports 
03.
PORT      STATE SERVICE 
04.
22/tcp    open  ssh 
05.
80/tcp    open  http 
06.
10000/tcp open  snet-sensor-mgmt
nmap von Windowskiste aus:
identisch natürlich zu der externen IP

wieder nur TCP und IPv4
Bitte warten ..
Mitglied: Cthluhu
12.12.2013, aktualisiert um 14:47 Uhr
Das sieht doch gut fast schon aus.
Was ist mit den krummen ports wie upd 5353. 518, 517?
Teste die mal mit nmap.

Edit: nmap testet im Default-Fall (keine Ports extra angegeben) nur eine handvoll ports (so dass nmap schnell durch ist).
Bitte warten ..
Mitglied: Luciver1981
12.12.2013 um 15:00 Uhr
Sieht so aus wie Netzwerkkonfig Tools vom Anbieter.

01.
nmap -sU -p 5353,518,517 127.0.0.1 
02.
 
03.
Starting Nmap 4.62 ( http://nmap.org ) at 2013-12-12 14:56 CET 
04.
Interesting ports on localhost.localdomain (127.0.0.1): 
05.
PORT     STATE         SERVICE 
06.
517/udp  open|filtered talk 
07.
518/udp  open|filtered ntalk 
08.
5353/udp open|filtered zeroconf
Bitte warten ..
Mitglied: Cthluhu
12.12.2013 um 15:05 Uhr
Nicht intern testen. Wir wollen wissen, ob die Ports von außen erreichbar sind.
Bitte warten ..
Mitglied: Luciver1981
12.12.2013 um 15:19 Uhr
Ja leider
PORT STATE SERVICE
517/udp open|filtered talk
518/udp open|filtered ntalk
5353/udp open|filtered zeroconf

zeroconf kommt mit sehr hoher Wahrscheilichkeit vom Anbieter

Was ist mit talk und ntalk?
Bitte warten ..
Mitglied: Luciver1981
12.12.2013 um 15:47 Uhr
Ok Talk und Ntalk kommen scheinbar mit debian mit.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Server-Hardware
Lenovo Server System X 3650 M5 Festplatten (9)

Frage von Hendrik2586 zum Thema Server-Hardware ...

Netzwerke
gelöst Zugriff auf Server von verschiedenen VLANs aus (6)

Frage von Kroeger02 zum Thema Netzwerke ...

Server-Hardware
gelöst Supermicro 813-4 Server - hängt bei Neustarts (4)

Frage von NetzwerkDude zum Thema Server-Hardware ...

Heiß diskutierte Inhalte
Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...

Exchange Server
DNS Einstellung - zwei feste IPs für Mailserver (15)

Frage von ivan0s zum Thema Exchange Server ...