Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Ubuntu 11.04 - WLAN lässt sich nach Neustart nicht aktivieren

Frage Linux Ubuntu

Mitglied: bolshi

bolshi (Level 1) - Jetzt verbinden

31.05.2011 um 10:01 Uhr, 8897 Aufrufe, 4 Kommentare

Moin,
hab gestern Ubuntu 11.04 installiert. Im Anschluss WLAN die '/etc/interfaces' und '/etc/wpa_supplicant/wpa_supplicant.conf' wie folgt eingerichtet:

/etc/interfaces:
01.
# loopback network interface 
02.
auto lo 
03.
iface lo inet loopback 
04.
 
05.
# LAN 
06.
# auto eth0 
07.
iface eth0 inet dhcp 
08.
        test missing-cable 
09.
        pre-up echo No link present. 
10.
        pre-up false 
11.
 
12.
# Wireless 
13.
auto wlan0 
14.
iface wlan0 inet dhcp 
15.
         wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
/etc/wpa_supplicant/wpa_supplicant.conf:
01.
network={ 
02.
    ssid="mein Netz" 
03.
    scan_ssid=1 
04.
    mode=0 
05.
    key_mgmt=WPA-PSK 
06.
    proto=WPA 
07.
    auth_alg=OPEN 
08.
    pairwise=TKIP 
09.
    psk="password" 
10.
}
Im Anschluss WLAN wie folgt aktiviert:
01.
sudo ifconfig wlan0 up
Es erscheint folgende Meldung:
01.
operation not possible due to rf-kill
Darauf gebe ich folgenden Befehl ein:
01.
sudo rfkill unblock all
Beim ersten Versuch nach anlegen der wpa_supplicant.conf funktioniert die WLAN-Verbindung einwandfrei. Nach wiederholtem Neustart nicht mehr.

Auch bei ifconfig taucht wlan0 nicht auf.

Was kann ich unternehmen, dass die WLAN-Verbindung per default verfügbar ist?

Grüße, bolshi
Mitglied: KowaKowalski
31.05.2011 um 12:17 Uhr
Hi Bolshi,

arbeite mal dies hier durch.
Achte auch auf die Teile: "WLAN-Sondertasten" und "Konfiguration der Kanäle 12 und 13".


mfg
kowa
Bitte warten ..
Mitglied: bolshi
31.05.2011 um 14:04 Uhr
Hi kowa,

Zitat von KowaKowalski:
arbeite mal dies hier durch.
Achte auch auf die Teile: "WLAN-Sondertasten" und "Konfiguration der Kanäle 12 und 13".

WLAN läuft auf Kanal 11. Ich versteh's nicht, dass die WLAN-Verbindung nach Neuinstallation und einrichten der wpa_supplicant.conf funktioniert, um dann nach wiederholtem Neustart auszufallen.

'rfkill list' meldet folgendes:

01.
0: acer-wireless: Wireless LAN 
02.
            Soft blocked: no 
03.
            Hard blocked: no 
04.
1: phy0: Wireless LAN 
05.
            Soft blocked: no 
06.
            Hard blocked: yes
Kann ich mir grad nicht erklären. rfkill ist in der aktuellsten Version installiert.
Bitte warten ..
Mitglied: bolshi
31.05.2011 um 14:26 Uhr
Hab grad folgendes probiert:

01.
$sudo rm /dev/rfkill
Im Anschluss
01.
$sudo shutdown -r now
Nach login ist wlan0 inaktiv. Ändern mit
01.
$sudo ifconfig wlan0 up
Wiederholte Meldung:
01.
Operation not possible due to RF-kill
Erneutes eingeben
01.
sudo rfkill unblock all
Anschließen erneut
01.
$sudo ifconfig wlan0 up

Siehe da: WLAN-Verbindung hergestellt.

Danach wiederhole ich alles ab dem Neustart. Ergebnis: wlan0 lässt sich nicht erneut aktivieren

Womöglich könnte ich das Ganze jetzt wieder von vorn beginnen und rfkill erneut löschen usw. Ist aber nicht mein Anliegen.

Zwei Fragen:

Wie kommt rfkill auf zwei WLAN-Karten?

Könnt ihr alternative Software emfpehlen, mit der sich die WLAN-Verbindung konfigurieren lässt?
Bitte warten ..
Mitglied: bolshi
31.05.2011 um 14:52 Uhr
Ist wohl mehr als ich dachte: http://ubuntuforums.org/showthread.php?t=1753072&page=3

Shit happens
Bitte warten ..
Ähnliche Inhalte
Ubuntu
gelöst Installation Atheros AR242x WLAN-Adapter unter Ubuntu 16.04 (10)

Frage von achklein zum Thema Ubuntu ...

Ubuntu
VMware 11 Workstation auf Ubuntu 16.04

Frage von bolle01 zum Thema Ubuntu ...

Ubuntu
Ubuntu 17.04 veröffentlicht (10)

Link von Frank zum Thema Ubuntu ...

Neue Wissensbeiträge
Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Router & Routing

PfSense auf Supermicro Intel Xeon D-15x8 SoC Bare Bone

Tipp von Dobby zum Thema Router & Routing ...

Windows Server

Exchange 2010 auf Windows Server 2016 und AD

(2)

Tipp von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Basic
Programmierung von Windows Programmen (9)

Frage von Ghost108 zum Thema Basic ...

LAN, WAN, Wireless
Brauche Hilfe: Mit (schnellem) WLAN Strecke überbrücken (8)

Frage von pierrehansen zum Thema LAN, WAN, Wireless ...

C und C++
Fehlendes verständiss von C und C++ (8)

Frage von zelamedia zum Thema C und C ...