Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Ubuntu 11.04 - WLAN lässt sich nach Neustart nicht aktivieren

Frage Linux Ubuntu

Mitglied: bolshi

bolshi (Level 1) - Jetzt verbinden

31.05.2011 um 10:01 Uhr, 8988 Aufrufe, 4 Kommentare

Moin,
hab gestern Ubuntu 11.04 installiert. Im Anschluss WLAN die '/etc/interfaces' und '/etc/wpa_supplicant/wpa_supplicant.conf' wie folgt eingerichtet:

/etc/interfaces:
01.
# loopback network interface 
02.
auto lo 
03.
iface lo inet loopback 
04.
 
05.
# LAN 
06.
# auto eth0 
07.
iface eth0 inet dhcp 
08.
        test missing-cable 
09.
        pre-up echo No link present. 
10.
        pre-up false 
11.
 
12.
# Wireless 
13.
auto wlan0 
14.
iface wlan0 inet dhcp 
15.
         wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
/etc/wpa_supplicant/wpa_supplicant.conf:
01.
network={ 
02.
    ssid="mein Netz" 
03.
    scan_ssid=1 
04.
    mode=0 
05.
    key_mgmt=WPA-PSK 
06.
    proto=WPA 
07.
    auth_alg=OPEN 
08.
    pairwise=TKIP 
09.
    psk="password" 
10.
}
Im Anschluss WLAN wie folgt aktiviert:
01.
sudo ifconfig wlan0 up
Es erscheint folgende Meldung:
01.
operation not possible due to rf-kill
Darauf gebe ich folgenden Befehl ein:
01.
sudo rfkill unblock all
Beim ersten Versuch nach anlegen der wpa_supplicant.conf funktioniert die WLAN-Verbindung einwandfrei. Nach wiederholtem Neustart nicht mehr.

Auch bei ifconfig taucht wlan0 nicht auf.

Was kann ich unternehmen, dass die WLAN-Verbindung per default verfügbar ist?

Grüße, bolshi
Mitglied: KowaKowalski
31.05.2011 um 12:17 Uhr
Hi Bolshi,

arbeite mal dies hier durch.
Achte auch auf die Teile: "WLAN-Sondertasten" und "Konfiguration der Kanäle 12 und 13".


mfg
kowa
Bitte warten ..
Mitglied: bolshi
31.05.2011 um 14:04 Uhr
Hi kowa,

Zitat von KowaKowalski:
arbeite mal dies hier durch.
Achte auch auf die Teile: "WLAN-Sondertasten" und "Konfiguration der Kanäle 12 und 13".

WLAN läuft auf Kanal 11. Ich versteh's nicht, dass die WLAN-Verbindung nach Neuinstallation und einrichten der wpa_supplicant.conf funktioniert, um dann nach wiederholtem Neustart auszufallen.

'rfkill list' meldet folgendes:

01.
0: acer-wireless: Wireless LAN 
02.
            Soft blocked: no 
03.
            Hard blocked: no 
04.
1: phy0: Wireless LAN 
05.
            Soft blocked: no 
06.
            Hard blocked: yes
Kann ich mir grad nicht erklären. rfkill ist in der aktuellsten Version installiert.
Bitte warten ..
Mitglied: bolshi
31.05.2011 um 14:26 Uhr
Hab grad folgendes probiert:

01.
$sudo rm /dev/rfkill
Im Anschluss
01.
$sudo shutdown -r now
Nach login ist wlan0 inaktiv. Ändern mit
01.
$sudo ifconfig wlan0 up
Wiederholte Meldung:
01.
Operation not possible due to RF-kill
Erneutes eingeben
01.
sudo rfkill unblock all
Anschließen erneut
01.
$sudo ifconfig wlan0 up

Siehe da: WLAN-Verbindung hergestellt.

Danach wiederhole ich alles ab dem Neustart. Ergebnis: wlan0 lässt sich nicht erneut aktivieren

Womöglich könnte ich das Ganze jetzt wieder von vorn beginnen und rfkill erneut löschen usw. Ist aber nicht mein Anliegen.

Zwei Fragen:

Wie kommt rfkill auf zwei WLAN-Karten?

Könnt ihr alternative Software emfpehlen, mit der sich die WLAN-Verbindung konfigurieren lässt?
Bitte warten ..
Mitglied: bolshi
31.05.2011 um 14:52 Uhr
Ist wohl mehr als ich dachte: http://ubuntuforums.org/showthread.php?t=1753072&page=3

Shit happens
Bitte warten ..
Ähnliche Inhalte
Ubuntu
Ubunto Wlan Problem bei Neustarts (1)

Frage von opc123 zum Thema Ubuntu ...

Ubuntu
gelöst Installation Atheros AR242x WLAN-Adapter unter Ubuntu 16.04 (10)

Frage von achklein zum Thema Ubuntu ...

Ubuntu
Virtuelles Ubuntu auf vorhandenem Ubuntu installieren (4)

Frage von traller zum Thema Ubuntu ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
gelöst Raid-Controller (Areca) Datenverlust trotz R5 (16)

Frage von sebastian2608 zum Thema Festplatten, SSD, Raid ...

Server-Hardware
HP ProLiant DL380 G7, POST Error: 1785-Drive Array not Configured (10)

Frage von Paderman zum Thema Server-Hardware ...

Server-Hardware
Starker PC zum Virtualisieren (10)

Frage von canlot zum Thema Server-Hardware ...

Microsoft Office
gelöst Office 365 Pro Domäne einrichten OHNE Webseite (9)

Frage von thklemm zum Thema Microsoft Office ...