Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Ubuntu 12.0.5 LTS: dpkg verweigert Kernel-Update

Frage Linux Ubuntu

Mitglied: smguenther

smguenther (Level 1) - Jetzt verbinden

18.01.2015 um 23:13 Uhr, 2193 Aufrufe, 9 Kommentare

Hi,

nach einem "apt-get upgrade" stehe ich vor dem Problem, dass dpkg bei den Abhöngigkeiten der Pakete linux-server, linux-image-server und linux-headers-server mit zwei verschiedenen Kernel-Versionen arbeitet. Der Versuch, mit dem vorgeschlagenen "apt-get -f install" das Problem zu lösen, führt zur folgenden Ausgabe:

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
Abhängigkeiten werden korrigiert... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
linux-server
Die folgenden Pakete werden aktualisiert (Upgrade):
linux-server
1 aktualisiert, 0 neu installiert, 0 zu entfernen und 21 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Es müssen noch 0 B von 1.724 B an Archiven heruntergeladen werden.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren [J/n]?
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von linux-server:
linux-server hängt ab von linux-image-server (= 3.2.0.74.88); aber:
Version von linux-image-server auf dem System ist 3.2.0.76.90.
linux-server hängt ab von linux-headers-server (= 3.2.0.74.88); aber:
Version von linux-headers-server auf dem System ist 3.2.0.76.90.
dpkg: Fehler beim Bearbeiten von linux-server (--configure):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
Es wurde kein Apport-Bericht verfasst, da die Fehlermeldung darauf hindeutet, dass dies lediglich ein Folgefehler eines vorherigen Problems ist.
Fehler traten auf beim Bearbeiten von: linux-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ich habe es schon mit

apt-get install --reinstall linux-headers-server linux-image-server linux-server
apt-get remove --purge linux-headers-3.2.0-74 linux-headers-3.2.0-74-generic linux-image-3.2.0-74-generic
apt-get remove --purge linux-headers-3.2.0-76 linux-headers-3.2.0-76-generic linux-image-3.2.0-76-generic

versucht, es ändert sich aber nichts an der Fehlermeldung.

Wie kann ich dieses Abhängigkeitsproblem lösen?

Danke für jeden Tipp oder Hinweis,

Stefan
Mitglied: Gersen
18.01.2015 um 23:40 Uhr
Hallo,

was gibt denn ein
apt-get update && apt-get dist-upgrade
?

Gruß,
Gersen
Bitte warten ..
Mitglied: smguenther
19.01.2015 um 08:20 Uhr
Hi,

leider dieselbe Meldung:

root@dellsrv:~# apt-get update
.....
Es wurden 72 B in 5 s geholt (12 B/s)
Paketlisten werden gelesen... Fertig
root@dellsrv:~# apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
Probieren Sie »apt-get -f install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
linux-server : Hängt ab von: linux-image-server (= 3.2.0.74.88) aber 3.2.0.76.90 ist installiert
Hängt ab von: linux-headers-server (= 3.2.0.74.88) aber 3.2.0.76.90 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie, -f zu benutzen.

Gruß,

Stefan
Bitte warten ..
Mitglied: Lochkartenstanzer
19.01.2015, aktualisiert um 09:33 Uhr
Zitat von smguenther:

Probieren Sie »apt-get -f install«, um dies zu korrigieren.

Und hast Du das schon gemacht?

lks

PS: Es gibt kein 12.0.5 LTS sondern nur ein 12.04 LTS.

PPS: lade Dir doch die debs manuell runte ruind installier sie mit dpkg.
Bitte warten ..
Mitglied: smguenther
19.01.2015 um 09:42 Uhr
apt-get -f install
bringt auch die Fehlermeldung.

Sorry, es ist 12.04.5

Hm, manuell ist natürlich in der Tat eine Option, aber auch dpkg ruft doch dann das configure auf, dass die Fehlermeldung produziert, nicht wahr?

Stefan
Bitte warten ..
Mitglied: Lochkartenstanzer
19.01.2015 um 09:45 Uhr
Zitat von smguenther:

Hm, manuell ist natürlich in der Tat eine Option, aber auch dpkg ruft doch dann das configure auf, dass die Fehlermeldung
produziert, nicht wahr?

was ich meinte, hol Dir aus dem repository die 3.2.0.74.88er versionen und installier diese manuell. Dann wird sich das meta-package "linux-server" zufriedengeben. Die Datenmengen sind nciht allzu groß udn wenn Dein grub richtig arbeitet, kommst Du auch nicht in die versuchung den älteren kernekl zu benutzen.

lks

PS: Wie sieht eigentlich Deine sources.list aus? Ist die Korrekt und beinhalte auch die Security-Updates?
Bitte warten ..
Mitglied: Gersen
19.01.2015 um 10:05 Uhr
Ggf. auch mal schauen, ob unter /var/cache/apt/archives die drei Pakete schon in einer einheitlichen Version vorliegen. Wenn ja, dann über
dpkg -i paket1.deb paket2.deb paket3.deb
installieren.

Gruß,
Gersen
Bitte warten ..
Mitglied: Lochkartenstanzer
19.01.2015 um 11:14 Uhr
Zitat von smguenther:

Sorry, es ist 12.04.5

Die Überschrift kann man editieren
Bitte warten ..
Mitglied: Looser27
19.01.2015 um 11:21 Uhr
Hast Du denn versucht Deine Distribution auf den neuesten Stand zu bringen bevor Du das Upgrade installierst?
Bitte warten ..
Mitglied: smguenther
19.01.2015 um 13:21 Uhr
Ich habe das Problem nun auf eine etwas brutale Art und Weise gelöst:

In der Datei /var/lib/dpkg/status war das Paket "linux-server" wie folgt aufgeführt:

Package: linux-server
.....
Version: 3.2.0.74.88
Depends: linux-image-server (= 3.2.0.74.88), linux-headers-server (= 3.2.0.74.88)
....

Das habe ich geändert in

Package: linux-server
.....
Version: 3.2.0.76.90
Depends: linux-image-server (= 3.2.0.76.90), linux-headers-server (= 3.2.0.76.90)
....

Danach kann der Kernel 3.2.0.76 installiert und konfiguriert werden.

Gruß,

Stefan
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Apache Server
gelöst Apache und PHP auf Ubuntu 12.04.5.TLS installieren (8)

Frage von laster zum Thema Apache Server ...

Ubuntu
gelöst PHP 5.4 installieren auf Ubuntu 14.04.5 LTS (4)

Frage von runasservice zum Thema Ubuntu ...

Ubuntu
Ubuntu 16.04 LTS friert immer ein (5)

Frage von Moddry zum Thema Ubuntu ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (24)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Erkennung und -Abwehr
Spam mit eigener Domain (12)

Frage von NoobOne zum Thema Erkennung und -Abwehr ...