Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Ubuntu 12.10 Fehler beim Einhängen des USB-Sticks

Frage Hardware Multimedia & Zubehör

Mitglied: runningriot

runningriot (Level 1) - Jetzt verbinden

23.01.2013 um 22:14 Uhr, 11904 Aufrufe, 20 Kommentare

Ich hoffe mir kann jemand helfen, da bis jetzt noch kein Forum dazu in der Lage war.
Danke im Vorraus.

Guten Tag,
seit langem habe ich mir nun wieder Linux auf den Rechner gezogen. Ich bin mit allem sehr zufrieden und alles funktioniert super. Es gibt nur ein Problem: ich kann auf meinen USB-Stick nicht zugreifen. Wenn ich ihn in den USB Port stecke passiert nichts. Im "Rechner" - Fenster wird er aber als Laufwerk angezeigt. Wenn ich darauf zugreifen möchte erscheint folgende Fehlermeldung:

Einhängen des Ortes nicht möglich
Datei konnte nicht eingehängt werden

Ich habe mich schon sehr viel in diversen Foren mit diesem Thema beschäftigt, jedoch hat bei mir nichts geholfen. Ich bitte um eine schnelle Lösung und bedanke mich schon mal
Mitglied: Dobby
23.01.2013 um 22:34 Uhr
Hallo runningriot,

ist es vielleicht möglich das dieser USB Stick dafür benutzt wird um zwischen anderen PCs und Deinem
Linux PC Daten auszutauschen?

Vielleicht sogar Windows Rechnern und dort wird der USB Stick nicht richtig
"abgezupft" oder einfach abgesteckt ohne ihn richtig vom OS abgemeldet zu haben!?

Gruß
Dobby
Bitte warten ..
Mitglied: runningriot
23.01.2013 um 22:39 Uhr
Guten Abend,
ich benutze den Stick um Musik zu übertragen. Der Laptop meines Freundes von dem ich die Musik habe hat als OS Windows Vista. Ich habe auch gesehen das er den Stick ordnungsgemäß entfernt hat. Formatiert ist er in Fat32, da ich mitbekommen habe das Linux kein NTFS unterstützt (stand so in einem Forum). Desweitern kann ich noch sagen das es sich um einen Medion 8Gbyte Stick handelt, sollte das relevant sein.

Gruß runningriot
Bitte warten ..
Mitglied: Pjordorf
23.01.2013, aktualisiert um 22:54 Uhr
Hallo,

Zitat von runningriot:
Ich habe mich schon sehr viel in diversen Foren mit diesem Thema beschäftigt
Ist es nicht besser wenn du deinen Link vom Ubuntu Forum hier rein stellst, oder erwartest du wirklich das wir alles noch mal mit dir durchkauen?
http://www.ubuntu-forum.de/artikel/61076/ubuntu-12-10-fehler-beim-einh% ...

Dann solltest du hier doch bitte noch erwähnen das deine dort gemachte Aussage
Also andere Sticks funktionieren auch nicht
auch hier noch gilt, oder? Prüfe mal die Treiber deines Ubuntu ob die mit deiner hardware auch korrekt klarkommen.

Poste mal bitte die Ausgabe von mount hier rein.

Gruß,
Peter
Bitte warten ..
Mitglied: hmarkus
23.01.2013 um 22:53 Uhr
Hallo,

öffne mal bitte ein Terminal, führe (nach einstecken des USB-Sticks) die Befehle
dmesg
und
ls /dev/sd*
aus, dann poste bitte mal die Ausgaben (von dmesg nur die letzten 20 Zeilen).

Markus
Bitte warten ..
Mitglied: Dobby
23.01.2013 um 22:55 Uhr
Hallo nochmal runningriot ,

Desweitern kann ich noch sagen das es sich um einen Medion 8Gbyte Stick handelt, sollte das relevant sein.

Ist zwar schön zu wissen aber das macht hier in Deinem Fall den Kohl nicht fett.
Das ist nur wichtig wenn es um die Lebensdauer, Verarbeitung und/oder die Performance geht.

Ich benutze OpenSUSE und Windows XP und Windows 7 und da kommt es halt ab und an vor das ich den
Stick einfach abziehe und dann lässt er sich nicht am Linux System lesen.

Gruß
Dobby
Bitte warten ..
Mitglied: hmarkus
23.01.2013 um 22:56 Uhr
Zitat von Pjordorf:
....
Ist es nicht besser wenn du deinen Link vom Ubuntu Forum hier rein stellst, oder erwartest du wirklich das wir alles noch mal
mit dir durchkauen?
Naja, in dem Thread vom Ubuntu-Forum steht doch nix drin ;)
Bitte warten ..
Mitglied: runningriot
23.01.2013 um 23:01 Uhr
dmesg:
[ 131.949424] usb 1-4: >SerialNumber: 0123456789ABCDEF
[ 132.104859] usbcore: registered new interface driver cdc_ether
[ 132.112528] rndis_host 1-4:2.0: >usb0: register 'rndis_host' at usb-0000:00:1d.7-4, RNDIS device, aa:bb:cc:dd:ee:ff
[ 132.114221] usbcore: registered new interface driver rndis_host
[ 132.236457] cfg80211: Calling CRDA to update world regulatory domain
[ 132.325570] usbcore: registered new interface driver rndis_wlan
[ 133.288200] cfg80211: World regulatory domain updated:
[ 133.288206] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 133.288210] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 133.288213] cfg80211: (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 133.288215] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 133.288218] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 133.288220] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

ls /dev/sd* :
/dev/sda /dev/sda2 /dev/sdb /dev/sdc /dev/sde
/dev/sda1 /dev/sda5 /dev/sdb1 /dev/sdd /dev/sdf
Bitte warten ..
Mitglied: hmarkus
23.01.2013, aktualisiert um 23:38 Uhr
Also vermutlich ist der Stick /dev/sdb1 (es sein denn Du hast mehrere Festplatten).

Du kannst mal mit
df -h
oder
mount
checken, ob er wirklich nicht eingehängt wurde.

Wenn nicht, dann führe bitte
sudo mkdir /mnt/tmp 
aus und danach
sudo mount /dev/sdb1 /mnt/tmp
Bitte die Fehlermeldungen hier posten, wenn keine kommen bitte die Ausgabe von "df -h", der Stick sollte dann eingebunden sein.

Markus
Bitte warten ..
Mitglied: runningriot
23.01.2013 um 23:10 Uhr
hallo Peter,
ja die Aussage gilt noch.

mount:
/dev/sda1 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
gvfsd-fuse on /run/user/nick/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=nick)
Bitte warten ..
Mitglied: Dobby
23.01.2013 um 23:10 Uhr
Kann es sein das Du da einen WLAN USB dran hattest und diesen einfach abgezogen hast und nun
den Medion USB Stick dran steckst und der Treiber vom WLAN Stick nun auf den Medion USB Stick zugreift
und mit diesem nichts anfangen kann?

Gruß
Dobby
Bitte warten ..
Mitglied: runningriot
23.01.2013 um 23:17 Uhr
@ D.o.b.b.y
der Wlan Stick steckt auch jetzt noch drin. Er war dort von Anfang an und auch nie wieder draußen. Der USB Stick ist halt in einem anderen Port.


@ Markus
also eine Fehlermeldung kam im Terminal nicht, aber wenn ich auf den Stick zugreifen will dann kommt die gleiche Meldung wie in der Einleitung beschrieben.

das ist die Ausgabe nach durchführung des Befehls:
Dateisystem Größe Benutzt Verf. Verw% Eingehängt auf
/dev/sda1 75G 3,6G 68G 5% /
udev 241M 4,0K 241M 1% /dev
tmpfs 100M 892K 99M 1% /run
none 5,0M 0 5,0M 0% /run/lock
none 249M 80K 249M 1% /run/shm
none 100M 44K 100M 1% /run/user
/dev/sdb1 7,6G 5,0G 2,6G 67% /mnt/tmp
Bitte warten ..
Mitglied: hmarkus
23.01.2013, aktualisiert um 23:24 Uhr
dann ist er ja auf /mnt/tmp eingehängt, führe doch mal den Befehl
ls /mnt/tmp
aus, dann sollte der Inhalt des Sticks angezeigt werden.

Also Du siehst ja, 8GB Stick, 5GB belegt, 2.6GB frei.

Frage ist: wieso wird der nicht automatisch eingehängt? das ist zu prüfen. Ich würde mal eine Live-CD einer anderen Linux-Distribution booten und es ausprobieren. Dann weiß man, ob's am Stick oder an Ubuntu liegt. Man kann allerdings problemlos dafür sorgen, dass er automatisch gemountet wird.

Markus
Bitte warten ..
Mitglied: runningriot
23.01.2013 um 23:27 Uhr
also ich bekomme jetzt eine Auflistung der Datein im Terminal. Nun kann ich sie ja einfach kopieren oder?

Ich wäre auf jedenfall auch noch sehr dankbar für eine Erklärung woran es gelegen hat das es nicht funktioniert hat.

Ich möchte mich auf jedenfall bei allen Helfenden schon mal bedanken
Bitte warten ..
Mitglied: hmarkus
23.01.2013 um 23:36 Uhr
Du kannst das Verzeichnis /mnt/tmp genauso gut auch in einem Dateimanager öffnen und die Dateien kopieren.

Wieso es nicht funktioniert hat ist nicht klar. Oder besser gesagt, auf Kernelebene funktioniert alles, allerdings bindet Ubuntu den Stick nicht automatisch ein. Du könntest eine udev-rule schreiben, die ihn automatisch einhängt. Aber vielleicht suchst Du vorher mal in den Ubuntu-Foren speziell nach dem Problem USB-Stick wird nicht automatisch eingebunden.

Du kannst über udev-rules hier http://www.reactivated.net/writing_udev_rules.html nachlesen, allerdings ist das Tutorial etwas veraltet. Es hilft aber, die grundlegenden Vorgänge zu verstehen. Mal ein Beispiel von meinem Laptop
SUBSYSTEMS=="usb", KERNEL=="sd?1", ACTION=="add", RUN+="/usr/local/bin/mount-usb.sh"
diese Regel führt ein Skript aus, welches einen USB-Stick mountet.

Markus
Bitte warten ..
Mitglied: runningriot
23.01.2013 um 23:46 Uhr
ok danke.
eine letzte Frage habe ich noch.
Ich hab es gerade hinbekommen einzelne Dateien mit dem Befehl cp zu kopieren, jedoch hat das bei dem Ordner nicht geklappt. Gibt es für das Kopieren von Ordnern einen bestimmten Befehl?
Bitte warten ..
Mitglied: hmarkus
23.01.2013, aktualisiert um 23:48 Uhr
cp -r 
mit der -r Option werde auch die Verzeichnisse kopiert.

Markus
Bitte warten ..
Mitglied: runningriot
24.01.2013 um 00:00 Uhr
vielen vielen dank
Bitte warten ..
Mitglied: Lochkartenstanzer
24.01.2013, aktualisiert um 08:54 Uhr
Moin,

nachdem ja grundsätzlich geklärt ist, daß der Stick funktioniert noch ein Tipp:

Mach mal einen fsck/chkdsk über das Filesystem des Sticks. Meine Erfahrung ist, daß das automatische Mounten meistens dann schiefgeht, wenn was mit dem Filesystem nicht in Ordnung ist.

lks
Bitte warten ..
Mitglied: hmarkus
24.01.2013 um 15:12 Uhr
Hallo nochmal,
Zitat von Lochkartenstanzer:
...
Mach mal einen fsck/chkdsk über das Filesystem des Sticks. Meine Erfahrung ist, daß das automatische Mounten meistens
dann schiefgeht, wenn was mit dem Filesystem nicht in Ordnung ist.
Ich hab von Ubuntu keine Ahnung, weiß also nicht, wie es dort innendrin funktioniert. Allerdings ist es ja so, dass der mount-Befehl das Dateisystem automatisch erkennt. Normalerweise erkennt man Probleme mit dem Dateisystem an Fehlermeldungen von mount, es sagt dann, man solle das Dateisystem angeben (mit der -t Option).

Es sollte auch bei Ubuntu so sein, dass das System den Stick erkennt, ein Verzeichnis (temporär) anlegt und den mount-Befehl ausführt.

Da nun aber tatsächlich ein Problem beim Mounten besteht, sollte man herausfinden, welche Befehle sonst noch ausgeführt werden. Vielleicht führt das zu einer Lösung.

Meine Erfahrung ist, dass Linux mit USB-Geräten souveräner umgeht als Windows. Wenn ich einen USB-Stick bekomme mit der Ansage "der funktioniert nicht", dann stecke ich ihn an einen Linuxrechner und guck mir die Ausgabe von dmesg an. Wenn da nix kommt, dann ist er wirklich kaputt. Ansonsten muss man an Windows rumschrauben.

Markus
Bitte warten ..
Mitglied: Lochkartenstanzer
24.01.2013, aktualisiert um 18:22 Uhr
Zitat von hmarkus:
Hallo nochmal,

Auch hallo,

Ich hab von Ubuntu keine Ahnung, weiß also nicht, wie es dort innendrin funktioniert. Allerdings ist es ja so, dass der
mount-Befehl das Dateisystem automatisch erkennt. Normalerweise erkennt man Probleme mit dem Dateisystem an Fehlermeldungen von
mount, es sagt dann, man solle das Dateisystem angeben (mit der -t Option).

Es sollte auch bei Ubuntu so sein, dass das System den Stick erkennt, ein Verzeichnis (temporär) anlegt und den mount-Befehl
ausführt.

Normalerweise ja, aber ich habe festgestellt, daß das automatische Mounten manchmal schiefgeht, wenn die Filesysteme beschädigt sind.

Normalerweise kann man dann immer noch "händisch", ggf. ro, mounten. Mit lsusb/dmesg kann man zumindest auch hier feststellen, ob der Stick überhaupt "da" ist.

Wie gesagt, beschädigte Dateisysteme machen manchmal Probleme, die man aber mit fsck (oder chkdsk unter windwos) meist in den Griff bekommt, sofern der Stick nicht defekt ist.

lks
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Speicherkarten
Tool zum neuformatieren eines USB-Sticks (6)

Frage von flyingKangaroo zum Thema Speicherkarten ...

Windows 10
Windows 10 von externer USB-HDD installieren (4)

Frage von cableguy007 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...