Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Ubuntu 13.10 Server amd64, bricht bei Installation ab

Frage Linux Ubuntu

Mitglied: alaim89

alaim89 (Level 1) - Jetzt verbinden

17.03.2014, aktualisiert 18.03.2014, 2795 Aufrufe, 14 Kommentare

Hallo liebe Gemeinde,

mein momentanes vorhaben ist, das ich die Ubuntu 13.10 Server_amd64 & Ubuntu 12.10 Server_amd64 nicht auf ein Server installiert bekomme. Mehrer Varianten sind probiert worden.
1. --> Über USB-Stick
2. --> Über cd
Das System selber soll eigentlich auch nur als Fileserver dienen. Dort sollen die Platten in RAID1 konfiguriert werden.
Das eigentliche Betriebssystem soll auf eine 250 GB SATA Festplatte installiert werden.

Problem bei Ubuntu 13.10:
CD wie auch Stick bootbar. Bei der Auswahl der Art der Installation, friert der immer wieder bei der Auswahl der Tastatur ab. Ich habe mir auch die CD-Problembehandlung schon angeschaut unter ubuntu, aber alle hexereien ausprobiert und keine Lösung funktionierte.

Problem bei Ubuntu 12.10:
CD wie auch Stick bootbar. Ich möchte die SATA Festplatte auswählen für das installieren der Grundsystems. Die Meldung sagt mir immer wieder das er den bootloader nicht installieren kann. Nachfolgend kann ich nichts zu sagen, weil ich ab da einfach nicht weiterkomme.

Ich kann mir nicht vorstellen, das er die Fehler macht weil ein RAID System vorzufinden ist ???


Gruß



alaim89


p.s. immer bereit weiter zu konkretisieren falls man das ganze nicht versteht
Mitglied: Chonta
17.03.2014 um 17:54 Uhr
Hallo,

was für Serverhardware ist denn im Einsatz?
Funktioniert eine Live-CD von Linux ohne Probleme?
Die Tastatur tauschen? (USB oder PS2?)

Sind RAM und HDD vom Server noch in Ordnung oder schon alt und haben evtl einen Defekt?
Wie genau ist die Fehlermeldung für den Bootloader?, Wo will der den installieren?

Gruß

Chonta
Bitte warten ..
Mitglied: Lochkartenstanzer
17.03.2014, aktualisiert um 17:56 Uhr
Zitat von alaim89:

Problem bei Ubuntu 13.10:
Problem bei Ubuntu 12.10:

Hast Du die 12.04 (LTS) auch mal versucht? Die Nicht-LTS-Versione sind imho für Server ungeignet, weil die nicht ausgetestet sind (Beta-Release wäre noch geschmeichelt).

lks
Bitte warten ..
Mitglied: orcape
LÖSUNG 17.03.2014, aktualisiert 18.03.2014
Hi,
Ich kann mir nicht vorstellen, das er die Fehler macht weil ein RAID System vorzufinden ist ???
....mal nur so nebenbei.
Genau das wird Dein Problem sein.
Zum installieren des Grundsystems solltest Du die Raid-Platten vom SATA-Controller trennen.
Zumindest ist das bei Debian so, sollte dann bei Ubuntu nicht anders laufen.
Erst wenn die Installation beendet ist, wieder anstöpseln und den Rest erledigen.
Gruß orcape
Bitte warten ..
Mitglied: mrtux
17.03.2014, aktualisiert um 19:40 Uhr
Hi!

Was ist das für ein RAID? Onboard (FakeRAID)? Diese Teile sind unter Linux grundsätzlich immer problematisch. In so einem Falle die RAID "Funktion" im BIOS abschalten und besser die einzelnen Platten zu einem Linux Software RAID verbinden, das ist mindestens genauso gut und schnell wie ein Fakeraid. Ansonsten wurde das Thema Fakeraid hier schon oft (viel zu oft) diskutiert. Suchfunktion des Forums verwenden!

Und bei einem echten Hardware RAID, welcher Hersteller/Controller?

Wie der Kollege schon schrieb, versuche die Installation mal ohne das RAID mit nur der einzelnen Platte. Hast Du mal versucht testweise eine andere Distribution (Debian Netboot, Knoppix o.ä.) zu booten, ob die dann wenigstens bis zur Platteneinrichtung/Erkennung bootet? Ubuntu hat in der Vergangenheit den Kernel meist stark angepasst (gepatcht), evt. gibt es ein spezielles Problem mit genau deiner Hardware. Ich habe hier z.B. auch einen Rechner wo ein Ubuntu Standardkernel definitiv nicht bootet! War auf der 250er SATA schon mal ein OS installiert?

Fragen über Fragen und bei meiner Glaskugel ist das Guthaben aufgebraucht....

mrtux
Bitte warten ..
Mitglied: alaim89
17.03.2014 um 19:31 Uhr
Hi,

JA die 12.04 habe ich auch versucht.
Ich habe auch die die nicht LTS-Version genutzt, kam die Meldung das der Bootloader auf /dev/sda installieren will ! Ihn aber nicht findet, da /dev/sda über USB gemountet wird oder die Cd-Version ihn nicht findet (habe schon mehrere CD's gebrannt).

An den Tastaturen lag es nicht, kann ich ausschließen, weil ich tatsächlich zur Sicherheit immer beide Varianten bei mir trage.

Mainboard: MSI 7721
Arbeitsspeicher: 4 GB DDR3 von Kingston
CPU: AMD A4-4000 APU


Der Server ist kein Monat alt. Zuvor hat das ein bekannter von mir gemacht, den ich momentan nicht erreiche da er im Ausland für ein halbes Jahr tätig ist.

Gruß


alaim89
Bitte warten ..
Mitglied: alaim89
17.03.2014 um 19:40 Uhr
Zitat von orcape:

Hi,
> Ich kann mir nicht vorstellen, das er die Fehler macht weil ein RAID System vorzufinden ist ???
....mal nur so nebenbei.
Genau das wird Dein Problem sein.
Zum installieren des Grundsystems solltest Du die Raid-Platten vom SATA-Controller trennen.
Zumindest ist das bei Debian so, sollte dann bei Ubuntu nicht anders laufen.
Erst wenn die Installation beendet ist, wieder anstöpseln und den Rest erledigen.
Gruß orcape

Hi orcape,

ach nö :D, das kann doch nicht wahr sein. Ich hätte nicht gedacht das die RAID's die eigentliche Installation unterbinden können.
Bitte warten ..
Mitglied: alaim89
17.03.2014 um 19:44 Uhr
Zitat von mrtux:

Hi!

Was ist das für ein RAID? Onboard (FakeRAID)? Diese Teile sind unter Linux grundsätzlich immer problematisch. In so
einem Falle die RAID "Funktion" im BIOS abschalten und besser die einzelnen Platten zu einem Linux Software RAID
verbinden, das ist mindestens genauso gut und schnell wie ein Fakeraid. Ansonsten wurde das Thema Fakeraid hier schon oft (viel zu
oft) diskutiert. Suchfunktion des Forums verwenden!

Und bei einem echten Hardware RAID, welcher Hersteller/Controller?

Wie der Kollege schon schrieb, versuche die Installation mal ohne das RAID mit nur der einzelnen Platte. Hast Du mal versucht
testweise eine andere Distribution (Debian Netboot, Knoppix o.ä.) zu booten, ob die dann wenigstens bis zur
Platteneinrichtung/Erkennung bootet? Ubuntu hat in der Vergangenheit den Kernel meist stark angepasst (gepatcht), evt. gibt es ein
spezielles Problem mit genau deiner Hardware. Ich habe hier z.B. auch einen Rechner wo ein Ubuntu Standardkernel definitiv nicht
bootet! War auf der 250er SATA schon mal ein OS installiert?

Fragen über Fragen und bei meiner Glaskugel ist das Guthaben aufgebraucht....

mrtux

Hi mrtux,

ich habe es mit anderen Distributionen versucht u.a. auch Debian netboot. Aber auch dort habe ich Fehlermeldungen erhalten.
Die Idee die RAID mal auszustöpseln werde ich gleich mal in Angriff nehmen. Wie ich vorhin schon bei orcape erwähnt habe, hätte ich nicht gedacht, das die eigentliche Anbindung der Festplatten als RAID in der TAT zur Fehler führen kann.

Infos folgen ...


Gruß


alaim89
Bitte warten ..
Mitglied: orcape
LÖSUNG 17.03.2014, aktualisiert 18.03.2014
Die Idee die RAID mal auszustöpseln werde ich gleich mal in Angriff nehmen. Wie ich vorhin schon bei orcape erwähnt
habe, hätte ich nicht gedacht, das die eigentliche Anbindung der Festplatten als RAID in der TAT zur Fehler führen kann.
...mache hin, das ist so, habe ich mir bei Debian auch schon mal die "Zähne dran ausgebissen"....
Bitte warten ..
Mitglied: Lochkartenstanzer
17.03.2014 um 20:18 Uhr
Zitat von alaim89:

ach nö :D, das kann doch nicht wahr sein. Ich hätte nicht gedacht das die RAID's die eigentliche Installation
unterbinden können.


unterbinden nicht. Mann kann die Bootdateien imemr noch manuell draufklatschen.

Aber in manchen Situationen funktionieren die vordefinierten Installationsroutinen nicht. Deswegen bin ich schon lange dazu übergegangen, meine Installationen "händisch" zu machen:

RAIDS, VGs, LVs, Filesysteme werden manuell eingerichtet und anschließend das Grundsystem mit debootstrap draufgeklatscht. Danach kann man mit tasksel/apt-get/aptitude sich das System so zruechtinstallatieren, wie man es benötigt.

Ist nicht wesentlich langsamer als mit dem installer, funktioniert dafür aber garantiert.

lks

PS: Man kann sich natürlich auch einfach ein Image zurchtlegen und das draufklatschen und individualisieren. Lohnt sich, wenn man das öfters machen muß.
Bitte warten ..
Mitglied: alaim89
17.03.2014, aktualisiert um 21:32 Uhr
So ich habe es nun endlich geschafffffttttttt....... ,
Habe mir die Ubuntu 12.04.4 nochmal auf ein USB Stick mit dem "Startmedienersteller" erstellt.
Nachdem mein USB-Stick fertig erstellt war, hatte man auf den Stick selber Aktualisierungen gefunden, die ich dann installiert habe.
(Habe leider keine Ahnung was aktualisiert worden ist).

Ich habe weder Kabel getrennt bei dem RAID noch das RAID deaktiviert gehabt.
Ich habe die Installation einfach durchlaufen lassen, und auf der SATA den Einbindungspunkt " / --> Wurzelverzeichnis " genommen.

4 GB SWAP Speicher zur Verfügung gestellt.

Meine RAID Platten waren sichtbar aber wie erwähnt habe ich dort nichts geändert.

Mittlerweile bin ich auf der Kommandozeile. Ich seh zwar das die Platten eingehängt sind (meiner Meinung nach)

das bekomme ich bei: dmesg | egrep "raid*"

[ 2.156433] md/raid1:md0: active with 2 out of 2 mirrors
[ 2.162535] md/raid1:md1: active with 2 out of 2 mirrors



, bin mir aber nicht sicher ob die RAID Konfiguration noch vorhanden ist. Wie erwähnt habe ich dort weder in den Einstellungen, noch bei der neu Installation irgendetwas an Änderungen vorgenommen.

Vor allem möchte ich die Platten auch dem Windows 7 Client beim start des BS zur Verfügung stellen.


PS: Von mir persönlich auf jeden Fall nochmal ein Super dickes Lob an das Forum hier. Ihr seit wirklich zeitnah zur Hilfe bereit. Musste nochmal erwähnt werden von mir.

Gruß


alaim89
Bitte warten ..
Mitglied: Lochkartenstanzer
18.03.2014 um 07:24 Uhr
Zitat von alaim89:

[ 2.156433] md/raid1:md0: active with 2 out of 2 mirrors
[ 2.162535] md/raid1:md1: active with 2 out of 2 mirrors

Was sagen denn cat /proc/mdstat und parted -l?
Bitte warten ..
Mitglied: alaim89
18.03.2014 um 14:37 Uhr
Zitat von Lochkartenstanzer:

> Zitat von alaim89:
>
> [ 2.156433] md/raid1:md0: active with 2 out of 2 mirrors
> [ 2.162535] md/raid1:md1: active with 2 out of 2 mirrors

Was sagen denn cat /proc/mdstat und parted -l?

Also beide sagen mir, das sie zur Verfügung stehen bzw. aktiv sind.
Ich habe die beiden RAID Platten jetzt mit mount /media/mdx eingehängt und habe die Kapazitäten zur Verfügung, na endlich :D. 7

Jetzt geht es eigentlich nur noch darum das die beiden windows als Netzlaufwerk zur Verfügung stehen sollen.

für dieses Thema werde ich wahrschinlich hier im Thread aber etwas finden oder einen neuen eröffnen müssen.


Gruß

alaim89
Bitte warten ..
Mitglied: Chonta
18.03.2014 um 16:08 Uhr
Hallo,

Du hast mit 2 HDD einen Linuxsoftwareraid gemacht und hast beide gemountet?

Gruß

Chonta
Bitte warten ..
Mitglied: alaim89
18.03.2014, aktualisiert um 16:26 Uhr
Zitat von Chonta:

Hallo,

Du hast mit 2 HDD einen Linuxsoftwareraid gemacht und hast beide gemountet?

Gruß

Chonta

Hi,in

ich habe 4 Festplatten in Betrieb. Jeweils 2 genutzt für ein RAID 1 Verbund. Jede Platte hat 4 TB. Somit ist jede RAID 1 auch nur genau genommen 3,xx TB groß. Da ja die Platten auch nicht genau 4 TB an Speicherplatz bieten. :D

Gruß

alaim89
Bitte warten ..
Ähnliche Inhalte
Ubuntu
Installation von OTRS auf Ubuntu Server 16.04
gelöst Frage von Server2503Ubuntu29 Kommentare

Hallo Zusammen, hat hierfür jemand eine kleine Schritt-für-Schritt-Anleitung? Danke

Ubuntu
Anleitung für die Installation von tripwire unter Ubuntu
gelöst Frage von windelterroristUbuntu2 Kommentare

Hallo! Ich würde sehr gerne tripwire unter Ubuntu Desktop installieren Im Internet hab ich keine gute Anleitungen für eine ...

Ubuntu
Ubuntu Installation: Nur das Titelbild
Frage von gabeBUUbuntu12 Kommentare

Hallo Zusammen Ich würde gerne auf meinem etwas älterem PC gerne ein Ubuntu 32 Bit installieren (neuste Version) Die ...

Windows 7
Installation einer Anwendung bricht mit Fehlercode 1628 Failed to complete installation! ab
Frage von trallerWindows 711 Kommentare

Hallo, ich versuche ein Programm auf Windows 7 zu installieren. Es öffnet wohl der MSI, bricht aber mit Fehlercode ...

Neue Wissensbeiträge
Sicherheit

Blackberry stirbt - Keine Updates für Priv mehr

Tipp von certifiedit.net vor 34 MinutenSicherheit

Blackberry wird zu einer 08/15 Firma und geht wohl mehr und mehr den Weg, den HTC schon ging. Von ...

Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 2 TagenWindows 108 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 2 TagenSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 2 TagenInternet5 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

Heiß diskutierte Inhalte
Batch & Shell
Kann man mit einer .txt Datei eine .bat Datei öffnen?
gelöst Frage von HelloWorldBatch & Shell20 Kommentare

Wie schon im Titel beschrieben würde ich gerne durch einfaches klicken auf eine Text oder Word Datei eine Batch ...

LAN, WAN, Wireless
WLAN Reichweite erhöhen mit neuer Antenne
gelöst Frage von gdconsultLAN, WAN, Wireless10 Kommentare

Hallo, ich besitze einen TL-WN722N USB-WLAN Dongle mit einer richtigen Antenne. Ich frage mich jetzt ob man die Reichweite ...

Router & Routing
Wieso kann ich den UPD 7000-9000 nicht freigeben?
Frage von Jayk0bRouter & Routing8 Kommentare

Router: Telekom W 723V Ports: UDP 7000-9000 Können nicht frei gegeben werden. Benutzgrund: Rocket League 7000 – 9000 UDP ...

Router & Routing
Fritzbox Gastnetz - exposed Host - zur Sophos IPTV
Frage von medikopterRouter & Routing8 Kommentare

Hallo zusammen, ich habe eine Frage bezüglich des Fritz box Gastzugangs an einer Sophos UTM Home. An liebsten wäre ...