Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Ubuntu 8.04 - WLAN-Modul wird nicht erkannt

Frage Linux Ubuntu

Mitglied: pi314

pi314 (Level 1) - Jetzt verbinden

16.05.2008, aktualisiert 29.05.2008, 14269 Aufrufe, 6 Kommentare

802.11b/g USB WLAN

Hi,

habe hier ein nagelneues Laptop, das ganz jungfräulich zu mir kam - also kein BS jemals auf der Platte.
Legte also los und installierte Ubuntu 7.10 d'rauf.
Funktioniert alles soweit, nur ich bekomme das WLAN-Modul nicht erkannt.

Auch ein Update auf Ubuntu 8.04 brachte hier nix.
Laut Beschreibung ist ein 802.11b/g USB WLAN eingebaut.
Eingeschalten habe ich ihn auch.

Folgende Ausgabe erscheint bei ifconfig:
01.
eth0      Link encap:Ethernet  Hardware Adresse 00:90:f5:6c:3c:c3   
02.
          inet Adresse:192.168.2.7  Bcast:192.168.2.255  Maske:255.255.255.0 
03.
          inet6-Adresse: fe80::290:f5ff:fe6c:3cc3/64 Gültigkeitsbereich:Verbindung 
04.
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1 
05.
          RX packets:1958 errors:0 dropped:0 overruns:0 frame:0 
06.
          TX packets:2042 errors:0 dropped:0 overruns:0 carrier:0 
07.
          Kollisionen:0 Sendewarteschlangenlänge:1000  
08.
          RX bytes:1449429 (1.3 MB)  TX bytes:349298 (341.1 KB) 
09.
          Interrupt:21 Basisadresse:0x6400  
10.
 
11.
lo        Link encap:Lokale Schleife   
12.
          inet Adresse:127.0.0.1  Maske:255.0.0.0 
13.
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine 
14.
          UP LOOPBACK RUNNING  MTU:16436  Metrik:1 
15.
          RX packets:1830 errors:0 dropped:0 overruns:0 frame:0 
16.
          TX packets:1830 errors:0 dropped:0 overruns:0 carrier:0 
17.
          Kollisionen:0 Sendewarteschlangenlänge:0  
18.
          RX bytes:91652 (89.5 KB)  TX bytes:91652 (89.5 KB)

iwconfig bringt erwartungsgemäß:
01.
lo        no wireless extensions. 
02.
  
03.
eth0      no wireless extensions.
Ist leider nur eine Windows-Treiber dabei.
Auch ndiswrapper schafft keine Abhilfe. Konnte den Treiber zwar installieren, es erscheint aber:
01.
Hardware verfügbar: nein
ndiswrapper -l bringt:
01.
netrtuw : driver installed
Das ganze Ding bringt mich noch zum Wahnsinn! Will doch nur so'n klitzekleines WLAN zum Laufen bringen..

Danke für eu're Hilfe,
pi314
Mitglied: pi314
16.05.2008 um 20:25 Uhr
zur Zusatzinfo:

beim Abschalten des WLAN-Moduls wird folgendes auf syslog gemeldet:
01.
May 16 22:20:28 laptop kernel: [ 3199.407960] ACPI Error (psargs-0355): [COWL] Namespace lookup failure, AE_NOT_FOUND 
02.
May 16 22:20:28 laptop kernel: [ 3199.407977] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.PIB_.EC__._Q14] (Node f7c4b558), AE_NOT_FOUND 
03.
May 16 22:20:28 laptop kernel: [ 3199.531044] usb 5-7: USB disconnect, address 4 
04.
May 16 22:20:28 laptop NetworkManager: <debug> [1210969228.429005] nm_hal_device_removed(): Device removed (hal udi is '/org/freedesktop/Hal/devices/usb_device_bda_8189_00e04c000001_if0').  
05.
May 16 22:20:28 laptop NetworkManager: <debug> [1210969228.432839] nm_hal_device_removed(): Device removed (hal udi is '/org/freedesktop/Hal/devices/usb_device_bda_8189_00e04c000001').
Beim Einschalten das hier:
01.
May 16 22:23:28 laptop kernel: [ 3379.583309] ACPI Error (psargs-0355): [COWL] Namespace lookup failure, AE_NOT_FOUND 
02.
May 16 22:23:28 laptop kernel: [ 3379.583324] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.PIB_.EC__._Q14] (Node f7c4b558), AE_NOT_FOUND 
03.
May 16 22:23:29 laptop kernel: [ 3379.890442] usb 5-7: new high speed USB device using ehci_hcd and address 5 
04.
May 16 22:23:29 laptop kernel: [ 3380.029988] usb 5-7: configuration #1 chosen from 1 choice 
05.
May 16 22:23:29 laptop NetworkManager: <debug> [1210969409.235624] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/usb_device_bda_8189_00e04c000001').  
06.
May 16 22:23:29 laptop NetworkManager: <debug> [1210969409.315684] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/usb_device_bda_8189_00e04c000001_if0').
Nach dem Einschalten gibt lsusb folgendens aus:
01.
Bus 005 Device 005: ID 0bda:8189 Realtek Semiconductor Corp.  
02.
Bus 005 Device 001: ID 0000:0000   
03.
Bus 004 Device 001: ID 0000:0000   
04.
Bus 003 Device 001: ID 0000:0000   
05.
Bus 002 Device 001: ID 0000:0000   
06.
Bus 001 Device 001: ID 0000:0000
Nur kann ich damit nix anfangen..
Ich schau' derweil mal, ob ich irgendwelche Mainboard-Infos auftreibe..
Bitte warten ..
Mitglied: brammer
16.05.2008 um 21:09 Uhr
Hallo,

hilfreich wäre es wenn du uns verrätst welchers 'Laptop du denn hast und vor allen ob aus deinen ZUnterlagen dazu irgendwie hervorghtwasfür WLAN Karte in ddem Gerät drin ist...

Ansonsten ist alles weitere nur was für die GLaskugel.
(und die Glaskugel steht im Büro! und jetzt ist Wochenende)


brammer
Bitte warten ..
Mitglied: pi314
17.05.2008 um 13:14 Uhr
Tja, wie gesagt ist das einzige, das ich der Beschreibung entlocken konnte, das ein
01.
802.11b/g USB WLAN 
02.
Wireless LAN 54 MBit, intern 
03.
für Notebook Funk-LAN Adapter, 2.4GHz, Datenrate: 54 Mbps 
04.
Verschlüsselung: 128bit WEP/WPA; IEEE 802.11g 
05.
 
06.
WLAN nach 802.11A/B/G Standard 
07.
PCI Express Mini Card
verbaut ist.

Das Schlepptop ist ein KCSmobile premium, 17", Intel Core2Duo T5550</b>, 3.66 GHz, 3GB RAM.
Bitte warten ..
Mitglied: brammer
17.05.2008 um 23:58 Uhr
Hallo,

ohne genaue Kenntniss des WLAN Karten Typs wirst du wohl nicht weiter kommen.
Wenn dir de rSupport deshersteller snicht helfen kann/will solltest du überlegen mal WindowsXP in einer VMware zu installieren in der Hoffnung das du so die Typenbezeichung findest.
Andere Alternative wäre, das Laptop zu öffnen und nachzusehen was auf der Karte drauf steht. Zumindest eine FCC nummer sollte drauf stehen.
Oftmals sind die Mini PCI Karten von asussen zugänglich.

brammer
Bitte warten ..
Mitglied: pi314
18.05.2008 um 11:45 Uhr
Ist ein RTL8187B_WLAN_Adapter von Realtek.
01.
Bus 001 Device 003: ID 0bda:8189 Realtek Semiconductor Corp.  
02.
Device Descriptor: 
03.
  bLength                18 
04.
  bDescriptorType         1 
05.
  bcdUSB               2.00 
06.
  bDeviceClass            0 (Defined at Interface level) 
07.
  bDeviceSubClass         0  
08.
  bDeviceProtocol         0  
09.
  bMaxPacketSize0        64 
10.
  idVendor           0x0bda Realtek Semiconductor Corp. 
11.
  idProduct          0x8189  
12.
  bcdDevice            2.00 
13.
  iManufacturer           1 Manufacturer_Realtek 
14.
  iProduct                2 RTL8187B_WLAN_Adapter 
15.
  iSerial                 3 00e04c000001 
16.
  bNumConfigurations      1 
17.
  Configuration Descriptor: 
18.
    bLength                 9 
19.
    bDescriptorType         2 
20.
    wTotalLength           81 
21.
    bNumInterfaces          1 
22.
    bConfigurationValue     1 
23.
    iConfiguration          4 Wireless Network Card 
24.
    bmAttributes         0x80 
25.
      (Bus Powered) 
26.
    MaxPower              500mA 
27.
    Interface Descriptor: 
28.
      bLength                 9 
29.
      bDescriptorType         4 
30.
      bInterfaceNumber        0 
31.
      bAlternateSetting       0 
32.
      bNumEndpoints           9 
33.
      bInterfaceClass       255 Vendor Specific Class 
34.
      bInterfaceSubClass    255 Vendor Specific Subclass 
35.
      bInterfaceProtocol    255 Vendor Specific Protocol 
36.
      iInterface              2 RTL8187B_WLAN_Adapter 
37.
      Endpoint Descriptor: 
38.
        bLength                 7 
39.
        bDescriptorType         5 
40.
        bEndpointAddress     0x83  EP 3 IN 
41.
        bmAttributes            2 
42.
          Transfer Type            Bulk 
43.
          Synch Type               None 
44.
          Usage Type               Data 
45.
        wMaxPacketSize     0x0200  1x 512 bytes 
46.
        bInterval               0 
47.
      Endpoint Descriptor: 
48.
        bLength                 7 
49.
        bDescriptorType         5 
50.
        bEndpointAddress     0x04  EP 4 OUT 
51.
        bmAttributes            2 
52.
          Transfer Type            Bulk 
53.
          Synch Type               None 
54.
          Usage Type               Data 
55.
        wMaxPacketSize     0x0200  1x 512 bytes 
56.
        bInterval               0 
57.
      Endpoint Descriptor: 
58.
        bLength                 7 
59.
        bDescriptorType         5 
60.
        bEndpointAddress     0x05  EP 5 OUT 
61.
        bmAttributes            2 
62.
          Transfer Type            Bulk 
63.
          Synch Type               None 
64.
          Usage Type               Data 
65.
        wMaxPacketSize     0x0200  1x 512 bytes 
66.
        bInterval               0 
67.
      Endpoint Descriptor: 
68.
        bLength                 7 
69.
        bDescriptorType         5 
70.
        bEndpointAddress     0x06  EP 6 OUT 
71.
        bmAttributes            2 
72.
          Transfer Type            Bulk 
73.
          Synch Type               None 
74.
          Usage Type               Data 
75.
        wMaxPacketSize     0x0200  1x 512 bytes 
76.
        bInterval               0 
77.
      Endpoint Descriptor: 
78.
        bLength                 7 
79.
        bDescriptorType         5 
80.
        bEndpointAddress     0x07  EP 7 OUT 
81.
        bmAttributes            2 
82.
          Transfer Type            Bulk 
83.
          Synch Type               None 
84.
          Usage Type               Data 
85.
        wMaxPacketSize     0x0200  1x 512 bytes 
86.
        bInterval               0 
87.
      Endpoint Descriptor: 
88.
        bLength                 7 
89.
        bDescriptorType         5 
90.
        bEndpointAddress     0x89  EP 9 IN 
91.
        bmAttributes            2 
92.
          Transfer Type            Bulk 
93.
          Synch Type               None 
94.
          Usage Type               Data 
95.
        wMaxPacketSize     0x0200  1x 512 bytes 
96.
        bInterval               0 
97.
      Endpoint Descriptor: 
98.
        bLength                 7 
99.
        bDescriptorType         5 
100.
        bEndpointAddress     0x0a  EP 10 OUT 
101.
        bmAttributes            2 
102.
          Transfer Type            Bulk 
103.
          Synch Type               None 
104.
          Usage Type               Data 
105.
        wMaxPacketSize     0x0200  1x 512 bytes 
106.
        bInterval               0 
107.
      Endpoint Descriptor: 
108.
        bLength                 7 
109.
        bDescriptorType         5 
110.
        bEndpointAddress     0x0b  EP 11 OUT 
111.
        bmAttributes            2 
112.
          Transfer Type            Bulk 
113.
          Synch Type               None 
114.
          Usage Type               Data 
115.
        wMaxPacketSize     0x0200  1x 512 bytes 
116.
        bInterval               0 
117.
      Endpoint Descriptor: 
118.
        bLength                 7 
119.
        bDescriptorType         5 
120.
        bEndpointAddress     0x0c  EP 12 OUT 
121.
        bmAttributes            2 
122.
          Transfer Type            Bulk 
123.
          Synch Type               None 
124.
          Usage Type               Data 
125.
        wMaxPacketSize     0x0200  1x 512 bytes 
126.
        bInterval               0 
127.
Device Qualifier (for other device speed): 
128.
  bLength                10 
129.
  bDescriptorType         6 
130.
  bcdUSB               2.00 
131.
  bDeviceClass            0 (Defined at Interface level) 
132.
  bDeviceSubClass         0  
133.
  bDeviceProtocol         0  
134.
  bMaxPacketSize0        64 
135.
  bNumConfigurations      1 
136.
Device Status:     0x0000 
137.
  (Bus Powered)
greetz,
pi
Bitte warten ..
Mitglied: Hertie
29.05.2008 um 08:19 Uhr
welchen Windows-Treiber hast du denn installiert?? Den Windows XP-Treiber??
Wenn ja, hättest du vllt vorher Google benutzen sollen.

Mir scheint, du bist noch Linux-Neuling, deswegen mal als Tipp:
Bus 005 Device 005: ID 0bda:8189 Realtek Semiconductor Corp.
kopieren, bei Google einfügen, sinnvolle Links anklicken!
z.B. help.ubunutu.com
Fazit: Windows 98-Treiber laden und installieren. Einfach nach Anleitung vorgehen!

über Ubuntuusers.de hättest du auch herausgefunden (mit der Angabe deines Typs RTL8187B), dass der Chip in 2 Netgear-Geräten verbaut ist, du somit diesen Treiber möglicherweise verwenden kannst. Einfach mal ein bisschen rumprobieren

Mit freundlichen Grüßen
Bitte warten ..
Neuester Wissensbeitrag
Festplatten, SSD, Raid

12TB written pro SSD in 2 Jahren mit RAID5 auf Hyper-VServer

Erfahrungsbericht von Lochkartenstanzer zum Thema Festplatten, SSD, Raid ...

Ähnliche Inhalte
Ubuntu
Ubuntu 16.04 LTS friert immer ein (5)

Frage von Moddry zum Thema Ubuntu ...

Linux Netzwerk
Windows Netzwerkfreigaben unter Ubuntu 14.04 (2)

Frage von hildefeuer zum Thema Linux Netzwerk ...

Ubuntu
VMware 11 Workstation auf Ubuntu 16.04

Frage von bolle01 zum Thema Ubuntu ...

Apache Server
gelöst Apache und PHP auf Ubuntu 12.04.5.TLS installieren (8)

Frage von laster zum Thema Apache Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...