Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Ucarp: Interface wird nicht gestartet

Frage Netzwerke Cluster

Mitglied: BirdyB

BirdyB (Level 2) - Jetzt verbinden

19.11.2013 um 21:32 Uhr, 2039 Aufrufe, 1 Kommentar

Hallo zusammen,

ich habe 2 Loadbalancer mit HAProxy aufgesetzt, die ich mit UCARP ausfallsicher machen möchte.
Nun habe ich ucarp nach dieser Anleitung: http://www.debian-administration.org/articles/678 konfiguriert.
Leider startet das ucarp Interface auf keinem der beiden Hosts. Wenn ich versuche das Interface manuell zu starten (ifup eth0:ucarp), erhalte ich folgende Fehlermeldung:
01.
root@***:~# ifup eth0:ucarp 
02.
Missing required variable: address 
03.
Missing required configuration variables for interface eth0:ucarp/inet. 
04.
Failed to bring up eth0:ucarp.
obwohl ich in der /etc/network/interfaces folgende Konfiguration stehen habe:

01.
# The loopback network interface 
02.
auto lo 
03.
iface lo inet loopback 
04.
 
05.
# The primary network interface 
06.
allow-hotplug eth0 
07.
iface eth0 inet static 
08.
	address 10.10.20.15 
09.
	mask 255.255.255.0 
10.
	gateway 10.10.20.2 
11.
 
12.
# UCARP Setup 
13.
 
14.
        # vid : The ID of the virtual server [1-255] 
15.
        ucarp-vid 3 
16.
        # vip : The virtual address 
17.
        ucarp-vip 10.10.20.25 
18.
        # password : A password used to encrypt Carp communications 
19.
        ucarp-password secret 
20.
        # advskew : Advertisement skew [1-255] 
21.
        ucarp-advskew 1 
22.
        # advbase : Interval in seconds that advertisements will occur 
23.
        ucarp-advbase 1 
24.
        # master : determine if this server is the master 
25.
        ucarp-master yes 
26.
 
27.
# The carp network interface, on top of eth1 
28.
iface eth0:ucarp inet static 
29.
        address 10.10.20.25 
30.
        netmask 255.255.255.0
weiß jemand einen Rat? Danke für die Hilfe und Grüße!

Berthold
Mitglied: BirdyB
20.11.2013 um 00:22 Uhr
Okay, UCARP reagiert sehr allergisch auf Leerzeichen am Anfang einer Zeile...
Jetzt funktioniert es auch.
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
gelöst Verständnisfrage DMZ, warum nicht LAN2 Interface? (4)

Frage von Bytedreher zum Thema LAN, WAN, Wireless ...

Hardware
gelöst Bus Interface Unit (3)

Frage von xaver-2 zum Thema Hardware ...

LAN, WAN, Wireless
gelöst DHCP auf VLAN-Interface von PfSense nicht aktiv (13)

Frage von Asmodes zum Thema LAN, WAN, Wireless ...

Grafikkarten & Monitore
Intel User Interface - Sprache ändern (4)

Frage von FA-jka zum Thema Grafikkarten & Monitore ...

Neue Wissensbeiträge
Sicherheit

Millionen Euro in den Sand gesetzt?

(2)

Information von transocean zum Thema Sicherheit ...

Sicherheit

How I hacked hundreds of companies through their helpdesk

Information von SeaStorm zum Thema Sicherheit ...

Erkennung und -Abwehr

Ccleaner-Angriff war nur auf große Unternehmen gemünzt

(10)

Information von Lochkartenstanzer zum Thema Erkennung und -Abwehr ...

Heiß diskutierte Inhalte
Humor (lol)
gelöst Freidach Beitrag (40)

Frage von Penny.Cilin zum Thema Humor (lol) ...

Firewall
gelöst Firewall Firmeneimsatz (20)

Frage von wiesi200 zum Thema Firewall ...

Multimedia & Zubehör
gelöst 8 GB USB Stick besitzt nur noch 4 MB Kapazität (13)

Frage von Gwahlers zum Thema Multimedia & Zubehör ...