Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Ucarp: Interface wird nicht gestartet

Frage Netzwerke Cluster

Mitglied: BirdyB

BirdyB (Level 2) - Jetzt verbinden

19.11.2013 um 21:32 Uhr, 1933 Aufrufe, 1 Kommentar

Hallo zusammen,

ich habe 2 Loadbalancer mit HAProxy aufgesetzt, die ich mit UCARP ausfallsicher machen möchte.
Nun habe ich ucarp nach dieser Anleitung: http://www.debian-administration.org/articles/678 konfiguriert.
Leider startet das ucarp Interface auf keinem der beiden Hosts. Wenn ich versuche das Interface manuell zu starten (ifup eth0:ucarp), erhalte ich folgende Fehlermeldung:
01.
root@***:~# ifup eth0:ucarp 
02.
Missing required variable: address 
03.
Missing required configuration variables for interface eth0:ucarp/inet. 
04.
Failed to bring up eth0:ucarp.
obwohl ich in der /etc/network/interfaces folgende Konfiguration stehen habe:

01.
# The loopback network interface 
02.
auto lo 
03.
iface lo inet loopback 
04.
 
05.
# The primary network interface 
06.
allow-hotplug eth0 
07.
iface eth0 inet static 
08.
	address 10.10.20.15 
09.
	mask 255.255.255.0 
10.
	gateway 10.10.20.2 
11.
 
12.
# UCARP Setup 
13.
 
14.
        # vid : The ID of the virtual server [1-255] 
15.
        ucarp-vid 3 
16.
        # vip : The virtual address 
17.
        ucarp-vip 10.10.20.25 
18.
        # password : A password used to encrypt Carp communications 
19.
        ucarp-password secret 
20.
        # advskew : Advertisement skew [1-255] 
21.
        ucarp-advskew 1 
22.
        # advbase : Interval in seconds that advertisements will occur 
23.
        ucarp-advbase 1 
24.
        # master : determine if this server is the master 
25.
        ucarp-master yes 
26.
 
27.
# The carp network interface, on top of eth1 
28.
iface eth0:ucarp inet static 
29.
        address 10.10.20.25 
30.
        netmask 255.255.255.0
weiß jemand einen Rat? Danke für die Hilfe und Grüße!

Berthold
Mitglied: BirdyB
20.11.2013 um 00:22 Uhr
Okay, UCARP reagiert sehr allergisch auf Leerzeichen am Anfang einer Zeile...
Jetzt funktioniert es auch.
Bitte warten ..
Neuester Wissensbeitrag
Festplatten, SSD, Raid

12TB written pro SSD in 2 Jahren mit RAID5 auf Hyper-VServer

Erfahrungsbericht von Lochkartenstanzer zum Thema Festplatten, SSD, Raid ...

Ähnliche Inhalte
LAN, WAN, Wireless
SONICwALL erkennt down-Interface nicht und "glaubt" sie sei noch ONLINE ! (5)

Frage von SauBaer2014 zum Thema LAN, WAN, Wireless ...

Router & Routing
gelöst Sind virtuelle Interface mit VLANs bei einer PFSense möglich? (4)

Frage von StefanKittel zum Thema Router & Routing ...

Router & Routing
Squid3 auf PfSense CARP Interface

Frage von theoberlin zum Thema Router & Routing ...

Netzwerke
PfSense Netzwerkgeschwindigkeit von Interface zu Interface (2)

Frage von christianW zum Thema Netzwerke ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...