Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

UltraVNC hinter SBS Server

Frage Netzwerke Router & Routing

Mitglied: Nikkin

Nikkin (Level 1) - Jetzt verbinden

09.08.2007, aktualisiert 10.08.2007, 4069 Aufrufe, 9 Kommentare

Hallo

Ich arbeite erst seit kurzem mit Windows SBS 2003 und versuche nun folgendes (leider seit ein paar Tagen ):
Ich habe ein Moden/Router, welches mit dem Internet verbunden ist. Der SBS Server ist mit diesem Modem verbunden. Über die 2. Netzwerkkarte des SBS Servers ist ein Hub installiert, an welchem die verschiedenen Clients angeschlossen sind.

Nun möchte ich übers Internet auf einen Client mittels UltraVNC zugreifen. Ist dieser Client direkt am Router angeschlossen, funktioniert alles wunderbar. Ist jedoch der Server dazwischen, funktioniert ist nicht mehr. Ich glaube ich muss irgend eine Einstellung unter RAS/Routing vornehmen... habe aber leider keine Ahnung wie. Kann mir jemand einen Tipp geben? Client: XP, Server: SBS 2003 Standard.

Beispiel:
Ich habe einen Router (Modem) und dieser ist direkt mit dem "Client"-Computer (192.168.1.101) verbunden. Beim Router (192.168.1.1) habe ich die "Statische NAT-IP-Adresse:" auf diesen Client eingestellt. UltraVNC hat so funktioniert.

Nun schliesse ich den Server dazwischen. Ich erstelle wieder diese Statische NAT-IP Adresse, diesmal aber auf den Server (192.168.1.2). Die zweite Netzwerkkarte im Server hat die IP 192.168.10.100. Aus meiner Sicht weis nun der Router, das Anfragen an die öffentliche IP an den Server weitergeleitet werden müssen. Nun muss doch der Server noch wissen, dass er diese Anfrage an den Client (192.168.10.101) weiterleiten muss. Wo kann ich dies in SBS 2003 einstellen? Desweitern: Was meint ihr zur Sicherheit, falls ich dies so installiere?



Besten Dank für Eure Beiträge im Voraus.
Gruess
Nik
Mitglied: aqui
09.08.2007 um 14:52 Uhr
Nein mit RAS/Routing hat das rein gar nichts zu tun ! Dein Szenario ist dieses hier:

http://www.administrator.de/Routing_mit_2_Netzwerkkarten_unter_Windows_ ...

Das Problem ist der NAT Prozess im Router bzw. dessen Port Forwarding Einstellung.
Wenn du das Port Forwarding im Router für VNC (Port TCP 5900) einrichtest dann musst du dort als lokale Zieladresse ja eine IP aus deinem Client Segment vorsehen, nämlich die die du remote administrieren willst.
Das Problem ist nun das diese ja in einem ganz anderen IP Netz liegt als der Router bzw. dessen LAN Interface selber.
Die Masse aller Consumer DSL Router kommt damit nicht klar und verweigert meist schon bei der Einrichtung des PFW strikt die Zusammenarbeit und das obwohl dieser Router natürlich eine statische Route zum Client IP Netz via Server in seiner Routing Tabelle eingetragen hat, er das Netz also sicher kennt.
Das ist ein generelles Firmware Problem dieser preiswerten DSL Router Systeme...leider. In Routern etwas höherer Preisklassen existiert dieses unsinnige Problem nicht.

Du hast also nur einen Workaround wenn du keine neue HW kaufen willst: Du machst eine VNC Session auf den Server und startest von diesem Wiederum eine VNC Session auf den Client. Nicht das Gelbe vom Ei... aber funktioniert !
Bitte warten ..
Mitglied: Nikkin
09.08.2007 um 15:53 Uhr
Hallo

Besten Dank schon mal. Habe das ganze nun mal versucht auf diese Weise aufzusetzen. Mit dem Router kann ich eine statische NAT zuweisen. Als Möglichkeit habe ich da aber nur den Server (wo die Clients dahinter sitzen) und dieses Notebook, womit ich schreibe. Wo genau muss ich nun einstellen, dass der Server weiss, dass Pakete an den Client geschickt werden soll? Ich gehe davon aus, dass dies doch beim Server eingestellt werden muss oder nicht? Wie funktioniert dies in SBS 2003?

Vielen Dank für die Hilfe... mit nun schon so lange dran...

Gruess
Nik
Bitte warten ..
Mitglied: Nikkin
09.08.2007 um 16:09 Uhr
Noch ein Nachtrag:

Beim Netopia Router kann ich wählen zwischen IP-Weiterleitung und NAT. Was ist korrekt? Wenn ich IP-Weiterleitung nutzen will, wie muss die öffentliche IP (die aktuell laufend ändert weil ich keine statische habe) immer neu eintragen. Wäre dies der korrekte Weg?

Ich habe das mal probiert, jedoch habe ich aktuell keine Webverbindung

öffentliche IP
Subnetz 255.255.255.0
Standardgateaway 192.168.1.1 (Router zwischen Internet und Server)
Bevorzugte DNS 192.168.1.1

Was mach ich falsch?
Bitte warten ..
Mitglied: 51705
09.08.2007 um 16:51 Uhr
Was mach ich falsch?

Sorry, aber eigentlich alles ;)

1. NAT auf dem Router einschalten
2. Route auf dem Router einrichten: alle Pakete an 192.168.10.101 sind an 192.168.1.2 zu senden (ggf. Netzwerk-Route, z.B. 192.168.10.0/255.255.255.0 -> 192.168.1.2)
3. Port für VNC im NAT auf den Client weiterleiten (192.168.10.101/5900?)
4. Firewall oder gar NAT auf dem SBS aktiviert? -> Hol dir jemanden, der sich damit auskennt.

Nicht falsch verstehen, aber da besteht doch etwas mehr Lernbedarf, als ich hier schreiben mag.

Grüße, Steffen
Bitte warten ..
Mitglied: aqui
09.08.2007 um 17:05 Uhr
@Nikkin

Du hast dir das Turorial von oben ja sicher durchgelesen, aber scheinbar nicht richtig verstanden...
Dann wiesst du also das dein Server ja schon Packete per se weiterreicht nämlich vom Router eben in das Client Segment. Er routet also alle deine Daten die vom Router oder Clientsegment kommen, ist also selber ein Router.

Das Problem ist die Port Weiterleitung im Internet Router. Die müsste um einen PC im Client Segment zu erreichen ja eine IP Zieladresse aus dem Clientsegment bekommen also ein IP Netz was am Router ja selber gar nicht angeschlossen ist und was der Router so gar nicht kennt. Deine Netze zwischen Router Verbindung und Clientsegment sind ja vollkommen unterschiedlich !

Das ist das Problem das die Masse der Consumer Router so eine lokale IP Weiterleitungs Adresse die, wie gesagt, NICHT im eigenen IP Netz liegt was der Router am eigenen LAN Port hat (denn es ist ja dein Clientsegment und damit hinter dem Server !) klarkommen.
Entweder nehmen sie die Adress Konfig gar nicht erst an oder sie führen die Weiterleitung nicht aus auch wenn der Router eine statische Route via Server (als Router) hat. Das ist also dein Problem was du auch niemals mit einer Konfig regeln kannst, denn das ist ein Fehler in der Firmware dieser Router !

Setzt du die IP Weiterleitung nun auf deine Server IP Adresse schickt der Router eingehende Packete an seinem DSL Port die die Portnummer TCP 5900 haben nun an diese Serveradresse. Die Portnummer bleibt aber erhalten und wenn der Server nun keinen Prozess/Applikation hat der auf Port TCP 5900 lauscht (wie VNC) schmeisst er das Packet sofort weg.

Fazit: Es bleiben nur 2 Lösungen:
a.) der doppelte VNC Hop über den Server mit VNC drauf und von dort wiedermit VNC zum Client wie oben beschrieben
b.) Den Server selber im NAT bzw. ICS Modus bei Windows laufen zu lassen und dann ein Port Forwarding dort nochmal auf dem Server zu konfigurieren was aber Probleme bereiten kann
Dafür gilt aber dann wieder Punkt 4. von smerlin oder.....die MS Knowledgebase !
Bitte warten ..
Mitglied: Nikkin
09.08.2007 um 23:36 Uhr
Hallo

Das Tutorial habe ich jetzt schon sicherlich 2-3x durchgelesen. Nun, ich musste auch diesen Text mehrmals durchlesen. Ich habe Netopia 3357WG als Router. Dort kann ich statische NAT einstellen. So wie ich es jetzt verstanden habe, sollte ich folgendes tun:

83.83.83.83 öffentliche IP [ÖIP]
192.168.1.1 Router [R]
192.168.1.2 Server Netzwerkkarte 1 [SN1]
192.168.10.100 Server Netzwerkkarte 2 [SN2]
192.168.10.101 Client PC [CPC]
Server = SBS 2003 Standard

Nun erstelle ich eine statische NAT Weiterleitung vom Router an SN1. Somit kommen alle Anfragen vom ÖIP direkt zum Server SN1. Nun muss ich den Server so konfigurieren, dass er diese Portnummer 5900 (Woher kommt diese überhaupt?) an den Client weiterleitet, oder weiss dass er das Paket an den Client weiterleiten muss. Wo stelle ich dies ein im SBS 2003?

@steffen

Also (1) wäre damit erledigt.
Meinst Du bei Nr. (2) mit Router den Server (als Router)? Wo finde ich dies im SBS 2003?
Zu (3): Wo leite ich die PortNr im SBS 2003 weiter?
....

Nun, ich verstehe Dich nicht falsch und bin überhaupt schon dankbar, dass jemand was schreibt... bin nun schon seit Montag am üben, testen und eben lernen...wobei mir halt das Basiswissen leider noch fehlt.

Werde morgen weiterüben...
Gruess Nik
Bitte warten ..
Mitglied: 51705
10.08.2007 um 09:23 Uhr
@Steffen

Also (1) wäre damit erledigt.
Meinst Du bei Nr. (2) mit Router den Server
(als Router)? Wo finde ich dies im SBS 2003?
Zu (3): Wo leite ich die PortNr im SBS 2003
weiter?

Im Moment weis dein Router, das das Netz 192.168.1.0/24 (also 0-255) intern ist. Der Router weis nicht, das auch das Netz 192.168.10.0/24 intern ist. Der Router würde also Paket mit der IP 192.168.10.101 in Internet senden (Default Route).

Deshalb muß auf dem Router eine weiterer Eintrag im Routing Table gemacht werden (Netzwerk Route): Alle Pakete an das Netz 192.168.10.0/24 sind an 192.168.1.2 weiterzuleiten. Oder (Host Route): Alle Pakete an 192.168.10.101/32 sind an 192.168.1.2 weiterzuleiten.

Auf dem SBS ist eigentlich nichts weiter einzustellen, denn der kennt ja die beiden Netze.
Bitte warten ..
Mitglied: Nikkin
10.08.2007 um 09:54 Uhr
Juhui Juhui Juhui, es hat geklappt.

Folgender Link hat mir ebenfalls weitergeholfen.
http://technet2.microsoft.com/WindowsServer/de/Library/6dd18466-d9dc-43 ...

-> Router mit NAT auf Server umleiten
-> Auf dem Server Port weiterleitung erstellen auf Netzwerkkarte Internet.

Super, es geht Juhui.
Gruess
Nik
Bitte warten ..
Mitglied: aqui
10.08.2007 um 12:11 Uhr
Zum Schluss noch eine Anmerkung:

Du machst dann aber KEIN klassisches Routing Szenario mit deinem Server wie im o.a. Tutorial beschrieben ist, sondern du NATest 2mal nämlich einmal mit dem Server zum Routersegment und dann einmal mit dem Router ins Internet. IP technisch eher suboptimal da fehlerträchtig und nicht gerade performant aber was solls, wenn es denn jetzt alles klappt ist ja alles gut !!! Never touch a running system...

Bitte dann
http://www.administrator.de/index.php?faq=32
nicht vergessen !!!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...