Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Umlaute bei Telnetverbindung gehen verloren

Frage Linux

Mitglied: MartinKl

MartinKl (Level 1) - Jetzt verbinden

11.03.2009, aktualisiert 17:52 Uhr, 4252 Aufrufe, 1 Kommentar

Guten Abend,

wir haben eine Applikation im Einsatz die Intern über Telnet angesprochen wird.

Nun möchte jemand von Extern diese Applikation nutzen. Also habe ich einen Linux (Debina Lenny) Rechner genommen und mir gedacht, dass der Nutzer mittels SSH auf die Linuxkiste sich verbindet. Von dort geht es dann per Telnet weiter.
Dies funktioniert auch soweit.
Nun habe ich ein Problem mit Umlauten.

Es stellt sich wie folgt dar:
- LinuxBox, Console -> Telnet -> Applikation : Umlaute sind OK
- Extern (mindterm Applet) -> LinuxBox, Console : Umlaute sind OK
- Extern (mindterm Applet) -> LinuxBox, Console -> Telnet -> Applikation : Umlaute werden nicht dargestellt
Für ein kleine ö kommt ein umgedrehtes T, nach Beendigung der Telnet-Verbindung wird dies Zeichen auch auf der Console der LinuxBox angezeigt

und nun das beste:
- Extern (Putty) -> LinuxBox, Console -> Telnet -> Applikation : Umlaute sind OK

Ich habe schon alle Einstellungen bei mindterm durch und bin am ende von Google angelangt. Vielleicht weis jemand von euch rat, oder hat noch einen Tipp, damit ich bei Google noch ein wenig suchen kann.

Vielen Dank und einen schönen Abend,
Gismo
Mitglied: n.o.b.o.d.y
11.03.2009 um 20:11 Uhr
Hallo,

das Zauberwort ist natürlich der Emulationstyp (VT100 und wie sie alles heißen), den die Applikation in der Telnetsession vordert. Den muß das mindterm natürlich mitbringen.
Wobei ich mich frage, wo das Problem ist, wenn es doch mit PuTTY läuft.
Bitte warten ..
Ähnliche Inhalte
Voice over IP
Gigaset C430G - Verbindungszuordnungen gehen regelmäßig verloren

Frage von istike2 zum Thema Voice over IP ...

Monitoring
gelöst SNMP Traps gehen nicht (mehr) (4)

Frage von Ex0r2k16 zum Thema Monitoring ...

LAN, WAN, Wireless
VPN Tunel geht verloren nach VM Switching (5)

Frage von staybb zum Thema LAN, WAN, Wireless ...

Neue Wissensbeiträge
Batch & Shell

Batch - ein paar Basics die man kennen sollte

Tipp von Pedant zum Thema Batch & Shell ...

Microsoft

Restrictor: Profi-Schutz für jedes Window

(6)

Tipp von AlFalcone zum Thema Microsoft ...

Batch & Shell

Batch zum Zurücksetzen eines lokalen Profils

Tipp von Mr.Error zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Windows Server
gelöst Benutzer lässt sich nur an einem Clientcomputer anmelden (17)

Frage von Ammann zum Thema Windows Server ...

Netzwerke
SFP Modul (miniGibic) (11)

Frage von apranet zum Thema Netzwerke ...

Batch & Shell
gelöst Gruppenzugehörigkeit von AD Usern ermitteln - die Perfektion fehlt (11)

Frage von Stefan007 zum Thema Batch & Shell ...