Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Unattend.xml fügt Computer NICHT zur Domäne hinzu und Loggt Administrator NICHT automatisch beim ersten mal ein.

Frage Microsoft Windows Installation

Mitglied: Schulnetzwerk

Schulnetzwerk (Level 1) - Jetzt verbinden

01.10.2012 um 21:24 Uhr, 5962 Aufrufe, 4 Kommentare

Die Computer einer Schule sollten sich dank unattend.xml bei der Neuinstallation über WDS automatisch an der Domäne anmelden. Der angelegte lokale Administrator soll sich auch gleich einloggen. Leider funktioniert beides nicht.

Liebe Leidensgenossen,

mit meinem unattend.xml konnte ich bereits den lokalen Admin anlegen, Windows registrieren und vieles mehr. Der Computername muss noch per Hand eingegeben werden, doch das ist gewollt.

Doch leider gelingt es mir nicht den Computer zur Domäne hinzuzufügen. Außerdem sollte der lokale Administrator sich per Autologon nach dem Installationsprozess einloggen; doch auch das wird mir verweigert.

Wo liegt der Fehler in meinem XML-File? Ich wäre um Vorschläge dankbar, da ich zur Zeit nur noch rumprobiere:


<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="generalize">
<component name="Microsoft-Windows-Security-SPP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<SkipRearm>1</SkipRearm>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<RunSynchronous>
<RunSynchronousCommand wcm:action="add">
<Order>1</Order>
<Path>net user administrator /active:yes</Path>
</RunSynchronousCommand>
</RunSynchronous>
</component>
<component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<SkipAutoActivation>true</SkipAutoActivation>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<CopyProfile>true</CopyProfile>
<ShowWindowsLive>false</ShowWindowsLive>
<TimeZone>W. Europe Standard Time</TimeZone>
</component>
<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<Identification>
<UnsecureJoin>false</UnsecureJoin>
<Credentials>
<Domain>domain.loc</Domain>
<Password>Password1+</Password>
<Username>administrator@domain.loc</Username>
</Credentials>
<JoinDomain>domain.loc</JoinDomain>
</Identification>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<InputLocale>de-DE</InputLocale>
<SystemLocale>de-DE</SystemLocale>
<UILanguage>de-DE</UILanguage>
<UserLocale>de-DE</UserLocale>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<AutoLogon>
<Password>
<Value>LoKalPassword1+</Value>
<PlainText>true</PlainText>
</Password>
<Enabled>true</Enabled>
<LogonCount>5</LogonCount>
<Username>administrator</Username>
</AutoLogon>
<FirstLogonCommands>
<SynchronousCommand wcm:action="add">
<Order>1</Order>
<RequiresUserInput>false</RequiresUserInput>
<CommandLine>cscript b c:\windows\system32\slmgr.vbs /ipk XXXX-RXXXXED-XXXXP-XXXXX-9XXXX4 </CommandLine>
</SynchronousCommand>
<SynchronousCommand wcm:action="add">
<Order>2</Order>
<RequiresUserInput>false</RequiresUserInput>
<CommandLine>cscript
b c:\windows\system32\slmgr.vbs /ato</CommandLine>
</SynchronousCommand>
</FirstLogonCommands>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Home</NetworkLocation>
<ProtectYourPC>1</ProtectYourPC>
</OOBE>
<UserAccounts>
<AdministratorPassword>
<Value>dwAzAGsAVAAxADgAcAAzAFMAQQBkAG0AaQBuAGkAcwB0AHIAYQB0AG8AcgBQAGEAcwBzAHcAbwByAGQA</Value>
<PlainText>false</PlainText>
</AdministratorPassword>
<LocalAccounts>
<LocalAccount wcm:action="add">
<Password>
<Value>dwAzAGsAVAAxADgAcAAzAFMAUABhAHMAcwB3AG8AcgBkAA==</Value>
<PlainText>false</PlainText>
</Password>
<Name>Administrator</Name>
<Description>Local Administrator</Description>
<DisplayName>Administrator</DisplayName>
<Group>Administrators</Group>
</LocalAccount>
</LocalAccounts>
</UserAccounts>
<RegisteredOrganization>Meine Organisation</RegisteredOrganization>
<RegisteredOwner>Chef-Name</RegisteredOwner>
</component>
</settings>
<cpi:offlineImage cpi:source="wim:c:/install.wim#Windows 7 ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>
Mitglied: tikayevent
01.10.2012 um 22:28 Uhr
Der Computername muss noch per Hand eingegeben werden, doch das ist gewollt.
Das geht nicht! Der Domain-Join läuft bereits ab, ehe du ins OOBE kommst, in dem du den Computernamen setzen kannst. Entweder vergibst du den Namen bereits per WDS, sprich du nimmst den Computer vorab ins AD auf, mit seiner MAC-Adresse, gibst ihm dadurch einen Namen, welchen das WDS dann benutzen kann oder du scriptest den Domain-Join als Befehl nach dem OOBE.
Bitte warten ..
Mitglied: Schulnetzwerk
01.10.2012 um 22:38 Uhr
Hallo tikayevent,

vielen Dank für den Tipp. Werde also mal <Computername>*</Computername> im Spezialize-Bereich setzen. Dadurch müsste es somit gehen.
Zu deinem zweiten Vorschlag: Wie krieg ich den Spezialize-JoinDomain-Teil hinter mein OOBE. Werden die Spezialize-Abschnitte nicht immer zuerst ausgeführt?

Ich bin schon mal am tippen und Image-Bastenl/Ausprobieren. Vielen Dank schon mal für die Denkanstöße.
Bitte warten ..
Mitglied: tikayevent
01.10.2012 um 22:41 Uhr
Nein, mit dem JoinDomain aus der XML gehts gar nicht. Du müsstest das entweder über die netdom.exe oder per add-Computer der Powershell machen.
Bitte warten ..
Mitglied: Schulnetzwerk
01.10.2012 um 22:50 Uhr
Danke für diesen schnellen Hinweis. Hätte sogar schon sysprep mit einer veränderten unattend.xml durchlaufen lassen. Werde jetzt erst mal ein Image ohne Domänenbeitritt erstellen (für die Arbeit morgen), mir ein Bierchen aufmachen und mich dann gemütlich in die Beschreibungen von netdom und add-Computer einlesen
Danke!
Bitte warten ..
Ähnliche Inhalte
Windows Installation
Unattend.xml Sysprep Antwortdatei mit Domäneneintritt (7)

Frage von LDoYouKnow zum Thema Windows Installation ...

Hyper-V
Wieso werden Computer aus der Domäne "geworfen" ? (5)

Frage von Tastuser zum Thema Hyper-V ...

Server-Hardware
gelöst Mein erstes Mal: ProLiant DL180 G6 sinnvoll? Was muss ich beachten? (25)

Frage von alex999 zum Thema Server-Hardware ...

Server
gelöst NTPD loggt keine Zugriffe (4)

Frage von ketanest112 zum Thema Server ...

Neue Wissensbeiträge
Windows 10

Heise Newsticker: Microsoft veröffentlicht das "Fall Creators Update

(8)

Information von Penny.Cilin zum Thema Windows 10 ...

LAN, WAN, Wireless

Schwachstelle im WPA2 Protokoll veröffentlicht

(3)

Information von colinardo zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows Server
gelöst Gruppenrichtlinie greift nicht zu! (23)

Frage von Syosse zum Thema Windows Server ...

Hosting & Housing
Mailserver Software Empfehlungen (20)

Frage von sunics zum Thema Hosting & Housing ...

Windows 7
gelöst Windows 7 Anmeldedomäne festlegen (13)

Frage von flotaut zum Thema Windows 7 ...