Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Unattended-Deployment mit WDS: Nur der original gesysprepte Rechner installiert sich richtig.

Frage Microsoft Windows Installation

Mitglied: Schulnetzwerk

Schulnetzwerk (Level 1) - Jetzt verbinden

02.09.2013 um 12:51 Uhr, 2039 Aufrufe, 4 Kommentare, 1 Danke

Liebe Leidensgenossen,

ich habe einen Win 7 Prof.-Rechner virtuell (HyperV / 2008 R2) aufgesetzt und ihn mit Sysprep für den WDS vorbereitet. Dabei habe ich die unten angefügte Unattended.xml-Datei verwendet.
Nach dem problemlosen Aufzeichnen des Images durch den WDS konnte ich das Image auf die gewünschten Rechner verteilen. Allerdings waren die im unattended-File angegebenen Parameter nicht berücksichtigt.

Beim Starten des originalen mit Sysprep vorbereiteten Rechners wurde jedoch der korrekte Installationsvorgang inkl. Anlegen des Admins mit korrekter Passwortvergabe, DomainJoin, Aktivierung von Windows) vollzogen.

Wieso kommt es zu dieser unterschiedlichen Verarbeitung. Eigentlich müsste sich doch das WDS-Image ebenso verhalten wie der "Master-Image-Rechner"?

Gibt es etwa einen Fehler in meinem Unattended-File, der den ganzen Schlamassel verursacht hat?

Vielen Dank für eventuelle Hinweise.

Wolfgang Pöschl

--
<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="specialize">
<component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<RunSynchronous>
<RunSynchronousCommand wcm:action="add">
<Order>1</Order>
<Path>net user administrator /active:yes</Path>
</RunSynchronousCommand>
</RunSynchronous>
</component>
<component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<SkipAutoActivation>true</SkipAutoActivation>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<ComputerName>*</ComputerName>
<CopyProfile>true</CopyProfile>
<ShowWindowsLive>false</ShowWindowsLive>
<TimeZone>W. Europe Standard Time</TimeZone>
</component>
<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<Identification>
<Credentials>
<Domain>schule.loc</Domain>
<Password>DomainPasswort</Password>
<Username>administrator</Username>
</Credentials>
<JoinDomain>schule.loc</JoinDomain>
<UnsecureJoin>false</UnsecureJoin>
</Identification>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<InputLocale>de-de</InputLocale>
<SystemLocale>de-de</SystemLocale>
<UILanguage>de-de</UILanguage>
<UserLocale>de-de</UserLocale>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Home</NetworkLocation>
<ProtectYourPC>1</ProtectYourPC>
</OOBE>
<TimeZone>W. Europe Standard Time</TimeZone>
<UserAccounts>
<AdministratorPassword>
<Value>LokalPasswort</Value>
<PlainText>true</PlainText>
</AdministratorPassword>
<LocalAccounts>
<LocalAccount wcm:action="add">
<Password>
<Value>LokalPasswort</Value>
<PlainText>true</PlainText>
</Password>
<Description>Administrator Lokal</Description>
<DisplayName>Administrator</DisplayName>
<Group>Administrators</Group>
<Name>Administrator</Name>
</LocalAccount>
</LocalAccounts>
<DomainAccounts>
<DomainAccountList wcm:action="add">
<Domain>Schule.loc</Domain>
<DomainAccount wcm:action="add">
<Group>Administrators</Group>
<Name>Administrator</Name>
</DomainAccount>
</DomainAccountList>
</DomainAccounts>
</UserAccounts>
<AutoLogon>
<Password>
<Value>DomainPasswort</Value>
<PlainText>true</PlainText>
</Password>
<Domain>Schule.loc</Domain>
<Enabled>true</Enabled>
<LogonCount>2</LogonCount>
<Username>administrator</Username>
</AutoLogon>
<RegisteredOrganization>Schulname</RegisteredOrganization>
<RegisteredOwner>Schulname</RegisteredOwner>
<FirstLogonCommands>
<SynchronousCommand wcm:action="add">
<CommandLine>cscript b c:\windows\system32\slmgr.vbs /ipk MAK-Keyfile</CommandLine>
<Order>1</Order>
<RequiresUserInput>false</RequiresUserInput>
</SynchronousCommand>
<SynchronousCommand wcm:action="add">
<CommandLine>cscript
b c:\windows\system32\slmgr.vbs /ato</CommandLine>
<Order>2</Order>
<RequiresUserInput>false</RequiresUserInput>
</SynchronousCommand>
</FirstLogonCommands>
</component>
</settings>
<settings pass="generalize">
<component name="Microsoft-Windows-Security-SPP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<SkipRearm>1</SkipRearm>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<UserAccounts>
<DomainAccounts>
<DomainAccountList wcm:action="add">
<Domain>schule.loc</Domain>
<DomainAccount wcm:action="add">
<Group>Administrators</Group>
<Name>Administrator</Name>
</DomainAccount>
</DomainAccountList>
</DomainAccounts>
<AdministratorPassword>
<Value>DomainPasswort</Value>
<PlainText>false</PlainText>
</AdministratorPassword>
</UserAccounts>
</component>
</settings>
<cpi:offlineImage cpi:source="wim:c:/install.wim#Windows 7 ENTERPRISE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>


Mitglied: ollioe
02.09.2013 um 15:34 Uhr
Moin,
hast du in den Eigenschaften des zu verteilenden Image (in der Konsole für Win Bereitstellung, Installaionsabbilder) die unbeaufsichtigte Installation mit dem Script verknüpft?
Bitte warten ..
Mitglied: Schulnetzwerk
02.09.2013 um 16:14 Uhr
Hallo ollioe,

nein habe ich nicht. Die obige unattend.xml ist ja nicht die für eine unbeaufsichtigte WDS-Installation, sondern die unattend.xml des Images. Ich dachte die jeweiligen Einstellungen werden beim Durchlauf von Sysprep gespeichert und sind somit bei der Übertragung auf den WDS schon integriert. Oder bringe ich schon wieder alles durcheinander.
Ich werde mir die WDS-Einstellungen noch mal genauer anschauen.

Wolfgang
Bitte warten ..
Mitglied: ollioe
02.09.2013 um 16:22 Uhr
Solange dem zu verteilenden Image keine Antwortdatei beiliegt werden "nur" die Imageeigenschaften abgearbeitet, nicht jedoch der Userteil, dieser wurde per Sysprep entfernt. Domänenbeitritt, User etc. müssen per Antwortdatei an das Image übergeben werden und in den Imageeigenschaften zugewiesen werden.
Bin ich zu Anfang auch drauf reingefallen.
Bitte warten ..
Mitglied: Schulnetzwerk
02.09.2013 um 23:12 Uhr
Danke,

genau das war das Problem. Die ersten Testläufe waren erfolgreich. Werde jetzt noch mit den XML-Dateien ein wenig herumspielen.
Wenn nur das ewige Warten nicht wäre um endlich zu sehen, ob nach dem Austeilen des Images die ganzen Einstellungen auch übernommen wurden.

Danke noch mal und gute Nacht!

Wolfgang
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...