Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Unerklärliche Konnektivitätsprobleme SBS 2008

Frage Microsoft Windows Server

Mitglied: highmoe

highmoe (Level 1) - Jetzt verbinden

15.05.2012 um 08:55 Uhr, 3407 Aufrufe, 9 Kommentare

Seit ca. 4 Wochen habe ich bei einem Kunden nachfolgend beschriebenes Problem. Recherche hat bisher nicht viel ergeben

Setup:
- SBS 2008 SP2 auf Dell R310
- 1 Terminalserver W2K8R2 (virtuell) für wenige Benutzer
- 1 Server W2K3 (nur für TKA, sonst keine Funktionen
- 2 Netgear ReadyNAS+, davon 1 mit 2 Shares, 1 für Backupzwecke
- 14 Clients alle Win7
- 2 ThinClients HP
- 2 Netzwerkdrucker
- Netzwerk durchgängig Gigabit Ethernet
- DSL-Anbindung über Astaro

Problem:
Aufgrund noch nicht ganz klaren Anlasses kommt es dazu, dass kein Client mehr auf Netzwerkshares zugreifen kann, ebenfalls kann Outlook nicht mehr auf den Exchange Server zugreifen.
Prinzipiell ist aber Konnektivität vorhanden, es kann gedruckt werden, Zugriff auf Internet ist weiterhin möglich, der SBS kann per RDS erreicht und sauber neu gestartet werden.
Nach Neustart des Servers klappt alles wieder.
Dies passiert in unregelmäßigen Intervallen, manchmal geht es dann einige Tage wieder, das Problem ist aber auch schon bis zu 4 mal an einem Tag aufgetreten.
Durch die ewig langen Shutdown- und Startzeiten des SBS geht aber jedesmal locker eine halbe Stunde Arbeitszeit für alle flöten...

Bisherige Analyse und Lösungsansätze:
Der virt. Terminalserver lief zunächst huckepack auf dem SBS. Nachdem ich erfahren hatte, dass das keine so gelungene Kombination ist und MS davon abrät (es können laut einiger Artikel, die fand, exakt solche Probleme auftreten), habe ich den TS auf einen zweiten Dell R310 gepackt und die Hyper-V-Rolle auf dem SBS entfernt - Problem jedoch nicht gelöst.
Die Logs des SBS geben absolut NIX her, das bei der Fehlersuche hilfreich ist.
Bisher konnte ich in einigen (nicht allen!) Fällen mögliche Auslöser finden:
- GF synchronisiert einige Bereiche der Dateiablage mit seinem Notebook, bisher mit SyncToy, jetzt mit Synkron. Mit beiden Tools folgt der "Absturz" bei einem bestimmten Verzeichnisbaum
- Nach Installation eines Management Tools für die Malwarescanner auf dem SBS erfolgte der Absturz kurz nach Beginn des Netzwerkscans
- Nach absturzbedingten Reboots des SBS erfolgte kurz nach Neustart-Freigabe für die Clients ein erneuter Absturz
Diese drei Szenarien deuten für mich darauf hin, dass eine Vielzahl von Netzwerk-Requests Auslöser des Problems sein _könnten_, andererseits setze ich seit Bestehen des jetzigen Netzwerks Synkron (auf dem SBS) für die Replikation der Dateiablage ein (auf ein NAS), das läuft zwei Mal am Tag ohne Probleme und macht ja auch ne Menge Traffic.
Ein anderer Verdacht meinerseits ist, dass irgendwie das AD "aussteigt", jedoch finde ich dafür keine Hinweise in den Logs, ist ein reines Bauchgefühl *sic*. Erwähnenswert wäre vielleicht noch, dass nach "absturzbedingtem" Reboot sehr oft - aber halt auch nicht immer - 3 Dienste nach dem Reboot nicht automatisch gestartet werden (Exchange IS und 2 SQLAgents) und manuell gestartet werden müssen.

Für Ideen oder Erfahrungen möglicher Leidensgenossen wäre ich sehr dankbar.

LG, Haimo Grebenstein
Mitglied: Pago159
15.05.2012 um 11:39 Uhr
Hallo Haimo,

welches AV-Tool (Version bitte auch angeben), und MMC (bitte auch Version angeben) für das AV benutzt du denn?
Hast du mal geschaut, ob dieses auch den SBS 2008 unterstützt?
Evt. mal das AV-Programm testweise deaktiviert? Ist leider etwas unglücklich, wenn man nicht weis, wann der Fehler genau Auftritt,
du könntest aber dann mal den SYNC mit SYNC-TOY testen, wenn das AV deaktiviert ist und mal schauen, wie sich das ganze verhält.

Lg Grapper
Bitte warten ..
Mitglied: highmoe
15.05.2012 um 11:55 Uhr
Hallo Grapper,

auf dem SBS selbst läuft gar keine AV- oder Malware-Software, nur die Clients haben das installiert.
Bitte warten ..
Mitglied: Pago159
15.05.2012 um 12:01 Uhr
Sorry, man sollte auch schauen, was man liest und schreibt

Welchen Malewarescanner und MMT setzt du auf dem Server ein?
Bitte warten ..
Mitglied: frakaci
15.05.2012 um 12:29 Uhr
Erwähnenswert wäre vielleicht noch, dass nach "absturzbedingtem" Reboot sehr oft - aber halt auch nicht immer - 3 Dienste nach dem Reboot nicht automatisch gestartet
werden (Exchange IS und 2 SQLAgents) und manuell gestartet werden müssen.

Hi,
kommt mir Bekannt vor. Hast du IPv6 deaktiviert ?
"Mein" SBS 2008 wurde mit akt. IPv6 aufgesetzt und danach wurde, weil nicht vorhanden IPv6 deaktiviert. Und plötzlich startete Exchange und IIS nicht mehr.
Hakerl wieder gesetzt und alles OK

LG, frakaci
Bitte warten ..
Mitglied: highmoe
15.05.2012 um 13:02 Uhr
@Grapper:
KEIN Scanner auf dem SBS, die Clients haben Emsisoft drauf

@frakaci:
das mit IPV6 habe ich kurz nach der Erstinstallation auch gehabt
Ist aktiviert und konfiguriert auf den 2008er Servern, aber nicht auf den Clients.

LG, Haimo
Bitte warten ..
Mitglied: Pago159
15.05.2012 um 13:24 Uhr
So, habe gerade mal bei Emsisoft auf der Homepage geschaut, als Systemanforderungen sind gestellt:

W2k3 und w2k8 Server, allerdings kein SBS.


Hast du das MMT noch laufen? Wenn ja, schalte das mal ab.

Hast du evt. noch irgend etwas kurz vor dem ersten Auftreten des Problemes geändert.

Lg
Bitte warten ..
Mitglied: highmoe
15.05.2012 um 13:49 Uhr
@Grapper:
das Management Tool von Emsisoft wurde erst nach den ersten Abstürzen installiert und nach dem ersten Ausprobieren (mit verbundenem Absturz wie beschrieben) gleich wieder deinstalliert.

Ansonsten habe ich auf der Maschine nichts Nennenswertes geändert. Der DHCP-Server war für einige Tage deaktiviert (hatte den auf der Astaro im Einsatz) aber nicht deinstalliert, nach dem ersten Absturz wurde er mit bestehender Konfiguration wieder aktiviert. DHCP läuft aber nur pro forma und für neue Geräte mit - ich stehe auf feste IP-Adressen, wenn die Netze überschaubar sind
Bitte warten ..
Mitglied: Pago159
15.05.2012 um 16:38 Uhr
Kannst du bitte nochmal in deine Ereignisanzeige schauen?
Bist du sicher, dass dort keine Meldungen zu Netzwerk bereitstehen? Irgendwelche Warnungen oder Fehlermeldungen?
Wenn du dir nicht sicher sein solltest Poste doch einfach mal die letzten Logs nach solch einem Ausfall,
dass mal gemeinsam darüber geschaut werden kann.

Lg Grapper
Bitte warten ..
Mitglied: highmoe
04.06.2012 um 22:03 Uhr
So, nicht gelöst, aber sozusagen abgeschlossen....

Der Fall kann offensichtlich nicht vollständig gelöst werden. Ich habe noch zwei externe Server-Spezialisten drüber schauen lassen; beide nix gefunden.
Der Verdacht ist jedoch recht groß, dass es an einzelnen Dateinamen liegt, mit den Windows selbst anscheinend klarkommt, Programme von Drittherstellern (und auch MS SyncToy) beim Netzwerkzugriff jedoch nicht. Ich habe einige bemerkenswerte Dateinamen entdeckt (z.B. "Hochzeitsstrauß, weiß.pdf") *sic*, bei denen SyncToy von einem im Netz laufenden Rechner aus den "Absturz" (der eigentlich keiner ist...) reproduzierbar verursacht.

Die Lösung ist einfach: ich setze die Domäne neu auf - das hat natürlich _auch_ diverse andere Gründe, z.B. Umstieg auf Virtualisierung, weitere Umstrukturierungen etc.

Danke für die Hinweise und Ideen,
Haimo
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(3)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...