Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Ungwollte Abmeldung ca. 2 Minuten nach der Entsperrung des PCs, WinXP

Frage Microsoft Windows XP

Mitglied: acid-mic

acid-mic (Level 1) - Jetzt verbinden

11.01.2010 um 15:30 Uhr, 4030 Aufrufe, 4 Kommentare

Ich habe auf einem Windows XP Pro SP3 Client (in einer Active Directory 2003 Domain) folgendes Phänomen:

Der User sperrt den PC über längere Zeit (Mittagspause, meist ca. 30 bis 45 Minuten). Nach Aufheben der Sperrung läuft der PC etwa 2 Minuten, dann zeigt er ein Verhalten als würde man sich abmelden: Der blaue Windows Hintergrund erscheint (Windows Explorer etc. wird ausgeblendet) und in der Mitte erscheint die Statusmeldung "Netzwerkverbindungen werden getrennt", danach "Ihre Einstellungen werden gespeichert...". Hier bleibt der Computer dann auch hängen.

Wenn man den PC nur kurz sperrt (z. B. 5 Minuten) läuft alles ganz normal.

Energieoptionen wurden bereits überprüft, auch ist keinerlei MalWare auf dem System zu finden. Das Profil des Users wurde bereits erneuert - leider auch ohne Erfolg.

Kennt jemand dieses Verhalten?
Kann jemand einen Tipp geben?

Danke!
Mitglied: TheDarkLord
11.01.2010 um 15:54 Uhr
Hallo

Vielleicht ist die userinit.exe kaputt oder der Registrierungseintrag fehlerhaft.
Versuch mal folgendes (ohne Garantie und auf eigenes Risiko natürlich):
1. PC mit der Windows-Ultimate-Boot-CD starten die Registrierung bearbeiten
2. Zu HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon gehen
3. Der Wert von "Userinit" muss so aussehen: C:\WINDOWS\system32\userinit.exe,
Falls das nicht geholfen hat oder der Eintrag schon so ist:
4. Diese userinit.exe in den system32-Ordner kopieren
5. Neu starten

Selten kann auch das automatische Abmelden nach einer Festplattenspiegelung mit Norton Ghost den MBR zerschießen und dieses Verhalten hervor rufen.
Falls also das oben nicht hilft und Du mal ne Spiegelung mit Ghost gemacht hast, dann mit der WinXP CD booten und in der Reperaturkonsole "fixmbr" eingeben.

Vielleicht hilft Dir ja was davon

Gruß Dark
Bitte warten ..
Mitglied: DerWoWusste
11.01.2010 um 18:32 Uhr
Ganz einfach: Lass procmon mitloggen, was das passiert. Wer den logoff hervorruft, sollte problemlos erkennbar sein. Vielleicht zunächst filemon nehmen, dessen Logs sind übersichtlicher.
Bitte warten ..
Mitglied: TheDarkLord
14.01.2010 um 12:07 Uhr
Hallo

Was ist den bei dem Problem herausgekommen? Lösung gefunden?
Wenn ja, dann doch bitte den Beitrag als "Gelöst" markieren und die Lösung nochmal niederschreiben, falls andere das selbe / ein ähnliches Problem haben!

Gruß Dark
Bitte warten ..
Mitglied: acid-mic
14.01.2010 um 12:35 Uhr
Hallo,

sorry dass ich noch keine Rückmeldung gegeben habe. Der PC steht in einer Niederlassung und ich werde erst nächste Woche wieder vor Ort sein um weiter zu prüfen.

Das mit dem MBR verstehe ich jedoch nicht ganz. Der enthält doch "nur" die Partitionstabelle und gegebenenfalls den Boot Loader. Mit defektem MBR sollte der Rechner doch nicht mehr starten, oder?

Auch haben wir mittlerweile den Rechner über längerem Zeitraum nicht gesperrt und einfach laufen lassen. Dann tritt das Problem auch nicht auf. Somit hat es definitiv mit der Sperrung des PCs zu tun. Bei einer kurzen Sperrung - von nur etwa 5 Minuten zum Beispiel - tritt das Problem nicht auf. Nur ab etwas 30 Minuten Sperrung.

Nach meinem Termin nächste Woche wissen wir hoffentlich mehr.

Der Tipp mit der userinit sowie ProcessMonitor finde ich gut!
Danke!



EDIT: Es hat sich gerade herausgestellt dass wir nun auch ein zweites Gerät haben was das selbe Fehlerbild aufweist. Beides sind Lenovo Notebooks. Ich werde neben den Analysen meine Suche bei der Lenovo spezifischen Software fortsetzen.
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Utilities
gelöst Teamviewer - Zugriff nur 5 Minuten (9)

Frage von Zockervogel zum Thema Utilities ...

Rechtliche Fragen
USA: NASA-Forscher bei Wiedereinreise zu Handy-Entsperrung gedrängt (1)

Link von kaiand1 zum Thema Rechtliche Fragen ...

Windows Server
gelöst Nur XP PCs können nur auf einem Server keine Freigabe mappen (4)

Frage von BPeter zum Thema Windows Server ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (20)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...