Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Unverständliche Meldung STP Loopback Detection

Frage Netzwerke LAN, WAN, Wireless

Mitglied: laster

laster (Level 2) - Jetzt verbinden

14.03.2011 um 09:49 Uhr, 8167 Aufrufe, 4 Kommentare

Kein Zugriff von Switch 2 auf Geräte/Server an Switch 1

Hallo,

habe beim Kunden zwei Switche (1.: AT-8000GS/48 und 2.: AT-8000S/24), die mit genau einem LWL-Kabel verbunden sind.
Jetzt ist es zwei mal passiert, dass nach 20:00 Uhr die Verbindung zwischen den beiden Switchen weg war.
Nach dem ersten mal hab ich auf den Switchen Syslog aktiviert, nach dem zweiten mal darin einige Einträge gefunden, die mir unverständlich sind:
01.
10.03.2011 20:17:38 %STP-W-PORTSTATUS: g48: STP status Blocking 
02.
10.03.2011 20:17:38 %STP-W-LOOPBACKDET: g48: STP Loopback Detection. 
03.
... 
04.
11.03.2011 00:25:07 %STP-W-LOOPBACKDETRSLV: g48: STP Loopback Detection resolved. 
05.
11.03.2011 00:25:22 %STP-W-PORTSTATUS: g48: STP status Forwarding 
06.
...
Der Port g48 ist der LWL-Port an Switch 1, von dem die Leitung zum zweiten Switch geht. Im Falle des Ausfalls, können alle Geräte am zweiten Switch nicht mehr auf die Server am ersten Switch zugreifen.
Ich bin mir ganz sicher, dass es keine zweite Verbindung zwischen den Switchen gibt, die Grund für STP ist, den Port g48 zu blocken.

Kann irgend ein Endgerät den Switch zu solch einer Aktion 'verleiten'?

Ich hab das Problem erst einmal gelöst, in dem ich auf dem ersten Switch das STP deaktiviert habe. Seit dem gibt es die oben beschriebenen Probleme nicht mehr. Aber ich verstehe trotzdem nicht, wie das Problem entsteht, weil ich viele solche Konfigurationen kenne, wo ein solches Problem nicht existiert.

Hat jemand einen Hinweis für mich?

Schon mal vielen Dank und Grüße
LS
Mitglied: aqui
14.03.2011 um 11:44 Uhr
Ja, aber nur wenn dieses Endgerät auch STP spricht. Der STP Status ist auf Blocking gegangen, was bedeutet das irgendjemand in dem Netz ein Loop gesteckt hat oder einen anderen STP Switch mit höherer Priority (default ist 32000) angeklemmt hat.
Dein Problem ist auch vermutlich das du den Switches keine STP Priority gegeben hast um einen dediziert als STP Root Switch zu selektieren. Damit besteht auch die Gefahr das jemand einen anderen Switch mit höherer Priority anklemmt und deinen STP durcheinenaderbringt was vermutlich auch passiert ist. Genausogut kann das eine fehlkonfigurierte Aggregation verbindung sein. Das lässt sich letztlich aus der STP meldung nicht mehr feststellen.
Unverständlich ist die Meldung jedenfalls nicht, sondern eine klassische Port STP Statusmeldung.
STP zu deaktivieren ist laienhaft und auch gefährlich. Damit setzt du dich der Gefahr aus das ein Dau oder andere einen Loop stecken und das ganze Netz dann kollabiert ohne das man das dann schnell finden kann.
Warum solche Meldungen auftauchen erklärt dir das STP Protokoll selber:
http://de.wikipedia.org/wiki/Spanning_Tree_Protocol
Bitte warten ..
Mitglied: laster
14.03.2011 um 11:49 Uhr
Hallo aqui,

vielen Dank für die Infos, das hilft mir erst einmal weiter (auf die Idee mit zusätzlichen Switch und höherer Prio bin ich nicht gekommen). Werde Deine Hinweise ernst nehmen

vG
LS
Bitte warten ..
Mitglied: aqui
14.03.2011 um 11:53 Uhr
Setz einen der AT-8000er auf die STP Prio 128 im Setup und den anderen auf 1024. Dann hast du einen dedizierten Root Switch und einen backup Root und dann passiert das auch nicht wieder.
Sofern die AT-8000er Gurken natürlich keinen STP Firmware Bug haben....?!
Bitte warten ..
Mitglied: laster
14.03.2011 um 11:58 Uhr
Hallo aqui,

nochmals vielen Dank für die Infos!
(AT hat bei den Netzwerkprofis wohl keinen guten Ruf? Was sollte man denn stattdessen nehmen HP/3Com, Dell, Cisco, ...?)

vG
LS
Bitte warten ..
Ähnliche Inhalte
Windows Server
gelöst Meldung, dass das Zertifikat ausläuft beim Aufbau einer RDP Verbindung SBS2008 (5)

Frage von pitamerica zum Thema Windows Server ...

Netzwerkprotokolle
STP ausschalten (11)

Frage von homermg zum Thema Netzwerkprotokolle ...

Windows Server
Ewige Meldung "Druckertreiber muss aktualisiert werden"

Frage von thaefliger zum Thema Windows Server ...

Server-Hardware
APC 1500 Meldung "Batterwie Wechseln" nach Batteriewechsel (11)

Frage von PizzaPepperoni zum Thema Server-Hardware ...

Neue Wissensbeiträge
Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(4)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(9)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
Exchange Server
Exchange 2016 Standard Server 2012 R2 Hetzner Mail (41)

Frage von Datsspeed zum Thema Exchange Server ...

Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (18)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (13)

Frage von Andy1987 zum Thema Exchange Server ...