Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Unvollständige Installation von den als Admin installierten Programmen im Nuteraccount

Frage Microsoft Windows Userverwaltung

Mitglied: Aguaviva

Aguaviva (Level 1) - Jetzt verbinden

02.03.2007, aktualisiert 20:00 Uhr, 3958 Aufrufe, 3 Kommentare

Hallo,

ich habe eine Frage und hoffe, dass mir jemand weiterhelfen kann: Ich habe auf meinem Computer (Windows XP) zwei Nutzerkonten eingerichtet: ein Adminkonto und ein Nutzerkonto mit eingeschränkten Rechten. (Ich weiß nicht, ob das relevant ist: es gibt zwei Partitionen: eine für Daten und eine für Programme und Systemdateien)
Nun habe ich schon desöfteren das Problem gehabt, dass bei der Installation von Programmen diese zwar im Adminaccount vollständig installiert wurden, im Benutzeraccount jedoch nur zu Teilen bzw. muss ich jedes Mal die Eingangskonfigurationen nochmals vornehmen.

Einige Beispiele:
Ich habe Audiograbber installiert und dazu das Lame-Plugin installiert. Letzteres ist jedoch im Benutzeraccount nicht installiert worden. (Ebensowenig der ASPI)
Oder bei der Installation von iTunes musste ich die Konfigurierung nochmal vornehmen, das Programm erscheint nicht im Startmenue unter Programmen, etc.
Das Literaturverwaltungsprogramm Ideanote ist z.B. nur auf dem Adminaccount gelandet.

Woran kann das liegen, dass die Admin-installationen nicht automatisch im Benutzeraccount installiert werden, sondern nur Teile.
Ich hoffe, dass mir jemand weiterhelfen kann und bitte darum, auch darauf Rücksicht zu nehmen, dass ich ein relativer Computerlaie bin.
Vielen Dank, Aguaviva
Mitglied: seether2
02.03.2007 um 19:01 Uhr
Servus,

ohne mich zu weit aus dem Fenster lehnen zu wollen, behaupte ich mal, dass sämtliche von dir erwähnten Programme Multiuserfähig sind.
Das bedeudet, das verschiedene Benutzer, verschiedene Einstellungen haben können.
Z.B. falls dein Admin benutzer ein anderes hintergrundbild hat als der eingeschränkte benutzer.

Solche Informationen werden Teils in der Registry (HKEY_CURRENT_USER\Software) oder im Profil Verzeichnis abgespeichert. Das kann von Software zu Software unterschiedlich sein.

Du sagtest, das die Programme für deinen Admin Benutzer eingerichtet sind. Ich gehe mal davon aus, das dieser Benutzer einfach Admin heißt. Wenn nicht, so ersetze das entsprechend.

Schau mal unter "C:\Dokumente und Einstellungen\Admin\Anwendungsdaten" nach, ob da nicht einen Ordner, wie z.B Apple oder I-Tunes, findest.
Kopiere diesen Ordner und füge ihn bei
"C:\Dokumente und Einstellungen\EingeschränkterBenutzer\Anwendungsdaten" ein.
Schau aber vorher nach, ober da nicht schon ein Ordner mit entsprechenden Namen vorhanden ist. Falls ja, dann bennene ihn sicherheitshalber mal um. Dann hast du zumindest eine Sicherung, denn die einstellungen vom Eingeschränkten Benutzer werden womöglich überschrieben.
Dann solltest du eigentlich die Einstellungen, oder zumindest irgendwelche Daten oder Datenstrukturen, vom Admin Account sehen.

Viel Glück!
Gruß
Torsten
Bitte warten ..
Mitglied: Aguaviva
02.03.2007 um 19:32 Uhr
Lieber Thorsten,
danke für die schnelle Antwort. Ich bin mir aber nicht sicher, ob Deine Antwort mein Problem völlig aus der Welt schafft. In Bezug auf iTunes habe ich das Problem mittlerweile gelöst.
Aber der Audiograbber ist beispielsweise unter:C:\Programme und nicht in irgendeiner nutzerdefinierten Version unter Admin. Trotzdem ist das LamePlugIn und der ASPI nicht auf dem anderen Nutzerkonto installiert.
Auch Ideanotes ist unter dem Programmepfad und nicht in dem von dir angegebenen Pfad zu finden.
Oder habe ich Deine Antwort noch nicht ganz verstanden?
Lieber Gruß, A.
Bitte warten ..
Mitglied: seether2
02.03.2007 um 20:00 Uhr
Ja und Nein.

Was ich ursprünglich sagen wollte ist, das Programmiere Benutzerspezifische Informationen an zwei Orten ablegen könnten. Sofern Sie sich natürlich an Standards halten und keine Neuen kreieren.
Das eine ist normalerweise unter C:\dokumente und einstellungen\benutzername\Anwendungsdaten

Es ist aber auch gut Möglich, das Settings, wie z.B das laden eines Plugins über die Registry gesteuert wird.

Nur um das nochmal klar zu machen. Das Hauptprogramm selber wird regulär unter C:\Programme gespeichert. Die Einstellungen für diese Programme (z.B. Benutzernamen, Playlisten, Emails, etc.) werden häufig in solche Profilordner oder in der Registry gespeichert.

Ich weiß leider nicht, wie gut du dich mit der Registry auskennst, lasse aber mal eine Erklärung weg. Eins schon mal vorweg:
"Falsche" Änderungen an der Registry können für das System oder auch für den angemeldeten Benutzer tötlich sein.

Gehe mal auf Start->Ausführen und Tippe "regedit" ein.
Anschlissend schaust du mal nach, welche "Ordner" sich unter HKEY_CURRENT_USER\Software befinden.
Dort sollte es eigentlich einen geben, der wenn du glück hast, Audiograbber heißt.
Wenn nicht, dann such mal nach dem Firmennamen, welcher diesen Audiograbber betreibt.
Wenn du ihn gefunden hast, so markiere ihn und klicke auf File->Export...blabla
Speicher ihn irgenwohin, wo auch dein eingeschränkter benutzer zugriff hat.
Log dich aus und melde dich als eingeschränkter benutzer an.
Tu genau das gleich wie beim Adminaccount und exportiere die Einstellungen. Nenne es irgenwie backup oder so, damit du, falls irgendetwas schief geht, eine Sicherung hast, die du zurückspielen kannst.

Nun mache einen Doppelklick auf die vom Adminaccount erstellte Datei und bestätige die Meldung mit Ja.
Anschliesend schau mal ob es geklappt hat.

Kann dir leider nicht mehr dazu sagen, da ich Audiograbber selber nicht benutze.
Aber normalerweise ist es überall dasselbe.

Hoffe du hast glück und findest den richtigen Eintrag in der Registry.
Gruß
Torsten
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Batch & Shell
gelöst Script zur Installation von Programmen (4)

Frage von Markus2016 zum Thema Batch & Shell ...

Windows Systemdateien
Keine Berechtigung trotz Domänen-Admin User (10)

Frage von M.Marz zum Thema Windows Systemdateien ...

Windows Installation
Server 2016 UEFI Installation von USB (3)

Tipp von DerWoWusste zum Thema Windows Installation ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...