Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Nach update von Ubuntu 6.10 auf 8.04 fehlen in dev mehrere gerätedateien

Frage Linux Ubuntu

Mitglied: PapaZivi

PapaZivi (Level 1) - Jetzt verbinden

02.07.2008, aktualisiert 03.07.2008, 5145 Aufrufe, 3 Kommentare

Vor allem fehlt mir /dev/st0!

Ich hatte vor einer Woche unseren Fileserver von Ubuntu 6.10-Server auf Ubuntu 8.04-Server gehoben. nach dem update, und einen anschliessenden neustart wegen neuem kernel, habe ich nun unter /dev den verlust mehrerer gerätedateien zu beklagen.

zu meinen fragen:
1. wie kann das überhaupt passieren?
und
2. wie krieg ich (ganz speziell /dev/st0) wieder her?

bittebittebitte um hilfe.
Mitglied: masterG
02.07.2008 um 19:11 Uhr
Frage 1 kann ich dir beantworten.
Du hast mehrere Versionen übersprungen. Da kanns passieren das so was rausgehaut wird und dann irgendwo fehlt!

masterG
Bitte warten ..
Mitglied: theton
02.07.2008 um 20:05 Uhr
Und Antwort auf Frage 2: Einfach den Treiber laden, der für das Device st0 zuständig war. Ausserdem würde ich mal mittels 'apt-get -f install && apt-get update && apt-get dist-upgrade' sicherstellen, dass auch wirklich alle Pakete korrekt konfiguriert wurden beim Update. Bei übersprungenen Versionen reicht ein einfaches 'dist-upgrade' nämlich zumeist nicht aus. Unter http://www.hackerwiki.org/index.php/Update_eines_Ubuntu_Servers hatte ich mal eine Anleitung dafür geschrieben.
Bitte warten ..
Mitglied: PapaZivi
03.07.2008 um 12:09 Uhr
danke an masterG und theton,

ich habe das problem nun endlich lokalisieren können:

das scsi tape wurde nur als ein generic scsi device erkannt, weil zur bootzeit das modul st gefehlt hat. nachdem ich st in /etc/modules eingetragen habe und den scsi-treiber entfernt, st geladen und dann wieder den scsi treiber geladen hatte, war auch /dev/st0 wieder da und funktionsfähig.

danke nochmals für die hilfe.

p.s.: ich weiss, das ich mehrere versionen übersprungen habe ;)
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Router & Routing
gelöst Empfehlung günstiges ADSL2+ nur Modem (10)

Frage von TimMayer zum Thema Router & Routing ...

Server-Hardware
Lenovo Server System X 3650 M5 Festplatten (9)

Frage von Hendrik2586 zum Thema Server-Hardware ...