Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

URGENT - Postfix, uvscan und amavisd auf FreeBsd hängt immer wieder

Frage Internet E-Mail

Mitglied: lucifer11

lucifer11 (Level 1) - Jetzt verbinden

16.05.2007, aktualisiert 10:03 Uhr, 3850 Aufrufe, 4 Kommentare

Logs zeigen dabei, dass amavsid (bzw. perl) exit on signal 11 ausgeben, (uvscan) exit on signal 10. Nach Neustart von Amavisd und Postfix Reload geht es wieder eine Zeit lang. KEINE Änderungen an Konfiguration o.ä. - wo ist der Haken?

Hallo zusammen,

als eigentliche Windows-Menschen sind wir im Moment noch mit einem Linux-Proxy konfrontiert, der auf FreeBSD läuft und Routing, HTTP-Proxy und Mail-Gateway übernimmt. Erstere beide Funktionen immer noch tadellos. Bei der Mailbearbeitung gibt es seit ca. 3 Tagen immer wieder massive Probleme - nach einer gewissen Zeit gehen keine Mails mehr nach draußen durch, andersum auch nicht.
Das ganze läuft über Postfix und amavisd, wobei amavisd uvscan als Virenscanner nutzt (die letzte kostenlose Version mit dem letzten dazu passenden Update - also etwas älter).
Das funktionierte die ganze Zeit tadellos. Vor einigen Wochen einmal ein Hänger, das keine Mails gingen / kamen - nach Reboot des Servers gings wieder. Seit drei Tagen hängt sich die Mailerei regelmäßig auf. Aus den Logs kann ich (soweit als Unix-Null machbar) sehen, dass uvscan ab und an ausgibt "exit on signal 10 core dumped" und viel häufiger perl (unter der amavisd userid) aussteigt mit "exit on signal 11". Dann ist es bald wieder soweit, das Mails nicht raus oder rein gehen, Postfix deferred die Mails, weil das Zwischenstück (amavisd) nicht reagiert. Wenn ich dann amavisd erneut starte und Postfix reloade, geht es wieder eine Weile - ein paar Stunden - konkreter Zeit / VOrgangs-Zusammenhang nicht erkennbar bis jetzt. Dann wieder das gleiche.
Wenn das ganze erstmal hängt, bekomme ich im messages-Log ausserdem "FATAL: unknown command line argument : )o". Als ob, nachdem irgendetwas aufgetreten ist oder hängt, amavisd wiederum irgendwas nicht (mehr) so aufrufen kann, wie es will?

Ich bin komplett rat- und machtlos und kurz vor dem Verzweifeln, da eigentlich Linux-mäßig vollkommen unbeleckt - der Proxy sollte demnächst eh einer anderen Lösung weichen, die sich aber nicht von jetzt auf gleich umsetzen lässt, ich muss also irgendwie dieses Problem erstmal lösen / orten.
Wenn jemand ähnliches hatte, daraus Lösungen erahnen kann oder mir helfen kann, was / wie ich wo nachsehen kann muss um die Ursache zu finden, würde ich mich freuen. Vielen Dank!
Mitglied: cykes
16.05.2007 um 09:11 Uhr
Wenn das ganze erstmal hängt, bekomme
ich im messages-Log ausserdem "FATAL:
unknown command line argument : )o".

Das würde ich als erstes mal überprüfen,
durchsuche mal die Konfigurationsfiles von Postfix/Amavisd
(und eventuell SpamAssassin, falls installiert) nach ")o" - das sieht
nach einem Tippfehler aus...

Gruß

cykes
Bitte warten ..
Mitglied: lucifer11
16.05.2007 um 09:28 Uhr
Hallo,

danke für die schnelle Antwort. Das hatte ich schon geschaut, eben nochmal nachgesehen, da ist nichts, was zu dem ") o" passen könnte. Außerdem hat ja niemand etwas geändert, seit das auftritt.
Die Meldung mit illegal argument kommt von postfix/smtpd im übrigen, also wird das (wovon?) falsch aufgerufen?
Bitte warten ..
Mitglied: cykes
16.05.2007 um 09:35 Uhr
Hast Du das bei der Suche auch zusammen geschrieben, also ")o" statt ") o" ?
sollte vermutlich eher "-o" oder "/o" heissen ....
Bitte warten ..
Mitglied: lucifer11
16.05.2007 um 10:03 Uhr
Hi,

nee, hatte es schon korrekt als ") o" geschrieben bzw. dann auch noch nach ") o "gesucht, weil ersteres nur treffer wie ") or die...)" gefunden hatte. Und da keiner was an configs o.ä. gemacht hat...

Habe mittlerweile eine weitere Spur, laut amavisd News gibt es ein Problem mit der utility file(1), die amavisd benutzt, da wurde eine Macke erst ca. im März entdeckt, die zu overflow führen kann. Das riecht gut, file ist nämlich auf dem Ding uralt.

Wie update ich das? Habe mir ein tar.gz Paket geladen, in dem zig Dateien sind, aber ich weiß nicht, wie das zu updaten íst... aargh...
Bitte warten ..
Ähnliche Inhalte
Sonstige Systeme
FreeBSD und Gnome3
gelöst Frage von AlchimedesSonstige Systeme3 Kommentare

Hallo, euch allen ein schoenen Sonntag, hoffe ihr wart brav in der Kirche und habt beim Pfaffen gebeichtet. :) ...

Windows 10
Urgent- Verständnisfrage Windows-Migration+Tests
Frage von l2ubenWindows 103 Kommentare

Hallo ihr Lieben, ich habe einige Verständnisfragen, welche mich seit langem verfolgen und ich werde einfach nicht schlauer. Und ...

Linux
FreeBSD - Laufwerke auflisten und mounten?
gelöst Frage von grinserLinux5 Kommentare

Guten Abend! Leider fehlt das entspr. FreeBSD Unterforum, daher poste ich hier. Ich hoffe das ist richtig so. Mein ...

Linux Tools
Kolab und amavisd Dienst? Mailserver funktioniert nicht
Frage von flyingmichaelLinux Tools8 Kommentare

Guten Morgen Zusammen, ich habe mir bei Strato einen V-Server gehostet mit Cent-OS 7 . Darauf will ich einen ...

Neue Wissensbeiträge
Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 6 StundenInternet3 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registierunf von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 13 StundenVerschlüsselung & Zertifikate1 Kommentar

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 1 TagWindows 103 Kommentare

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 1 TagSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless17 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement16 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...