Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

USB Diskettenlaufwerk mit ASR Wiederherstellung

Frage Microsoft

Mitglied: geTuemII

geTuemII (Level 3) - Jetzt verbinden

23.04.2008, aktualisiert 24.04.2008, 6858 Aufrufe, 9 Kommentare

Hallo @all,

ich habe mir in den Kopf gesetzt, endlich mal aus den beiden 500er SATA-Platten in meinem Rechner ein RAID1 zu bauen. Also ein ASR-Backup gemacht und die Daten gesichert. Dann das SATA-RAID gebaut, den OEM-Treiber für das SATA-RAID geholt und mit auf die ASR-Diskette gepackt.

Nach dem Start des Setup erst F6 (für den neuen Treiber) und dann F2 (für die Systemwiederherstellung) gedrückt. Treiber wird abgefragt und von der Diskette geladen. Danach wird der Monitor schwarz (IMHO wird die Kontrolle an der Stelle vom Setup übernommen).

Wenn nun der Monitor wieder auf den blauen Setuphintergrund zurückgeht, werde ich mit der folgenden Info begrüßt:
"Setup kann nicht fortgesetzt werden. Es konnte kein Diskettenlaufwerk gefunden werden. Drücken Sie F3, um Setup zu beenden."

Muß ich jetzt echt im "Hardwarelager" ein internes Diskettenlaufwerk suchen und es temporär in die Kiste mimen? Oder hat jemand eine zündende Idee?

Kopfschüttelnd, geTuemII
Mitglied: LordGurke
23.04.2008 um 23:49 Uhr
Zwei Ideeen sogar:

- Lässt sich im BIOS eventuell explizit einstellen, dass USB-Speicher auch ohne Betriebssystem (nennt sich je nach Hersteller USB-Thumb-Driver oder USB-Disk-Support usw...) erkannt werden?

- Erstelle dir mit nLite eine personalisierte Setup-CD und binde einfach die Treiber bereits dort ein, dann brauchts keine Diskette mehr.
Bitte warten ..
Mitglied: geTuemII
23.04.2008 um 23:55 Uhr
Zwei Ideeen sogar:
Das ist ja heldenhaft

- Lässt sich im BIOS eventuell explizit einstellen, dass USB-Speicher auch
ohne Betriebssystem (nennt sich je nach Hersteller USB-Thumb-Driver oder
USB-Disk-Support usw...) erkannt werden?
Da sehe ich morgen mal nach, das könnte was sein.

- Erstelle dir mit nLite eine personalisierte Setup-CD und binde einfach
die Treiber bereits dort ein, dann brauchts keine Diskette mehr.
Ich bin ja immer für nLite zu haben, aber in diesem Fall bringt das nichts. ASR besteht stoisch auf der Diskette. In diesem Punkt ist MS wiedermal seiner Zeit weit voraus.

geTuemII
Bitte warten ..
Mitglied: 54487
24.04.2008 um 00:36 Uhr
Nlite ist m. E. so lange nicht empfehlenswert, wie der Entwickler zwingend dieses dämliche .NET voraussetzt.

Eine Alternative, die genauso empfehlenswert ist und ohne auskommt, ist
http://winfuture.de/xpisobuilder

Da das Setup von W2k/XP zwingend ein Diskettenlaufwerk erwartet (wahrscheinlich werden die Funkionen über die Diskettenports angesprochen), könnte ich mir vorstellen, dass mit USB nichts funktionieren wird.
Bitte warten ..
Mitglied: 60730
24.04.2008 um 16:39 Uhr
Da das Setup von W2k/XP zwingend ein Diskettenlaufwerk erwartet (wahrscheinlich
werden die Funkionen über die Diskettenports angesprochen), könnte ich
mir vorstellen, dass mit USB nichts funktionieren wird.

Fast richtig - das dumme an der Sache ist wirklich - es kommt auf das Floppylaufwerk, bzw. den Apater auf USB an - ob es geht oder nicht.

"Lustigerweise" hab ich für diese Zwecke eine Apple USB Floppy (eingebaut ist ein Samsung Laufwerk), das mich bisher in diesem Zusammenhang immer gerettet hat.

Auch wenn ein HP USB Laufwerk am HP Server nicht erkannt wurde, das Apple wird immer erkannt.
(beim starten wird zwar immer der Bootblock gesucht {Motor springt an} -das wars dann aber auch )

Probier daher mal ein anderes Laufwerk - am besten von Samsung.
Bitte warten ..
Mitglied: geTuemII
24.04.2008 um 17:57 Uhr
Ich habe mich für die Variante "Hardwarelager" entschieden.

Aber evtl. kann mir doch noch jemand erklären, warum der RAID-Treiber von der Diskette geladen wird und selbiges im weiteren Verlauf des Textsetups nicht mehr erkannt wird. Der RAID-Treiber ändert doch nichts an USB oder Diskettenlaufwerk?!

geTuemII
Bitte warten ..
Mitglied: 60730
24.04.2008 um 18:04 Uhr
Hi geTuemII,

also ich kanns dir auch nicht sagen, warum es so ist.

Vermuten tue ich folgendes:

Beim ersten einlesen des Laufwerkes (da funktionierts noch) wird das Bios "gefragt"
Danach läuft ja der ganze Treiber Schmonz von Wind00f und der erkennt wohl "irgendwas" hängt an USB aber nicht mehr das Laufwerk, das "dahinter" ist.

Wie gesagt, ich bin da auch schon wie Rumpelstilzchen um den (die) Server gehoppelt, bis ich mal das Apple Laufwerk (ursprünglich) zum Spass angeschlossen habe.
Bitte warten ..
Mitglied: 54487
24.04.2008 um 20:46 Uhr
Aber evtl. kann mir doch noch jemand erklären, warum der RAID-Treiber von der
Diskette geladen wird und selbiges im weiteren Verlauf des Textsetups nicht mehr
erkannt wird.

Da oben steht zwar
Treiber wird abgefragt und von der Diskette geladen.
bloß ob nur auf der Diskette gesucht wurde, ob die Diskette vielleicht fehlerhaft, der richtige Treiber drauf war und auch wirklich geladen wurde, geht aus dieser Bemerkung nicht hervor, das ist lediglich eine - zumindest von mir - nicht überprüfbare Behauptung.
Außerdem steht dort noch was von Systemwiederherstellung, die dazwischengefunkt hat.
Woraus schließt du belegbar, dass der richtige Treiber auch wirklich geladen wurde?
Bitte warten ..
Mitglied: geTuemII
24.04.2008 um 21:16 Uhr
bloß ob nur auf der Diskette gesucht wurde, ob die Diskette vielleicht fehlerhaft,
der richtige Treiber drauf war und auch wirklich geladen wurde, geht aus dieser
Bemerkung nicht hervor, das ist lediglich eine - zumindest von mir - nicht
überprüfbare Behauptung.
Du glaubst mir aber auch gar nichts

Woraus schließt du belegbar, dass der richtige Treiber auch wirklich geladen wurde?

  • Wenn keine Diskette im Laufwerk lag (normaler Start des Setups , auch ohne ASR-F2-Drückerei), wurden keine Festplatten erkannt.
  • Setup hat auf die Diskette hörbar zugegriffen, danach waren die Platten im normalen Setup verfügbar.
  • Nachdem ich ein altes internes DiskettenLW aus dem "Hardwarelager" gefischt und an den Rechner gemimt hatte, lief sowohl das RAID als auch das ASR.
Ist das Beleg genug?

Scheint sich also um ein Windows-Feature zu handeln. Offenbar funktionieren USB-DiskettenLW zwar, solange die Kontrolle beim BIOS liegt, sobald aber Windows übernimmt, werden nur noch bestimmte Typen unterstützt. Mir ist dazu auch ein KB-Artikel über den Weg gelaufen, den ich aber wieder verbuddelt habe.

geTuemII
Bitte warten ..
Mitglied: 54487
24.04.2008 um 21:34 Uhr
Das mag sein, was mich stutzig gemacht hatte, war die Systemwiederherstellung, die nach der Treiberinstallation gelaufen war. Wenn dabei Hardwareeinstellungen erneuert wurden, könnten dir die passenden Treiber wieder gefehlt haben.
Und ja, USB während des und nach dem Setup wird von Windows etwas merkwürdig behandelt. Das ist auch einer der Gründe, warum Booten von USB selten funktioniert und von MS nicht unterstützt wird.

Der Artikel trifft zwar nicht den Kern, ist aber vielleicht doch was für deine Sammlung. ;)
http://www.microsoft.com/whdc/archive/usb-boot.mspx
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Humor (lol)
Der Unterschied zwischen USA und USB

Link von BirdyB zum Thema Humor (lol) ...

Windows Netzwerk
USB-Gerät ins Netzwerk (Domäne) einbinden (4)

Frage von griss0r zum Thema Windows Netzwerk ...

Drucker und Scanner
USB-Drucker über virtuellen COM LPT- Port ansteuern (27)

Frage von magicman zum Thema Drucker und Scanner ...

Speicherkarten
Tool zum neuformatieren eines USB-Sticks (6)

Frage von flyingKangaroo zum Thema Speicherkarten ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...