Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

User anlegen unter openSuSE 10.3

Frage Linux Suse

Mitglied: 69495

69495 (Level 1)

09.09.2008, aktualisiert 10.09.2008, 10899 Aufrufe, 7 Kommentare

Neben Plesk-Installation

Hallo Community!

Ich habe mal den Schritt gewagt, von meinem Debian-Server auf openSuSE umzusteigen. Man will ja was lernen. Jedenfalls habe ich erstmal Version 10.3 auf meinem Rechner installiert, und dazu Plesk 8.4. Voher war ich mit Debian 3 und ner älteren Version von Confixx unterwegs. Da musste ich schon mit der Einschränkung leben, dass manche User über die Shell nicht korrekt angelegt wurden, bzw. vom Updatescript der Confixx-Version gelöscht wurden (evtl. wegen reservierter User-IDs).
Ich möchte auf dem Server nun IRC, Bots und nen Teamspeak-Server installieren, wofür ich eigene User einrichten möchte. Ging bisher unproblematisch über useradd - führe ich das nun unter suse durch, bekomme ich keine Fehlermeldung. Ergo hat's funktioniert mit dem Anlegen. Will ich mich nun aber mit dem User einloggen, bekomme ich die übliche Meldung, wenn z. B. das Passwort falsch ist. Ok, kann mal passieren, ist aber nun mehrere Male aufgetreten. Also versuchte ich mit adduser den User anzulegen, aber der Befehl existiert nicht.
Ich habe dann verschiedene User angelegt, aber mit keinem kann ich mich per SSH einloggen (Rechner steht ein Zimmer weiter).
Was mache ich da falsch? Oder verhindert Plesk das Anlegen neuer User?
Mitglied: theton
09.09.2008 um 15:07 Uhr
Da Plesk im Einsatz ist, sollten die Benutzer auch mit Plesk angelegt werden. Ansonsten kann es passieren, dass Plesk die wieder entfernt. Interfaces wie Plesk, Confixx & Co sind auch nur dann sinnvoll, wenn man viele Domains mit verschiedenen Usern zu verwalten hat. Bei einem "einfachen" Server ist Webmin sicherlich das brauchbarere Interface, wenn man schon eines braucht. Besser ist natürlich, wenn man die Kiste komplett via SSH verwaltet, vor allem, wenn man nicht ständig Änderungen machen muss, nachdem alles läuft.

Unter SuSE legt man sonst User übrigens via YaST an ('yast users' als root).
Bitte warten ..
Mitglied: 69495
09.09.2008 um 16:32 Uhr
Ah, ok, vielen Dank für die Info. Dann werd ich mal raussuchen, wie ich Plesk wieder wegmache. Wenn's sich sonst eh nicht lohnt...
Bitte warten ..
Mitglied: theton
09.09.2008 um 16:48 Uhr
Eine saubere Neuinstallation dürfte vermutlich die schnellste und sauberste Lösung sein. Plesk greift ja teilweise recht tief in's System ein.
Bitte warten ..
Mitglied: 69495
10.09.2008 um 08:41 Uhr
Hm... nagut, mal sehen wie ich mich da arrangieren kann.

Nächstes Problem: Ich greife über putty auf den Server zu, starte yast und gehe auf "Sicherheit & User" (heißt so, glaub ich) und schon stoße ich da an eine Grenze - auf der rechten Seite kommt nichts. Links das Menü besteht weiterhin, aber normalerweise sollte ja rechts eine Auswahl kommen. Das Feld bleibt aber komplett leer. Wenn ich links den Eintrag "Sicherheit & User mit Enter bestätige tut sich rechts ebenfalls nichts.
Eine Idee dazu?
Bitte warten ..
Mitglied: theton
10.09.2008 um 09:51 Uhr
Ist das Paket 'yast2-users' installiert?
Bitte warten ..
Mitglied: 69495
10.09.2008 um 09:58 Uhr
Werd ich nachher mal prüfen, sitz zz. bei der Arbeit. Das kann ich auch über yast prüfen und ggf. installieren, richtig?
Bitte warten ..
Mitglied: theton
10.09.2008 um 10:21 Uhr
Richtig. Fast die komplette Systemverwaltung kann man bei SuSE via YaST machen. Wenn du allerdings Debian gewohnt bist, wirst du auf Dauer mit SuSE vermutlich eh keine Freude haben. Gerade YaST ist dank SuSEConfig sehr gewöhnungsbedürftig.
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Windows 10
Windows 10 - Logon Screen - Nachricht an User (1)

Frage von OpusMagnum zum Thema Windows 10 ...

Windows 10
OpenVPN Windows 10 als domain user (4)

Frage von lululala zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (32)

Frage von Maik82 zum Thema Linux Netzwerk ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (20)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Hardware
gelöst PCI-Express-Adapterfrage (14)

Frage von DerWoWusste zum Thema Hardware ...