Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

USG20W Network Bridge VLAN mit ManagedSwitch - DHCP funktioniert nicht richtig

Frage Sicherheit Firewall

Mitglied: yvesfrey

yvesfrey (Level 1) - Jetzt verbinden

15.10.2014, aktualisiert 14:51 Uhr, 1660 Aufrufe, 4 Kommentare

Liebe Community

Ich betreibe in einem kleinen Hotel eine Zyxel USG20W [Firmware: 3.30(BDR.5) / 1.15 / 2014-05-15 14:45:59], um im ganzen Hotel eine optimale Wireless-Empfang zu gewährleisten, wird auf einen managedbarer Switch (GS1900-8, aktuelle Firmware) in Kombination mit einem Access Point NWA-1100-N das Wireless-Netzwerk erweitert. Um das interne und externe Netz separat zu betreiben, werden zwei unterschiedliche Netze betrieben.

Ich habe mir schon durch einige Problemstellung (bsp. http://www.administrator.de/frage/vlan-funktioniert-nicht-keine-dhcp-ve ...) gelesen, bin jedoch nicht wirklich schlau geworden daraus. Vielleicht könnt ihr mir ja helfen.

Einstellungen:
Firewall USG20W:
Network Bridge auf LAN1, WLAN1, VLAN1 und DMZ, WLAN2, VLAN2 nach Anleitung: https://www.studerus.ch/de/support/download/58487_1
VLAN1 und VLAN2 nach Anleitung: https://www.studerus.ch/de/support/download/58518_1

Switch GS1900-8:
VLAN nach Anleitung: https://www.studerus.ch/de/support/download/58465_1

Nun habe ich folgendes Problem:

Wenn ich die Geräte direkt mit der USG-Verbinde, verteilt der DHCP wunderbar IP's.
Sobald ich den Switch mit der USG verbinde und Geräte an die "untagged" Links anschliesse werden vom DHCP, welcher auch auf der USG läuft, keine IP-Adressen an OS X sowie Linux bzw. Android Geräte verteilt. Mein Windows-System im BootCamp auf dem Mac holt sich wunderbar eine IP ab, auf dem Wireless über den Access Point sowie über das LAN.

Komischerweise verbindet sich auch mein IPhone ohne Probleme in die Wireless Netzwerke.

Nun meine Fragen:

Könnte es sein, dass der DHCP-Server, solange der Lease noch gültig, die IP-Adressen nicht neu über den Switch verteilen kann? Vielleicht bleibt er irgendwie im VLAN modus hängen oder so.

Oder woran könnte dieses Problem liegen?

Herzlichen Dank für Ratschläge. Falls ihr noch mehr Informationen benötigt, werde ich mich bemühen diese bereit zustellen.

Hier noch einige Screenshots zur Unterstützung meiner Ausführungen:

fb904c12eae3d5d339cadb390203a47f - Klicke auf das Bild, um es zu vergrößern
e68d3206753c97829c2198945ba9f232 - Klicke auf das Bild, um es zu vergrößern
906379533cdc239fed67030a6476a97d - Klicke auf das Bild, um es zu vergrößern
00f14ed326f59bba41f363480d3e96fc - Klicke auf das Bild, um es zu vergrößern
6ef87c731b30d9280ac3164487523827 - Klicke auf das Bild, um es zu vergrößern
Mitglied: MrNetman
15.10.2014 um 12:12 Uhr
Hi Yves
Die Zyxel Switches sind Layer2.

Um von einem VLAN an den DHCP zu kommen muss in dem Bereich des Switches bekannt gegeben werden woher die Anfrage kommt.
Der Switch wird also getaggt mit der USG und den APs verbunden. Also alle relevanten VLAN werden getaggt übermittelt.
Danach werden diese VLANs an der USG, wieder getaggt, mit dem DHCP Server verbunden. Da die USG weiss, aus welchem VLAN der Request kommt, kann sie auch die passenden IPs ausliefern und jedes VLAN hat damit einen IP-Bereich mit einem default Gateway in der USG aus dem selben IP-Bereich bekommen.

Für die APs gilt dann ähnliches. Sie werden mit einem getaggten Port verbunden und haben pro VLAN eine SSID. SSID und VLAN sind damit fest verbunden und könne via USG wieder mit den Adressen aus dem DHCP versorgt werden.
Wenn du die VLANs über getrennte Ports mit der USG verbindest muss in der USG auch jeder Port fest einem VLAN zugeordnet sein, sonst klappt es wieder nicht mit der Verteilung.

Gruß
Netman
Bitte warten ..
Mitglied: yvesfrey
15.10.2014, aktualisiert um 14:53 Uhr
Ciao Netman

Ok, das was du beschreibst, ist eigentlich das selbe was man mit dieser Anleitung einstellt: https://www.studerus.ch/de/support/download/58465_1
Oder sehe ich da etwas falsch?

Wie meinst du: "Danach werden diese VLANs an der USG, wieder getaggt, mit dem DHCP Server verbunden." ? Dies passiert doch automatisch auf der USG...

Ich habe die Links von der FW und zum AP jeweils als getaggt eingestellt, auf dem Switch. Jedoch kann mein Mac OSX keine IP-Adresse ab dem DHCP über den AP, welcher über die VLAN's laüft, abrufen. Die Windows 7 Partition schafft dies aber ohne Probleme.

Vielleicht liegt es auch schlicht weg an der Networkbridge, die es nicht akzeptiert das auf dem selben Lan zwei unterschiedliche VLAN's laufen, von welchem eines auf der DMZ liegt.

Ach ich stehe mir total auf dem Schlauch...
Bitte warten ..
Mitglied: MrNetman
15.10.2014 um 17:18 Uhr
Was ist eine Netzwerkbridge in dem Zusammenhang?
Die uplinks vom Switch zur USG und zu den APs müssen für alle! VLANs getaggt sein. Es gibt auch die Möglichkeit, dass man solche Ports gemischt betreibt. Außerdem gibt es häufig ein default-VLAN, das machmal nicht änderbar ist und eine besondere Funktion erfüllt, die im Fehlerfall zum Tragen kommt.

bridge ist die Bezeichnung innerhalb von Zyxel. Hier müssen, je nach Gerät das jeweilige VLAN mit der SSID (AP) oder mit dem IP-Berich (DHCP), verbunden werden.

Und DMZ oder WLAN oder Haustechnik ist dem VLAN egal. Ein VLAN verhält sich mehr oder weniger wie ein getrenntes Netzwerk und wird über den Router, hier deine UWG, verbunden.
In deinem PDF werden die Ports mit der VLAN-zuighörigkeit als PVID (Port VLAN ID) dargestellt. Der Uplinkport zu UWG und AP hat PVID1 und muss Mitglied in jedem VLAN sein (T), Ausnahme DMZ. Wenn ein Uplinkport, getaggter Port eine PVID erhält, dann werden ungetaggte Pakete mit diese PVID versehen und weiter geleitet.

Gruß Netman
Bitte warten ..
Mitglied: yvesfrey
15.10.2014, aktualisiert um 22:53 Uhr
Eine Netzwerkbridge, so wie sie ich bei meiner USG kennengelernt habe, ist eine Verbindung zwischen den verschiednen internen Netzwerken (Interface). Es besteht dan nur ein DHCP-Server für zum Beispiel LAN1,WLAN1 & VLAN1. (1. der Ursprungsfrage angehängtes BIld)
Verstehst du was ich meine? Kennst du ähnliche Funktionen?

Vielleicht is das Problem, das br0 die LAN1-,WLAN1- & VLAN1-Interfaces enthalt und br1 die DMZ-,WLAN2- & VLAN2-Interfaces enthält. Zudem ist VLAN1 sowie VLAN 2 auf den selben Port auf der USG gemapt.

Ich denke wenn ich die "Network-Bridge" auflöse, kriege ich das Problem vielleicht in den Griff.
Jedoch hat dan jedes Interface seine eigne IP-Ranges und die Kommunikation untereinander funktioniert nur über spezelle Routing regeln

Edit: Vielleicht hat es auch mit meiner Zonenkonfiguration zu tun! Ich teste dies morgen kurz!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Netzwerk
gelöst Windows 8 Embedded - Network Bridge - Restore MAC Bridge (2)

Frage von Nintox zum Thema Windows Netzwerk ...

Router & Routing
Vlan Verbindungsproblem mit WLAN Bridge (6)

Frage von MackDaddy zum Thema Router & Routing ...

Windows Server
Raid funktioniert nicht richtig (20)

Frage von Roadrunner777 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...