Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

UTF-8 Darstellung unterschiedlich in verschiedenen Browsern, wieso?

Frage Internet Webbrowser

Mitglied: CallmeGOD

CallmeGOD (Level 1) - Jetzt verbinden

23.04.2009, aktualisiert 13:03 Uhr, 3558 Aufrufe, 3 Kommentare

Moin,

ich schreibe gerade eine Webanwendung und möchte einige "Sonderzeichen" aus dem UTF-8 Zeichensatz nutzen.
So, ich dachte wenn die Seite in UTF-8 ausgeliefert wird und der Browser UTF-8 unterstützt, sieht das Zeichen auf einem System gleich aus.

Wenn ich aber mir aber mal die Zeichen ausgeben lassen: http://techblog.7d0.de/wp-content/uploads/utf8_all.html
Sieht man schnell, dass beispielsweise Opera im unteren Teil fasst gar nichts darstellt (nur Kästchen), IE 6/7 noch weniger, Firefox hat unter diesen dreien noch die beste Ausbeute.

Die Frage die ich mir stelle, woran liegt das? Also wovon ist das abhängig?
Mitglied: LotPings
23.04.2009 um 14:39 Uhr
Hallo,
dein Username ist unpassend bei einer Frage, Gott weiss doch alles

Das ein UTF-8 Zeichen transportiert werden kann, heisst noch lange nicht, das es in dem vom Browser benutzten Font auch eine Glyphe gibt, um es korrekt darstellen zu können.

Gruß
LotPings
Bitte warten ..
Mitglied: CallmeGOD
23.04.2009 um 14:55 Uhr
Okay, das macht Sinn, aber wie regelt man sowas denn dann?
Ich meine, es ist ja irgendwie sinnlos wenn man nicht sicherstellen kann, dass ein Text für alle Leute gleich angezeigt wird, egal mit welchen Browser, OS, ... sie unterwegs sind.

Gibt da irgendeine eine Schriftart die es überall gibt und auch alle UTF-Zeichen kann?
Bitte warten ..
Mitglied: LotPings
23.04.2009 um 15:35 Uhr
Zitat von CallmeGOD:
Gibt da irgendeine eine Schriftart die es überall gibt und auch alle UTF-Zeichen kann?

AFAIK nein, und da du keinen direkten Einfluß auf die beim User vorhandene Umgebung hast, gibt es auch keine universelle Lösung.
Schau einfach wie andere damit umgehen: zum Beispiel Wikipedia

Gruß
LotPings
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (52)

Frage von sabines zum Thema Internet ...

Netzwerke
LAN2LAN Verbindung sehr langsam flaschenhals gesucht (27)

Frage von PixL86 zum Thema Netzwerke ...

Router & Routing
PFsense - Netzverbindung steht, aber kein Internet vorhanden (24)

Frage von aschmid zum Thema Router & Routing ...

Windows Server
gelöst Windows 2016 Hyper-V und VHDS (19)

Frage von emeriks zum Thema Windows Server ...