Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VB.NET(VS2010)-Anchor-Eigenschaft fuktioniert nur in der Enwicklungsumgebung

Frage Entwicklung Visual Studio

Mitglied: mathe172

mathe172 (Level 1) - Jetzt verbinden

20.04.2011, aktualisiert 21.04.2011, 4688 Aufrufe, 1 Kommentar

Hallo zusammen,
ich hab mal wieder eine Frage...

...und zwar habe ich ein Problem mit meiner Windows-Forms-Anwendung:
Ich habe, zur Anpassung der Controls an die Grösse des Formulars, die Anchors gesetzt. Wenn ich nun die Anwendung starte, werden die Controls richtig Positioniert, passend zur Startgrösse des Formulars. Also wenn ich das Formular mit WindowState Normal oder Maximized starte, stimmt alles. Verändere ich nun aber die Grösse, bleiben die Controls dort wo sie sind!?
Wenn ich also die Anwendung Maximiert starte, stimmt wie gesagt alles, verkleinere ich sie dann aber, sieht man die Hälfte der Controls nicht mehr, aber: Starte ich sie mit Normalgrösse stimmt auch alles, jedoch passen sich die Controls bei Grössenänderung ebenfalls nicht an...
Ach ja, und im VS drin stimmt auch alles wenn ich das Formular im Designer in der Grösse ändere.

Weiss jemand, woran das liegt?

MfG,
Mathe172
Mitglied: mathe172
21.04.2011 um 11:56 Uhr
Hallo,

ich hab den Fehler jetzt gefunden:
Ich habe im Load-Event des Formulars die Layoutlogik per Me.Suspendlayout ausgeschaltet...und mit Me.Performlayout wieder "eingeschaltet" (oder es versucht...)
Als ich die Zeile auf Me.ResumeLayout geändert habe, hat alles wieder funktioniert. (Juhu )

MfG,
Mathe172
Bitte warten ..
Neuester Wissensbeitrag
Router & Routing

192.168er Adresse im öffentlichen Netz

(2)

Erfahrungsbericht von visco-c zum Thema Router & Routing ...

Ähnliche Inhalte
Visual Studio
gelöst VB.Net - Hilfe bei Regex (8)

Frage von emeriks zum Thema Visual Studio ...

Visual Studio
gelöst VB.Net - Problem mit Umleitung der Standard-Ausgabe (4)

Frage von emeriks zum Thema Visual Studio ...

Heiß diskutierte Inhalte
Zusammenarbeit
Als Administrator im Großraumbüro (29)

Frage von Dopamin85 zum Thema Zusammenarbeit ...

Exchange Server
Test-ActiveSyncConnectivity Error nach neuem Zertifikat (22)

Frage von Driphex zum Thema Exchange Server ...

Hyper-V
HYPER V und USB (16)

Frage von Hendrik2586 zum Thema Hyper-V ...

SAN, NAS, DAS
Backupserver für KMU (14)

Frage von Leo-le zum Thema SAN, NAS, DAS ...