Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

(VBS) Problem beim Netzlaufwerk einbinden

Frage Entwicklung VB for Applications

Mitglied: Vortax

Vortax (Level 1) - Jetzt verbinden

04.02.2008, aktualisiert 05.02.2008, 3888 Aufrufe, 2 Kommentare

Hallo, ich bin im Moment damit beschäftigt ein umfangreiches VBS Skript zu schreiben, welches jede Nacht für unsere 20 Server prüfen soll ob die Virendefinition aktuell ist, Backups durchgeführt wurden, etc. Dazu werden diverse Logs auf den Servern vom Hauptserver aus ausgerufen. Dies funktioniert bei 17 von 20 Servern auch einwandfrei, 3 Server müssen aus Sicherheitsgründen jedoch ein eigenes Passwort und einen eigenen Login haben und genau da fangen die Schwierigkeiten an. Da ich hier nicht einfach mit \\xxx.xxx.xxx.xxx\C$\ zufreifen kann. Daher habe ich versucht mir für diese 3 Server jeweils das Netzlaufwerk einzubinden und es danach wieder zu trennen. Mein Code dazu sieht so aus:

Set wn = WScript.CreateObject("WScript.Network")
wn.MapNetworkDrive "z:", "\\194.180.254.4\c$\", False, s(z,9), s(z,10)

wobei ich in s(z,9) den Benutzernamen und in s(z,10) das Passwort stehen habe (das Programm soll später durch weitere Server ergänzbar sein, daher gibt es einen editierbaren Initialisierungsteil in dem alles eingetragen wird). Danach führe ich ganz normal meine Operationen z.B. auf z:\windows\windowsupdate.log aus und trenne am Ende wieder das Netzlaufwerk. Leider funktioniert das irgendwie nicht und ich habe nicht so richtig eine Idee an was das liegt - das Netzlaufwerk scheint mir nie eingebunden zu werden, Passwort&Benutzername sind aber sicher richtig. Hat Jemand noch eine Idee was ich da probieren könnte?

Gruß und danke für die Hilfe!

Vortax
Mitglied: TuXHunt3R
04.02.2008 um 13:00 Uhr
Ich denke, so sollte es gehen:

01.
Set wn = WScript.CreateObject("WScript.Network") 
02.
wn.MapNetworkDrive "z:", "\\194.180.254.4\c$", "False", s(z,9), s(z,10)

Alternativ hier die Lösung in Batch:

01.
net use Z: \\194.180.254.4\c$ /user:Domainname\User
Dort musst du aber jeweils das Passwort eingeben.
Bitte warten ..
Mitglied: Vortax
05.02.2008 um 08:50 Uhr
Die andere Schreibweise hat leider auch nichts gebracht, ich gehe inzwischen davon aus, daß das Ganze an Sicherheitseinstellungen scheitert. Hab es jetzt erstmal so gelöst, daß ich Batch-Dateien aus dem Script aufrufe und das Script dann kurz schlafen lasse. Ist keine sonderlich elegante Lösung, scheint anders aber leider nicht möglich zu sein - trotzdem danke für die Antwort!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
DSL, VDSL
Problem mit variernder Internetgeschwindigkeit (12)

Frage von schaurian zum Thema DSL, VDSL ...

Windows Netzwerk
gelöst Problem mit PSexec64 von Sysinternals (8)

Frage von MaxMoritz6 zum Thema Windows Netzwerk ...

Windows Server
gelöst Problem nach DC-Installation unter Server 2012 R2 (9)

Frage von manuel1985 zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...