Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Veeam findet QNAP NAS nicht zur Datensicherung

Frage Hardware SAN, NAS, DAS

Mitglied: matrix753

matrix753 (Level 1) - Jetzt verbinden

13.05.2014 um 10:53 Uhr, 6264 Aufrufe, 12 Kommentare

Hallo Community,

bisher war ich Mitleser, jetzt habe ich ein Problem, zu dem ich keine Lösung gefunden habe.

Ich betreue einen HyperV-Host (WS2012), auf dem 5 VMs laufen. Jede einzelne VM soll nun mit Veeam auf ein QNAP NAS gesichert werden. Der Host hat grundsätzlich Zugriff auf das NAS. Wenn ich aber in Veeam versuche, ein Repository hinzuzufügen, klappt das nicht. Veeam findet das NAS nicht. Die VMs hängen in einer Domäne, der Hyper-V nicht. Das NAS ist über einen Switch mit dem Netzwerk verbunden.

Wäre nett, wenn mir jemand beschreiben könnte, wie ich NAS, Veeam und Hyper-V zusammen bringe. Herzlichen Dank!

Gruß - matrix753
Mitglied: Ausserwoeger
13.05.2014 um 11:14 Uhr
Hi

Da gibts nicht viel zu wissen passt alles wie es ist bei dir. Auf der NAS einen Backup ordner anlegen zb. backup
Und im Veeam ein Repository hinzufügen \\Nasname\freigabe

Natürlich müssen die Berechtigungen auf der Qnap richtig eingestellt sein.

LG
Bitte warten ..
Mitglied: matrix753
13.05.2014 um 14:06 Uhr
Ich bin jetzt einen Schritt weiter. Die QNAP war noch nicht in der Domäne. Habe das Teil jetzt in die Domäne gehoben, aber trotzdem kann ich in Veeam kein Repository einrichten, das auf dem NAS liegt. Berechtigungen auf dem NAS sind vorhanden. Daran liegt es nicht.
Bitte warten ..
Mitglied: Juckie
13.05.2014 um 16:47 Uhr
Hi,

ich hatte mal ein ähnliches Problem allerdings mit vRanger und einer QNAP. Die Lösung war damals, dass das Volume auf der QNAP zu groß war. vRanger konnte in der Version wie wir es hatten nur mit Volumens < 2 TB umgehen.

Gruß
Bitte warten ..
Mitglied: Ausserwoeger
14.05.2014, aktualisiert um 09:07 Uhr
Zitat von Juckie:

Hi,

ich hatte mal ein ähnliches Problem allerdings mit vRanger und einer QNAP. Die Lösung war damals, dass das Volume auf
der QNAP zu groß war. vRanger konnte in der Version wie wir es hatten nur mit Volumens < 2 TB umgehen.

Gruß

Das kann nicht das Problem sein ich hab hier einen Server mit Veeam und einem Repository auf einer Qnap mit 12 TB.Und die sind 1 Volume.

Hast du schon alle Veeam Updates eingespielt ? Sind alle Windows Updates installiert ?

LG Andy
Bitte warten ..
Mitglied: matrix753
14.05.2014 um 09:18 Uhr
Hast du schon alle Veeam Updates eingespielt ? Sind alle Windows Updates installiert ?

Ja - habe alles auf aktuellem Stand. Habe auch die Berechtigungen auf der QNAP nochmals überarbeitet. Da passt auch alles. Die QNAP hängt jetzt in der Domäne, der Hyper-V-Host allerdings nicht. Könnte es damit zu tun haben? Aber es ging auch nicht, als die QNAP noch nicht in der Domäne hängt.

Wenn ich vom HyperV aus die QNAP per "Shared Folder" einbinden möchte, bekomme ich die Meldung "Invalid shared folder". Versuche ich, die QNAP per "Linux Server" zu mappen, kann ich zwar die QNAP über die IP als Server ansprechen. Wenn ich dann aber versuche, auf den explizit eingerichteten Backup-Ordner auf der QNAP zu verweisen, dauert es 5 min. und dann kommt Timeout.
Bitte warten ..
Mitglied: Ausserwoeger
14.05.2014 um 09:27 Uhr
Hi

Also ich würde die QNAP nicht in die Domain hängen das hat ja keine Vorteile ausser du willst sie als datenspeicher für benutzer verwenden.

Hast du die neueste Firmware auf der Qnap installiert ? Hast du versucht auf einen Ordner zu backupen der Keine Berechtigungen gesetzt hat und für alle zugänglich ist ?

Hast du Sonderzeichen im Ordnernamen ?

LG Andy
Bitte warten ..
Mitglied: matrix753
14.05.2014 um 10:04 Uhr
Hast du die neueste Firmware auf der Qnap installiert ?

Ja - gerade überprüft. Ist die neueste.

Hast du versucht auf einen Ordner zu backupen der Keine Berechtigungen gesetzt hat und für alle zugänglich ist ?

Ja - habe jetzt zum Test ein Backup angestoßen auf einen Ordner, der innerhalb der Domain hängt. Rennt wie Sau. 10 GB in knapp 2 Minuten.

Hast du Sonderzeichen im Ordnernamen ?

Nein. Der Ordner heißt "Datensicherung", die QNAP an sich heißt "QNAPNAS" im Netzwerk.

Ist echt wie verhext. Die QNAP und der HyperV-Host kennen sich, kommunizieren auch miteinander aber dieses depperte Veeam will die QNAP nicht finden.

Danke, Andy für deinen Einsatz!
Bitte warten ..
Mitglied: Ausserwoeger
14.05.2014 um 15:27 Uhr
Hi

hmm... Wie greifst du den auf die NAS zu ? über den Namen oder über IP ?
Was passiert wenn du das Backup verzeichnis als Netzlaufwerk mountest und versuchst das als Repository zu verwenden ?

LG Andy
Bitte warten ..
Mitglied: Dobby
15.05.2014 um 01:18 Uhr
Hallo,

aber trotzdem kann ich in Veeam kein Repository einrichten,
Gibt es dazu auch eine Fehlermeldung?

Gruß ♪
Dobby♬
Bitte warten ..
Mitglied: matrix753
15.05.2014 um 09:01 Uhr
Gibt es dazu auch eine Fehlermeldung?

Es gibt verschiedene Fehlermeldungen - je nachdem, wie ich das Repository erstelle. Dazu gibt mir Veeam drei Vorschläge: "Microsoft Windows Server", "Linux Server" und "Shared Folder".

Versuch 1:
Neues Repository -> "Microsoft Windows Server" -> "This Server" -> Dann verweise ich auf das gemappte Verzeichnis von der QNAP -> Fehlermeldung "Das Objekt muss ein Stammverzeichnis (C:\) oder ein Laufwerksbuchstabe (C) sein". Trage ich manuell in die Path-Zeile "Z:\Sicherung" ein, komme ich zum nächsten Dialog. Dann kommt die Zusammenfassung und wenn ich dann auf "Next" klicke, um das Repository zu erstellen, kommt "Das System kann den angegebenen Pfad nicht finden" und ich kann nur "Cancel" klicken.

Versuch 2:
Neues Repository -> "Linux Server" -> Ich füge die QNAP mit dessen IP als neuen Repository Server hinzu -> Wähle den Admin-Account aus, den ich vorher angelegt habe und der auch Schreibrechte auf die QNAP hat -> Bekomme eine Zusammenfassung -> Klicke "Finish" -> Erfolgsmeldung, dass der Server ordnungsgemäß angelegt wurde -> Dann möchte ich auf das Verzeichnis "Sicherung" verweisen, das es auf der QNAP unter der Freigabe gibt -> Fehlermeldung "Timed out waiting for operation bla bla bla". Ich kann dann nur das Erstellen des Repository abbrechen.

Versuch 3:
Neues Repository -> "Shared Folder" -> Ich trage alle erdenklichen Versionen des Pfades in die Path-Zeile ein (mit IP, mit Freigabename, mit Laufwerksbuchstaben ect) -> Fehlermeldung "Invalid shared folder". Versuche ich, über "Browse" den Folder zu selektieren, wird mir kein Shared Folder angezeigt.

Es muss an der QNAP liegen, denn vom Veeam aus habe ich alle Möglichkeiten durch. Die Kommunikation zwischen dem HyperV-Host und der QNAP klappt einwandfrei. Irgendwas muss ich an der QNAP anders konfigurieren, damit Veeam da drauf zugreifen kann (glaube ich). Aber was?
Bitte warten ..
Mitglied: Dobby
LÖSUNG 20.05.2014, aktualisiert um 16:37 Uhr
Hallo,

Irgendwas muss ich an der QNAP anders konfigurieren, damit Veeam
da drauf zugreifen kann (glaube ich). Aber was?
- Erstelle eine Laufwerksverknüpfung zum QNAP auf dem Server
und dann verwende diesen Buchstaben als Laufwerksbuchstaben.
- Lege auf dem QNAP den selben Benutzer an unter dem Veeam
gestartet wird so dass Veeam auch darauf zugreifen darf.
- Hast Du eine AD (Active Directory) melde das NAS in dieser an
bzw. nimm das NAS Gerät in diese auf!

Hier noch ein paar Links dazu:

- VM-Sicherungslösung mit QNAP und Veeam
- How to directly backup image to NAS instead on local drive
- CONFIGURATION GUIDE VEEAM BACKUP & REPLICATION V6 WITH NETGEAR READYNAS

Ich habe es bei mir so hinbekommen wie in dem letzten Link beschrieben!
Ist zwar kein QNAP NAS, aber es hat funktioniert.

Gruß ♪
Dobby♬
Bitte warten ..
Mitglied: matrix753
20.05.2014 um 10:20 Uhr
Vielen Dank, Dobby. Habe ich alles gemacht - erst ohne Erfolg.

Meine letzte Amtshandlung war dann, dass ich das QNAP NAS einfach vom Netz nehme und gegen ein einfaches NAS von WesternDigital tausche. Damit funktionierte das Anlegen des Repository sofort. Schon nahe dran, das QNAP aus dem Fenster zu werfen, dachte ich mir, hängste das Teil nochmal dran und *ZACK* - alles funktionierte wie gewollt. Ich habe keine Erklärung dafür. Das Anlegen des Repository klappte anstandslos, obwohl ich es genau so gemacht habe, wie 1000mal vorher versucht.

Vielen Dank an alle für das Engagement. Tolles Forum, tolle Leute! Ganz anders als der Support von QNAP. Ich bekam dort praktisch keine Hilfe. Veeam ist dort nicht bekannt (muahahaha!) und der Support-Mitarbeiter, an den ich geraten war, glänzte mit absoluter Unlust, mir auch nur ansatzweise zu helfen.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
SAN, NAS, DAS
Zweiwege-Synchronisierung mit QNAP NAS und AD-Berechtigungen (3)

Frage von Sinzal zum Thema SAN, NAS, DAS ...

Windows 10
gelöst QNAP NAS und Windows 10 Kein Netzlaufwerke (9)

Frage von berlinger zum Thema Windows 10 ...

Backup
gelöst Veeam Backup auf NAS . Zugriff verweigert (5)

Frage von DeathNote zum Thema Backup ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...