Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Keine Verbindung über Modem am Server

Frage Netzwerke Router & Routing

Mitglied: BradPitt

BradPitt (Level 1) - Jetzt verbinden

05.02.2007, aktualisiert 09.02.2007, 3959 Aufrufe, 10 Kommentare

Server kommt ins Netz, Hosts nicht

Hallo!

Ich habe das Problem, daß ich an meinem Fileserver ein Modem angeschlossen habe und alle Rechner im Netzwerk somit ins Internet kommen sollten. Vom Server komme ich ins Netz. Von den Hosts aus nicht. Der Server ist als Gateway auf den Hosts eingetragen. In der ppp-Konfiguration habe ich die Option "defaultroute" gesetzt und die entsprechenden Einträge erscheinen auch in der Routingtabelle. Was ist falsch? Soll ich Ausgaben, Logfiles schicken?
Wäre nett, wenn mir diesbezüglich jemand weiterhelfen könnte.

System:
Server: Debian 3.1
Hosts: Suse 10.2
Mitglied: Dani
05.02.2007 um 20:24 Uhr
Abend,
probier mal von einem Client aus einen traceroute www.google.de! Wenn das nicht geht, stimmt die Konfig des Clients nicht.
Ursache könnte sein, falscher GW (Tippfehler), Routen gesetzt, die nicht gebraucht werden, usw...

Wenn der Traceroute funktioniert, liegts am Server!


Gruß
Dani
Bitte warten ..
Mitglied: BradPitt
06.02.2007 um 16:05 Uhr
Hallo.
Danke für die schnelle Antwort.
Traceroute kommt auch nicht weiter. Also liegt's am Client? Ich habe hier mal die Routingtabelle eines Clienten abgedruckt. Vielleicht kommt jemand drauf, was falsch ist.

01.
Host IP Routentabelle 
02.
Ziel            Router          Genmask         Flags Metric Ref    Use Iface 
03.
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0 
04.
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth0 
05.
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo 
06.
0.0.0.0         192.168.1.20    0.0.0.0         UG    0      0        0 eth0 
07.
 
08.
09.
10.
11.
                        L > Das ist die IP des Servers, an dem das Modem dranhängt.
PS: Die Firewall ist (fürs erste) deaktiviert.
Bitte warten ..
Mitglied: Dani
06.02.2007 um 17:07 Uhr
Hi,
wie sieht die Routing-Tabelle vom Server aus?!
Der Server kommt ins Internet!


Gruß
Dani
Bitte warten ..
Mitglied: Dani
06.02.2007 um 17:07 Uhr
Bitte warten ..
Mitglied: BradPitt
06.02.2007 um 21:09 Uhr
Ja, der Server kommt ins Netz. Hier die Routingtabelle bei aktivierter ppp-Verbindung:
01.
Server IP Routentabelle 
02.
Ziel            Router          Genmask         Flags Metric Ref    Use Iface 
03.
62.104.206.33   0.0.0.0         255.255.255.255 UH    0      0        0 ppp0 
04.
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0 
05.
0.0.0.0         62.104.206.33   0.0.0.0         UG    0      0        0 ppp0 
06.
07.
08.
09.
                    L > dynamische IP des ISP
Bitte warten ..
Mitglied: Dani
07.02.2007 um 17:52 Uhr
Hi,
hast du mal die Firewall auf allen Clients bzw. Server deaktiviert?! Zuerst mal nur am Server. Könnte mir gut vorstellen, dass die da noch was blockt.


Gruß
Dani
Bitte warten ..
Mitglied: BradPitt
07.02.2007 um 20:13 Uhr
Daran liegt es leider nicht. Die Firewalls auf Client und Server sind deaktiviert.
Bitte warten ..
Mitglied: Dani
07.02.2007 um 20:50 Uhr
Hi,
also hier ist mal n Ansatz oder sogar die Lösung:
http://www.linux-praxis.de/linux3/masq.html


Gruß
Dani
Bitte warten ..
Mitglied: BradPitt
08.02.2007 um 21:20 Uhr
Vielen Dank für den Link!!!! Es geht jetzt.
Das war zwar nicht die Lösung (aber so gut wie), aber hat mich auf die richtige Idee gebracht. Stichwort ip-forwarding, masquerading.
Ich habe folgendes gemacht:
01.
# echo 1 > /proc/sys/net/ipv4/ip_forward 
02.
# iptables -t nat -A POSTROUTING  -o ppp0 -j MASQUERADE
Das wars! Schon hat das ganze Netz Internetzugang.

Für alle, die sich wundern, was man in einem Modem im Netzwerk macht: Von diesem Netz werden hauptsächlich alle paar Tage Quellcode und Textdateien verschickt, evtl. mal 'ne mail. Für diesen Zweck ist das vollkommen ausreichend, insbesondere weil es sehr unwahrscheinlich ist, daß dies mehrere Benutzer zur gleichen Zeit tun.

Vielen Dank nochmal und eingeschneite Grüße aus einem kleinen 300-Seelen-Dorf.

mp
Bitte warten ..
Mitglied: Dani
09.02.2007 um 00:05 Uhr
Abend,
du wirst lachen, ich wollt dir zuerst du beiden Themen den Link schicken. Aber dann habe ich gedacht, dass hast du ja schon mal gemacht! Sry..Aber schön zu hören!
Bitte den Thread als "gelöst" markieren. Dazu oben bei der Problembeschreibung auf editieren klicken und den entsprechenden Hacken setzen. Danke...


Gruß
Dani
Bitte warten ..
Ähnliche Inhalte
Netzwerke
VPN Server hinter Modem-Router möglich? (6)

Frage von Zero01 zum Thema Netzwerke ...

TK-Netze & Geräte
Externes USB Modem zum Faxen (7)

Frage von tsunami zum Thema TK-Netze & Geräte ...

Router & Routing
gelöst Empfehlung günstiges ADSL2+ nur Modem (10)

Frage von TimMayer zum Thema Router & Routing ...

ISDN & Analoganschlüsse
SIP Modem für Windows gesucht (13)

Frage von Herbrich19 zum Thema ISDN & Analoganschlüsse ...

Neue Wissensbeiträge
Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(8)

Information von thomasreischer zum Thema Windows 10 ...

Microsoft

Die neuen RSAT-Tools für Win10 1709 sind da

(2)

Information von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
Router & Routing
Allnet - VDSL2 Modem - SFP (mini-GBIC) (20)

Frage von Dobby zum Thema Router & Routing ...

Monitoring
Netzwerk-Monitoring Software (18)

Frage von Ghost108 zum Thema Monitoring ...

Windows 10
Seekrank bei Windows 10 (17)

Frage von zauberer123 zum Thema Windows 10 ...

Windows Server
gelöst Kopiervorgang schlägt fehl, weil Datei- und Ordnername zu lang sind (14)

Frage von Schroedi zum Thema Windows Server ...