Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Verbindungsabbrüche beim Kopieren großer Dateimengen über das Netzwerk

Frage Microsoft Windows Netzwerk

Mitglied: Christian-25

Christian-25 (Level 1) - Jetzt verbinden

23.10.2009 um 00:01 Uhr, 13728 Aufrufe, 8 Kommentare

Hallo an Euch alle,

folgende Ausgangssituation: Kleines Netzwerk mit 6 Rechnern alle Windows Vista SP2 x86 und Server 2008 SP2 x64 (DNS, Proxy, DHCP, Fileserver). Gigabit-Lan mit nicht managbaren Switches (HP ProCurve 1400(http://h10010.www1.hp.com/wwpc/de/de/ho/WF05a/12883-12883-3445275-34452 ...)). Kaspersky ist als Virenschutz installiert und die Windowsfirewall wird genutzt.

Beim Kopieren von größeren Dateimengen (>200 MB) auf Netzlaufwerke kommt es regelmäßig und provozierbar zu Verbindungsabbrüchen (tritt wohl manchmal auch beim Kopieren der Nutzerprofile auf). Diese äußern sich darin, dass plötzlich der Kopiervorgang mit der Meldung (Der Pfad ist nicht verfügbar.....) abbricht (als hätte man z.B.: den USB-Stick auf den man kopiert mittendrin raus gezogen). Ab dann kann man von diesem Rechner aus, keinen anderen Rechner (inkl. Server) mehr anpingen (Meldung "Zeitüberschreitung" oder "Zielhost ist nicht erreichbar") und dieser ist auch von anderen Rechnern nicht erreichbar. Alle anderen PCs arbeiten problemfrei weiter und können untereinander gepingt werden. Internet, Remotedesktop und alle Programme die das Netzwerk benötigen funktionieren natürlich auch nicht.
Beobachtet man das Ganze im Taskmanager fällt die Netzwerkauslastung plötzlich auf 0,01% und bleibt dort konstant stehen, selbst über lange Zeit (> 15 min). Windows selbst zeigt eine eingeschränkte Konnektivität an. ipconfig -all liefert völlig korrekte Ergebnisse. ping localhost funktioniert auch korrekt. Selbst nach einer Stunde stellt sich die Verbindung nicht wieder her. Nach einem Neustart funktioniert es sofort wieder völlig normal bis man eben wieder große Dateien kopiert.....
Am Switch selbst blinkt die LED woran der jeweilige Rechner, der das Problem hat angeschlossen ist, ganz schnell als würde man große Mengen Dateien kopieren. Auch ein Rebooten des Swich (stromlos machen) ändert an der Situation nicht (daraus folgere ich, dass es nicht am Switch liegt): Anfangs blinken alle LEDs schnell nach kurzer Zeit nur noch die mit dem Problemrechner; alle anderen Rechner können normal überall zugreifen und gepingt werden außer dem aktuellen Problemrechner.
Das Problem tritt gleichermaßen auf allen der 6 Rechner auf und zwar immer beim Kopieren größerer Dateimengen. Ist man nur im Internet oder verschiebt nur wenig Dateien tritt über Stunden hinweg kein Problem auf. Ich habe bereits alle NIC Treiber aktualisiert. Da nicht alle Rechenr baugleich sind, denke ich kann man ein Treiberproblem eh ausschließen.
Ein Zurücksetzten der Netzwerkkarte löst das Problem nicht; ein ipconfig -all liefert dann jedoch eine völlig falsche IP und DNS Server und Gateway sind nicht mehr eingetragen.
Die Windows-Netzwerkdiagnose meldet "Das Modem oder der Router ist nicht erreichbar. Starten Sie das Gerät neu....."

Da das Problem auf allen Rechnern auftritt, schließe ich einen Hardwaredefekt an einem Rechner aus. Genauso auch ein Treiberproblem (bei den Rechnern handelt es sich jeweils um Dell Optiplex einmal jedoch 360 mit Intelprozessor und einmal den 720 mit AMD).
Auch den Defekt eines Kabels schließe ich aus, da die Rechner jeweils verschiedene Leitungen benutzen.
Da auch ein Rebooten des Switches keine Veränderung bringt schließe ich auch ein Absturz/Fehler im Switch aus. Da die Probleme gleichermaßen auch auf allen Ports auftreten schließe ich auch einen Hardwaredefekt aus.

Da alle PCs absolut identisch installiert worden sind und die gleiche Software etc. installiert ist, gehe ich von einem Fehler in Windows Vista aus. Der Server selbst hat noch nie die Verbindung verloren.

Da es mir an der nötigen Erfahrung fehlt meine Frage an Euch: Hatte jemand schon mal dieses Problem? Wie würdet Ihr bei der Suche weiter vorgehen bzw. welche Fehlerquellen könnt ihr ausschließen und welche vermutet Ihr?

Vielen Dank für Eure Ideen und Eure Hilfe
Gruß
Christian
Mitglied: xm-bit
23.10.2009 um 08:39 Uhr
Hi,

ist denn das kopierziel immer das gleiche??
Wenn es ein Server ist, wieviel NIC sind verbaut, und wieviel davon in dem Netzwerk verfügbar???

Hast du denn Einträge während des Abbruches in der Ereignisanzeige???
Wie sieht es mit IRQ-Sharing auf den Problempc aus???

Mit freundlichen Grüßen
Sascha
Bitte warten ..
Mitglied: northern
23.10.2009 um 09:12 Uhr
Moin Christian,

es klingt zwar etwas einfach aber hast Du mal versucht Kaspersky zu deaktivieren und dann zu kopieren?
Ich habe mit Kaspersky die Erfahrung gemacht, dass die standardmäßig sehr restrektiv eingestellten
Schutzkomponenten oft Probleme bereiten.

Gruss

northern
Bitte warten ..
Mitglied: inspiration-is-gone
23.10.2009 um 09:26 Uhr
Guten Morgen,

da das Problem reproduzierbar ist, versuche mal folgendes: Nimm eine sehr große Datei und kopiere die auf den Server. Bricht der Vorgang immer an der gleichen Stelle ab oder variiert das?

Vermute ja mal, der Vorgang läuft zu 99% und bricht dann ab, was sehr stark auf den Kaspersky hindeuten würde. Falls dieser auf dem Server installiert sein sollte, würde ich den onehin gleich dort runterschmeissen, bekommst nur Probleme davon.
Bitte warten ..
Mitglied: Kirschi
23.10.2009 um 09:31 Uhr
Moin,

deaktiviere mal IPv6 in den Lan-Einstellungen der Ethernet-Karten. Das machte bei mir auch immer mal Probleme. Ansonsten könntest Du es noch mit fest vergebenen IP-Adressen versuchen.
Andreas
Bitte warten ..
Mitglied: Christian-25
23.10.2009 um 17:35 Uhr
Guten Tag,

erstmal Danke für die vielen und schnellen Ideen!

@Sascha: Bei meinen reproduzierbaren Versuchen ist das Kopierziel das gleiche: Ein Netzlaufwerk welches auf dem Server liegt. Dabei tritt das Problem gleichermasen auf ob ich zum Server hin kopiere oder vom Server weg auf die lokale Platte. Nach dem Abbruch ist definitiv garnichts mehr erreichbar. Es gibt jedoch auch manchmal Probleme beim Laden großer Userprofile (Servergespeicherte Profile wird genutzt). Diese liegen auf einer (physikalisch) anderen Platte auf dem Server.
Der Server selbst hat 2 Nics: Eine ist für das Netzwerk, die andere für das Internet (zum Internet hin hängt noch ein Router mit Firewall dazwischen). Beide laufen auf verschiedenen IP-Adressen. Der Server selbst hat noch nie die Verbindung verloren. Es passiert immer nur bei einem der Clients der halt große Dateien verschiebt; alle anderen Clients können weiterarbeiten.
In der Ereignisanzeige vom Server konnte ich nichts finden, bei den Clients muss ich noch schauen.
IRQ-Sharing hat mir bis eben nichts gesagt, der Wiki-Artikel hat weitergehofen. Ich nehme mal an, daß es darum geht, was msinfo dazu sagt. Werde ich nachschauen.

@northern, inspiration-is-gone: Wir haben Kaspersky Business Space Security also Kaspersky Server Enterprise auf dem Server und Workstations auf den Clients. Zusätzlich überall das Adminkit. Ich halte wenig davon das vom Server runter zuschmeißen. Zwar machen Antivirenprogramme oft ein wenig ärger. Viren hingegen machen aber meist noch mehr ärger ;)
Ich werde es mal deaktivieren und schaun ob das daran liegt. Leider ist das nicht so einfach per rechtsklick möglich, wenn man die Adminkonsole nutzt.....
Da ich im Kasperskyforum keinen Beitrag in die Richtung gefunden habe, habe ich mich darum noch gedrückt....

@ Andreas: Am Server habe ich das schon getan. Bei den Clients habe ich mich selbst davon ausgesperrt (per GPO), werde das aber jetzt noch machen

Nochmal zu den Verbindungsabbrüchen: Bei großen Dateien treten sie reproduzierbar auf. Nicht jedoch zwingend am Ende sondern auch am Anfang oder in der Mitte. Ich habe jetzt mehrfach die selben Dateien kopiert und dabei ist es immer ziemlich an der selben Stelle aufgetreten (als Dateien habe ich im Übrigen Bilder (teilweise mit Videos dabei)). Einmal ist es zu einem solchen Abbruch auch gekommen als mit einer größeren Excel-Datei gearbeitet wurde, die auf dem Netzlaufwerk lag. Bei so kleinen Dateien ist es mir jedoch noch nicht gelungen das zu reproduzieren und mir ist auch nur ein Fall bekannt. Bei großen Mengen tritt es hingegen (leider) sehr zuverlässig auf.

Freue mich natürlich über weitere Ideen. Werde natürlich berichten, falls es einen (hoffentlich baldigen) Erfolg gab.

Gruß
Christian
Bitte warten ..
Mitglied: Christian-25
25.10.2009 um 23:29 Uhr
Hallo,

also es war wohl in der Tat der Kaspersky Schuld.
Ich habe diesen zurückgestellt, da ein ähnliches Problem bisher in den FAQs und im Forum von Kaspersky (wo man eigentlich viele der bekannten Probleme findet) nicht beschrieben ist.
Mittlerweile gibt es eine neuere Version. Ich werde diese Aufspielen und das weiter testen. Wenn ich dann sichere Fakten habe, berichte ich hier nochmal ausführlich (kann etwas dauern), falls mal jemand anderes in diese Situation kommt.

Danke für Eure Unterstützung

Christian
Bitte warten ..
Mitglied: northern
26.10.2009 um 07:25 Uhr
Moin Christian,

schau mal bei Kaspersky in den Einstellungen. Ich kann es jetzt nicht genau benennen, aber da gibt es Einstellungen
die die Überwachung von HTTP-Traffic betreffen sowie Portüberwachungen. In den jeweiligen Kategorien kannst Du
die Einstellungen mehr oder weniger restrektiv gestalten. Ich habe in Erinnerung dass ich z.B. die Überwachung des
HTTP-Traffic ganz deaktivieren musste um zufriedenstellende Performance bei Internet- und Lan-Traffic zu erzielen.
VPN-Tunnel, speziell Socks5-Traffic ist damals bei mir so dermaßen von Kaspersky-Antivirus beeinträchtigt worden,
dass ich Kaspersky gegen ein anderes Antivirus ersetzen musste.

northern
Bitte warten ..
Mitglied: Christian-25
26.10.2009 um 09:19 Uhr
Guten Morgen,

also das Problem bei uns ließ sich dadurch lösen, daß man in den Eigenschaften der Netzwerkkarte den Haken bei "Kaspersky Anti-Virus NDIS Filter" heraus nimmt. Ansonsten kann man alles beim alten lassen.

Ich wollte mich schon an den Support wenden, habe aber wie gesagt gesehn, daß es neue Versionen gibt. Ich möchte jetzt erstmal diese testen. Es soll die Performance deutlich gesteigert worden sein und auch der Proaktive-Schutz und Firewall etc. überarbeitet.
Ich bin mal gespannt.
Wie gesagt ich berichte dann.

Gruß
Christian
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
LAN, WAN, Wireless
Neuplanung Netzwerk mit VLAN, VOIP, Gästenetz (2)

Frage von GKKKAT zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows Server 2003 SBS Netzwerk durch neuen Server Ersetzen (9)

Frage von MultiStorm zum Thema Windows Netzwerk ...

Windows Netzwerk
USB-Gerät ins Netzwerk (Domäne) einbinden (4)

Frage von griss0r zum Thema Windows Netzwerk ...

Monitoring
Netzwerk-Qualität Monitoring Toolempfehlung (9)

Frage von michmeie zum Thema Monitoring ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...