Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Verbindungsproblem zu FTP-Server über SSL

Frage Internet Server

Mitglied: hermonn

hermonn (Level 1) - Jetzt verbinden

10.01.2006, aktualisiert 27.12.2006, 7125 Aufrufe, 13 Kommentare

Hallo Freunde,
ich habe einen FTP-Server am laufen, der so einwandfrei funktioniert. Intern kann ich ohne Probleme regulär oder über SSL darauf zugreifen, demnach wie ich es am Server einstelle. Auch klappt die Verbindung über das Internet, leider nur regulär, also offen, ohne Probleme. Wenn ich SSL aktiviere, dann verbindet sich der Client mit meinem Server, dass kann ich auch sehen, aber er zeigt mir keine Daten an. Im Protokollfenster des Clients steht dann "425 Cannot open data connection". Der Client ist aber verbunden, dass sehe ich auf dem Server, trotz SSL das aktiviert ist. Im Fenster des Clients steht nach dem Verbinden ca. 20 sec. "Ausgelastet", dann erscheint die Meldung "Verbindung mit IP... ist hergestellt, auch das Schlüsselsymbol wird angezeigt. Aber ich sehe keine Daten.
Wer kann mir helfen, ich denke das kann nichts großartiges sein, aber ich bekomme es nicht hin.

Danke schon mal

Server: Gene6 3.4.0
Client: WS FTPpro 2006
Mitglied: Freak2k
11.01.2006 um 08:48 Uhr
Die Schilderung deines Problems ist etwas verwirrend aber ich versuche es einfach mal...

Wenn ich das jetzt richtig verstanden habe versuchst du per SSL auf deinen FTP-Server zuzugreifen. Wenn dem so ist und du hast die nötigen Ports getunnelt solltest du mal versuchen am FTP-Server in den passiven Modus zu wechseln. Hatte das Problem ebenfalls vor einiger Zeit mit dem FTP-Server von BulletProof. Nach der Umstellung funktionierte es einwandfrei...

Gruß
Stefan
Bitte warten ..
Mitglied: hermonn
11.01.2006 um 12:27 Uhr
Hallo Stefan,
an meiner FritzBox 7050 ist der Port zum FTP-Server offen. Ich komme ja auch aus dem Internet drauf, regulär, also ohne SSL läuft alles super. Nur wenn ich SSL am Server aktiviere, bekomme ich zwar eine Verbindung zum Server, sehe aber meine Daten nitt. Das ist das Problem! Am Server sehe ich ja, dass jemand Verbunden ist, dann kommt nach 20 sec. die Meldung "425 Cannot open data connection".

Danke

MfG
hermonn
Bitte warten ..
Mitglied: Freak2k
11.01.2006 um 12:47 Uhr
probier mal den FTP-Server in die DMZ zu hängen und anschließend zu verbinden. Sollte das klappen liegts an den Ports die im Router noch nicht eingetragen sind...
Bitte warten ..
Mitglied: hermonn
11.01.2006 um 13:55 Uhr
Hallo Freak,
sorry wenn ich frage, aber welche Ports außer 21 sollten noch offen sein. Ich hab da nix gelesen, dass noch andere Ports offen sein müssen.
Weche sind das denn??
Im Router ist nur der Port 21 auf meine feste IP vom FTP-Server durchgeschalten.

Danke
Bitte warten ..
Mitglied: Freak2k
11.01.2006 um 14:37 Uhr
eins nach dem anderen... probier erstmal aus ob du von außen auf den FTP-Server kommst wenn du ihn in die DMZ stellst. Darüber hinaus müsste ich wissen ob er nun im Passiv- oder Aktivmodus läuft...
FTP-Verbindungen laufen Standardmäßig auf Port 21 und 20
Bitte warten ..
Mitglied: hermonn
11.01.2006 um 15:44 Uhr
Servus Freak,
wir kommen der Sache etwas näher. Ich habe den FTP-Server direkt mit dem DSL-Modem verbunden und eingewählt. Mit meinem Notebook bin ich dann über Analog Telefonverbindung auf den FTP-Server gegangen und SSL hat funktioniert.
Also kann es dann nur noch eine Einstellung an der FritzBox 7050 sein, aber welche??

DHCP habe ich aus, feste IP`s.
Port 20 und 21 sind auf FTP-Server IP weitergeschaltet.
Was noch???
Was heißt Passiv oder Aktivmodus??

Danke
hermonn
Bitte warten ..
Mitglied: Freak2k
11.01.2006 um 20:08 Uhr
na das ist doch schon mal was...obwohl du ihn ja nicht hinter dem Router betrieben hast. Versuche doch mal unter der Portfreigabe im Router den Rechner als "Exposed Host" zu deklarieren. Damit steht der Rechner in der DMZ. Wenn das geht probiere mal den Passiv Mode einzustellen. Wie das geht erfährst du in der Onlinhife des FTP-Servers die du <a href="http://www.g6ftpserver.de/manual/tutorials.html#Tutorials.4;>hi ..." findest.
Was die Ports angeht, würde ich empfehlen etwas zu experimentieren. Normalerweise nutzt SSL den Port 990. Probiere mal den externen Port 990 auf den internen 21 zu mappen...
Bitte warten ..
Mitglied: hermonn
12.01.2006 um 01:59 Uhr
Hallo,
habe noch Port 990 geöffnet auf 990 gelegt, nix, das gleiche Spiel.
Port 990 auf 21 gelegt, nix, das gleiche Spiel, Client verbindet sich, sehe aber die Daten nicht.
Pasiv Modus getestet mit meiner dynDNS Adresse, wieder das gleiche, nix.
Wie stelle ich den "Exposed Host" an?? Habe die FritzBox 7050!
Ich weis nicht mehr was ich noch tun kann!
Wenn er nicht am Router läuft, komme ich doch mit SSL drauf. Es kann doch nur noch
an so ner scheiss freigabe liegen. Ich weis es nitt!

Danke
hermonn
Bitte warten ..
Mitglied: Freak2k
12.01.2006 um 08:16 Uhr
OK den gemappten Port 990 kannst du getrost wieder entfernen. Normalerweise sollte es auch über Port 21 funktionieren. Empfehlen würde ich dir den FTP-Server im passiven Modus laufen zu zu lassen.
Um herauszufinden über welchen Port du Zugriff bekommst gilt die Regel viele Wege führen nach Rom.Der einfachste Weg ist wahrscheinlich den FTP-Server noch einmal direkt ans Netz zu klemmen und von außen drauf connecten. Wenn du drauf bist einfach mal am Server (ich nehme mal an es ist Windows) in die Eingabeaufforderung gehen und "netstat" eingeben ung gucken welche Ports offen sind. Mit dieser Information weiß man schonmal welcher Port genutzt wird. Darüber hinaus würde ich mal empfehlen das du das Protokoll vom Server postest damit ich mir ein Bild machen kann, denn im Moment tappe ich etwas im Dunkeln da ich nicht weiß ob die restlichen Einstellungen die du vorgenommen hast stimmen.
Bitte warten ..
Mitglied: hermonn
12.01.2006 um 15:22 Uhr
Servus,
es hat geklappt, es funktioniert, so wie ich es will, super!

Was wars:
- PASV-Ports am FTP-Server 810-840 eingestellt
- Ports in der Firewall göffnet, auf meine feste Server IP
- Verbindungen auf Ports <1024 erlauben in der Server konfig

Tests durchgeführt, alles wunderbar



Danke nochmals an alle
hermonn
Bitte warten ..
Mitglied: Freak2k
12.01.2006 um 19:03 Uhr
glückwunsch
Bitte warten ..
Mitglied: hermonn
28.03.2006 um 22:06 Uhr
Hi,
das Mappen der Ports 990 auf 21, heißt das Du in der Firewall die Anfragen die von außen Port 990 kommen, auf den Port 21 Intern umleitest.
DMZ heißt Demilitirarsierente Zone, das ist der Bereich vor einer Firewall, ungeschützt!

mfg
hermonn
Bitte warten ..
Mitglied: loylennox
27.12.2006 um 02:58 Uhr
Hallo zusammen!Ich habe auch ein kleines Problem mit dem Zugriff auf einen FTP-Server via IE6.x. Kurze Beschreibung meiner SOLL-Konfiguration:
Ich möchte via Browser (IE oder Firefox etc...) auf unseren FTP-Server zugreifen. Mit FTP funktioniert das auch alles einwandfrei... Jedoch haben wir die Auflagen zur Verschlüsselung bekommen und jetzt fängt das Problem an:
Ich benutze FTP over SSL (implicit Port 990). Habe auf dem FTP-Server dies auch mit eigem erstelltem Zertifikat konfiguriert. Wenn ich mit einem X-beliebigem Client (Voyager, PSFTP, WS-FTP etc...) darauf zugreifen habe ich KEINE Probleme. Die Verbindung wird in kurzer Zeit hergestellt.
Möchte ich aber mit dem IE oder Firefox darauf zugreifen (Ich habe das Zertifikat bereits installiert -> vertrauenwürdige Stammzert...stellen) such IE sich tot. Im Log des Servers wird kurzzeitig die Connection angezeigt und ist dann wieder weg...
Die passive Portrange (serverseitig) habe ich auf 810-840 gestellt. Im IE habe ich auch mal den pass Mode ausgestellt -> ohne Erfolg. Als FTP-Server verwende ich PSFTP, ich habe es aber auch schon mit ServU und G6FTP-Server versucht...immer mit dem gleichen scheiss Ergebnis.
Ich teste auf einer W2k3-Maschine OHNE Firewall oder ähnlichem. Hat jemand einen Plan?
Wäre der Knaller!!! Danke schon mal im Voraus!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Linux Tools
CURL mehrere Dateien vom ftp-Server herunterladen (10)

Frage von highpriest zum Thema Linux Tools ...

Netzwerkmanagement
Zugriff auf FTP-Server durch Chrome in Windows 7 klappt nicht (3)

Frage von emilien2 zum Thema Netzwerkmanagement ...

Batch & Shell
gelöst Per Batch FTP-Server Dateien ändern (1)

Frage von Marlon1 zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...