Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
Kommentar vom Moderator Biber am 19.01.2012 um 19:59:39 Uhr
Verschoben von "Linux"-"Office" nach "Windows"-"Office"

Verschachtelte Funktion in Excel

Frage Microsoft Microsoft Office

Mitglied: UteSaft

UteSaft (Level 1) - Jetzt verbinden

19.01.2012, aktualisiert 19:59 Uhr, 2335 Aufrufe, 3 Kommentare

Hallo,
ich hab da ein kleines Problem und würde euch gern um Rat bitten.
Ich habe für meine Ausbildung ein Zeiterfassungssystem über Excel erstellen sollen.
Hat soweit super geklappt bis auf eins:
die Berechnung der Pausenzeit.

Und zwar,soll es wie folgt sein:
-Wenn die Arbeitszeit zwischen 6,5h und 10h liegt gibt es 30min pause
-ab 10h gibt es 45min pause

-Schwierigkeit: ab 6h - 6,5h(die 6,5nicht mehr mit eingeschlossen) möchte mein Chef das mir das System die überschüssigen Minuten ausgibt,
also zb bei 6:17h Arbeitszeit soll er mir in der Pausenspalte 0:17 ausgeben.


Ich hab es hiermit versucht:
=WENN(J8<6,5/24;J8-6;WENN(J8>=6,5/24;0,5/24;WENN(J8>=10/24;0,75/24)))

--> J8 = Arbeitszeit
Mitglied: bastla
19.01.2012 um 14:45 Uhr
Hallo UteSaft und willkommen im Forum!

Etwa so:
=WENN(J8<6/24;0;WENN(J8<6,5/24;J8-6/24;WENN(J8<10/24;0,5/24;0,75/24)))
Hinsichtlich der Grenze bei 10 Stunden ist Deine Angabe widersprüchlich - ich habe die zweite Aussage ("ab 10h gibt es 45min pause") zugrundegelegt, sodass es also ab genau bereits 10 Stunden die 45 Minuten gibt ...

Als Grundregel für das Verschachteln mehrer Bedingungen: Wenn Du mit einem "<" beginnst, sollten auch alle weiteren Bedingungen "<" oder "<=" abfragen ...

Grüße
bastla

P.S.: Da Du vermutlich kein "Linux-Excel" verwendest, wäre ein anderer Bereich angebracht ...

[Edit]] Behandlung der Grenze "10 Stunden" angepasst [Edit]
Bitte warten ..
Mitglied: UteSaft
19.01.2012 um 14:50 Uhr
oh vielen lieben dank,
hat gut geklappt.

allerdings beschwert sich mein excel(2000),
dass die makros deaktiviert sind, die ich fälschlicherweise installiert hab.
kann ich gegen diese meldung etwas tun ?
ich war schon bei der makrosicherheit und habe auf geringe sicherheit gestellt.
die einzelnen module hab ich eigentlich auch gelöscht.
Bitte warten ..
Mitglied: bastla
19.01.2012 um 14:51 Uhr
Hallo UteSaft!

allerdings beschwert sich mein excel(2000),
Mein Excel 2000 (und auch die Hardware, auf der es installiert war) macht keinen Mucks (mehr) ...

Hinsichtlich der Makros: Im Zweifelsfall einfach die Tabelle(n) in eine neue Mappe kopieren ...

Grüße
bastla
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Verschachtelte FOR-Schleife mit einem Argument (3)

Frage von mp-home zum Thema Batch & Shell ...

Microsoft Office
gelöst Excel Dateikarte samt Funktionen kopieren (1)

Frage von Yanmai zum Thema Microsoft Office ...

Batch & Shell
Verschachtelte For Schleife für Batch Neuling (3)

Frage von yperiu zum Thema Batch & Shell ...

Microsoft Office
gelöst EXCEL: WENN Funktion mehrfach verwenden (2)

Frage von sims zum Thema Microsoft Office ...

Neue Wissensbeiträge
LAN, WAN, Wireless

Schwachstelle im WPA2 Protokoll veröffentlicht

(3)

Information von colinardo zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte