Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Nach verschieben von Daten, von einer Partion zu einer anderen, ist das Starten von einzelnen Programmen nicht mehr möglich.

Frage Linux

Mitglied: MSC

MSC (Level 1) - Jetzt verbinden

03.05.2009, aktualisiert 18:25 Uhr, 3695 Aufrufe, 5 Kommentare

Hallo Leute,
wahrscheinlich habe ich wieder einen besonderen Punkt im Betrieb eines Linux Servers erwischt oder es ist das Zusammenspiel mit der eingesetzten Software.

Dies ist die Einsatz Umgebung:
Suse Linux 9.3, durchgepatcht
Samba Server läuft stabil und macht sonst keine Probleme.

Die Ausgangslage:
Der Urspünliche Plattenplatz ist zu klein geworden, RAID 1 mit insgesamt 150 GB für System und Bewegungsdaten.
Wie folgt für den Sambaserver gemountet.

Daten/Daten und Daten/Data Ja ist so entstanden da es vorher so auf dem abzulösenden Novell Server angelegt war.

Dem System nun ein weiteres RAID1 (1TB) hinzugefügt und unter /daten2 in das System gemountet.
Zugriffsrechte für alle User gesetzt ( Zugriff für alle User ok.)

Nun haben ich alle Daten von /daten/daten nach /daten2/daten_neu verschoben bzw. erst einmal kopiert.

Habe mir dann gedacht das ich nur noch die Freigaben umlenken muss, um vom Client, unter den gleichen gemappten Laufwerksbuchstaben halt auf die die neue Partition zu kommen.

Also Daten/daten umbenant in Daten/daten_alt und /daten2/daten_neu in /daten2/daten.

Zugriff auf /daten2/Daten von verschiedenen Programm und per Dateibrowser geht, auch das Arbeiten mit Nemeschek Allplan (CAD Software für den Hochbau) geht einwandfrei.

Nun zum Problem:

Es gibt zwei Applikationen, Kobra v8.0 und S-Control, lassen sich nicht mehr starten, bzw. sie werden mit einer Fehlermeldung beendet.
Bei Cobra wird gemeldet das eine Datenbank nicht gefunden wird, habe daraufhin alle Daten aus dem Qeuell- und dem Zielverzeichniss verglichen und sie sind gleich und es hat auch niemant in der Zwischenzeit gearbeitet.

Bei S-Contoll, Programm zu Erfassung von Projekt zeiten wird von den einzelnen Nutzer aufgerufen um die Projektarbeitszeit zu erfassen, kommt die Meldung das das Programm auf dem Client nicht registriert wurde. Prgrammende.

Und nun das kuriose, mache ich die oben genanten Änderungen wieder rückgäng, rolle also auf die original Zuordnung zurück funktionieren die beiden genannten Programme wieder problemlos.


Ich möchte eine Neuinstallation der beiden Programme, nach dem Verlegen des Speicherortes vermeiden und ich möchte gerne wissen woher dieses Problem kommt.
Denn ich kann mir vorstellen das das Hinzufügen von Plattenplatz ohne LVM und ein verschieben der Daten des öffteren vorkommt .


Freue mich auf eure Anregungen dieses Problem zu lösen!

Gruß MSC
Mitglied: mrtux
03.05.2009 um 18:08 Uhr
Hi !

Zitat von MSC:
Ich möchte eine Neuinstallation der beiden Programme, nach dem
Verlegen des Speicherortes vermeiden und ich möchte gerne wissen
woher dieses Problem kommt.
Denn ich kannt mir vorstellen das das Hinzufügen von
Plattenplatz ohne LVM und ein verschiebn der Daten des öffteren
vorkommt .

Ja schon aber so würde ich das nicht machen.
Hast Du es schon mal mit Verlinkung (Stichwort Sym- o. Hardlink) versucht ? Ich vermute mal, irgendwo hat, ein echter Held, die Pfade hardcoded oder es ist ein Lizenzproblem.

mrtux
Bitte warten ..
Mitglied: MSC
03.05.2009 um 18:23 Uhr
Hallo mrtux,

danke für deine Antwort.
Von den beiden Verlinkungen habe ich schon viel gelesen aber aktiv noch nicht eingestezt und wenn dann nicht bewust.
Kannst Du mir sagen wie ich mir die Sym- und Hardlinks anzeigen lassen kann?

Bei dem Programm S-Contoll kann ich mir gut vorstellen das das Programm eine ID erstellt in der die Client Hardware und die Lage der Datenbank verarbeitet wurde,
dies werden ich am Montag bei der Hotline abklopfen.

Nun ich bin gerad dabei in meinen Linux Büchern zu schmökern. Werden Sym- und Hardlinks mit hinzunehmen.

Gruß

MSC
Bitte warten ..
Mitglied: mrtux
03.05.2009 um 20:35 Uhr
Hi !

Zitat von MSC:
Kannst Du mir sagen wie ich mir die Sym- und Hardlinks anzeigen
lassen kann?

mit "ls -l" und mit "ln" kannst Du sie erstellen.

"man ls" und "man ln" hilft auch ohne Buch weiter

mrtux
Bitte warten ..
Mitglied: jhinrichs
04.05.2009 um 08:06 Uhr
Noch ein Hinweis:
Wenn ich Dich richtig verstehe, hast Du die Partitionen unter Linux erstellt und die Daten unter Linux kopiert. Die Anwendungen, die Probleme machen, laufen aber unter Windows und greifen auf die Daten über Samba-Freigaben zu?
Wenn das so ist, kann es Probleme mit den Berechtigungen geben, da die NTFS-Berechtigungen beim Kopieren mit cp (dann hoffentlich mit cp -p, um die Unix-Rechte zu erhalten) nicht immer korrekt mitkopiert werden. Eine Lösung könnte also sein, die Daten unter Windows zu kopieren.
Bitte warten ..
Mitglied: MSC
04.05.2009 um 19:16 Uhr
Hi jhinrichs,

habe es heute hin bekommen!

Kopiert habe ich unter Linux mit dem X-Windos Dateiexplorer.

Du hast recht es war zu einem ein Rechteproblem und zum anderen, wie schon vermutet must die Software S-Control neu autoresiert werden.
S-Control bekommt mit wenn die Daten wo anders im Pfad liegen!
HOtlien angerufen, neuen Code bekommen und fertig.

Aber es währe schlimmer gekommen wenn ich nicht das Mapping beibehalten hätte. Glück gehabt.

Das Adressprogramm Kobra funktionierte auch wieder allerdings erst nach dem ich die Rechte unter Linux neu gesetzt hatte.

Danke für eure Unterstützung ich werde in der nächsten Woche kurz beschreiben was ich gemacht habe damit es wieder läuft und diesen Betrag als gelöst einstellen.

Gruß

MSC
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Programm über CMD starten (9)

Frage von Galawayne zum Thema Batch & Shell ...

Windows 7
gelöst Programme starten nicht und werden nicht installert (4)

Frage von Zoom78 zum Thema Windows 7 ...

Windows Server
Windows Server 2016 Programme unter einem anderen Benutzer starten (3)

Frage von Rademacher zum Thema Windows Server ...

Windows Server
gelöst Leerer Start-Programme Folder nach Migration und Neuanmledung (4)

Frage von 321Jahn zum Thema Windows Server ...

Neue Wissensbeiträge
Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(8)

Information von thomasreischer zum Thema Windows 10 ...

Microsoft

Die neuen RSAT-Tools für Win10 1709 sind da

(2)

Information von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
Windows 10
Seekrank bei Windows 10 (18)

Frage von zauberer123 zum Thema Windows 10 ...

Windows 10
Windows 10 Fall Creators Update Fehler (14)

Frage von ZeroCool23 zum Thema Windows 10 ...

Router & Routing
gelöst Getrenntes Routing bei VoIP und Daten (12)

Frage von Hobbystern zum Thema Router & Routing ...