Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Verschiedene Probleme mit meinen für XP gebastelten Anmeldescripten unter Windows 7

Frage Entwicklung Batch & Shell

Mitglied: holsthn

holsthn (Level 1) - Jetzt verbinden

29.10.2009 um 15:51 Uhr, 5743 Aufrufe, 5 Kommentare

Unter Windows XP funktionieren meine Anmeldescripte wunderbar - unter Windows 7 gibt es leider verschiedene Probleme.

Hallo
Ich habe in eine SBS2003-Domäne 2 Scripte für die Anmeldung. Diese Scripte bewirken, dass alle Netzlaufwerke und Drucker verbunden werden und "schöne" Anzeigenamen über die Registry zugewiesen bekommen.

Unter Windows XP laufen die Scripte herforragend durch und haben nie Probleme verursacht.
Unter Windows 7 habe ich nun folgende Probleme:

Ein Netzlaufwerk kann nicht verbunden werden:
Eines meiner Netzlaufwerke gehört nicht zur Domäne und ich gebe im Script Benutzname und Kennwort mit.
Bei der Anmeldung unter Windows 7 wird mir gleich gesagt, dass ein Netzlaufwerk nicht verbunden werden konnte.
Klicke ich diese Laufwerk an, fragt er nach User und Passwort und ich speicher dieses und alles geht.
Melde ich mich erneut an hat er sich dieses leider nicht gemerkt und ich bekomme erneut die Nachricht, dass es nicht verbunden werden konnte.
Hier der Scriptteil dazu:
01.
net use u: \\192.168.44.201\ftp /user:192.168.44.201\user passwort /persistent:yes
Ich glaube zwar nicht, dass es damit etwas zu tun hat, aber danach führe ich noch folgende reg-Datei aus kosmetischen Gründen aus:
01.
Windows Registry Editor Version 5.00 
02.
 
03.
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2\##192.168.44.201#ftp] 
04.
"_AutorunStatus"=hex:01,df,df,00,df,01,00,01,01,ee,ff,ff,ff,ff,ff,ff,ff,ff,ff,\ 
05.
  ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,\ 
06.
  ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,ff,\ 
07.
  ff,ff,00,00,20,00,00,08,00,00,00 
08.
"_LabelFromReg"="FTP" 
09.
"BaseClass"="Drive" 
10.
"_CommentFromDesktopINI"="" 
11.
"_LabelFromDesktopINI"=""
Das ist mein erstes kleines Problem, welches mein altes Script verursacht.


Nun zu meinem viel größeren Problem:
Über eine VBS Datei lasse ich die Netzwerkdrucker verbinden. Es werden 4 Drucker verbunden und der Standarddrucker gesetzt.
Auch hier - Unter Windows XP läuft alles super unter Windows 7 habe ich mit dem Script folgendes Problem:
Windows 7 fragt, ob es die Treiber installieren soll und macht dies auch brav nach Bestätigung.
Jedoch bekomme ich danach eine Fehlermeldung und nur der Standarddrucker wird installiert bzw angezeigt.
Hier erstmal mein Script:
01.
' Variablen deklarieren 
02.
Dim objNetwork, objShell 
03.
Set objNetwork = CreateObject("WScript.Network") 
04.
Set objShell = CreateObject("Shell.Application") 
05.
 
06.
 
07.
' Variable belegen 
08.
strPrintSRV = "DeinDruckServer" 
09.
 
10.
' Drucker verbinden 
11.
WshNetwork.AddWindowsPrinterConnection "\\srv-bgl\CD1018" 
12.
WshNetwork.AddWindowsPrinterConnection "\\srv-bgl\HPColorLaser" 
13.
WshNetwork.AddWindowsPrinterConnection "\\srv-bgl\HP1300Briefp" 
14.
WshNetwork.AddWindowsPrinterConnection "\\srv-bgl\HP_JCGU" 
15.
 
16.
' MsgBox Err.Number & vbCrLf & Err.Description 
17.
 
18.
' Als Standarddrucker setzen 
19.
 
20.
WshNetwork.SetDefaultPrinter "\\srv-bgl\CD1018" 
21.
Set objNetwork = Nothing 
22.
Set objShell = Nothing
Und jetzt noch die Fehlermeldung die ich bekomme

f74d9fd79638d11a4298834ba07a70cd-fehler - Klicke auf das Bild, um es zu vergrößern

So - ich hoffe ich habe alles richtig formatiert und detailliert genug beschrieben.
Bei den Antworten müsste beachtet werden, dass die Scripte auch weiterhin unter XP lauffähig sein müssen.
Über jede Antwort und Hilfe freue ich mich riesig und möchte mich schonmal im Voraus bedanken!
Viele Grüße
Mitglied: ahe
29.10.2009 um 16:41 Uhr
Hallo,

es könnte auch am UAC liegen siehe auf der Seite: http://technet.microsoft.com/en-us/library/cc766208%28WS.10%29.aspx (Group Policy Scripts can fail due to User Account Control)

Es gibt auch den Hinweis (bei Vista) UAC generell auszuschalten, da es dann keine Probleme mehr mit Skripten geben soll... http://forum.fachinformatiker.de/windows-betriebssysteme/116372-windows ...

Hier gibt es auch ein paar Beispiele, beziehen sich zwar auf Vista, ich könnte mir aber vorstellen, dass es bei Windows 7 ähnlich ist:
http://windowsinfrastructure.spaces.live.com/blog/cns!1E054DDD8CCB6A8A! ...

Allg. Tipps zum Drucker anbinden: http://www.gruppenrichtlinien.de/index.html?/HowTo/rundll32_printui.htm

Leider konnte ich bislang nicht mit Windows 7 im Netz testen ...

Welche Version(en) verwendest du denn? Home? Enterprise? Ultimate? 32-/64-Bit?

mfg
Axel
Bitte warten ..
Mitglied: holsthn
29.10.2009 um 18:10 Uhr
Hi
Bringt leider so nichts - Die Scripte werden ja komplett ausgeführt - nur eben mit Fehlern.
Das erste Script verbindet insgesamt 8 Netzlaufwerke. Alle anderen ohne Username und Kennwort, da es sich um Domäneninterne Netzlaufwerke handelt.
Ich habe nur den Schnipsel rauskopiert der nicht läuft. Naja er läuft, aber irgendwas stimmt bei der Kennwortübergabe nicht. Das Laufwerk wird im Explorer angezeigt, nur muss man eben jedesmal Username und PW eingeben.
Auch das 2te Script wird ausgeführt - er installiert ja die Druckertreiber und der eine Drucker wird auch installiert - aber eben leider nur einer.
Ich nutze Windows 7 Enterprise (ist das gleiche wie Ultimate, aber für Unternehmen) - habs mit 64bit und 32bit probiert - gleiches Problem.
Trotzdem Vielen Dank für Deine Antwort
Viele Grüße
Bitte warten ..
Mitglied: DerWoWusste
29.10.2009 um 18:32 Uhr
Führ' das Netzlaufwerkskript mal sichtbar aus - kommt eine Meldung, mit der wir was anfangen können?
Bitte warten ..
Mitglied: holsthn
30.10.2009 um 10:08 Uhr
Hi
Bringt nicht wirklich was - Der Befehl wurde erfolgreich ausgeführt...
Ich habe es jetzut anders gelöst. Im Login-Script werden zuerst alle Netzlaufwerke getrennt - Hab ich gemacht, um zu verhindern, dass es Probleme gibt, wenn jemand unter dem gleichen Laufwerksbuchstaben Netzlaufwerke bei sich zu Hause (Notbooks) gemappt hat.
Das habe ich jetzt für das Laufwerk rausgenommen. Wenn das Script jetzt das erste mal ausgeführt wird gibt es natürlich noch immer den Fehler, wenn man dann jedoch die Anmeldeinformationen händisch eingibt und Anmeldeinformationen speichern klickt, läuft es beim nächsten Mal.
Das ist zwar nicht wirklich eine Lösung, aber hilft trotzdem weiter.

Soll ich dieses Thema auf gelöst setzen und das DruckerScript-Problem nochmal neu einstellen oder einfach hoffen, dass jetzt nur noch auf das Druckerscript geantwortet wird?

Vielen Dank
Bitte warten ..
Mitglied: DerWoWusste
30.10.2009 um 10:13 Uhr
Soll ich dieses Thema auf gelöst setzen und ...
Musst Du wissen - vielleicht besser, es neu zu machen.
Bitte warten ..
Ähnliche Inhalte
Windows 7
GPO-Anmeldescript - Abarbeitungsposition im Anmeldevorgang (11)

Frage von SarekHL zum Thema Windows 7 ...

Windows 7
Probleme bei Windows 7 Updates (13)

Frage von TechnoX zum Thema Windows 7 ...

Windows 7
gelöst Sind euch verstärkte Probleme bei Windows 7 Updates aufgefallen? (4)

Frage von RadioHam zum Thema Windows 7 ...

Samba
gelöst Qnap als Samba4 und Fileserver, Anmeldescript, Netzlaufwerke (3)

Frage von Brunium zum Thema Samba ...

Neue Wissensbeiträge
Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(8)

Information von thomasreischer zum Thema Windows 10 ...

Microsoft

Die neuen RSAT-Tools für Win10 1709 sind da

(2)

Information von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
Monitoring
Netzwerk-Monitoring Software (18)

Frage von Ghost108 zum Thema Monitoring ...

Windows 10
Seekrank bei Windows 10 (17)

Frage von zauberer123 zum Thema Windows 10 ...

Windows Server
gelöst Kopiervorgang schlägt fehl, weil Datei- und Ordnername zu lang sind (14)

Frage von Schroedi zum Thema Windows Server ...

Windows 10
Windows 10 Fall Creators Update Fehler (13)

Frage von ZeroCool23 zum Thema Windows 10 ...