Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Verteilung von Java RE per GPO bleibt hängen

Frage Microsoft

Mitglied: sayAlex

sayAlex (Level 1) - Jetzt verbinden

07.05.2010, aktualisiert 16:55 Uhr, 6551 Aufrufe, 9 Kommentare

Verteilung von Java RE per GPO bleibt hängen, sofern bereits eine Version von JRE installiert ist.

Ich habe ein Problem bei der Verteilung von Java RE v6 Update 20.
Ich habe Testweiße die GPO bei 5 Clients zu einer Test-OU hinzugefügt. Die 5 Rechner haben unterschiedliche Versionen von JRE bereits intstalliert bzw noch garnicht installiert. Wenn Java noch nicht installiert ist, läuft die Installation reibungslos ab. Sobald aber bereits eine ältere Version vorhanden ist steht für eine geschätzte halbe Stunde beim starten von Windows, dass Java installiert wird, was danach aber dann auch nicht der Fall ist.
Im Netz berichtet Mehrere von diesem Problem, allerdings bin ich auf noch keine brauchbare Lösung gestoßen.
Einige Vermutungen dort gehen auf den "Java Quick Starter Dienst" zurück der die Installation behindert.
Welche Möglichkeiten gibt es dieses Problem zu umgehen bzw. wie könnte ich am besten die bereits installierten Java-Versionen mit einem überschaubarem Aufwand deinstallieren und im selben Moment wieder installieren?
Oder gibt es den im allgemeinen eine elegantere Lösung JRE upzudaten, mal abgesehen vom Self-Update?
Mitglied: 48507
07.05.2010 um 17:22 Uhr
Du kannst auch per GPO die Deinstallation eines Paketes anstossen.. Die Frage ist, was er als erstes macht
Bitte warten ..
Mitglied: DerWoWusste
07.05.2010 um 19:16 Uhr
DIe GPO-SW-Verteilung sieht doch Upgrades vor. Beim Einchecken des Paketes auf advanced/=erweitert? klicken und dort auf dem Tab Upgrade einstellen, welche Versionen es upgraded und aussuchen, dass es zuvor deinstalliert werden sollen.
Hatte keine Probleme beim Upgrade von 19 auf 20.
Bitte warten ..
Mitglied: sayAlex
07.05.2010 um 21:22 Uhr
Mein Problem ist aber dass die derzeit installierten JRE-Versionen per Hand installiert wurden. Ich müsste diese also zunächst deinstallieren und am besten im Anschluss gleich wieder installieren. Hat hier jemand eine Idee wie ich das am besten machen könnte?
Bitte warten ..
Mitglied: DerWoWusste
09.05.2010 um 16:33 Uhr
Du kannst ein Shutdown- oder Startskript nutzen, dass msiexec /x nutzt und dem die ID von JRE mitgeben, um es zu deinstallieren.
MsiExec.exe /X{26A24AE4-039D-4CA4-87B4-2F83216020FF}
[MsiExec.exe /X{26A24AE4-039D-4CA4-87B4-2F83216019FF} für U19, usw.]
Bitte warten ..
Mitglied: sayAlex
10.05.2010 um 08:25 Uhr
Die Möglichkeit kenne ich bereits. Wie aber kann ich in diesem Fall sicherstellen, dass zunächst deinstalliert wird und erst dann wieder installiert wird? Kann man eine Art Priorität einstellen nachdem die GPOs abgearbeitet werden bzw. wo nach richtet sich das ganze?
Bitte warten ..
Mitglied: DerWoWusste
10.05.2010 um 19:31 Uhr
Tja, was kam eher, Startskripte oder Software-GPOs? Sollte sich durch ausprobieren finden lassen, es wird ja bei Start angezeigt, wann Startskripte laufen (Bei Vista/Win7 Protokollierung einschalten).
Bitte warten ..
Mitglied: sayAlex
11.05.2010 um 08:01 Uhr
Natürlich genau die falsche Reihenfolge. Bzw. zunächst sehe ich beim starten nur das Softwarepaket und garnichts von dem Startskript. Im Eventlog finde ich dann aber das Startskript wieder. Sehr komisch. Außerdem klappt diesmal die Installation selbst bei Vorinstallierter Altversion von Java. Werd das heute nochmal an ein paar Clients testen, ob´s bei allen so klappt und dann verteilen.

Zwischdrin aber noch kurz eine andere Frage. Nach dem starten des exe-Installers krieg ich ja die .msi .mst und. cab Dateien. Zum editieren der .mst benutze ich Orca. Sollte man hier die bereits enthaltene .mst verwenden (in dieser ist schon ziemlich viel als verändert markiert). Oder eine neue erstellen, oder sogar die .msi direkt bearbeiten. Was ist hier am sinnvollsten bzw. der richtige Weg?

Vielen Dank für die Hilfe schon mal!
Bitte warten ..
Mitglied: DerWoWusste
11.05.2010 um 08:25 Uhr
Will man die Ur-MSI noch haben, um damit anderes anzustellen, dann nimmt man eine mst, wenn nicht, bearbeite ich die MSI direkt.
Bitte warten ..
Mitglied: schmidtshauser
24.06.2010 um 16:24 Uhr
Hallo,

dann klink ich mich mal ins Thema ein. Ich hab die gleiche Situation wie "sayAlex": Eine Menge Rechner und überall sind verschiedene Versionen drauf.
Ich hab den Version 20 Bug folgendermaßen gelöst:
Ich hab bei der Softwareinstallation erst Version 19 und dann Version 20 eingerichtet.
Dabei werden beide Versionen hintereinander (ohne Neustart) installiert und dann funktioniert es.
Hab es bis jetzt auf sieben Rechner erfolgreich getestet und lass es jetzt auf die restliche Meute los
Bitte warten ..
Ähnliche Inhalte
Windows 7
Windows installation bleibt hängen (13)

Frage von jensgebken zum Thema Windows 7 ...

Batch & Shell
gelöst Powershell Windows Update Management - get-WUinstall bleibt hängen (10)

Frage von MartinAD zum Thema Batch & Shell ...

Netzwerkmanagement
Proxy Verteilung über GPO rückgängig machen (10)

Frage von WinLiCLI zum Thema Netzwerkmanagement ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Batch & Shell
Skripterstellung Lehrling (22)

Frage von 133119 zum Thema Batch & Shell ...

Windows Userverwaltung
gelöst Wie verfahrt Ihr mit den Windows-Benutzerkonten und -dateien von ausgeschiedenen Mitarbeitern? (14)

Frage von Bl0ckS1z3 zum Thema Windows Userverwaltung ...

Exchange Server
Microsoft Exchange Weiterleitung mit anderer primären E-Mail Adresse (14)

Frage von Rene12345 zum Thema Exchange Server ...

LAN, WAN, Wireless
Devolo DLAN 500 pro Wireless+ (13)

Frage von IceAge zum Thema LAN, WAN, Wireless ...