Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Verursacht CPU-Zeit Scriptfehler 500?

Frage Entwicklung PHP

Mitglied: OiledAmoeba

OiledAmoeba (Level 1) - Jetzt verbinden

22.11.2009, aktualisiert 02.12.2009, 5656 Aufrufe, 1 Kommentar

Wir nutzen Joomla auf einem Server von domainfactory. Installieren neuer Komponenten erzeugt 500'er Fehler.

Hallo,

ich bin gerade dabei, unsere Homepage auf Joomla!1.5 umzustellen. Vorgänger war Joomla! 1.0.15
Die Datenbank ist soweit übertragen, jetzt stoße ich auf ein schier unlösbares Problem bei der Installierung der benötigten Komponenten.
Es läuft wie sonst auch immer: Installationsscript auswählen, hochladen und ausführen. Fertig. Oder auch nicht.
Nach kurzer Zeit (etwa 10 Sekunden) bricht die Installation nun mit einem Fehler 500 ab.

Woran könnte das liegen? Ich vermute, dass es die Einschränkung des Servers ist, dass ein Script nur so wenig CPU-Zeit erhält. Andererseits sollte ein Script doch eigentlich nur von der Scriptlaufzeit-Beschränkung betroffen sein, oder?
Hier mal die Einstellungen des Servers (und nein, ich kann sie nicht ändern!):

Für Ihren Account gelten gemäß dem ihrerseits genutzten Tarif die folgenden Skriptlimits zur Ausführung von Skripten (z.B. PHP und Perl):
Arbeitsspeicher 13 MB RAM
CPU-Zeit 8 Sekunden
Skriptlaufzeit 90 Sekunden

In der php.ini habe ich die Laufzeit auf 75 Sekunden gesetzt und den Ram auf 13 MB. Zuerst dachte ich, dass es die Speicherbeschränkung ist. Aber auch andere Limits erzeugen diesen Fehler...
Kann ich vielleicht Joomla noch irgendwie beibringen, nicht mehr als 8 Sekunden CPU-Zeit zu nutzen? Bzw. Was heißt diese CPU-Zeit überhaupt? Der Scriptfehler kommt nach etwa 10 Sekunden. Das könnte ja der Hinweis auf diese - für mich - ominöse CPU-Zeit sein...

Gruß
Florian
Mitglied: OiledAmoeba
23.11.2009 um 00:13 Uhr
Ich habe den Fehler soeben gefunden.
Es scheint nicht an Joomla zu liegen. Nachdem ich das Paket fertig entpackt auf den Server lud und die Unstallation von dort aus aufrief, ging es. Das ZIP-file war nur ~700 kb, aber das Entpacken war wohl die Ursache dafür, dass die Kiste sich aufgehängt hat. Anscheinend wurden durch das Entpacken die Limits des Servers erreicht.

--Gelöst
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
gelöst HyperV Host CPU Kaufempfehlung (4)

Frage von adrian138 zum Thema Windows Server ...

Grafikkarten & Monitore
AMD GPU zusammen mit Intel CPU (3)

Frage von KungLao zum Thema Grafikkarten & Monitore ...

LAN, WAN, Wireless
Windows 10 - Nach einiger Zeit Internetausfall (14)

Frage von Irepeps zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...