Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Verzeichniss löschen per batch schlägt fehl

Frage Microsoft

Mitglied: ajjantke

ajjantke (Level 1) - Jetzt verbinden

14.10.2010 um 14:39 Uhr, 2617 Aufrufe, 7 Kommentare

Hallo,

ich habe ein kleines Problem, vielleicht kann mit jemand ein Tip geben woran es liegt.

Ich musss auf Ca 70 Pc´s TrendMicro deinstallieren und gegen eine aktuelle Version ersetzt.

Für die automatische deinstallation habe ich ein script geschrieben um dieverse Dienste und Gerätetreiber zu
deinstallieren.
Das klappt wunderbar.

Jetzt will ich eigentlich nur noch unnötige Verzeichnisse löschen und da fängt mein Problem an:

rd "C:\Dokumente und Einstellungen\All Users\Startmenü\Programme\Trend Micro Client-Server Security Agent" /S /Q

sollte eigentlich das Verzeichniss löschen
Dort erhalte ich immer die Fehlermeldung
"Das System kann den angegebenen Pfad nciht finden"

Gebe ich den Befehl direkt in der Kommandozeile eine klappt es

rd "C:\Programme\Trend Micro" /S /Q

Dieser Befehl funktioniert einwandfrei und der wird eine Zeile früher aufgerufen.

Hat da jemand eine Idee

Im Einsatz ist Win XP SP3 der User ist Admin / DomänAdmin.
Mitglied: ShitzOvran
14.10.2010 um 14:44 Uhr
hat der user, mit dem du das ausführst, evtl nicht die ausreichende berechtigung um im "AllUsers"-Ordner rumzudoktorn?

wenns das nicht ist, könnte es noch am 'Ü' liegen, womit hast du die atch erstellt?
Bitte warten ..
Mitglied: Berndinox
14.10.2010 um 14:45 Uhr
cmd hat probleme mit den Leerzeichen bei "Dokemente und Einstellungen" ich goolge mal schnell ob es eine umschreibung gibt.
Bitte warten ..
Mitglied: AndreasHoster
14.10.2010 um 14:49 Uhr
Tja, Windows und die Kommandozeile haben unterschiedliche Codepages.
Vermutlich hat für die Kommandozeile Dein Skript kein ü im startmenü drin.

Starte in der Kommandozeile man den Editor edit (ist bei XP dabei) und schau mal, ob Dein Skript ein ü hat.
Lösung: Einfach einen Editor nehmen, der Codepage 850 kann, z.B. edit auf der Kommandozeile.

Wenn man seine Skripte mitloggen würde, müsste man das im Log eigentlich sehen, daß da kein ü ist.
Bitte warten ..
Mitglied: ShitzOvran
14.10.2010 um 14:50 Uhr
Zitat von Berndinox:
cmd hat probleme mit den Leerzeichen bei "Dokemente und Einstellungen" ich goolge mal schnell ob es eine umschreibung
gibt.


wenn man die Pfade in Anführungszeichen setzt sollte das doch kein Problem sein
Bitte warten ..
Mitglied: ShitzOvran
14.10.2010 um 14:53 Uhr
man kann versuchen das ganze ding nochmal im Wordpad zu schreiben und dann abzuspeichern
Bitte warten ..
Mitglied: bastla
14.10.2010 um 15:09 Uhr
... oder sich einfach (teilweise) kürzer fasssen:
rd "C:\Dokumente und Einstellungen\All Users\STARTM~1\Programme\Trend Micro Client-Server Security Agent" /S /Q
Grüße
bastla
Bitte warten ..
Mitglied: ajjantke
14.10.2010 um 16:37 Uhr
Hallo,

danke erst mal an alle.

Habe das script jetzt mal mit notepad++ erstellt aber es hat auch noch nicht geholfen. Werde es mit dem letzten Vorschlag auch noch mal prüfen. Das wird jetzt allerdings ein paar Tage dauern da ich nicht im Haus bin. Ich dachte die Lösung bis zum Urlaub hinzubekommen. Jetzt werde ich es auf danach verschieben.

Vielen Dank für die Tips. Ich werde sie ausprobieren und eine Feedback geben.

Gruß

Andreas
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(1)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Windows Tools
gelöst DotNet Installation schlägt fehl (1)

Frage von emeriks zum Thema Windows Tools ...

Windows Server
TeamViewer 11 MSI Installation schlägt fehl (13)

Frage von Ghost108 zum Thema Windows Server ...

Windows Server
Upgrade von MSSQL Server 2008 R2 auf MSSQL Server 2012 schlägt fehl (4)

Frage von Argoadmin zum Thema Windows Server ...

Heiß diskutierte Inhalte
Hyper-V
gelöst Reiner Hyper- V Server oder lieber Rolle (28)

Frage von Winuser zum Thema Hyper-V ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

SAN, NAS, DAS
gelöst Synology Version 6.1 Probleme (18)

Frage von Hendrik2586 zum Thema SAN, NAS, DAS ...