Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VHD mounten, vorher prüfen ob schon vorhanden

Frage Entwicklung Batch & Shell

Mitglied: d4shoerncheN

d4shoerncheN (Level 2) - Jetzt verbinden

07.10.2014, aktualisiert 09:08 Uhr, 1848 Aufrufe, 6 Kommentare

Guten Morgen Kollegen,

ich hab seit einigen Tagen Probleme mit der Datensicherung (BackupAssist auf NAS) und auch der Support konnte noch nicht 100%ig helfen - wir sind aber dabei.

Ich sichere unseren SBS 2011 über BackupAssist auf unsere NAS (QNAP TS-412). Im BackupAssist wurde eingestellt, dass eine Daten-Container-Datei (.vhd) erstellt wird und in dieser gesichert wird. Seit einiger Zeit bekomme ich nun immer die Meldung: "BA5001 Konnte maximale Größe des Schattenkopie-Speicherbereichs nicht ermitteln oder setzen" und "BA2521 Der Backup-Speicherort ist nicht verfügbar oder wurde getrennt." obwohl die NAS erreichbar ist.

Nun kam vom Support der Hinweis, ich sollte die .vhd Datei in der Datenträgerverwaltung mal mounten und ein Laufwerksbuchstaben zuweisen. Die Sicherung dann von NAS auf "Lokale Platte" ändern und den Laufwerksbuchstaben angeben. Gesagt getan, heute Morgen leider wieder den selben Bericht bekommen. Was aufgefallen ist, er hat das Laufwerk wieder getrennt. Nun habe ich die Datei wieder gemoutet und die Datensicherung manuell angetrieben, bislang läuft sie.

Ich habe die Möglichkeit im BackupAssist vor und nach der Datensicherung ein Script ausführen zu lassen und hierbei bräuchte ich Eure Hilfe. Ich benötige ein Script welches schaut, ob Laufwerk T: schon verbunden ist. Wenn ja, nichts tun. Wenn nicht, soll er die .vhd Datei (Netzwerkspeicherort) mounten und dem Laufwerksbuchstaben T zuweisen.

Das sollte mein Problem vorübergehend ein wenig eindämmen, bis wir eine richtige Lösung gefunden haben.

Vielen Dank.

Gruß
Toni
Mitglied: colinardo
LÖSUNG 07.10.2014, aktualisiert 10.10.2014
Hi Toni,
kleine Batch löst das
01.
@echo off 
02.
If exist t:\ exit 
03.
net use z: \\nas\share /user:Admin PASSWORD 
04.
diskpart /s attachvdisk.txt
Und dann legst du noch ein Textfile (attachvdisk.txt) mit folgendem Inhalt an:
01.
select vdisk file=Z:\diskname.vhd 
02.
attach vdisk 
03.
assign letter=T
Ich vermute aber mal das du Netzwerkprobleme oder Treiber/Hardware-Probleme mit der Netzwerkkarte/Switch hast . Hier würde ich mal ansetzen.

Grüße Uwe
Bitte warten ..
Mitglied: d4shoerncheN
07.10.2014, aktualisiert um 09:55 Uhr
Hallo Uwe,

vielen Dank. Ich habe es nun wie folgt:
01.
@echo off 
02.
If exist t:\ goto :eof  
03.
net use z: \\NAS\Backup\SBS2011\System\ 
04.
diskpart /s e:\attachvdisk.txt
und in der Datei attachvdisk.txt
01.
select vdisk file=\\NAS\Backup\SBS2011\System\DataContainer.vhd 
02.
attach vdisk 
03.
assign letter=T
Ist das so korrekt?

Bzgl. Netzwerkprobleme, es passiert nur bei dieser einen Datensicherung. Alle anderen laufen problemlos, auch auf der selben Maschine.

Gruß
Bitte warten ..
Mitglied: colinardo
07.10.2014, aktualisiert um 10:45 Uhr
Ist das so korrekt?
in der Attachvdisk.txt den Pfad zur VHD mit mit Laufwerksbuchstaben Z:\ angeben und in der Batch natürlich nur das Share mappen, nicht den kompletten Pfad ...

Grüße Uwe
Bitte warten ..
Mitglied: d4shoerncheN
07.10.2014, aktualisiert um 10:48 Uhr
Hallo Uwe,

vielen Dank. So?
01.
@echo off 
02.
If exist t:\ goto :eof  
03.
net use z: \\NAS\Backup\SBS2011\System\ 
04.
diskpart /s e:\attachvdisk.txt
und in der Datei attachvdisk.txt
01.
select vdisk file=Z:\DataContainer.vhd 
02.
attach vdisk 
03.
assign letter=T
Gruß
Bitte warten ..
Mitglied: colinardo
07.10.2014 um 10:51 Uhr
01.
@echo off 
02.
If exist t:\ goto :eof  
03.
net use z: \\NAS\Backup 
04.
diskpart /s e:\attachvdisk.txt
01.
select vdisk file=Z:\SBS2011\System\DataContainer.vhd 
02.
attach vdisk 
03.
assign letter=T
wenn z: \\NAS\Backup das Share ist.
Bitte warten ..
Mitglied: d4shoerncheN
07.10.2014 um 10:55 Uhr
Hallo Uwe,

besten Dank. Schwere Geburt.... sorry.

Ich berichte morgen, ob es funktioniert hat.

Gruß
Toni
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Powershell - Datei prüfen ob vorhanden, dann löschen (9)

Frage von Bugger zum Thema Batch & Shell ...

Hyper-V
gelöst Hyper-V: nur noch vhd vorhanden - wie vServer wiederherstellen? (3)

Frage von StefanMUC zum Thema Hyper-V ...

Drucker und Scanner
Officejet 250 WLAN nicht vorhanden (9)

Frage von Kimaro zum Thema Drucker und Scanner ...

Windows 10
gelöst Profillaufwerk vorhanden und gleichzeitig nicht vorhanden (4)

Frage von Hanuta zum Thema Windows 10 ...

Neue Wissensbeiträge
Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(7)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(6)

Anleitung von BassFishFox zum Thema Windows 10 ...

Administrator.de Feedback

Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen

Tipp von pattern zum Thema Administrator.de Feedback ...

Heiß diskutierte Inhalte
Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Batch & Shell
gelöst Batch um Benutzer aus Sitzung abzumelden (15)

Frage von zeroblue2005 zum Thema Batch & Shell ...

Linux
gelöst Google Chrome startet nicht (12)

Frage von Thomas91 zum Thema Linux ...