Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Videos von Youtube einbetten - problem

Frage Entwicklung PHP

Mitglied: hausens

hausens (Level 1) - Jetzt verbinden

19.03.2014, aktualisiert 08:37 Uhr, 2665 Aufrufe, 8 Kommentare

Hallo,

Habe ein Problem mit youtubevideos einbetten.

Kurze Erläuterung: Ich spiele mich in letzter Zeit zuhause mit Serverdienste wie owncloud, typo3, websachen eben ;) und nun wollte ich ein paar videos über phpscript einbetten, funktioniert auch problemlos.

Mein Problem:
Meine php scripts schreibe ich am Windowsrechner mit NetBeans, zum testen nehme ich den Apache2 Server der bei XAMPP dabei ist. Wenn ich nun das Script teste funktioniert es und das Video wird abgespielt.

Kopiere ich die Scripts aber auf den Server bekomme ich die bekannten Meldungen: Dieses Video enthält Inhalte von WMG. Es darf auf Bestimmten Websites nicht wiedergegeben werden.
Meine Frage: Warum funktioniert es mit dem Apache auf dem Windows 7 Rechner aber mit dem Ubuntuserver nicht?

Fg
Hausens
Mitglied: Androxin
19.03.2014 um 10:05 Uhr
Hallo,

nutzt du den selben Browser zum Testen?
Bitte warten ..
Mitglied: hausens
19.03.2014 um 10:12 Uhr
Ja, benutzer Firefox, aber auch mit dem IE oder Opera ist es das selbe.
Bitte warten ..
Mitglied: Androxin
19.03.2014 um 10:16 Uhr
Steht der Win7 Rechner bei dir Zuhause und der Ubuntu Server in einem Rechenzentrum?
Bitte warten ..
Mitglied: hausens
19.03.2014 um 10:20 Uhr
alles steht unterm selben dach/ selben (WAN) IP.
Bitte warten ..
Mitglied: colinardo
19.03.2014, aktualisiert um 12:01 Uhr
Hallo Hausens,
wenn du die YouTube-Videos mit einem iFrame in deine Seite einbaust kann YouTube mit dem HTTP-Header X-Frame-Options festlegen auf welchen Seiten bestimmte Videos eingebettet werden dürfen (sagt ja schon die Meldung). Dies ist von den Betreibern so gewünscht, wenn du versuchst dies bei diesen Videos zu umgehen, wirst du vermutlich schon bald Post vom Anwalt bekommen

Grüße Uwe
Bitte warten ..
Mitglied: hausens
19.03.2014 um 13:16 Uhr
okay, danke.
Was mich aber am meisten interessieren würde ist, warum es am localhost mit dem XAMPP Apache geht und beim Linux Server nicht.

lg
Hausens
Bitte warten ..
Mitglied: Androxin
19.03.2014 um 13:26 Uhr
Wie genau hast du das Video denn in die Seite eingebunden? Ein iframe hat ja grundsätzlich erst einmal nichts mit PHP zutun.
Bitte warten ..
Mitglied: hausens
19.03.2014 um 13:59 Uhr
Eingebunden habe ich es mit dem embedded code von der Youtubeseite (Video -> Teilen -> Embedded Code).
Also ohne Verwendung von iframe
Bitte warten ..
Ähnliche Inhalte
Off Topic
OT: YouTube-Videos (5)

Frage von FA-jka zum Thema Off Topic ...

Internet
Musikrechte: YouTube einigt sich mit GEMA

Link von Treemanhero98 zum Thema Internet ...

Neue Wissensbeiträge
Windows Installation

Unorthodoxer Weg, um an einen Offline-Installer für Adobe Flash zu kommen

(8)

Tipp von beidermachtvongreyscull zum Thema Windows Installation ...

Datenschutz

Gefährdeter Datenschutz: Firefox löscht lokale Datenbanken nicht

Information von BassFishFox zum Thema Datenschutz ...

Firewall

PfSense OpenVPN beschleunigen

Tipp von Dobby zum Thema Firewall ...

Utilities

CCleaner 5.33 mit Malware infiziert

(27)

Information von SeaStorm zum Thema Utilities ...

Heiß diskutierte Inhalte
Utilities
CCleaner 5.33 mit Malware infiziert (27)

Information von SeaStorm zum Thema Utilities ...

Festplatten, SSD, Raid
gelöst Problem mit DELL 815R Server und Windows Bluescreen (24)

Frage von Leo-le zum Thema Festplatten, SSD, Raid ...

Windows Systemdateien
Windows bootet nicht mehr Fehlermeldung 0xc0000098 (19)

Frage von franzgoerlich zum Thema Windows Systemdateien ...

Windows Netzwerk
Dateien mit Intelligenz per GPO ins Programmverzeichnis (14)

Frage von erwin.t zum Thema Windows Netzwerk ...