Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VirtualBox export Problem bzw. Import

Frage Virtualisierung

Mitglied: Pampersjoe

Pampersjoe (Level 1) - Jetzt verbinden

29.01.2010, aktualisiert 30.01.2010, 12188 Aufrufe, 6 Kommentare

Hallo zusammen,

um nicht um die heißen Brei zu reden...

VirtualBox ist installiert auf Windows Server 2008 Standard und läuft einwandfrei. Habe auch schon Exports gezogen und auch das ging aber seit kurzem habe ich diese Fehlermeldung beim Export erstellen:


____________________________________________________________
Fehlercode:
E_FAIL (0x80004005)
Komponente:
Appliance
Interface:
IAppliance {07495095-d16c-4911-8964-5914341ced5d}

Die Appliance Laufwerk:\Ordner\Datei.ovf konnte nicht exportiert werden.

Could not create the clone hard disk 'E:.... (verr_unresolved_error).
____________________________________________________________


Ehrlich gesagt verstehe ich diese Meldung nicht und unter Google finde ich nicht wirklich etwas Gescheites.

Grundsätzlich ist es mir WICHTIG immer eine Sicherung "am WE" von der VM zu machen. (VM war natürlich aus! damit ich den Export überhaupt erst ziehen kann über die integrierte Exportfunktion)

Meine Vermutung wäre eine schon recht große .vdi da diese schon die 100 GB geknackt hat, aber das will ich irgendwie nicht glauben, warum sollte man denn dann so große überhaupt erst zulassen?

Sollte es absolut nicht mehr über den Export funktionieren, dann bliebe noch die Variaten die .vdi händig zu sichern. (beinhaltet SBS2003 unserer Firma und daher SEHR wichtig, Daten werden zwar gesondert gesichert aber letztendlich habe ich keine Lust nur weil VBOX gerade keine Lust hat einen Export zu machen im Falle eines Falles den Server neu installieren zu müssen sofern die Hardware mal im Eimer wäre.

Wie gesagt, sollte ein Export nicht mehr möglich sein wäre die Frage, reicht die .vdi aus?

Versucht habe ich nämlich schon diese zu kopieren und auf einem komplett anderen Rechner in eine dort schon bestehende VBOX einzufügen sprich... Neues OS angeben... auf diese .vdi verweisen und starten... dort kommen aber gleich Fehler bzw. wenn ich das System oben habe wäre Dienste oder Treiber nicht aktiv... und in die Logs komme ich auch nicht mehr rein. Mit anderen Worten das System ist nicht sofort nutzbar damit die Firma nahtlos weiter arbeiten könnte = schlecht!

Wie könnte ich im Schlimmstfall dann ein .vdi wieder "anständig" zum Laufen bringen? Wobei mir der Export echt am Liebsten wäre, da man hier nichts mehr basteln müsste.

Bin um jede Hilfe echt dankbar gerade.

Es ist zwar nicht so, dass es momentan brennt (da der Server = Hardware komplett neu ist) aber ich habe jetzt nicht umsonst virtualisiert, denn ein Import wäre weitaus schnell als alles neu zu installieren. Vor allem weil momentan alles läuft.

Gruß


Edit:

Da mir das Thema keine Ruhe gelassen hat, habe ich heute in der früh gleich mal an das Thema erneut dran gemacht und habe etwas anderes probiert:

- in bestehende VBOX die Platte hinzugefügt
- in VBOX ein neues OS angelegt und auf die Platte verwiesen (aber noch nicht gestartet)
- alte Maschine.xml anstelle der aktuellen ersetzt und gestartet

Wieder gleiches Problem

- NTFS Probleme
- Dienst oder Treiber nicht gestartet
- Logs sind blockiert aber diesmal nicht alles (könnte wiederum mit NTFS Problemen zu tun haben)

Ich bin irgendwo ratlos...

Klar könnte ich versuchen diese Probleme zu fixen aber bevor ich mir diesen Aufwand mache warte ich lieber, ob ich evtl. vllt. etwas falsch mache oder jemand eine Idee hat wie man doch einen "gescheiten" Export ziehen kann?!

Gruß
Mitglied: bytecounter
30.01.2010 um 10:32 Uhr
Hallo,

wir arbeiten auch mit VBox, allerdings unter SuSE Linux, daher kann ich dir nur ansatzweise helfen, aber vielleicht bringt es ja was. Für eine Sicherung pausieren wir die Maschine über die Shell (bei Windows ist das die Kommandozeile) mit

VBoxManage controlvm unsereVM pause

Anschließend sichern wir die vdi- und Konfig-Dateien auf eine externe Platte (einfach mit copy, nicht mit den VM-Tools!). Und starten dann die VM wieder mit

VBoxManage controlvm unsereVM resume

Folgende Szenarien haben wir in einem Testsystem durchgespielt:
Teil 1:
2 HDDs, 1x System (Linux), 1 VM (MS Server 2003 SBS),
die VM-HDD ist abgeschmiert
Die 2. scheinbar defekte Platte haben wir "plattgemacht" und die Verzeichnisse von der Sicherung eingespielt => lies wieder problemlos starten

Teil 2:
Alles auf einer HDD
Die als defekt angenommene Platte "plattgemacht", das Image von unserem Suse aufgespielt (keine Neuinstallation!), anschließend wie oben die VM-Verzeichnisse von der letzten Sicherung zurück kopiert => lief ebenfalls problemlos weiter


Hast du den kompletten Server mal neu gestartet? Eventuell muss einfach der VBox-Kernel neu geladen werden?

vg
Bytecounter
Bitte warten ..
Mitglied: Pampersjoe
30.01.2010 um 12:03 Uhr
Grüß dich

also das mit dem "pausieren" habe ich jetzt noch nicht gemacht aber ob die jetzt pausiert oder gestoppt ist denke ich nimmt sich nichts oder?

Kopiert habe ich auch die .vdi und die dazugehörige .xml für die VM (NICHT die aus dem .VirtualBox-Ordner! sondern die xml aus den Maschines, da ich auf einem weiteren System ja schon ein VirtualBox mit anderen VMs am laufen habe... daher dachte ich, ich brauch NUR die .vdi und eben die dazu xml der VM)

Zitat von bytecounter:

Folgende Szenarien haben wir in einem Testsystem durchgespielt:
Teil 1:
2 HDDs, 1x System (Linux), 1 VM (MS Server 2003 SBS),
die VM-HDD ist abgeschmiert
Die 2. scheinbar defekte Platte haben wir "plattgemacht" und die Verzeichnisse von der Sicherung eingespielt => lies
wieder problemlos starten

Teil 2:
Alles auf einer HDD
Die als defekt angenommene Platte "plattgemacht", das Image von unserem Suse aufgespielt (keine Neuinstallation!),
anschließend wie oben die VM-Verzeichnisse von der letzten Sicherung zurück kopiert => lief ebenfalls problemlos
weiter


Hast du den kompletten Server mal neu gestartet? Eventuell muss einfach der VBox-Kernel neu geladen werden?

Also...

Rechner habe ich schon komplett neu gestartet aber hat nichts geändert weder beim dem System bei dem ich den ursprünglichen Export machen wollte damit dieser vllt. funktioniert, noch auf dem System (anderer Rechner) wo die VM als Test mal mit eingebunden werden soll.

Grundsätzlich habe ich wie gesagt:

a) versucht ein Export zu machen mit Fehler (VM an sich funktioniert aber einwandfrei nur der Export nicht) wobei mir hier auch auffällt, dass der Export "komplett" durch läuft aber am Ende diese Meldung erst kommt...

daher

b) .vdi von der entsprechenden VM genommen und die dazugehörige .xml (kopiert ohne VBox Tools, also wie von dir beschrieben)
c) auf dem neuen System (anderer Rechner) die .vdi über VBox hinzugefügt über den Festplattenmanager von VBox
d) neues System bei VBox mit Hinweis auf die hinzugefügte .vdi angegeben (aber noch nicht gestartet!)
e) die dadurch erstellte xml ausgetauscht mit der alten (dann kommt logischerweise der Hinweis, dass die UUI nicht stimmt und die angepasst)

VM gestartet und fährt auch ansatzweise hoch... chkdsk läuft automatisch an weil angeblich Fehler mit NTFS korrigiert werden müssten als ist hier wohl schon ein Fehler!

Wiederholte Meldungen "bevor der Server oben ist"

"Ein Indexeintrag wird in Index $O der Datei 25 eingefügt."

Ist der Server dann endlich oben kommt der nächste Fehler:

Ein Dienst oder Treiber will ich in die Logs gucken = geht nicht... Fehler.

Irgendwie macht mir das gerade "etwas" Sorgen...

Noch ne Idee?
Bitte warten ..
Mitglied: bytecounter
30.01.2010 um 12:33 Uhr
Spontan würde ich sagen, dass die Kopie der vdi beschädigt ist, das passt aber nicht zum restlichen Fehlerbild. Hätte die Original vdi einen Fehler, müsste es auch auf dem produktiven SBS Probleme geben. Nun das erstmal zum Brainstorming...

Was passiert, wenn du auf der Testmaschine die Platte mit
VBoxManage modifiyvdi meinevdi.vdi compact
schrumpfst und dann einbindest?

Hast du SMART auf dem Server aktiviert? Was sagen die SMART-Werte?
Was sagt checkdisk vom Wirtsystem? Nicht, dass die physikalische Platte einen falschen Eintrag oder sogar einen an der Waffel hat und die vdi-Datei genau dort liegt, wo sie gerade nicht liegen.

Wenn das alles in Ordnung scheint, wird es schon schwerer..

vg
Bytecounter
Bitte warten ..
Mitglied: Pampersjoe
30.01.2010 um 15:05 Uhr
Zitat von bytecounter:
Spontan würde ich sagen, dass die Kopie der vdi beschädigt ist, das passt aber nicht zum restlichen Fehlerbild.
Hätte die Original vdi einen Fehler, müsste es auch auf dem produktiven SBS Probleme geben. Nun das erstmal zum
Brainstorming...

Was passiert, wenn du auf der Testmaschine die Platte mit
VBoxManage modifiyvdi meinevdi.vdi compact
schrumpfst und dann einbindest?

Hm... also ich bin ehrlich... ich weiss nicht was du mit VBoxManage mod.... etc. meinst WEIL die VBox die ich habe ist grafisch und nichts mit Konsole.


Hast du SMART auf dem Server aktiviert? Was sagen die SMART-Werte?

Sorry... was meinst du damit? Wo finde ich das?

Was sagt checkdisk vom Wirtsystem? Nicht, dass die physikalische Platte einen falschen Eintrag oder sogar einen an der Waffel hat

chkdsk ohne Probleme (sind auch nagelneue Platten drin)

und die vdi-Datei genau dort liegt, wo sie gerade nicht liegen.

Hm? Wenn der Pfad falsch wäre (sofern du das meinst), dann würde das System ja garnicht erst starten oder liege ich falsch?

Wenn das alles in Ordnung scheint, wird es schon schwerer..

Also die VM läuft munter vor sich hin... ich kann Sie ohne Probleme herunter fahren... und ohne Problem hoch fahren... keine Fehler gar nichts.

Exportieren auf eine andere Platte hatte die ganze Zeit (aus der grafischen Oberfläche) funktioniert. Nur jetzt nicht mehr. Max 300 GB eingerichtet und 110 GB momentan verbraucht (dynamisch). Da kann man auch nichts mehr kleiner machen, da die Daten so dem schon entsprechen.

Nur der Import ist echt ne harte Nuss... wie gesagt... die .vdi eingebunden startet er sofort automatisch (sofern ichs nicht abreche) ...
Bitte warten ..
Mitglied: bytecounter
01.02.2010 um 13:10 Uhr
Zitat von Pampersjoe:
> Zitat von bytecounter:
> ----
> Spontan würde ich sagen, dass die Kopie der vdi beschädigt ist, das passt aber nicht zum restlichen Fehlerbild.
> Hätte die Original vdi einen Fehler, müsste es auch auf dem produktiven SBS Probleme geben. Nun das erstmal zum
> Brainstorming...
>
> Was passiert, wenn du auf der Testmaschine die Platte mit
> VBoxManage modifiyvdi meinevdi.vdi compact
> schrumpfst und dann einbindest?

Hm... also ich bin ehrlich... ich weiss nicht was du mit VBoxManage mod.... etc. meinst WEIL die VBox die ich habe ist grafisch
und nichts mit Konsole.

Wir arbeiten (fast) nur mit Konsole..ist ressourcenschonender..


> Hast du SMART auf dem Server aktiviert? Was sagen die SMART-Werte?

Sorry... was meinst du damit? Wo finde ich das?

SMART => google.de Kurz: liest Werte der Festplatte aus und wenn zu viele Fehler auftauchen, schmeißt es eine Warnung.
> Was sagt checkdisk vom Wirtsystem? Nicht, dass die physikalische Platte einen falschen Eintrag oder sogar einen an der Waffel
hat

chkdsk ohne Probleme (sind auch nagelneue Platten drin)

> und die vdi-Datei genau dort liegt, wo sie gerade nicht liegen.

Hm? Wenn der Pfad falsch wäre (sofern du das meinst), dann würde das System ja garnicht erst starten oder liege ich
falsch?
Du liegst falsch. Ich meine, wenn die Datei einen fehlerhaften Sektor belegt...je nachdem mit welchen Optionen du checkdisk hast laufen lassen, kann man das ggf ausschließen.

> Wenn das alles in Ordnung scheint, wird es schon schwerer..

Also die VM läuft munter vor sich hin... ich kann Sie ohne Probleme herunter fahren... und ohne Problem hoch fahren... keine
Fehler gar nichts.

Exportieren auf eine andere Platte hatte die ganze Zeit (aus der grafischen Oberfläche) funktioniert. Nur jetzt nicht mehr.
Max 300 GB eingerichtet und 110 GB momentan verbraucht (dynamisch). Da kann man auch nichts mehr kleiner machen, da die Daten so
dem schon entsprechen.

Nur der Import ist echt ne harte Nuss... wie gesagt... die .vdi eingebunden startet er sofort automatisch (sofern ichs nicht
abreche) ...

Da fällt mir leider auch nichts mehr zu ein..

vg
Bytecounter
Bitte warten ..
Mitglied: Pampersjoe
01.02.2010 um 17:38 Uhr
Hi ho....

das Hauptproblem ist zwar noch nicht gelöst (Export) aber ich hab die Kiste zum Laufen gebracht...

Zu meiner Schande muss ich gestehen, dass ich "dachte" die VM gestoppt zu haben... war wohl aber nicht so... heute nochmal probiert mit gestoppter VM und schon kam kein chkdsk Fehler mehr!

Thema Treiber oder Dienst nicht gestartet ist auch gelöst und zwar war die falsche Netzwerkkarte ausgewählt... richtige genommen und tada =)

Bin ich erleichtert!

Und ehrlich gesagt scheint das "kopieren" der VDI schneller zu gehen als ein Export zu erstellen.

Wie auch immer... danke für die Hilfe!

Ach ja... der Thread kann eigentlich geschlossen werden "ausser" jemand hätte noch ne Idee für einen normalen Export.

Gruß
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Outlook & Mail
Outlook Export und Import zwischen Windows und Mac

Frage von VoDa81 zum Thema Outlook & Mail ...

Virtualisierung
VHD Image import VirtualBox (10)

Frage von oGutIT zum Thema Virtualisierung ...

Datenbanken
Problem beim Export aus dem SQL-Developer (4)

Frage von Roadrunner777 zum Thema Datenbanken ...

DSL, VDSL
Problem mit variernder Internetgeschwindigkeit (12)

Frage von schaurian zum Thema DSL, VDSL ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...