Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VirtualBox - Kali Linux - Zugriff auf WLAN Adapter

Frage Virtualisierung Vmware

Mitglied: citroendsvier

citroendsvier (Level 1) - Jetzt verbinden

27.02.2015, aktualisiert 25.04.2015, 9311 Aufrufe, 20 Kommentare

Hallo zusammen,

vorerst: VirtualBox ist zwar nicht VMware, ich weiß aber nicht, wo es besser passen würde...

ich versuche schon seit längerer Zeit, in einer Kali Linux VM unter Oracle VirtualBox eine Verbindung zum WLAN Adapter herzustellen.
Da ich mich mit Linux nicht sonderlich auskenne (das soll noch kommen :D), habe ich parallel eine Windows 7 VM aufgesetzt und dort das selbe versucht (um die VirtualBox Einstellungsmöglichkeiten auszuschließen).
Windows erkennt die Netzwerkkarte (TP-Link 300 Mbps PCI) zwar vom Namen her als WLAN Modul, behandelt sie aber wie eine LAN-Karte. Dadurch habe ich in der Windows-VM unten das LAN-Symbol mit rotem Kreuz. Also den Windows-WLAN-Dienst gestartet (wlansvc), ändert nichts.

Unter Netzwerk in den Einstellungen der VM ist eingestellt:
Angeschlossen an: Netzwerkbrücke
Name: TP-Link ...
Adaptertyp: Intel PRO/1000 MT Server (82545EM) --> Ich habe gelesen, dass die Standardeinstellung 'MT Desktop' Probleme mit Netzwerkbrücken macht
Promiscuous-Modus: verweigern (deny)
[Checkbox] Kabel verbunden <-- nicht gesetzt, was bedeutet das?

Was muss ich also in der Linux/Windows VM ändern, um auf die WLAN-Karte zugreifen zu können?
Mein Ziel ist nicht die Windows, sondern die Kali VM 'ans WLAN zu bringen' ;)

Freue mich über jeden Tipp!

Mit freundlichen Grüßen, V40
Mitglied: Lochkartenstanzer
27.02.2015, aktualisiert um 12:31 Uhr
Moin,

versuchs mal mit PCI Passtrough.

lks

PS: Wird vermutlich mit einem Windows-Host nicht funktionieren.

PPS: Warum läßt Du Kali nciht nativ laufen. Ist doch viel sinnvoller.
Bitte warten ..
Mitglied: aqui
27.02.2015 um 12:31 Uhr
Oder nimm nen Raspberry Pi mit WLAN Stick wenn du im WLAN schnüffeln willst:
http://www.administrator.de/wissen/netzwerk-management-server-raspberry ...
Bitte warten ..
Mitglied: sk-it83
LÖSUNG 27.02.2015, aktualisiert 25.04.2015
Moin moin,
betreibe Kali in ähnlicher Konstellation unter der Oracle Virtual Box, allerdings benutze ich einen USB WLAN Adapter von TP-Link.

Der wird einwandfrei als USB Gerät in die VM durchgereicht.

Liegt der Fehler nicht schon in der Installation der Karte unter Windows? Ich meine eine WLAN Karte sollte als WLAN Adapter angezeigt werden und nicht als LAN Karte.

Wie hast du die Karte den installiert?

VG
Bitte warten ..
Mitglied: citroendsvier
27.02.2015 um 12:39 Uhr
Unter Windows (dem eigentlichen OS auf dem PC) ist das Teil nicht verwendet, Treiber sind aber installiert, mMn auch als WLAN Adapter erkannt.

Welche Einstellungen hast du denn im Netzwerk-Reiter der VM?
Bitte warten ..
Mitglied: citroendsvier
27.02.2015 um 12:40 Uhr
Ich steuere den PC über Teamviewer an und unter Windows erledigt er noch ein paar andere Homeserverdinge, die ich unter Linux mangels Erfahrung und Kenntnissen nicht hinbekommen würde.
Bitte warten ..
Mitglied: Gersen
27.02.2015, aktualisiert um 12:45 Uhr
Hallo,

Haken bei "Kabel verbunden" reinsetzen sollte das Problem eigentlich lösen.

VirtualBox reicht eine Netzwerkverbindung des Hosts (LAN/WLAN) an die VM weiter (hier: LAN - je nach Adaptertyp). Wenn Du den Haken nicht setzt, ist es so, als würde dem virtuallen LAN "der Stecker fehlen". Daher das rote Kreuz in der NW-Schnittstelle der Windows-VM. Oder?

Gruß,
Gersen
Bitte warten ..
Mitglied: citroendsvier
27.02.2015, aktualisiert um 12:49 Uhr
Dachte ich auch, bringt aber nichts. Am Verhalten der VM ändert sich nichts.

EDIT: In Linux unter dem Netzwerksymbol oben rechts (übrigens auch ein LAN Symbol) steht "Kabelnetzwerk" und darunter in Grau "Gerät wird nicht verwaltet". Darunter sind Einstellungen zu VPNs zu finden, aber keine spur vom WLAN Adapter

EDIT 2: Der Raspberry ist bereits anders im Einsatz ;)

EDIT 3: airmon-ng zeugt auch keine Netzwerkadapter (da steht dann Interface - Chipset - Driver und darunter nichts mehr)
Bitte warten ..
Mitglied: Lochkartenstanzer
27.02.2015 um 12:49 Uhr
Nachtrag:

Zitat von citroendsvier:

Windows erkennt die Netzwerkkarte (TP-Link 300 Mbps PCI) zwar vom Namen her als WLAN Modul, behandelt sie aber wie eine LAN-Karte.

Kein Wunder, denn Du hast ja der VM gesagt, daß das eine LAN-Karte ist:

Adaptertyp: Intel PRO/1000 MT Server (82545EM)

lks
Bitte warten ..
Mitglied: sk-it83
27.02.2015 um 12:50 Uhr
Unter Netzwerkeinstellungen habe ich meine Ethernet Connection ausgewählt.

Unter Windows verwende ich sie auch nicht, da geh ich per Kabel ins LAN.

Ich reiche aber wie gesagt den Adapter als USB Gerät durch, nicht als Netzwerkgerät.
Bitte warten ..
Mitglied: Gersen
27.02.2015 um 12:52 Uhr
Zitat von citroendsvier:
Unter Windows (dem eigentlichen OS auf dem PC) ist das Teil nicht verwendet

Definiere das bitte mal. Die VM kann nur eine Verbindung benutzen, die besteht. Ist sie im Host deaktiviert (oder hat keine Verbindung), kann die VM das natürlich auch nicht nutzen.
Bitte warten ..
Mitglied: citroendsvier
27.02.2015, aktualisiert um 12:54 Uhr
Oh. Und was wäre die Richtige Einstellung?

weitere Möglichkeiten sind:
PCnet-PCI II (Am79C970A)
PCnet-FAST III (Am79C973)
Intel PRO/1000 MT Desktop (82540EM) - Standardeinstellung, funktioniert nicht
Intel PRO/1000 T Server (82543GC)
Intel PRO/1000 MT Server (82545EM)
Paravirtualisiertes Netzwerk (virtio-net)

Einige habe ich bereits ausgetestet - ohne Erfolg. Welches würde denn eurerer Meinung nach Sinn machen?

EDIT: Achso, USB ist ja dann was anderes

EDIT 2: Ich gehe unter dem 'Haupt-OS' mit Kabel ins Netzwerk, die WLAN Karte ist zwar installiert (Treibermäßig), wird aber nicht verwendet.
Bitte warten ..
Mitglied: Lochkartenstanzer
27.02.2015 um 12:57 Uhr
Zitat von citroendsvier:

Oh. Und was wäre die Richtige Einstellung?

weitere Möglichkeiten sind:
PCnet-PCI II (Am79C970A)
PCnet-FAST III (Am79C973)
Intel PRO/1000 MT Desktop (82540EM) - Standardeinstellung, funktioniert nicht
Intel PRO/1000 T Server (82543GC)
Intel PRO/1000 MT Server (82545EM)
Paravirtualisiertes Netzwerk (virtio-net)

Keines davon. Wie ich (und andere) schon sagten, mußt Du das Gerät durchreichen und keine Emulation. Das geht am einfachsten mit einem USB-WLAN-Adapter (oder dem RasPi ).

Einige habe ich bereits ausgetestet - ohne Erfolg. Welches würde denn eurerer Meinung nach Sinn machen?

Die RasPi-Lösung von aqui oder eine USB-Adapter anstöpseln, den Du als USB-Gerät durchreichst.

lks
Bitte warten ..
Mitglied: sk-it83
27.02.2015 um 12:57 Uhr
Ich sehe gerade das ich es doch unter Netzwerkeinstellungen auswählen kann.... sorry.

Da steht dann TP-Link Wireless N Adapter.

Aber wieso bei dir nix mit der Karte auftaucht weiss ich leider auch nicht...
Bitte warten ..
Mitglied: citroendsvier
27.02.2015 um 13:10 Uhr
Die Karte taucht in den Netzwerkeinstellungen ja auf. Einstellen kann ich sie, es hat halt eben nur keine Wirkung.

Ich werde jetzt einen 8€ USB WLAN Adapter testen - mal sehen, was es gibt. - Melde mich gleich wieder!
Bitte warten ..
Mitglied: citroendsvier
27.02.2015 um 13:29 Uhr
Also, der USB Adapter funktioniert. Als USB durchgereicht und keinen Netzwerkadapter angegeben.

Trotzdem würde ich es gerne mit der integrierten Karte probieren, habt ihr da noch Ideen bzgl der Fehlerquelle?
Bitte warten ..
Mitglied: Lochkartenstanzer
LÖSUNG 27.02.2015, aktualisiert 25.04.2015
Zitat von citroendsvier:

Trotzdem würde ich es gerne mit der integrierten Karte probieren, habt ihr da noch Ideen bzgl der Fehlerquelle?

Sagte ich doch: Du mußt die als PCI-Karte durchreichen und nicht als emuliertes LAN-Interface.

lks
Bitte warten ..
Mitglied: aqui
27.02.2015 um 15:34 Uhr
Ich werde jetzt einen 8€ USB WLAN Adapter testen
Wenn du damit WLAN Analyse machen willst dann nehme den richtigen und das ist einer von Alfa
http://www.amazon.de/s/?ie=UTF8&keywords=alfa+wireless+adapter& ...
Bitte warten ..
Mitglied: citroendsvier
01.03.2015, aktualisiert um 14:27 Uhr
@Lochkartenstanzer: Danke, werde ich mal testen!

@aqui: Das war leider der einzige, den ich zu Hause hatte. Funktioniert auch problemlos...
Bitte warten ..
Mitglied: MTXRGU
24.04.2015 um 20:28 Uhr
Wollte mich an der Stelle mal einklinken :D

Habe auch das Problem mit dem USB Adapter.
Habe Windows 8.1 als Hostsystem und Kali Linux in der VirtualBox.
Ich nutze den TP-Link TL-WN727N welcher auch von Windows selbst normal als WLAN Adapter erkannt wird und auch Verbindung aufbauen kann.

In der VirtualBox habe ich die Nötigen einstellungen getroffen jedoch wird mir in Kali keine Verbindung angezeigt.
Also über "airmon-ng" steht kein Wlan0 und auch wenn ich "Netzwerkadapter Verbinden" anklicke macht mein PC nur das Geräusch das er macht wenn man einen USB Physisch absteckt.

Kennt sich da jemand aus?
Bitte warten ..
Mitglied: aqui
25.04.2015, aktualisiert um 09:46 Uhr
Kennt sich da jemand aus?
Ja....
Folge einfach allen Anleitungs- und Troubleshooting Schritten die HIER stehen zum Thema airmon-ng:
http://www.administrator.de/wissen/netzwerk-management-server-raspberry ...
Damit bekommt man das sofort problemlos zum Fliegen !
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Batch & Shell
gelöst Wlan-adapter such algorithmus in batch (7)

Frage von TicoWrite zum Thema Batch & Shell ...

LAN, WAN, Wireless
gelöst Fritzbox 7490 - WLAN Geräte zugriff auf LAN Kamera hinter SONICWALL (25)

Frage von GoriBoy zum Thema LAN, WAN, Wireless ...

Router & Routing
Zugriff auf pfsense mit IPsec im WLAN (1)

Frage von maddig zum Thema Router & Routing ...

Apple
IPhone 6 im WLAN kein Zugriff auf Exchange Server (8)

Frage von montana zum Thema Apple ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...