Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Virtuelle Festplatte unter Server 2008 hinzufügen

Frage Microsoft Windows Server

Mitglied: barry99

barry99 (Level 1) - Jetzt verbinden

30.03.2011, aktualisiert 19:01 Uhr, 8252 Aufrufe, 14 Kommentare

Windows Server 2008 + SP2 (mit Hyper-V)
Als VM: Server 2008, Server 2003 und Windows 7

Hallo,
ich hoffe mir kann jemand helfen, weil langsam aber sicher werde ich wahnsinnig.

Ich versuche unter Win Server 2008 eine virtuelle Testumgebung vorzubereiten. Die Idee ist zwei Server und einen Client zu haben die sich sehen... ist hier nicht so relevant.
Mein Problem kommt von der fehlenden USB-Unterstützung durch Hyper-V. Ich brauch unbedingt eine Verbindung zwischen den VMs und dem Host um Daten in die virtuellen Systeme kopieren zu können. Immer alles zu brennen ist einfach zu umständlich.

Ich habe also eine virtuelle Festplatte (vUSB.vhd) erstellt. Diese habe ich in alle VMs eingebunden. Jetzt schaffe ich es aber nicht diese an das Host-System anzubinden um Daten rein kopieren zu können!

Kann mir jemand erklären wie ich es machen soll?


Für jede Hilfe wäre ich sehr dankbar!!!

Grüße aus Nürnberg
Mitglied: Mike.ekiM
30.03.2011 um 18:57 Uhr
Hi,

Ich verstehe dein Problem leider nicht ganz.
Was hälst du vom Wunder der Technik deine Daten über Netzwerk zu kopieren?

Gruß
Bitte warten ..
Mitglied: barry99
30.03.2011 um 19:03 Uhr
Es geht ja um die Verbindung zwische den virtuellen Systemen und dam Host-System. Die sehen sich doch nicht im Netzwerk.
Bitte warten ..
Mitglied: 90776
30.03.2011 um 19:35 Uhr
Hi Barry

Wenn ich mich nicht irre ist es genau so wie bei Windows 7

Computerverwaltung > Datenträgerverwaltung > Aktion > Virtuelle Festplatte anfügen > Pfad zur VHD angeben

Grüsse
Switcher
Bitte warten ..
Mitglied: barry99
30.03.2011 um 19:51 Uhr
Habe ich auch gedacht, aber leider sehe ich die Einträge mit den virtuellen Festplatten nicht Deswegen habe ich gedacht bei Server 2008 ist es anders. Muss ich da irgendwie in den Experten-Modus, erweiterte Ansicht oder so was?

http://www.wintotal.de/images/stories/artikel/vhdboot/vhdboot1.png Die gibt es bei mir nicht
Bitte warten ..
Mitglied: 90776
30.03.2011 um 20:06 Uhr
Als was bist du angemeldet?

Admini, oder eingebauter Administrator?

sonnst versuch mal Computerverwaltung > Rechtsklick > Im Autoren Modus starten
Bitte warten ..
Mitglied: barry99
30.03.2011 um 20:14 Uhr
Ich bin als der eingebauter Administrator angemeldet. Ich denke an den Rechten sollte es nicht liegen.
Bitte warten ..
Mitglied: Mike.ekiM
30.03.2011 um 20:18 Uhr
Dass dein Host nicht im gleichen Netz ist wie deine VM´s hast du an keiner Stelle erwähnt.
Da musst du deinen Aufbau schon prezise definieren!

Bin mit HyperV nicht sehr erfahren da ich VMware vSphere einsetze. Aber ich meine mich zu erinnern dass vhd´s sich erst mit Server 2008 R2 mit boardmitteln mounten lassen. Ansonsten kannst du den Umweg über vhdmount gehen, welches sich mit virtual Server installieren lässt.

Bitte um Korrektur falls das so nicht stimmt!

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: 90776
30.03.2011 um 20:29 Uhr
Zitat von Mike.ekiM:
dass vhd´s sich erst mit Server 2008 R2 mit boardmitteln mounten lassen

Jup hab mich vertan

Windows 7 = Server 2008 R2

also entweder über vhdmount oder mit Server 2008 VHD mouten

Grüsse
Switcher
Bitte warten ..
Mitglied: barry99
31.03.2011 um 19:26 Uhr
Danke!
Das war das Problem! Das hat jetzt mit "Server 2008 VHD mouten" sauber funktioniert.

Wie mache ich es, dass die Laufwerke die ich angebunden habe nach dem Neustart nicht verschwinden?
Bitte warten ..
Mitglied: 90776
31.03.2011 um 19:58 Uhr
ich glaube theoretisch ist das nicht möglich, abr du kannst natürlich das script als logonskript ausführen
Bitte warten ..
Mitglied: barry99
31.03.2011 um 20:09 Uhr
Ich weiss nicht, ich glaube ich bin einfach zu blöd für die ganze Geschichte.
Wenn die VM's laufen, kann ich die Laufwerke nicht mounten. Wenn ich sie mounte, dann kommt ein Fehler beim Start der WM's. Wie soll ich es also machen damit es geht???
Bitte warten ..
Mitglied: 90776
31.03.2011 um 20:41 Uhr
Hier

oder

Hier Seite 13
Bitte warten ..
Mitglied: barry99
01.04.2011 um 10:32 Uhr
Das ist mir schon alle klar.

Das Mounten und Demounten auf dem Host funktioniert auch. Es geht jetzt einfach um das Anbinden der Festplatte in der VM im laufendem Betrieb. Ich habe es jetzt na dieser Anleitung gemach http://www.hyper-v-server.de/tools/hyper-v-und-usb/ Das geht auch gut und man kann eben über das Rechte-Maustaste-Menü verbinden und trennen. Das Verbinden in der VM, im laufenden Betrieb sollte angeblich auch gehen, was bei mir nicht der Fall ist. Ist hier der Server 2008 wieder Schuld, oder liegt es nur an den Einstellungen?
Bitte warten ..
Mitglied: 90776
01.04.2011 um 13:20 Uhr
mach es doch einfach über das interne netzwerk, da hast du keine probleme mit dem Mouten

und mit dem Server 2008 kenn ich mich eben gar nicht aus, sorry
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...