Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Virtueller SMTP Server startet nicht

Frage Microsoft Exchange Server

Mitglied: Gunpowder

Gunpowder (Level 1) - Jetzt verbinden

04.04.2005, aktualisiert 05.04.2005, 17973 Aufrufe, 12 Kommentare

Fehlermeldung: Der Dienst kann keine Bindung mit Instanz 1 einrichten. Der Fehlercode befindet sich im Datenfeld.

Hi,
habe ein Problem mit dem virtuellen SMTP Server bei Exchange 2003 (SBS2003).
Der Exchange Server lief Wochenland ohne Probleme.
Gestern habe ich ein Bandlaufwerk eingebaut und und Veritas BackupExec mit dem SP1 installiert.
Weiterhin war der Network scanner von GFI installiert, den ich wieder deinstalliert habe. Weitere Änderungen habe ich nicht vorgenommen. Nachdem Neustart konnten keine mails mehr empfangen werden.
"In der Erreigniss Anzeige steht Der Dienst kann keine Bindung mit Instanz 1 einrichten. Der Fehlercode befindet sich im Datenfeld." Die betroffene Datei heißt SMTPSVC.DLL und befindet sich in c:\windows\system32\inetinf
Alle abhängigendienste sind gestartet. IIS/Informationstore etc.

Es können keine mails mehr Empfangen werden. Der Kunde sitzt mir im Nacken.
Hat jemand eine schnelle Idee?
Danke

Gunpowder
Mitglied: LarsJakubowski
04.04.2005 um 11:04 Uhr
Hi,

versuche mal den Dienst manuell zu starten. Das machst Du im IIS.

Lade Dir auch mal die neusten SP und Fixes runter.

Nach einem manuellen Start des Dienstes sollte dieser laufen und Mails können wieder empfangen werden.
Laueft denn die Systemaufsicht vom Exchange?

Lars
Bitte warten ..
Mitglied: Gunpowder
04.04.2005 um 11:55 Uhr
Hi,

die Systemaufsicht ist als Dienst gestartet.
Wo im IIS kann ich den SMTP Dienst neu starten?

Gruss

Gunpowder
Bitte warten ..
Mitglied: Gunpowder
04.04.2005 um 12:35 Uhr
Hallo,

habe den IIS (SMTP Dienste manuell neugestartet). Fehler ist der gleiche.
Habe versucht über Telnet den Port 25 anzusprechen über "open 192.168.100.235 25" und bekomme die Fehlermeldung "Es konnte keine Verbindung mit Host hergestellt werden".
Kann es sein das irgendetwas mein SMTP Port zu macht (AntiVirus?)
Gruss

Gunpowder
Bitte warten ..
Mitglied: LarsJakubowski
04.04.2005 um 13:06 Uhr
Hi,

möglich ist, dass z.B. die Windows Firewall den Port zu macht.
Oder Du hast eine entsprechende Firewall bereits auf dem Server drauf, die den Port zu macht.

Würde aber eher auf die Windows Firewall setzen!!

Einen AV macht Dir den Port nicht zu.
Das kannst Du wohl ausschließen!
Bitte warten ..
Mitglied: Gunpowder
04.04.2005 um 14:05 Uhr
Mails klappt. Habe den Mailgateway Server, den Dienst neugestartet und prompt konnte ich den Virtuellen SMTP starten.
Habe einen Scan nach Viren angestossen und habe jetzt einen Haufen Würmer auf dem Server. Habe jetzt das Problem das der SMTP Dienst ständig mails versendet. Wie kann ich es abstellen?
Als AntiVir läuft GDATA Client/Server mit GatewayServer Vers. 4.0.
Bitte warten ..
Mitglied: Gunpowder
04.04.2005 um 14:05 Uhr
Mails klappt. Habe den Mailgateway Server, den Dienst neugestartet und prompt konnte ich den Virtuellen SMTP starten.
Habe einen Scan nach Viren angestossen und habe jetzt einen Haufen Würmer auf dem Server. Habe jetzt das Problem das der SMTP Dienst ständig mails versendet. Wie kann ich es abstellen?
Als AntiVir läuft GDATA Client/Server mit GatewayServer Vers. 4.0.
Bitte warten ..
Mitglied: Gunpowder
04.04.2005 um 15:24 Uhr
AntiVir hat den Wurm gelöscht. Mails werden keine mehr aut. versendet.

Wie kann ich den Server jetzt richtig sauber bekommen? Hab das Vertrauen in GDATA AntiVir Client/Server verloren. Das Erklärt auch warum der virtuelle Dienst nicht mehr starten konnte, denn es scheint das der Wurm den Port 25 belegt hatte.

Gruss

Gunpowder
Bitte warten ..
Mitglied: LarsJakubowski
04.04.2005 um 15:35 Uhr
Du kannst mir einer Firewall halt schon gut vorsorgen.
Bei GData gibts auch noch extra ein Modul für Exchange Server.
Das its schon ziemlich vernünftig.

Dann solltest Du alle SP`s und Fixes einspielen!!

Exchange ist halt sehr empfänglich für Viren!! Das ist leider so.

Allternativ gibt es von MacAfee noch gute Lösungen!!

Lars
Bitte warten ..
Mitglied: Gunpowder
04.04.2005 um 18:51 Uhr
Hi,
hab jetzt das Problem das die Store.exe viel zu viel RAM- und CPU-Leitung in anspruch nimmt. Habe das Patch "Exchange 2003 Store Patch 6980.72 runter geladen, braucht man aber nicht da schion in SP1 enthalten.
Dem Support von GDATA habe ich die entsprechenden Logs vom AntiVir gegeben, wollen morgen Auskunft geben warum deren Dienst einfach stoppen.
Hast Du eine Idee wie ich die Store.exe normalisiere?
Gruss

Gunpowder
Bitte warten ..
Mitglied: Gunpowder
04.04.2005 um 19:05 Uhr
Habe gerade diesen Artikel von Microsoft gelesen.
http://support.microsoft.com/?id=867628
Scheint also eine Folge vom Update auf SP1.
Gruss

Gunpowder
Bitte warten ..
Mitglied: LarsJakubowski
04.04.2005 um 21:04 Uhr
Hi,

ja das Problem mit Store.exe kenne ich.
Hatte danach das SP wieder deinstalliert und es sah wieder ganz gut aus.
Danach habe ich den Server per Hand gepatcht.

Na ja, nicht die optimale Lösung, aber es geht.

Das Problem ist aber wohl konfigurationsabhängig. Bei manchen Kunden läuft es mit Sp super und bei anderen lass ich es schon lieber

Schmeiss das SP wieder runter und sammel die patches per Hand.

Dann sollte es laufen.

Bin ja mal gespannt, was GDATA findet. ALso würde mich auch interessieren, da ich GDATA auch öfters einsätze.

Lars
Bitte warten ..
Mitglied: Gunpowder
05.04.2005 um 22:52 Uhr
Habe jetzt Stellungnahme von GDATA den ich ungekürzt hier reinstelle.
Kurz gesagt: Der MailGateway Dienst von GDATA der eingehende Mails auf Port 25 empfängt befand sich in Kollision mit dem virtuellen SMTP Connector von Exchange der auch auf Port 25 stand.
Lösung : GDATA MailGateway bei eingehenden Nachrichten Mails annehmen auf Port 25 und weiterleiten an Exchange Server auf Port 7025.

Hier der original Text vom Support GDATA () Großes Lob!Cooler Support!)

Hallo,

siehe angehängten Screenshot. So kann es natürlich nicht funktionieren. MailGateway leitet SMTP eingehend und ausgehend jeweils an 192.168.100.235 (also sich selbst) auf Port 25 weiter,
ein prima Loop also. Exchange möchte Port 25 sicher auch gerne abhören, dies erklärt, warum sich der MailGateway-Dienst und der Exchange-Dienst beissen.

Eigentlich sollte das Routing so aussehen:

Eingehende Mail:

Eingehende Mailtrifft von außen auf Port 25 ein.
-> Dieser Port wird vom MailGateway abgehört, die Einstellung ist insoweit unter "eingehend SMTP" korrekt.

Die eingegangene Mail wird nach der Überprüfung durch das MailGateway weiter an 192.168.100.235 (gleiche Maschine), allerdings nicht Port 25,
da ja sonst das MailGateway selbst die Mail wiederum entgegen nehmen würde.
-> Die Mail muss also an einen anderen Port, z.B. 7025 weitergeleitet werden. Dieser Port muss vom ExchangeServer abgehört werden

Der ExchangeServer nimmt die Mail auf Port (z.B.) 7025 vom MailGateway entgegen. Die Mail ist somit korrekt zugestellt.

Ausgehende Mail:
Benutzer schreibt eine Mail. Exhange schickt diese an 192.168.100.235 weiter (gleiche Maschine), Zielport 25.
-> In den Einstellungen für ausgehendes SMTP muss Exchange also so konfiguriert werden, dass alle ausgehenden Mails
an den Smarthost 127.0.0.1 bzw. 192.168.100.235 weitergeleitet werden.

MailGateway nimmt die Mail vom Exchange auf Port 25 entgegen.
->Unter ausgehend SMTP im MailGateway sollte bei "IP-Adressen der Server, die ausgehende Mails senden" zusätzlich zum bereits eingetragenen 127.0.0.1 auch
die 192.168.100.235 eingetragen. Der momentan vorhandene Eintrag unter "Mails an diesen Server weiterleiten" ist Quatsch. Wenn 192.168.100.235 eingetragen bleibt,
haben wir ja wieder einen Loop. Die Mail muss ja nach draußen, also dort entweder einen externen SMTP-Relay Ihres Providers eintragen oder aber die Mails gleich per
DNS versenden lassen.

Das sollte es im großen und ganzen eigentlich sein. Wenn das MailGateway wie geschildert eingebunden wird, werden auch keine Probleme mehr mit dem ExchangeServer
auftreten. Ich bin mir sicher, dass die Problematik daher kommt, dass der ExchangeServer und das MailGateway sich darum prügeln, welcher von den beiden Port 25 abhören
darf. Der Dienst, der dabei als zweites gestartet wird, zieht den kürzeren.

PS: Ich musste die Kennwörter von MailGateway und AVK Administrator zurücksetzen, Sie können sich einfach mit leerem Kennwort anmelden und ein neues Kenwort verwenden.

Gruß

--
Customer Support
AntiVirenKit Client/Server
G DATA Software AG ? Königsallee 178b
D-44799 Bochum, Germany
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
E-Mail
gelöst Falsche SMTP Server IP Adresse (6)

Frage von laster zum Thema E-Mail ...

Festplatten, SSD, Raid
Server startet nicht mehr nach Festplattentausch (3)

Frage von Stibe88 zum Thema Festplatten, SSD, Raid ...

Windows Server
Server startet nicht mehr, Fehler 0xc000021a (15)

Frage von lgraap zum Thema Windows Server ...

Windows Server
Virtueller SMTP failover Smart-Host (4)

Frage von chrisboe zum Thema Windows Server ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...