Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Vista 64 iSCSI diskless PC - bleibt beim booten hängen

Frage Microsoft Windows Installation

Mitglied: Raketenschnecke

Raketenschnecke (Level 1) - Jetzt verbinden

10.07.2009, aktualisiert 21:03 Uhr, 7487 Aufrufe, 1 Kommentar

ich versuche gerade, einen diskless PC mittels ccboot zum laufen zu bringen. Leider bleibt der PC beim Booten hängen. Ich vermute...

ein Treiberproblem im Client-Image.

meine Umgebung:
Server 2003 32bit incl. aller Servicepacks und Updates mit installiertem CCBoot-Server (www.ccboot.com), Version 1.7 (der Server läuft schon seit 1 Jahr mit einigen Clients in der Domäne)
1Gbit-LAN
Client-PC: Vista 64bit incl. aller Servicepacks und Updates

das Problem:
ich bin jetzt soweit, dass ich den Client-PC über das LAN zum booten bewegen kann. Jedoch bleibt er im Vista Bootscreen hängen. Laut Monitoring auf dem Server lädt der Client-PC ca 61MB, wartet dann ca 2 Minuten und resettet sich dann selbst. Das Spiel beginnt dann von vorn. Ein Bootversuch im abgesicherten Modus führt zum gleichen Ergebnis: er lädt eine Menge Treiber und bleibt dann stehen, nach ca. 2 Minuten resettet er sich.

ich hab folgendes gemacht (Kurzbeschreibung)

1. Installation des CCBoot-Servers auf dem WIN 2k3 Server

2. lt. Anleitung von ccboot soll der ISCSI Initiator von Microsoft runtergeladen werden und installiert werden. Schon das funktioniert nicht (Fehlermeldung der Installationsroutine: ...could not find "update.inf"....) Nach Recherche weiss ich nun, dass Vista den ISCSI-Initiator schon an Bord hat und nur konfiguriert werden muss. Das habe ich getan, der ISCSI-Server und das zur Verfügung gestellte Laufwerk werden vom Client erkannt. Möglich ist aber, dass ich in der Konfig noch einen Fehler drin habe (aber dann würde der PC doch nicht booten oder ?

3. ich habe die DHCP-Funktion im CCBoot-Server abgeschaltet und statt dessen nach deren Anleitung auf der Homepage (im FAQ-Bereich) den Microsoft-DHCP-Server mit den entsprechenden DHCP-Optionen versehen

4. auf dem Client soll dann (nach der schon gescheiterten Installation des ISCSI-Initiators) eine von CCBoot mitgelieferte setup.bat gestartet werden. Diese prüft ob eine i386-CPU oder eine AMD64-CPU im System vorhanden ist und installiert dann den entsprechenden Treiber (iscsiboot.sys) aus dem entsprechenden Unterverzeichnis (Strinrunzel: ich habe ein 64bit-System, C2Q 6600 ?!) -> genau an der Stelle bricht die setup.bat mit folgender Meldung ab: Updating Driver for Hardware ID "ROOT\scsiboot" ab. Fehlermeldung in der nächsten Zeile: "could not update Driver: 103".

5. nach der Anleitung auf ccboot im FAQ-Bereich habe ich mir auf http://rom-o-matic.net/gpxe/gpxe-git/gpxe.git/contrib/rom-o-matic/ habe ich mir eine gPXE.pxe für die NIC im Client-PC erstellen lassen und diese wie beschrieben im Installationsverzeichnis von CCBoot auf dem Server abgelegt.

6. im BIOS des Client-PC habe ich als 1. Bootoption die NIC eingestellt, mit dem Imaging-Tool von CCBoot (CCDiskUpload.exe) ein Image vom Client-PC erstellen lassen und auf den Server hochgeladen sowie die Festplatte aus dem System entfernt

beim Bootvorgang scheint der Client-PC die gPXE-pxe mit dem NIC-Bootimage sowie auch das Client-Image auf dem Server zu finden. Aber wie oben schon geschrieben bleibt der Client nach laden von ca 61 MB Daten stehen.

Liege ich richtig mit meiner Vermutung (dass der Bootvorgang am nicht vorhandenen iscsiboot-Treiber scheitert) und hat jemand einen Tipp für mich wie ich das Problem lösen kann ?

Besten Dank schon mal
Mitglied: Raketenschnecke
11.07.2009 um 10:42 Uhr
aktueller Status: ich bin einen (halben) Schritt weiter: es lag tatsächlich am fehlenden iscsiboot-Treiber. Die Jungs von ccboot haben doch glatt unterschlagen, dass 1. das setup-Script und die iscsiboot-Treiber von etherboot.org stammt und 2. das von ccboot angebotene Setup-Paket nicht vollständig ist (die 64-bit Treiber fehlen).

Ich hab mir also das aktuelle und vollständige Setup-Paket von etherboot.org (http://git.etherboot.org/releases/sanbootconf/sanbootconf-latest.zip) runter geladen und die setup.bat gestartet. Funktionierte soweit, leider ist aber der iscsiboot-Treiber nicht digital signiert (das Problem stelle ich mal nach hinten.

Erfolg der geglückten Installation: der PC bootet jetzt auch und kommt wohl ein stückchen weiter als vorher: statt bisher 61 MB werden nun exakt 158,7 MB geladen, dann stoppt der Bootvorgang wieder (Vista kommt nicht über den grünen Ladebalken hinaus), der Client resettet sich wieder nach ca. 2 Minuten....

vielleicht hat hierzu (evtl. ist Vista nicht korrekt für das Booten über iscsi konfiguriert) jemnand Tipps für mich ?

herzlichen Dank
Bitte warten ..
Ähnliche Inhalte
Windows 7
PC bleibt bei Hersteller Logo hängen
gelöst Frage von beamenwaerschoenWindows 73 Kommentare

Hallo, der Titel sagt ja schon vieles ;-) Auf der HDD ist ein Win 7 64 im UEFI Modus ...

CPU, RAM, Mainboards
PC bleibt beim booten stecken
gelöst Frage von uridium69CPU, RAM, Mainboards13 Kommentare

Ich habe einen PC mit einem AMD CPU zusammengebaut. Das Mainboard ist ein Gigabyte GA-F2A88XM-D3HP, eingebaut sind folgende Komponenten: ...

Notebook & Zubehör
Bootmanager bleibt hängen
gelöst Frage von TheFalconNotebook & Zubehör9 Kommentare

Hallo liebe Community, ich habe folgendes Problem: Ich habe ein Toshiba Satelite Notebook. Nachdem der Akku leer war, ging ...

Windows 7
Windows bleibt am Start hängen
Frage von BigSnakeyeWindows 71 Kommentar

Grüsst euch Leute, ein Windows 7 Pro 64-Bit PC startet nicht mehr durch. Fehlerbild: - nach dem BIOS kommt ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 1 TagWindows 107 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 1 TagSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 2 TagenInternet5 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 2 TagenDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Batch & Shell
Kann man mit einer .txt Datei eine .bat Datei öffnen?
gelöst Frage von HelloWorldBatch & Shell20 Kommentare

Wie schon im Titel beschrieben würde ich gerne durch einfaches klicken auf eine Text oder Word Datei eine Batch ...

Router & Routing
OpenWRT bzw. L.E.D.E auf Buffalo WZR-HP-AG300H - update
gelöst Frage von EpigeneseRouter & Routing11 Kommentare

Guten Tag, ich habe auf einem Buffalo WZR-HP-AG300H die alternative Firmware vom L.E.D.E Projekt geflasht. Ich bin es von ...

LAN, WAN, Wireless
WLAN Reichweite erhöhen mit neuer Antenne
gelöst Frage von gdconsultLAN, WAN, Wireless8 Kommentare

Hallo, ich besitze einen TL-WN722N USB-WLAN Dongle mit einer richtigen Antenne. Ich frage mich jetzt ob man die Reichweite ...

Windows Server
Ping auf einen bestimmten Server nicht möglich
gelöst Frage von a.thierWindows Server7 Kommentare

Hallo, ich habe folgendes Problem. srv-dc1: Ping srv-nav > geht Ping srv-exchange > geht nicht srv-exchange: Ping srv-dc1 > ...