Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Vista: Anbindung von Netzwerk shares über ssh Tunnel auf loopback adapter funktioniert nicht? need help.

Frage Microsoft Windows Netzwerk

Mitglied: jojo-bs

jojo-bs (Level 1) - Jetzt verbinden

02.02.2007, aktualisiert 04.06.2008, 18788 Aufrufe, 3 Kommentare

Mit XP gehts, mit Vista nicht mehr? Tunnelier als Tool, ssh Tunnel, Portforwarding auf 139 an loopback device mit loakler IP. benötige dringed Hilfe.

Hallo Admins,

ich brauche dringend Hilfe.

Aktuelles System: Vista Business official release.
Shares: Samba shares in einem office Lan (gesichert durch ne firewall, kein VPN nur ssh möglich)

folgendes Problem:

Habe zu meinem Büronetz nur einen SSH Zugang, muss aber auf Projektlaufwerke (shares) von zuhause zugreiffen können. Die shares sind samba shares die zwar über sftp mittels eigenem username und passwort zugänglich wären, doch diese Zugangsdaten sind aus verschiedenen Gründen nicht für die User vorgesehen. Den usern wird lediglich zentral der Zugang gewährt.
Klappt auch wunderbar von intern und mit XP bisher auch über Umwege von extern.

Verfahren vorher (funktioniert auch immer noch mit nem XP Rechner):

Desktop von außerhalb: XP pro SP2, bitvise tunnlier als ssh software.

Zuerst loopback device auf desktop PC erstellen und im Bereich TCP/IP eine feste IP eintragen z.B. 10.10.10.6
Alles andere deaktivieren und NetBios over TCPIP ausschalten.
Mit tunnelier oder putty, wie auch immer, eine ssh Verbindung vom desktop zum Server innerhalb des office LAN's z.B. X.X.X.6 (Ist dann auch gleich Host für die shares). Dann das Portforwarding einrichten, das als Listen-Interface 10.10.10.6:139 und als Ziel-Interface X.X.X.6:139 verbindet. Halt alles Port 139 und vom loopback device zum server der die shares hosted. (Geht auch zu anderen Hosts inerhalb des Office Lans sofern dort auch shares angeboten werden.)

Dann kann man ganz einfach die Laufwerke mappen über net use ... oder Netzlaufwerk anbinden \10.10.10.6\$share mit dem entsprechenden eigenen User Namen und Passwort und schon bekommt man, ohne die Zugangsdaten der shares zu wissen, den entsprechenden Zugang dazu. (vorrausgesetzt man wurde zentral dafür eingetragen).

Dieses Prozedere funktioniert bei uns wunderbar seit langem für alle Mitarbeiter. nun kommt aber Vista und es scheint auf diesem Weg nicht mehr zu funktionieren.

Ich mache alles genau so wie bei XP nur wenn ich versuche das share anzubinden kommt:

The Error message is: Error code: 0x80070035. The network path was not found.

ich habe auch schon folgendes geändert:

IPv6 deaktiviert/aktiviert/in der regsitry deaktiviert/netbios aktiviert deaktiviert...

In der Verwaltung das LAN Manager auth to: Send LM & NTLM -- use NTLMv2 session security if negotiated geändert.

Hat aber auch nicht geholfen.

Könnte das nicht mal jemand netterweise ausprobieren und mir sagen ob es bei ihm funktioniert. Ich steh vor einem Rätsel!
ich hoffe es liegt an mir und ich habe etwas falsch gemacht und nicht am OS, denn dann würde Vista bei uns komplett erst mal nicht verwendbar sein.

Vielen Dank!

Jörn
Mitglied: stabilo1
06.08.2007 um 08:43 Uhr
Servus,

ich stehe vor demselben Problem. Testweise habe ich die Firewall von Vista deaktiviert und auch versucht, per Administrator das Netzlaufwerk herzustellen.

Um den Tunnel zu testen, habe ich ihn mal auf Port 80 verändert. Mit Erfolg, meinen Webserver erreiche ich per Browser. Weiterhin habe ich getestet, den SSH-Tunnel zu Port 139 per Telnet zu kontaktieren. Im Konsolenfenster von Plink habe ich gesehen, dass eine Verbindung gestartet wird. Somit kann ich davon ausgehen, dass der SSH-Tunnel erfolgreich aufgebaut wurde.

Nur das net use bringt dieselbe Fehlermeldung, die Jörn schon bekommen hat.

Ist jemand hier, der diese Aufgabe schon gelöst hat?
Bitte warten ..
Mitglied: badzox
27.11.2007 um 13:53 Uhr
Hallo zusammen,

im Gegensatz zu Windows XP muss unter Windows Vista nicht nur Port 139 sondern auch Port 445 umgeleitet werden .

Hier eine kleine Anleitung:

- Den MS Loopbackadapter über den Gerätemanager/Neue Hardware installieren .
Dies ist nötig, weil der lokale Port 139 vom eigenen System genutzt wird. Der Loopback Adapter ist nur eine virtuelle Netzwerkschnittstelle, dessen Ports man umleiten kann.

- Aus der Systemsteuerung Netzwerk- und Freigabecenter/Netzwerkverbindungen verwalten öffnen und die Eigenschaften des Loopbackadapter (Lan Adapter XXX - Loopbackadapter steht drunter!) auswählen.

- Alle Haken bis auf den Client für Microsoft-Netzwerke und Internetprotokoll Version 4 (TCP/IP 4) entfernen.

- Über die TCP/IP Optionen dem Adapter eine feste IP z.b. 10.0.0.1 /Subnetzmaske 255.255.255.0 zuweisen. KEIN STANDARDGATEWAY eintragen. NetBios over TCPIP in der Registerkarte Wins deaktivieren.

- Putty öffnen und mithilfe von Portforwarding (SSH/Tunnels) ein Umleitung der lokalen Ports von 10.0.0.1:139 zum Zielrechner x.x.x.x:139 und von 10.0.0.1:445 zum Zielrechner x.x.x.x:445 einrichten. Den Haken bei "Local ports accept connections from other hosts" aktivieren.

- Sobald jetzt die Verbindung geöffnet wird, und man sich per SSH angemeldet hat, kann man wie gewohnt die Freigabe auf dem Zielrechner über \\10.0.0.1\Freigabename verbinden.


Bebilderte Infos sind unter http://www.reviewingit.com/index.php/content/view/57/ zu finden.

Gruss
Badzox
Bitte warten ..
Mitglied: ljpascal
04.06.2008 um 09:03 Uhr
Hallo,
ich habe auch das Problem nur bei xp.

ich versuche von xp auf server 2003 durch ssh tunnel zuzugreifen. Alles so gemacht wie oben bekomme nur keine verbindung.

danke für eure hilfe
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Hyper-V
Grundsatz Frage Anbindung Hyper V Hosts ans Netzwerk (7)

Frage von Eifeladmin zum Thema Hyper-V ...

LAN, WAN, Wireless
Neuplanung Netzwerk mit VLAN, VOIP, Gästenetz (1)

Frage von GKKKAT zum Thema LAN, WAN, Wireless ...

Windows Vista
Vista Home Premium nur Basic Key (8)

Frage von Chonta zum Thema Windows Vista ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...