Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Vista bekommt Öffentliche IP im WLAN

Frage Netzwerke LAN, WAN, Wireless

Mitglied: LeFrog

LeFrog (Level 1) - Jetzt verbinden

13.05.2009, aktualisiert 16:47 Uhr, 4214 Aufrufe, 12 Kommentare

Hallo Community,

ich habe schon seit längerem ein Problem mit einem Vista Rechner. Der Rechner war ganz normal in einem WLAN-Netz und plötzlich bekam er nur noch ein öffentliche IP und man konnte demnach nicht ins Netz. Alle anderen Rechner (XP, Vista) hatten dieses Problem nicht. Wenn man nun die Verschlüsselung (ich glaube es war WPA) aus machte, bekam der Rechner wieder eine Private richtige Adresse. Auch das Netz löschen und neu hinzufügen hat nichts gebracht. Weiß jemand von Euch eine Lösung?

Grüße,
LeFrog
Mitglied: knut4linux
13.05.2009 um 17:00 Uhr
möp...

Sicher, dass er wirklich ne öffentliche IP bekommt? Hast du noch nen UMTS-geraffel an dem Ding? Wie vergibst du deine IP's im LAN?
Bitte warten ..
Mitglied: aqui
13.05.2009 um 17:01 Uhr
Was ist für dich eine öffentliche IP ???

Etwa 169.254.x.x ???

Das ist eine APIPA Adresse und keine öffentliche IP !! Vermutlich hast du da nur oberflächliche Kenntnisse der IP Adressierung ??!!:
http://de.wikipedia.org/wiki/Zeroconf

Ansonsten regelt der RFC 1918 was öffentlich ist und was nicht:
http://de.wikipedia.org/wiki/Private_IP-Adresse
Bitte warten ..
Mitglied: mrtux
13.05.2009 um 17:07 Uhr
Hi !

Zitat von LeFrog:
plötzlich bekam er nur noch ein öffentliche IP und man

Wie sieht die öffentliche IP aus ? 169. ?

dieses Problem nicht. Wenn man nun die Verschlüsselung (ich
glaube es war WPA) aus machte, bekam der Rechner wieder eine Private

Das hört sich eher nach falsch gesetzten WLAN Parametern (WPA, MAC Filter) an.

mrtux
Bitte warten ..
Mitglied: mrtux
13.05.2009 um 17:08 Uhr
Hi !

Zitat von aqui:
Was ist für dich eine öffentliche IP ???

Etwa 169.254.x.x ???

Uii Aqui, gleicher Gedanke, hatte Deinen Kommentar weiter unten, noch gar nicht gelesen, sorry

mrtux
Bitte warten ..
Mitglied: LeFrog
13.05.2009 um 17:33 Uhr
Zitat von aqui:
Vermutlich hast du da nur oberflächliche Kenntnisse der IP
Adressierung ??!!:

Ja, ich meine die IP fing wirklich so an. Mit IP Adressierung kenne ich mich wirklich nicht aus...

Zitat von mrtux:
Wie sieht die öffentliche IP aus ? 169. ?

Ich meine schon!

Zitat von aqui:
Das hört sich eher nach falsch gesetzten WLAN Parametern (WPA,
MAC Filter) an.

Beim Router und Rechner ist alles gleich geblieben. MAC Filter ist aus.
Bitte warten ..
Mitglied: aqui
13.05.2009 um 17:43 Uhr
Wenn er eine APIPA IP ala 169.254.x.x bekommt ist das zu 99% ein Indix dafür das er einen DHCP Server nicht findet was wiederum zu 99% an einer nicht aufgebauten WLAN Verbindung liegt.

Folgende Punkte solltest du prüfen im Setup des WLAN Routers (per kabelverbindung !)
  • Verschlüsselung auf WPA mit TKIP und preshared Keys setzen !!
  • Schlüsselpasswort ohne Sonderzeichen !
  • Eindeutige SSID (WLAN Kennung) vergeben und niemals die Default SSID vom Hersteller verwenden. Also sowas unverfängliches wie Bitschleuder oder Wurstsemmel verwenden !
  • Darauf achten das du von Nachbar WLANs mindestens 5 Funkkanäle entfernt bist damit die dein WLAN nicht stören ! Welche Kanäle (CH) die benutzen siehst du mit einem freien WLAN Sniffer wie z.B. WLANINFO

Das sollte dein problem im Handumdrehen lösen !
Bitte warten ..
Mitglied: mrtux
13.05.2009 um 17:48 Uhr
Hi!

Zitat von LeFrog:
Ich meine schon!

Dann ist es keine öffentliche Adresse, sondern eine, die von Windows vergeben wird, wenn keine Verbindung zu einem DHCP besteht.

Von hier aus würde ich sagen, Du hast keine Verbindung auf das WLAN, was sich dadurch bestätigt, dass es geht, wenn Du WPA abschaltest. Irgendwo da liegt das Problem aber nicht an der IP Vergabe !

WLAN Parameter und Treiber am Rechner prüfen.

mrtux
Bitte warten ..
Mitglied: LeFrog
13.05.2009 um 17:51 Uhr
Danke für die Ausführliche Hilfe!
Kann mir denn jemand einen Grund nennen warum so ein Problem aus einmal auftreten kann? Denn sonst hat WLAN immer ohne Probleme funktioniert.
Mir ist gerade auch noch eingefallen, dass ich mal eine manuelle IP vergeben habe. Danach hat es so weit ich weiß auch nicht funktioniert.
Bitte warten ..
Mitglied: aqui
13.05.2009 um 17:58 Uhr
Nein, das ändert logischerweise ja auch nichts weil die WLAN Verbindung gar nicht erst zustandekommt !!!

Vermutlich ist ein falscher Schlüssel oder Sonderzeichen im Schlüssel das Problem.
Oder generell wenn du WPA2 aktiviert hast aber keinen SP3 auf dem Rechner.
Deshalb auch der Tipp nur WPA und TKIP zu verwenden, das funktioniert immer !

Oder...du hast keine eindeutige persönliche SSID vergeben und die Hersteller SSID auf dem System belassen und so ein System ist auch im Nachbar WLAN. Dann bucht sich dein Client auf dem AP ein und scheitert am Passwort und endet mit einer APIPA IP...

Genau das was du in deinem Falle siehst !!!

Fazit: Punkte von oben umsetzen, dann sollte es klappen !!!
Bitte warten ..
Mitglied: LeFrog
13.05.2009 um 18:08 Uhr
Alles klar, danke für die Tipps, ich werde sie umsetzten!
Bitte warten ..
Mitglied: aqui
13.05.2009 um 21:57 Uhr
Wenns das dann war bitte
http://www.administrator.de/index.php?faq=32
nicht vergessen !!
Bitte warten ..
Mitglied: knut4linux
13.05.2009 um 22:01 Uhr
Danke @mrtux und aqui, dass ihr so direkt seit, ich habe so etwas vermutet, war mir aber sicher, dass LeFrog schon weiß, was ne öffentliche von einer privaten unterscheidet und was APIPA ist.

Ohne hier persönlich zu werden, aber das sind Beiträge (Fehler) über die man im nachhinein echt schunzeln muss *ROFL*

Also dann. Ich lasse meinen Datenterminator noch schnell den ping of death reiten, und wenn er aus dem Fenster gesprungen ist, leg mich ins Körbchen...

gun8 @ll
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Router & Routing
Lancom N:N-NAT - öffentliche IP und Firewall

Frage von devil77 zum Thema Router & Routing ...

LAN, WAN, Wireless
gelöst VPN Tunnel - Client bekommt falsche IP Adresse (16)

Frage von Markowitsch zum Thema LAN, WAN, Wireless ...

Netzwerke
LAN und WLAN je mit gleicher IP (13)

Frage von dauatitsbest zum Thema Netzwerke ...

Windows Netzwerk
Automatisches IP Setup für verschiedene (Wlan-)Netzwerke (4)

Frage von mraudi zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...