Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Vista-Business - Verknüpfung als Administrator starten - Übergabe eines Aufrufparameters in Leerzeichen schlägt fehlt

Frage Microsoft Windows Vista

Mitglied: prickel

prickel (Level 1) - Jetzt verbinden

09.01.2008 um 13:38 Uhr, 6549 Aufrufe

Ich habe eine Batchdatei (test.bat), der ich ein Pfad mit Lerrzeichen übergeben will. Da ich die Batchdatei als Administrator und aus dem SendTo-Kontextmenü aufrufen will, brauche ich eine Verknüpfung (test.lnk). In den Eigenschaften der Verküpfun hake ich "Als Administrator ausführen" an. Der Aufruf aus SendTo schlägt jedoch fehl, wenn in dem Verzeichnis- oder Dateinamen ein Leerzeichen vorkommt bzw. der String des Aufrufparameters in Anführungsstrichen steht. Einfaches Beispiel:
test.bat:
@echo off
echo %1

Wenn ich nun eine Eingabeaufforderung als Administrator öffne, passiert folgendes:
Der Aufruf von test.lnk "Hallo du" oder test.lnk "Hallo" schlägt fehl:
Der Befehl "\\winserv\server\Products\GTools\Regit-SoPart\test.bat" "Hallo" ist
entweder falsch geschrieben oder
konnte nicht gefunden werden.

Der Aufruf von test.lnk Hallo ist ok:
Hallo

Wenn ich bei der Verknüpfung das Häkchen "Als Administrator ausführen" nicht setze, ist das Verhalten in der Eingabeaufforderung und in der Administrator-Eingabeaufforderung identisch und der Mechanismus arbeitet ohne Fehler.

OS: Vista Business

Hat jemand eine Idee, worin das Problem liegt?

Vielen Dank!

Ralf
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Windows Server
Als Administrator starten geht nicht (5)

Frage von fabio84 zum Thema Windows Server ...

Windows 10
Windows 10: Version 1607 jetzt im Current Branch for Business

Link von Penny.Cilin zum Thema Windows 10 ...

Windows 7
gelöst Windows Administrator-Konto wieder aktivieren (13)

Frage von Fenris14 zum Thema Windows 7 ...

Microsoft Office
gelöst Dropdownlisten in Abhängigkeit mit Leerzeichen im Namen (Datenüberprüfung) (2)

Frage von kevische zum Thema Microsoft Office ...

Heiß diskutierte Inhalte
DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (9)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...