Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Vista-Business - Verknüpfung als Administrator starten - Übergabe eines Aufrufparameters in Leerzeichen schlägt fehlt

Frage Microsoft Windows Vista

Mitglied: prickel

prickel (Level 1) - Jetzt verbinden

09.01.2008 um 13:38 Uhr, 6557 Aufrufe

Ich habe eine Batchdatei (test.bat), der ich ein Pfad mit Lerrzeichen übergeben will. Da ich die Batchdatei als Administrator und aus dem SendTo-Kontextmenü aufrufen will, brauche ich eine Verknüpfung (test.lnk). In den Eigenschaften der Verküpfun hake ich "Als Administrator ausführen" an. Der Aufruf aus SendTo schlägt jedoch fehl, wenn in dem Verzeichnis- oder Dateinamen ein Leerzeichen vorkommt bzw. der String des Aufrufparameters in Anführungsstrichen steht. Einfaches Beispiel:
test.bat:
@echo off
echo %1

Wenn ich nun eine Eingabeaufforderung als Administrator öffne, passiert folgendes:
Der Aufruf von test.lnk "Hallo du" oder test.lnk "Hallo" schlägt fehl:
Der Befehl "\\winserv\server\Products\GTools\Regit-SoPart\test.bat" "Hallo" ist
entweder falsch geschrieben oder
konnte nicht gefunden werden.

Der Aufruf von test.lnk Hallo ist ok:
Hallo

Wenn ich bei der Verknüpfung das Häkchen "Als Administrator ausführen" nicht setze, ist das Verhalten in der Eingabeaufforderung und in der Administrator-Eingabeaufforderung identisch und der Mechanismus arbeitet ohne Fehler.

OS: Vista Business

Hat jemand eine Idee, worin das Problem liegt?

Vielen Dank!

Ralf
Ähnliche Inhalte
Ubuntu
gelöst Mailcow Installation schlägt fehlt (4)

Frage von ClepToManix zum Thema Ubuntu ...

Windows Systemdateien
gelöst Starten einer EXE mittels LogonSkript schlägt ständig fehl (17)

Frage von M.Marz zum Thema Windows Systemdateien ...

Rechtliche Fragen
Alter Systempartner weigert sich Übergabe zu machen (10)

Frage von Xartor zum Thema Rechtliche Fragen ...

Batch & Shell
Leerzeichen im Pfad (4)

Frage von Jallio zum Thema Batch & Shell ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(2)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Netzwerkprotokolle
gelöst Leiten "dumme" Switches VLAN-Tags mit durch? (26)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

Netzwerkgrundlagen
Kann auf Freigabe nicht Zugreifen (16)

Frage von leon123 zum Thema Netzwerkgrundlagen ...

Windows Server
gelöst Neues KB für W10 1607 und W2K16 wieder mal nicht im WSUS 3.0, hat das noch jemand? (16)

Frage von departure69 zum Thema Windows Server ...

Exchange Server
Apple Mail mit Exchange 2010 verbinden (12)

Frage von DieAzubinne zum Thema Exchange Server ...